17:01:50 <thinrichs> #startmeeting CongressTeamMeeting
17:01:51 <openstack> Meeting started Tue Feb 17 17:01:50 2015 UTC and is due to finish in 60 minutes.  The chair is thinrichs. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:54 <openstack> The meeting name has been set to 'congressteammeeting'
17:02:17 <thinrichs> Let's start with status updates.
17:02:19 <thinrichs> #topic status
17:02:37 <thinrichs> rajdeepd: since it's so late for you, want to start so you can hop off when you need to?
17:02:59 <rajdeepd> ok sure
17:03:22 <rajdeepd> i have been working on horizon data source status table
17:03:43 <rajdeepd> updated the CL based on review comments from jwh and arosen
17:04:07 <rajdeepd> sent it for review today morning india time
17:04:28 <rajdeepd> that summarizes my status update
17:05:20 <thinrichs> Thanks.  I'll try to remind them to give you another review in the next couple of days.
17:05:24 <thinrichs> I don't see them online now.
17:05:44 <thinrichs> sarob: want to go next?
17:05:51 <sarob> shirely
17:06:02 <sarob> #link http://lists.openstack.org/pipermail/openstack-dev/2015-February/056664.html
17:06:04 <rajdeepd> ok thanks
17:06:44 <sarob> we want to tidy up launchpad
17:07:09 <sarob> so bugs and blueprint assignments get
17:07:26 <sarob> published as completed as part of the
17:07:35 <sarob> of the completed milestone
17:08:08 <sarob> also tagging the repo with the same milestone
17:08:45 <sarob> ttx and fungi have responded to the thread
17:08:58 <sarob> i will do the tasks manually this time
17:09:20 <sarob> next milestone i will see if I can use ttx's script
17:09:29 <sarob> any questions?
17:09:33 <arosen1> Hiya, Sorry i was running late.
17:09:51 <sarob> arosen1: morn
17:09:55 <thinrichs> arosen1: we're doing status updates, as usual.
17:10:11 <thinrichs> sarob just went over our kilo2 release plans.
17:10:33 <thinrichs> sarob: seems okay to me.
17:10:35 <arosen1> cool, yea i saw his email on the mailing list last week. SOunds good to me.
17:10:45 <sarob> coolo
17:10:56 <thinrichs> sarob: have you looked at how many of our kilo2 bps are slipping to kilo3?
17:11:08 <sarob> hold a sec
17:11:51 <sarob> #link https://launchpad.net/congress/+milestone/kilo-2
17:12:28 <sarob> maybe one will be kilo-2
17:12:47 <sarob> or two
17:12:58 <sarob> rest are going to kilo-3
17:13:36 <sarob> #link https://review.openstack.org/#/c/150514/
17:14:01 <sarob> i believe completes
17:14:05 <sarob> #link https://blueprints.launchpad.net/congress/+spec/murano-driver
17:14:36 <sarob> i think
17:14:41 <sarob> #link https://blueprints.launchpad.net/congress/+spec/modal-operators-for-policy
17:14:46 <sarob> had some code pushed
17:14:54 <sarob> cant see the reference in the bp though
17:15:00 <thinrichs> Have you heard from Kishan about the action-execution interface?
17:15:34 <sarob> he was going to start work on it
17:15:49 <sarob> as the murano driver was completed
17:16:05 <thinrichs> What about Zhenzan and the policy-engine triggers?
17:16:07 <sarob> i havent seen him push any code
17:16:50 <stevenldt> hi. I'm working on murano-driver. I still have some revision I plan to submit for review.
17:16:50 <sarob> nothing since last week
17:17:09 <sarob> kishan around?
17:17:35 <sarob> zhenzan?
17:17:49 <thinrichs> stevenldt: Great!  Those drivers take a number of revisions before they're stable, typically.
17:18:08 <thinrichs> stevenldt: want to do your status update?
17:18:26 <sarob> i will follow up with those two
17:18:29 <sarob> im done
17:18:29 <stevenldt> sure
17:19:12 <stevenldt> I'm working on some revision to extend the datasource tables to sync up with Murano
17:19:23 <thinrichs> sarob: sorry—assumed you were done, but I should have asked.
17:19:47 <sarob> #action sarob follow up with kishan action-execution and zhenzan policy engine triggers
17:20:03 <stevenldt> I may have the code ready for review this week or early next since this week is a short week for me
17:20:04 <sarob> thinrichs: np!
17:21:14 <thinrichs> stevenldt: sounds good.  Let us know if you need anything from us.
17:21:33 <stevenldt> I have a question regarding the changes on the datasource query, at least on the cli
17:21:50 <arosen1> stevenldt:  shoot
17:21:53 <sarob> #action sarob will release kilo-2 milestone; launchpad milestone kilo-2 release and github tagging repo with 2015.1.0b2
17:22:37 <stevenldt> we now have to create the datasource before use, and to read the datasource table, we use the uuid instead of the name of the datasource
17:22:50 <stevenldt> is that what we're going forward with?
17:23:06 <arosen1> stevenldt: yup.
17:23:16 <thinrichs> From the CLI, we shouldn't need to use the datasource uuid.
17:23:20 <arosen1> This allows us to move to a multitenant api as well.
17:23:20 <thinrichs> That's a step backwards.
17:23:34 <arosen1> thinrichs:  right you don't need to use the uuid on the CLI
17:23:38 <stevenldt> Ok.  Thanks.  I may need to review my part to adapt to that.
17:23:58 <arosen1> I think there was one bug there where you did need to use the cli but here it is: https://review.openstack.org/#/c/154993/
17:24:09 <arosen1> thats the fix ^
17:24:44 <cloudtoa_> Keeping it usable by humans is a ++.
17:25:08 <arosen1> yup you can keep using the CLI by name  or uuid.
17:25:16 <thinrichs> stevenldt: anything else?
17:25:20 <stevenldt> Great. That's all from me.
17:25:43 <thinrichs> cloudtoa_: want to do a status report?
17:26:06 <cloudtoa_> I need 36 hours in a day.
17:26:53 <cloudtoa_> I'll have something submitted in the next couple of days for the control bus part.
17:27:25 <cloudtoa_> Assuming I have time, I'll have the first pass at the blueprint for the table-service submitted.
17:27:32 <cloudtoa_> By end of week.
17:28:16 <thinrichs> The kilo3 deadline is mid-March.
17:28:39 <thinrichs> After that we stop adding new features, for the most part.
17:28:46 <thinrichs> And we focus on stabilizing.
17:29:01 <thinrichs> Before the official kilo release.
17:29:26 <thinrichs> cloudtoa_: sounds like you'll have the control bus work done by kilo3.
17:29:31 <cloudtoa_> yes
17:29:33 <thinrichs> What do you think about the table-service work?
17:30:50 <cloudtoa_> What do you mean?  You mean the work that arosen is doing?
17:31:41 <thinrichs> cloudtoa_: you just said you'd make a first pass at the blueprint for the table-service work.
17:31:46 <thinrichs> That's what I'm asking about.
17:32:26 <cloudtoa_> I was thinking of splitting the datasource driver into different pieces.  It's probably too much to squeeze into an IRC session.
17:33:08 <thinrichs> OK.  We'll wait for your blueprint/spec then.
17:33:17 <thinrichs> cloudtoa_: anything else from you?
17:33:27 <cloudtoa_> No, that is all.
17:33:31 <thinrichs> Thanks!
17:33:43 <thinrichs> arosen1: want to tell us what you've been up to?
17:35:17 <arosen1> Sure
17:35:41 <arosen1> So, we just merged the patch that allows datasources to be configurable via the api on wednesday last week.
17:36:06 <arosen1> Now we no longer have the datasource.conf file and all the datasource information is stored in the database instead.
17:36:51 <arosen1> In addition, several changes were made to the api code to use uuid's in the URLs instead of names so that our api can eventually work with multiple tenants.
17:37:29 <arosen1> I've also been revamping our CI a little and now the congress ci also validates patches against the python-congressclient.
17:37:39 <arosen1> That's it unless someone wants to discuss.
17:38:13 <cloudtoa_> datasource.conf being gone...
17:38:20 <cloudtoa_> are we storing like a JSON blob in the database?
17:38:29 <arosen1> cloudtoa_: yup
17:38:42 <arosen1> there is a new api call /v1/drivers/<name>/config
17:38:45 <Radu-> Is there a way to update that without deleting the row?
17:39:13 <arosen1> which tells you want you need to pass in to congress to register a specific datasource drivers (since they all have different connection requirements)
17:39:40 <Radu-> ah, the'/config' part was missing in the git commit. That was confusing me a bit.
17:39:41 <arosen1> Radu-:  right now we only support POST/DELETE/GET on it. I didn't implement update
17:40:20 <arosen1> Radu-:  yea, check out the devstack changes I made as well which shows how to use it via the cli
17:40:26 <arosen1> it doesn't show getting the config though
17:41:33 <Yali_> Hello, everyone. It is the first time for me to enter this meeting. But Jim Xu has exchanged some ideas about congress UI. I hope I can do some contributions.
17:41:41 <Radu-> and it seems that you have to specific what values can be configured from the driver as well now.
17:42:23 <thinrichs> Yali_: Nice to have you join us!  After we finish up discussing these latest changes from arosen, we'll ask you to talk a bit about your interests.
17:42:28 <arosen1> Radu-:  yup
17:43:17 <Radu-> is that just a matter of updating the drivers get_datasource_info result[config] variable?
17:44:44 <Radu-> Sorry If Im repeating anything that was discussed when I had left the channel for a few minutes. Didn't think I would be able to stay any longer
17:44:50 <arosen1> Radu-:  https://github.com/stackforge/congress/blob/master/congress/datasources/plexxi_driver.py#L83
17:44:58 <arosen1> Radu-:  yea lets talk about it in #congress after
17:45:08 <Radu-> Ok thanks
17:45:24 <thinrichs> arosen1: Which APIs changed to require UUIDs instead of names?
17:46:28 <arosen1> thinrichs:  the data-sources one
17:46:42 <arosen1> since now an instance of a data-srouce is a uuid not a name
17:46:50 <arosen1> in the url
17:47:16 * arosen1 but the client hides all of that for you if you want to use the name
17:47:44 <thinrichs> Just the datasource then?
17:48:14 <arosen1> correct
17:48:49 <thinrichs> OK.  I think as a general rule we want to make the API friendly as well, in case someone isn't using the CLI.
17:49:23 <thinrichs> I should give a quick status update.
17:49:59 <thinrichs> I've been working on the problem of delegation recently: how do we carve off a piece of the policy the user has given us and give it to a domain-specific policy engine, eg. a VM-placement policy engine?
17:50:24 <thinrichs> You can find details if you look at the openstack-dev mailing list for messages with [Congress][Delegation] in the subject.
17:50:41 <thinrichs> Anyone else have a status update they want to give, before we hear from Yali.
17:50:43 <thinrichs> ?
17:51:41 <thinrichs> Yali_: could you tell us a bit about yourself and why you're interested in Congress?
17:52:02 <Yali_> sure
17:53:21 <Yali_> i an a newer for congress. but i think it is very important for the whole cloud.
17:53:44 <Yali_> to make the cloud compliance.
17:54:42 <thinrichs> Could you tell us your name and where you work, so we know you outside of IRC?
17:55:43 <Yali_> Ok. My name is Yali Zhang, from China. And i am working in Huawei Company, same with Jim Xu.
17:56:37 <thinrichs> Great!  Is there some part of Congress you're especially interested in?  Policy engine, datasources, UI?
17:57:58 <Yali_> Yes, I am interested in UI nowadays.
17:58:24 <thinrichs> Glad to have you.  Let us know if you need pointers to get started. Many of us hang out in #congress in IRC all day.
17:58:30 <thinrichs> 2 minutes remaining.
17:58:38 <thinrichs> Any topics to broach quickly?
17:58:42 <thinrichs> #topic open discussion
17:59:45 <sarob> im working on getting a design session room for at 60+ people for at three hour sessions
17:59:48 <Yali_> now I have some ideas about UI, and hope to share with you.
18:00:07 <thinrichs> sarob: nice!
18:00:24 <thinrichs> If the next summit is anything like the last we'll need it.
18:00:28 <sarob> yup
18:00:31 <thinrichs> Yali_: we're looking forward to it!
18:00:37 <thinrichs> And we're out of time.
18:00:37 <sarob> ill update on incubation next time
18:00:43 <arosen1> Also voting for openstack summit talks are now open.
18:00:49 <thinrichs> We can continue on #congress if anyone wants.
18:00:55 <thinrichs> Yes—everyone get out and vote!
18:00:58 <arosen1> Here's a list of the congress talks if you guys want to vote for all of them: http://blog.aaronorosen.com/congress-liberty-summit-talks/
18:01:10 <thinrichs> #endmeeting