17:00:45 <sarob> #startmeeting congressteammeeting
17:00:48 <openstack> Meeting started Tue Jan 20 17:00:45 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:51 <openstack> The meeting name has been set to 'congressteammeeting'
17:01:16 <sarob> Thinhichs, arosen, ayip are all out today
17:01:32 <sarob> Morning congress team
17:01:50 <sarob> Roll call
17:02:18 <alexsyip> I'm here
17:02:25 <sarob> Cool
17:02:38 <alexsyip> I can't make it to the office by 9am, so I use irc from home.
17:02:45 <sarob> Who else is here for the congress meeting
17:02:52 <sarob> Alexsip no prob
17:03:03 <jwy> I'm here
17:03:22 <sarob> Morn key
17:03:32 <sarob> Morn jwy
17:03:39 <sarob> Spell chk
17:03:40 <jwy> good morning
17:04:08 <sarob> Cloudtoad?
17:04:17 <sarob> Kiran?
17:04:34 <sarob> Well let's start then
17:05:07 <sarob> Let's go with abrev'd updates
17:05:26 <sarob> Alexsyip go first?
17:06:50 <sarob> Looks like lost alexsyip
17:07:00 <sarob> Jwy you update?
17:07:33 <jwy> met with some folks last week to brainstorm how the policy creation UI could look like in Horizon
17:07:57 <jwy> there are a couple things that still need to be worked out more
17:08:55 <jwy> I'll use what we came up with so far and then try to fill in the gaps from that
17:09:18 <jwy> did some code reviews
17:09:23 <jwy> I think that's about it
17:09:48 <alexsyip> I worked on the performance of initializing congress tables from a datasource
17:10:04 <sarob> Quick summary of the ideas and what you settled on jwy
17:10:13 <sarob> Jwy for the log
17:10:36 <jwy> the creation process is broken into three steps
17:11:02 <jwy> 1. "if": select the tables you're interested in and the columns from those tables
17:11:22 <jwy> 2. "where": any constraints, just as table joins (column a equals column b)
17:11:47 <jwy> 3. "then": build the result table, and select which of the columns from those available that you want in there
17:12:11 <jwy> basically, a form like the rules editor you might see in a mail client
17:12:36 <jwy> some of the fields will be dynamically populated based on other choices, and some will have autocompletion, to help pick values
17:12:59 <jwy> make sense?
17:13:18 <sarob> Yup to me
17:13:35 <sarob> Any questions team?
17:14:08 <sarob> Do you think this needs to be a spec
17:14:16 <sarob> Or just a code patch?
17:14:23 <jwy> an example of something that still needs to be worked out is what to do with tables whose columns don't have names
17:14:38 <jwy> i'll add these details to the existing spec
17:15:08 <sarob> Cool
17:16:15 <sarob> Anything else?
17:17:04 <sarob> #action jwy to update the existing horizon table spec
17:17:25 <jwy> that's it
17:17:34 <sarob> Alexsyip you're up
17:17:49 <sarob> Alexsyip it looked like you dropped
17:18:02 <sarob> Alexsyip so we continued on
17:18:12 <alexsyip> ok
17:18:21 <alexsyip> I was working on performance improvements
17:18:31 <alexsyip> for importing the initial table contents from a datasource driver.
17:18:48 <alexsyip> I made a few small changes that speed things up.
17:19:10 <alexsyip> I forget what the improvement was, but I think it was something between 3 to 10x faster
17:19:29 <sarob> Alexsyip oh that's all
17:19:39 <sarob> ;)
17:19:39 <alexsyip> We were generating a UUID for each row ( that turns out to be expensive)
17:20:05 <alexsyip> We were also computing a row has using a long process of creating a string, and then taking the hash of the string.
17:20:16 <alexsyip> So I changed that to compute a hash using a python-tuple instead.
17:20:23 <alexsyip> And then I started caching the hash values.
17:20:33 <alexsyip> I think that's all.
17:20:58 <alexsyip> The next thing I'll look at is memory consumption of table rows.
17:22:30 <sarob> Cool
17:22:51 <sarob> Who's next
17:23:01 <sarob> Radu_
17:23:30 <sarob> Madhuhuman?
17:24:28 <sarob> Samta
17:25:41 <sarob> Seeing if I can get cloudtoad to join us
17:26:02 <sarob> Hold on a minute
17:28:23 <sarob> Looks like he's stuck doing something else
17:28:52 <sarob> Anyone have design summit talks planned?
17:30:47 <jwy> eric lopez wants to apply to give a congress hands-on-lab
17:31:09 <sarob> Jwy it sound good
17:31:09 <jwy> sarob, do you know him?
17:31:15 <sarob> I do
17:31:36 <sarob> I've been discussing training and congress
17:31:59 <sarob> Jacob introduced me first day
17:32:07 <jwy> ok, cool
17:32:11 <sarob> Elo you there!
17:32:42 <rajdeepd> hi
17:33:01 <rajdeepd> i would also like to apply in helping for congress hands on lab
17:33:15 <sarob> Rajeepd certainly
17:34:06 <sarob> I am circulating ideas within Emc and VMware
17:34:24 <sarob> I will be posting publicly tomorrow
17:34:35 <sarob> What talks we have planned
17:35:08 <sarob> Anyone is welcome to help speak
17:35:27 <sarob> Voting up the talks and joining us are also welcome
17:36:31 <sarob> Pls offer up congress or other ideas if you have them
17:36:57 <sarob> Either here, email, or tweet
17:37:11 <sarob> So others can weigh in
17:37:24 <sarob> And you can get help
17:38:10 <sarob> That's all I have
17:39:10 <sarob> #action alexsyip working on table memory use
17:39:45 <sarob> #action sarob will blog post on planned summit talks
17:39:55 <sarob> Okey dokey
17:40:09 <sarob> I guess we can close early
17:40:30 <sarob> When you speak with other team members
17:40:52 <sarob> Remind them that irc meet attendance is important
17:41:10 <sarob> I'll make some inquires as well
17:41:17 <sarob> Cheers people
17:42:20 <sarob> #endmeeting