17:01:02 <pballand> #startmeeting CongressTeamMeeting
17:01:02 <openstack> Meeting started Tue Jul 15 17:01:02 2014 UTC and is due to finish in 60 minutes.  The chair is pballand. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:05 <openstack> The meeting name has been set to 'congressteammeeting'
17:01:08 <arosen> Hi!
17:01:13 <thinrichs> Hi all
17:01:14 <pballand> hello!
17:01:16 <kudva> Hi
17:01:21 <rajdeep> hi
17:01:29 <banix> hi
17:02:03 <pballand> last week, I said I would try to update the agenda on the wiki prior to the meeting - fail.
17:02:15 <pballand> the good news is I’m leaving room to improve :)
17:02:17 <sarob> moring
17:02:34 <sarob> :/
17:02:43 <arosen> :)
17:03:10 <pballand> I have a couple of high-level updates, then want to go through status again
17:03:43 <pballand> a big goal last week was to get the gate enabled, which it now is!
17:04:09 <arosen> woot woot
17:04:12 <pballand> we’ve hit a couple snags with requirements, but generally things seem to be working
17:04:14 <sarob> gate is goood
17:04:48 <thinrichs> It's good to mention that all the tests now run with tox.
17:04:56 <thinrichs> So tox -e py27 will run all the tests.
17:05:05 <pballand> thinrichs: good point
17:05:13 <thinrichs> It's a bit slow, so arosen has a patch that adds a script that runs a bit faster.
17:05:21 <rajdeep> thinrichs that is great
17:05:22 <pballand> some code has also been moved around a bit, to be more consistent with other projects
17:05:32 <kudva> thinrichs: so that is why the scripts directory has disappeared :), missed the last meeting
17:05:38 <arosen> yup ./run_tests.sh -N it avoids have to generate a tar of the congress directory :)
17:05:41 <pballand> so running the tests is no longer in scripts/ , etc
17:05:49 <arosen> https://review.openstack.org/#/c/105893/
17:06:13 <pballand> kudva: yup
17:06:23 <thinrichs> I'd recommend everyone using arosen's script if you want to run tests.
17:06:26 <sarob> faster is good
17:06:26 <thinrichs> tox is super slow.
17:06:41 <thinrichs> ./run_tests.sh -N —no-pep8 is what I usually use
17:06:54 <pballand> along with the big changes, have come a few conflicts, so some commits are taking longer to get in than we’d like
17:07:44 <kudva> thinrichs: do I need a particular branch to do that: ./run_tests.sh -N —no-pep8
17:07:48 <pballand> I expect things to calm back down over the next couple days though, unless arosen has another batch of restructuring proposals :)
17:07:57 <arosen> :)
17:08:00 <thinrichs> cherry-pick arosen's patch, which he linked to earlier.
17:08:13 <thinrichs> We should get the script merged in the next couple of days.
17:08:16 <kudva> thinrichs: got it
17:08:22 <thinrichs> Everyone's waiting on one of my changes.
17:08:27 <thinrichs> :(
17:09:15 <thinrichs> https://review.openstack.org/#/c/102951/
17:09:26 <thinrichs> But it's ready for another round of review
17:09:27 <pballand> the sooner we can get through the current backlog the better
17:10:16 <arosen> thinrichs:  I'll give it another round of review after the meeting. Hopefully we can get it in today.
17:10:26 <pballand> the other thing I wanted to touch base on was specs
17:10:34 <pballand> J-02 closes July 24
17:11:10 <pballand> from an incubation perspective, we want to follow the ‘official’ process as much as possible, so submitting specs for approval is important
17:11:45 <pballand> on the other hand, the project is in an early phase, so we don’t want to hamper innovation, so I plan on being flexible with submissions
17:12:09 <pballand> I do want to ensure that all features are associated with a spec, however
17:12:10 <sarob> can we vote/agree on what bp and spec to move to congress-specs?
17:12:28 <sarob> or just move everything and vote through gerrit?
17:12:49 <rajdeep> do we have a read me on how to author a spec / bp using rst for congress?
17:13:07 <arosen> sarob:  I think we should vote on gerrit
17:13:23 <pballand> rajdeep: https://wiki.openstack.org/wiki/Congress#How_To_Create_a_Blueprint
17:13:48 <pballand> there are only 7 blueprints currently proposed
17:14:00 <sarob> want me to move the guts over to the new project congress-specs?
17:14:01 <pballand> I expect 5 of them are definitely in
17:14:04 <arosen> So along the lines with blueprints:
17:14:18 <arosen> so the infra/config patch just merged to create congress-specs: https://github.com/stackforge/congress-specs
17:14:32 <sarob> pballand: we need to backport a few spec for existing bp
17:14:33 <arosen> should we migrate everything over?
17:14:45 <pballand> sarob: is there value in backporting?
17:15:17 <arosen> I set this up with the specs that are merged in congress (https://github.com/aaronorosen/congress-specs )  with unit tests to validate the format of the spec (shameless stolen from nova-specs :) )
17:15:19 <sarob> pballand: consistency
17:15:40 <sarob> pballand: i can do it. shouldnt be too much work
17:16:12 <pballand> if the work is ongoing, I think it is valuable to have a spec, but for completed work, I don’t see the need (but am not opposed if someone want’s to do it)
17:16:28 <sarob> #action sarob backport existing bp without spec to stackforge/congress-specs
17:16:33 <pballand> sarob: great, thanks for volunteering
17:17:15 <pballand> sarob: if you don’t mind moving existing specs over (and updating the docs), that would be great too
17:17:36 <sarob> #action sarob migrate existing openstack/congress/spec to stackforge/congress-specs
17:17:38 <pballand> everyone onboard with using congress-specs project instead of congress/specs now?
17:17:51 <arosen> yup makes sense to me.
17:17:56 <rajdeep> do we need any help with test coverage in API side
17:17:56 <sarob> yup
17:18:02 <pballand> #agreed specs now live in the congress-specs project
17:18:34 <pballand> is anyone considering adding any more specs at this time?
17:18:47 <pballand> (other than the backport by sarob)
17:18:58 <thinrichs> Before the summit?
17:19:03 <sarob> pballand: i will add the rest of the policy spec that got more than 2 votes
17:19:15 <rajdeep> kudva how is the ceilometer driver coming along?
17:19:27 <thinrichs> I assume we'd want specs for how we implement reactive enforcement (actions, etc.).
17:20:08 <thinrichs> That would be the only major spec I'd see writing before the summit
17:20:18 <kudva> rajdeep: I am working on the blueprint. I wanted to finish the builtin/runtime integration, which I just did
17:20:48 <kudva> rajdeep: once I am done with that (builtin/runtime), and check in next two days, full speed ahead on ceilometer blueprint for your review
17:21:03 <sarob> thinrichs: is that bp round out what we need to implement the two policy specs out there?
17:21:40 <pballand> ok, we still have plenty of time before feature freeze, but the sooner we publish specs, the more people can understand and help
17:21:55 <thinrichs> sarob: We'd need the reactive enforce spec and specs for each of the data source drivers we need.
17:22:09 <sarob> thinrichs: right
17:22:15 <thinrichs> I don't remember which data source drivers are necessary for those existing specs.
17:22:51 <sarob> thinrichs: i need to make source that work is identified in the policy specs
17:23:19 <thinrichs> sarob: agreed.
17:23:41 <sarob> i assume we will want some help from the respective projects on the plugin if not outright ownership?
17:23:53 <thinrichs> We don't need help from other projects.
17:24:04 <thinrichs> We just need to write code like is in congress/datasources/nova_driver.py
17:24:09 <pballand> as we close in on the policy specs, I expect we will want to tweak the datasource plugins, so I would expect associated specs to follow
17:24:18 <sarob> thinrichs: okay
17:24:58 <pballand> sarob: can you give an update on the mini-summit response?
17:25:31 <sarob> #action sarob verify policy specs have data source req identified
17:26:15 <sarob> pballand: mikal can only make 18-19 september
17:26:28 <sarob> pballand: so that looks like the date
17:26:41 <arosen> Far trip from Australia :)
17:26:43 * pballand updates calendar
17:26:54 <sarob> pballand: i believe mestery can make it, right?
17:27:36 <sarob> pballand: i have gotten various positive responses from the neutron team
17:28:16 <sarob> pballand: jharlow is coming
17:28:23 <arosen> Yup i know SumitNaiksatam said he could come.
17:28:50 <thinrichs> Perhaps we should circulate to the owners of blueprints on policy as well.
17:28:58 <thinrichs> We have a list of blueprints on the wiki.
17:29:00 <sarob> #info congress mid-cycle policy summit is set for 18-19 september in SF bay area
17:29:06 <mestery> sarob: Looking into it yet, but I *think* so, yes
17:29:20 <sarob> mestery: thank bro
17:29:22 <pballand> mestery: :)
17:29:45 <sarob> pballand: i want the heat people to join as well
17:30:29 <pballand> sarob: great
17:30:38 <SumitNaiksatam> arosen: yes, i am in!
17:30:46 <thinrichs> How about the swift people?
17:30:54 <sarob> pballand: general acceptance of sf area as the place
17:31:00 <thinrichs> They've actually released policy code
17:31:21 <sarob> thinrichs: notmyname is on my list to directly invite
17:31:37 <thinrichs> sarob: sounds good
17:31:49 <pballand> anyone from keystone?
17:32:35 <sarob> pballand: i havent reached out directly to anyone other than mikal and mestery yet
17:32:59 <sarob> pballand: now that i have a date i can start
17:33:37 <arosen> I've been talking to a few people in the keystone channel. I'll ping them to see if anyones interested.
17:34:02 <pballand> sarob: great, lets nail down a location (in the SF bay area) offline
17:34:20 <sarob> pballand: roger that
17:35:22 <pballand> since the repo has been under a lot of churn lately, I wanted to ask everyone to give a quick update on items they are working on that may impact others
17:35:42 <pballand> arosen: you’ve been moving a few things, would you mind going first?
17:35:47 <arosen> sure
17:36:21 <arosen> So I think this patch: https://review.openstack.org/#/c/105882/  - Refactor congress eventlet server code might have the biggest impact since I changed the eventloop in congress-server
17:36:46 <arosen> Hopefully, we'll be able to discuss this change in the congress channel later today if people are free.
17:37:00 <arosen> Patch for keystone integration (https://review.openstack.org/#/c/106911/) which is working but I still have some refactoring to do. We can disable the keystone auth via etc/congress.conf:   auth_strategy = noauth
17:37:36 <arosen> I hope this patch won't impact others because I was able to reuse the existing application that was already in congress.
17:37:46 <arosen> That's about it from me on changes I believe.
17:38:22 <thinrichs> I'll go.
17:38:38 <thinrichs> I have the implementation of the API data models that I linked earlier.
17:38:52 <thinrichs> https://review.openstack.org/#/c/102951/
17:39:00 <thinrichs> This should go in soon
17:39:31 <thinrichs> I'm working hard on integrating.  Bunch of bug fixes on top of arosen's Refactor eventlet patch and my API models patch.
17:39:43 <thinrichs> Think that's it.
17:40:11 <pballand> arosen, thinrichs: thanks
17:40:27 <pballand> anyone else?
17:40:31 <kudva> I'll go
17:41:06 <kudva> I had checked in some builtin/runtime integration earlier, after feedback from Tim added more tests for other (non-arithmetic) operator. It all works now :)
17:41:18 <kudva> Was going to check-in, but noticed the scripts directory missing
17:41:39 <kudva> so when I get a chance to run all the tests and have a clean run, will check in the code
17:41:56 <kudva> After that, the next step would be to do a ceilometer integration blueprint for Rajdeep's review
17:42:05 <pballand> kudva: do you have a spec for your change?
17:42:18 <kudva> pballand: the builtin change?
17:42:34 <kudva> https://review.openstack.org/#/c/99194/
17:43:04 <kudva> This does not have the additional tests I added, once I test locally using the new run_tests.sh, I'll complete and submit
17:43:51 <kudva> that's it from me
17:44:59 <sarob> im only working on rst right now, my stuff already inline
17:45:53 <pballand> I’m focusing on reviews and working with arosen on updating the event loop
17:46:20 <pballand> that’s all I have
17:46:25 <pballand> #topic Open Discussion
17:47:10 <pballand> any other items on people’s minds?
17:47:18 <sarob> the midcycle operators summit is happening 25-26 aug
17:47:49 <sarob> ideas on what / how to present policy to the operators?
17:48:06 <pballand> sarob: where is that held?
17:48:22 <sarob> rackspace san antonio tx
17:48:54 <thinrichs> For operators, I'd try giving them a mock-up of the kind of interaction we'd expect.  Slideware.
17:49:00 <sarob> #link http://sarob.com/2014/07/openstack-operators-mid-cycle-summit/
17:49:06 <pballand> what we would present depends on what we want from the operators
17:49:20 <pballand> I expect we would want use-cases
17:49:43 <pballand> in which case giving them an example of how congress can make their lives easier could help
17:50:01 <sarob> so a bit of inform what we are doing with policy and a lot of use cases from the operators
17:50:38 <sarob> sounds good to me
17:51:05 <pballand> I would think something like: “here’s something we know some operators do; here’s how to do it from the command line today, and here’s how to constantly evaluate that same workflow using congress"
17:51:53 <sarob> pballand: i like that.
17:52:09 <sarob> pballand: i can show off
17:52:13 <pballand> if we had one or two examples like that, I think it would set the right mindset for the operators to suggest their top pain points that could be addressed by congress
17:52:59 <sarob> pballand: add capacity, remove capacity
17:53:11 <arosen> One of the things i've been playing with with thinrichs is a policy to determine if an instance is uplinked to the internet.
17:53:25 <arosen> and if they have a security profile that matches X
17:54:10 <pballand> arosen: that sounds cool - is that hard for operators to determine today?
17:54:15 <arosen> We actually found that it's pretty hard to get all of this info would manually writing queries. I think a huge win for congress would be to provide an  easy way to do complex quires that we can't really do today easily.
17:54:32 <sarob> arosen: agreed
17:54:33 <arosen> all this info manually querying each component*
17:55:06 <arosen> For example, say you want to find which glance images are used on compute instances that are connected to the internet.
17:55:14 <arosen> One needs to query glance, nova,  and neutron
17:55:41 <arosen> and it requires multiple quries to neutron to determine if a port is able to go to the internet.
17:55:54 <arosen> i think that could be a good starting use case for operators.
17:56:24 <sarob> arosen: yes, i think that would go over well
17:56:39 <arosen> I know that at vmware we have this thing logsight that does all these graphs based on usage. It would be cool to hook some visuals that can query congress to make  interesting graphs.
17:56:48 <pballand> sarob: do we need to register for a slot to present?
17:56:57 <arosen> that operators would be interested in seeing.
17:57:14 <sarob> #action sarob will create mid-cycle operators summit policy session
17:57:30 <sarob> pballand: already on my list of to dos
17:57:46 <pballand> sarob: awesome, thanks!
17:58:03 <sarob> pballand: i am planned to help run so easy to add the session
17:59:15 <pballand> ok, that’s all the time we have this week
17:59:24 <pballand> thanks everyone for joining!
17:59:31 <sarob> cheers!
17:59:32 <arosen> Thanks! later
17:59:36 <thinrichs> Bye all!
17:59:44 <banix> bye
17:59:51 <pballand> #endmeeting