17:02:17 <pballand> #startmeeting CongressTeamMeeting
17:02:17 <openstack> Meeting started Tue Jul  1 17:02:17 2014 UTC and is due to finish in 60 minutes.  The chair is pballand. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:20 <openstack> The meeting name has been set to 'congressteammeeting'
17:03:38 <pballand> to start things off, I’m excited to announce that thinrichs was able to run congress with devstack and API last week
17:03:50 <sarob> Sweet
17:03:51 <pballand> (thinrichs is out this week)
17:04:01 <banix> cool
17:04:44 <pballand> just a very simple end-to-end test, but with the latest code in review, we have data-source plugins working inside the DSE framework, pulling data from nova and neutron, and exposing through the API
17:05:13 <pballand> the patch sets are fairly large, so help reviwing would be great
17:05:50 <sarob> I will start doing more
17:06:04 <pballand> on the API front, I pushed the dummy drivers, and worked with thinrichs to integrate the models that back to the policy
17:06:09 * sarob spread thin though
17:06:35 <pballand> am working on tests (shame on me for pushing sans tests) as well ans filling in the numerous holes in the API
17:06:56 <banix> pballand: do you have a list of patch sets? I see f ny Tim and a couple by you. are these all?
17:07:17 <pballand> #link https://review.openstack.org/#/q/project:stackforge/congress+status:open,n,z
17:07:47 <pballand> banix: the big ones are tagged ‘integ'
17:08:13 <banix> pballand: thanks
17:08:27 <sarob> I've got another #link https://review.openstack.org/#/c/101608/
17:09:07 <pballand> on the API, I received feedback that it is inconsistent to prefix APIs with /congress/api/v1/* as proposed, so I updated the spec
17:09:08 <sarob> Martin's first patch and all
17:09:25 <pballand> sarob: haha
17:09:52 <pballand> sarob: can you give an update on the specs?
17:10:13 <sarob> Sure
17:10:30 <sarob> I posted the spec bp steps to the wiki
17:10:51 <sarob> I locked down the use case gdoc
17:11:22 <sarob> The highest vote count is #link https://review.openstack.org/#/c/102935/
17:11:47 <sarob> Pushed the rst spec patch, a few reviews
17:12:09 <sarob> We need to debate it's merits on gerrit
17:12:27 <sarob> Update the rst patch with changes
17:12:46 <pballand> sarob: I will be sure to review
17:12:48 <sarob> And either pass this cycle or assign it to a Juno milestone
17:13:05 <sarob> Pballand thx
17:13:48 <sarob> If we all agree that this way of pushing spec bp is good
17:14:42 <pballand> it seems to be a reasonable format so far
17:14:54 <sarob> Then I will create the other < +2use cases policies as spec
17:15:27 <sarob> We should attempt to keep our bp and patches narrow
17:16:00 <sarob> That's is all I have on specs
17:16:28 <pballand> thanks sarob
17:16:48 <pballand> banix: anything to report?
17:17:24 <banix> I tried to follow the info in the readme file to do some testing but didn’t get far
17:17:48 <banix> Tim had suggested we file bugs so i am wondering if that is what we need to do
17:18:09 <banix> or we need to wait for the latests fpatches getting in first
17:18:12 <sarob> Generally on existing code
17:18:15 <pballand> banix: with the new patches, the dev environment should be easier
17:18:26 <pballand> but generally, scripts/run_tests should work
17:19:15 <pballand> one item that has been on my back burner for a while is re-enabling the gate tests - it currently doesn’t work because ‘make’ isn’t run in the virtualenv
17:19:23 <banix> coudn’t run the run_tests but didn’t spend much time trying to figure out wha the errors were about
17:19:45 <pballand> if anyone with strong tox-foo wants to jump in, that would be helpful :)
17:21:04 <pballand> that’s helpful feedback, now that we have the functionality skeleton, we should be able to focus more on stability
17:21:39 <banix> so for the tests you did, you included some of the under review patchsets? or from the git?
17:22:38 <pballand> thinrichs has a bunch of tests in his patches - I’m woefully behind from the API standpoint
17:23:24 <banix> ok; just wanted to see if i should spend time debugging the current code or wait for the patches to land
17:23:55 <aaronorosen> Hi, sorry I'm late. Looking to start helping out in congress though.
17:24:02 <pballand> if you are able to, pulling the new patches and testing / providing code review would be very helpful
17:24:13 <sarob> Arosen morning
17:24:18 <pballand> hi arosen, good to see you!
17:24:19 <arosen> hiya sarob
17:24:59 <sarob> Just mentioning the gate tests
17:25:22 <sarob> Pballand is that a starting point for arosen?
17:25:27 <pballand> arosen: were just going through some status updates - mind updating us on what you’re working on?
17:25:39 <arosen> sure, i'm starting to work on the client for congress.
17:25:46 <arosen> I got a patch up to create the stackforge repo.
17:25:54 <sarob> Nice
17:26:18 <arosen> I'm trying to figure out the best way to go about creating the client. My current thought is to try and piggy back on the python-openstackclient work
17:26:34 <arosen> So I'm still sorting through that but hopefully should have something up for review there shortly :)
17:27:00 <arosen> that's it from me.
17:27:37 <pballand> great, thanks arosen - it’s great to have you on board!
17:28:06 <pballand> #topic open discussion
17:28:20 <skn_> Sorry, I’mlate
17:28:21 <pballand> that’s all I had; anyone have open items they’d like to discuss?
17:28:34 <sarob> I do
17:28:38 <pballand> hi skn_ glad you could make it
17:28:47 <sarob> Hey skn_
17:29:13 <pballand> sarob: fire at will
17:29:33 <sarob> So I was prepping for the spec on Openstack upgrades
17:29:55 <sarob> I found #link https://review.openstack.org/#/c/95907/
17:30:20 <sarob> Heat team is working on very similar
17:30:50 <sarob> I spoke with ptl, interested in working together
17:32:00 <sarob> It looks like we will be able make admin upgrades happen by policy
17:32:13 <sarob> With a lot of help from our heat friend
17:32:16 <sarob> S
17:32:37 <sarob> The spec will reflect of this
17:32:42 <sarob> That's all
17:33:14 <arosen> sarob: cool, i'll read through that spec looks like a good usecase.
17:33:48 <sarob> Pretty common activity
17:33:59 <sarob> Yup
17:34:12 <pballand> that’s very interesting - from skimming the spec, it looks like congress is positioned to handle the ‘observed state’, and achieve ‘desired state’ through policy - it would still be up to heat to take the desired state and translate that to actions on the infrastructure
17:34:17 <banix> sarob: nice. will read.
17:34:39 <pballand> will definitely read more carefully :)
17:34:58 <sarob> Pballand yup, it's great timing they are starting this effort now
17:35:47 <sarob> More help and collaboration equals maximum goodness
17:36:09 <arosen> :)
17:37:06 <sarob> We should schedule a congress mini summit, closer to Juno-m2
17:37:27 <skn_> Sounds like a plan :)
17:37:27 <sarob> Get our team and collab project leads together
17:37:41 <sarob> Mestery mstill etc
17:37:45 <pballand> that’s a great idea
17:38:29 <sarob> #action sarob work with teams on jm2 mini summit
17:38:43 <skn_> And what’s the goal: to come up with a blueprint?
17:39:40 <sarob> Skn_ I'd expect more are we in sync with our bp deliver dates
17:39:55 <sarob> Coordination between projects
17:40:09 <skn_> Got it!
17:40:13 <sarob> What's broken and not stuff
17:40:19 <skn_> sarob: That’ll be great
17:40:25 <sarob> ;)
17:40:46 <skn_> Better interfacing
17:41:06 <skn_> between congress and other policy and core projects?
17:41:15 <sarob> Synergy, yessss
17:41:26 <sarob> Skn_ yup
17:42:09 <skn_> I’m all for it, it would be very useful
17:42:10 <sarob> I'm thoughted out
17:42:19 <sarob> Skn_ cool
17:42:46 <pballand> great ides, thanks sarob
17:43:16 * sarob stopped clock is right twice a day
17:43:44 <pballand> that’s it for this week
17:43:54 <banix> bye all
17:44:02 <pballand> looking forward to seeing progress on code, specs and reviews
17:44:05 <sarob> See ya
17:44:07 <pballand> bye!
17:44:13 <pballand> #endmeeting