17:03:35 <pballand> #startmeeting CongressTeamMeeting
17:03:35 <openstack> Meeting started Tue Jun 17 17:03:35 2014 UTC and is due to finish in 60 minutes.  The chair is pballand. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:39 <openstack> The meeting name has been set to 'congressteammeeting'
17:03:59 <pballand> I think thinrichs will be a bit late
17:04:05 <pballand> so lets get started
17:04:10 <pballand> agenda:
17:04:17 <pballand> - Reviews: sarob, banix, pballand
17:04:18 <pballand> - sarob: worked on getting processes in place
17:04:19 <pballand> - rajdeep: looked into ceilometer
17:04:21 <pballand> - use cases
17:04:22 <pballand> - pballand's API progress
17:04:23 <pballand> - thinrich's integration progress
17:04:24 <pballand> - skn_ adds data sources to use case doc
17:04:57 <pballand> #topic Code Reviews
17:05:23 <pballand> we are starting to get behind on code reviews - it would be really helpful if people could pitch in
17:05:44 <banix> I did some really first glance reviews. Will spend more time this week.
17:05:56 * banix blames the world cup!
17:06:12 <pballand> hehe
17:06:27 <pballand> I’ve been guilty of this as well, but trying to get better
17:06:59 <pballand> #topic Action item review
17:07:09 <pballand> sarob: you around?
17:07:33 <cloudtoa_> ping
17:07:37 <pballand> rajdeep_: you were going to look in to ceilometer - any updates?
17:08:05 <rajdeep_> pballand : did some research on attributes available in ceilometer
17:08:12 <rajdeep_> and how to access them --
17:08:25 <rajdeep_> created a doc https://docs.google.com/document/d/17IFyQLhwJRvvS0PYWLWlurH4o845YuLvu07K6TryrUg/edit#heading=h.nztjf141izg0
17:08:53 <rajdeep_> we should be able to get the information sergio wants through APIs
17:09:13 <rajdeep_> i created some samples to test this
17:09:25 <kudva> Where can I see the samples?
17:10:23 <rajdeep_> https://github.com/rajdeepd/openstack-samples/tree/master/lab1/ceilometersamples
17:10:53 <rajdeep_> currently i am getting a dump of the attributes listed in the doc
17:11:10 <rajdeep_> we could do some smart querying also where ever applicable
17:11:49 <cloudtoa_> Can ceilometer publish to mq?
17:11:52 <kudva> so I see you are exercising the apis. How does this connect to the data store?
17:12:17 <pballand> how frequently does ceilometer publish messages (in production)?
17:12:23 <rajdeep_> which data store?
17:13:01 <kudva> The congress data tables
17:13:23 <kudva> I mean what is the integration between Ceilometer API and Congress
17:14:06 <rajdeep_> kudva :  we will have to write the driver to get this data converted to tuples
17:14:25 <rajdeep_> pballand :  that depends on the meter type and the default frequency set
17:14:32 <kudva> rajdeep_: okay got it
17:14:47 <rajdeep_> i guess the rate at which metrics are collected could be altered - though i have not tried that yet
17:15:41 <cloudtoa_> rajdeep_:  Can ceilometer publish to oslo.messaging or AMQP?
17:15:52 <rajdeep_> i think it does
17:16:35 <pballand> rajdeep_: great, are you planning any next steps?
17:16:58 <rajdeep_> here is the design doc explaining in more detail
17:17:01 <rajdeep_> http://docs.openstack.org/developer/ceilometer/architecture.html
17:17:17 <rajdeep_> pballand : it depends on how we want to prioritize
17:17:27 <rajdeep_> shoud we write a driver for ceilometer
17:18:20 <kudva> rajdeep_: I have worked some with Ceilometer, and written code using the apis, I can help
17:18:34 <rajdeep_> deisgn doc recommends using API rather than messaging
17:18:40 <pballand> it seems like people were interested in that from a use case perspective - anyone else have thoughts?
17:18:54 <rajdeep_> kudva :
17:18:57 <cloudtoa_> I am working on an oslo.messaging plugin for Congress... this could be used to subscribe to ceilometer events.
17:19:00 <kudva> rajdeep_: yes definitely api's, ceilometer uses the notifications
17:19:13 <rajdeep_> that is great, why don't you start creating a design doc for the ceilometer driver
17:19:26 <cloudtoa_> ok
17:19:33 <kudva> rajdeep_: I can do that, but I need to understand the driver side better.
17:19:38 <kudva> rajdeep_: from you
17:19:50 <kudva> rajdeep_: not familiar with the congress data drivers
17:20:24 <rajdeep_> kudva : you could start looking at the data integration design doc as well as neutron and nova drivers
17:20:40 <kudva> rajdeep_: okay, can you remind me again the links
17:20:47 <rajdeep_> to get a better idea
17:20:50 <kudva> rajdeep_: for the docs
17:21:00 <kudva> rajdeep_: I can find the code
17:21:07 <pballand> I know thinrichs has been working on integrating the data source drivers with the DSE runtime as well…
17:22:01 <pballand> cloudtoa_: how much will the oslo.messaging change things?
17:22:50 <cloudtoa_> Well, it means we'll be able to subscribe to notifications or other pub'd data on whatever MQ is being used.
17:23:04 <cloudtoa_> Across multiple OpenStack clouds.
17:23:30 <cloudtoa_> Oslo does a great job of abstracting the MQ stuff.
17:23:53 <rajdeep> kudva : link to the doc https://docs.google.com/document/d/1K9RkQuBSPN7Z2TmKfok7mw3E24otEGo8Pnsemxd5544/edit
17:24:06 <pballand> #link  https://docs.google.com/document/d/1K9RkQuBSPN7Z2TmKfok7mw3E24otEGo8Pnsemxd5544/edit
17:24:12 <sarob_> sorry im late
17:24:44 <pballand> sarob_: no problem - was going to ask you to provide an update on the process
17:24:58 <pballand> (blueprints, etc)
17:25:03 <kudva> rajdeep: thanks!
17:25:12 <kudva> rajdeep: how can I contact you with questions?
17:25:35 <rajdeep> kudva : you can mail me : rajdeepd at vmware dot com
17:25:47 <sarob_> okay
17:25:54 <sarob_> ready now?
17:25:58 <pballand> yep
17:26:06 <kudva> rajdeep: okay, thanks will be in touch
17:26:12 <sarob_> here i go
17:26:35 <sarob_> we are setup up launchpad https://launchpad.net/congress
17:26:39 <sarob_> #link https://launchpad.net/congress
17:27:07 <sarob_> set us on the juno series with the next milestone as juno-2
17:27:11 <sarob_> 24july
17:27:41 <sarob_> we specs to get pushed, reviewed, and merged
17:27:56 <sarob_> so we can start assigning blueprints to the juno-2 milestone
17:28:13 <sarob_> its openstack scrumy
17:28:21 <sarob_> or as close as it gets
17:28:26 <sarob_> without storyboard
17:29:41 <sarob_> so questions, commennts?
17:29:53 <pballand> sarob_: thanks for pushing that forward
17:29:57 <sarob_> sure
17:30:08 <cloudtoa_> sarob_:  We have our own IRC channel now?  Will future meetings be there?
17:31:01 <pballand> I don’t think there is logging on that channel, so meetings should stay here
17:31:05 <sarob_> id recommend keeping the meeting as it
17:31:31 <sarob_> and using the congress channel for non meeting technical discussions
17:31:41 <pballand> any other questions on process before we move on to use cases?
17:31:42 <sarob_> thats how most others do it
17:31:46 <cloudtoa_> Excellent.
17:31:58 <rajdeep> should we convert the design docs to blueprints?
17:32:27 <sarob_> this is what i wrote up #link https://wiki.openstack.org/wiki/Training-guides#Create_a_Blueprint
17:32:38 <sarob_> for training-guides project
17:32:46 <sarob_> i think it works for congress too
17:33:21 <sarob_> altho we have #link https://docs.google.com/document/d/1ExDmT06vDZjzOPePYBqojMRfXodvsk0R8nRkX-zrkSw/edit# to help with the spec ideas
17:34:02 <sarob_> we need more people than sarob and banix
17:34:13 <sarob_> to review the use cases gdoc
17:34:18 <pballand> on that topic, it seems that momentum has stalled on updating use cases
17:34:30 <pballand> we are still looking for votes on topics
17:34:40 <sarob_> i can start the spec patches for the ones with the most votes
17:35:39 <pballand> sarob_: that would be great - although right now most use cases are tied with one vote :)
17:35:59 <sarob_> pballand can you take a vote on a few?
17:36:11 <pballand> will do
17:36:23 <pballand> #action pballand to review and vote on use cases
17:36:56 <sarob_> thinrichs two
17:37:19 <pballand> does anyone have something to discuss related to use cases?
17:37:33 <sarob_> ill start patches once i get any with a few votes for review
17:37:48 <sarob_> we can bypass this extra step pretty quickly
17:38:08 <sarob_> and just go straight to spec patches for debate through gerrit review
17:38:11 <skn_> Hi Guys, sorry, I’m late.
17:38:26 <pballand> skn_: hi - glad you could make it
17:38:32 <sarob_> hallo
17:38:38 <pballand> we were just talking about use cases
17:38:48 <banix> sarob_: makes sense
17:39:01 <pballand> skn_: you had mentioned that you were going to add data sources to the use case doc - any progress on this or other topics?
17:39:08 <skn_> I have some write up on the data sources for the security use cases that I have not been able to update to the main doc
17:39:19 <sarob_> you know what, pballand after you take a look at the use cases/user stories
17:39:37 <sarob_> i will just go ahead can create all the spec patches
17:39:42 <skn_> Yes, I’ve some stuff that I’m going to put in within the next couple days
17:39:53 <sarob_> and we can discontinue this gdoc as extra step
17:39:55 <pballand> sarob_: that would be great - I’ll set aside time this afternoon
17:40:31 <sarob_> pballand how about i copy #link https://wiki.openstack.org/wiki/Training-guides#Create_a_Blueprint to the congress wiki
17:40:39 <skn_> sarob: so, the plan is to update just the spec and we get rid of the gdoc?
17:40:53 <sarob_> idea -> spec -> blueprint process
17:41:10 <sarob_> skn_ right
17:41:10 <pballand> sarob_: sure - can you annotate the google doc link as deprecated at the same time?
17:41:34 <sarob_> pballand will do plus add URLs for reviews
17:42:13 <sarob_> ive deprecated use of trello for the training team as well
17:42:21 <sarob_> in favor of spec, blueprints
17:42:36 <sarob_> so we are more similar to rest of openstack projects
17:43:33 <skn_> Makes sense
17:43:43 <pballand> sarob_: thanks for keeping us on track there
17:44:09 <sarob_> ;)
17:44:30 <skn_> sarob: what’s the difference between a spec and a blueprint
17:45:01 <sarob_> skn_ spec is the pre-blueprint development
17:45:20 <skn_> that’s kind of clear, what additional stuffs do we need for the bp?
17:45:38 <sarob_> skn_ your idea get explained by filling out the spec template
17:46:09 <sarob_> skn_ saved as RST and pushed as gerrit patch
17:46:11 <banix> i think bp mainly helps with having milestones and tracking them etc
17:46:26 <sarob_> skn_ then reviewers debate the idea merits
17:46:36 <sarob_> skn_ clean it up some
17:47:01 <banix> specs mainly says what is to be done, the specification of proposed changes/additions; and review can be done efficiently
17:47:12 <skn_> banix: thanks
17:47:34 <sarob_> skn_ if approved then the merged patch info finishes out a blueprint and it gets approved for a milestone
17:47:44 <skn_> sarob: I think I understand the spec part now, was curious to know what more for the BP
17:47:55 <skn_> Got it
17:48:11 <pballand> really quickly on the API front, I have stubbed out the commands from the design doc, and will push to review soon.  For the alpha, I am planning on calling in to the policy engine directly for the data (policy engine as source-of-truth), and will refactor calls over message bus later
17:48:18 <pballand> #topic open discussion
17:49:15 <thinrichs> Hi all--sorry I'm so late.
17:49:31 <thinrichs> I've made progress on integrating the DSE, policy engine, and data sources.
17:49:53 <thinrichs> I now have a test that spins up two mocked up versions of Neutron, writes a policy over them, and we see reasonable results.
17:50:06 <cloudtoa_> Sweet!
17:50:44 <rajdeep> that is great!
17:50:44 <skn_> thinrichs: great
17:50:47 <thinrichs> Next step I'll try is getting rid of the mocks and talking to actual Neutron/Nova instances.
17:51:38 <thinrichs> There will be a few more change-sets to review.  I'll let you know when they're ready.
17:52:12 <pballand> thinrichs: cool!
17:52:26 <pballand> thinrichs: sarob_ and I signed you up for voting on use cases
17:52:42 <sarob_> so i can start creating spec patches
17:52:50 <thinrichs> There are a few more changes we'll need to hook up to the API (assigning IDs for rules, etc.).  But should be straightforward.
17:52:55 <sarob_> we need #link https://review.openstack.org/#/c/94692/ merged first though
17:52:55 <skn_> pballand: how do I sign up to vote?
17:53:01 <thinrichs> pballand, sarob_: by all means
17:53:09 <thinrichs> I'm happy to vote.
17:53:10 <sarob_> review #link https://docs.google.com/document/d/1ExDmT06vDZjzOPePYBqojMRfXodvsk0R8nRkX-zrkSw/edit#heading=h.fbota2qx0jad
17:53:12 <pballand> skn_: just put your name on the google doc :)
17:53:18 <skn_> oh ok
17:53:22 <sarob_> and i will create the spec patches from the gdoc
17:53:30 <thinrichs> I took a quick look at the doc--are there plans to add the requisite data sources?
17:53:43 <thinrichs> sarob_: great!
17:54:00 <sarob_> thinrichs we can add that either in the gdoc
17:54:10 <sarob_> thinrichs: and i will write it up in the first patch
17:54:31 <sarob_> thinrichs: or you can add to the patch after I push the first version
17:54:34 <thinrichs> So the votes are for what I like, not necessarily what's technically easiest to get into place?  That the idea?
17:54:49 <sarob_> thinrichs: either
17:54:59 <skn_> I only see votes from sarob and banix in this gdoc
17:55:17 <skn_> pballand: where are yours? Or, am I seeing the wronggdoc?
17:55:18 <sarob_> thinrichs: change up what is written and add more user stories/use cases
17:55:32 <pballand> skn_: I haven’t voted yet
17:55:49 <skn_> pballand: got it
17:56:09 <thinrichs> sarob_: right--I forgot to add our basic use case, didn't I?  I'll try to get that done as well.
17:56:17 <sarob_> sweet
17:56:37 <sarob_> ill plan on spec patches later today
17:56:42 <skn_> pballand: Can we add the slides that you used in OS summit to the congress wiki page?
17:57:02 <pballand> skn_: yeah, I can do that
17:57:05 <skn_> Or, are they already there?
17:57:06 <thinrichs> How about we link to the OS summit page?
17:57:08 <skn_> Ok
17:57:29 <skn_> Do we have the slides there in the summit page, or just the video?
17:57:31 <thinrichs> Or is it easy to upload arbitrary files to the wiki?
17:57:51 <pballand> the slides are linked from the etherpad from the summit
17:58:18 <banix> not easy to upload files last i tried to do that
17:58:40 <skn_> Then, may be we can add links to the etherpad and the video
17:58:41 <sarob_> linking somewhere else is prob besetg
17:59:17 <skn_> Could you please just add these two links, pballand?
17:59:28 <pballand> we’re collecting quite a few links on the wiki - does it make sense to add it there?
17:59:56 <skn_> Yeah, in the wiki.  I don’t think it makes sense to do that in any gdoc
18:00:00 <pballand> ok
18:00:05 <pballand> out of time
18:00:08 <thinrichs> Maybe it's time for subheadings on the links, or something.
18:00:11 <pballand> any last workds?
18:00:15 <sarob_> btw, there is a few reviews lining up #link https://review.openstack.org/#/q/status:open+project:stackforge/congress,n,z
18:00:16 <pballand> words
18:00:36 <pballand> ok, we’ll be in #congress
18:00:38 <sarob_> all for me
18:00:47 <pballand> thanks all!
18:00:49 <skn_> bye everyone
18:00:51 <pballand> #endmeeting