10:02:46 <DinaBelova> #startmeeting climate
10:02:46 <bauzas> fyi, swann is on maternity leave :)
10:02:47 <openstack> Meeting started Mon Dec  2 10:02:46 2013 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:02:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:02:50 <SergeyLukjanov> bauzas, happy b-day
10:02:51 <openstack> The meeting name has been set to 'climate'
10:03:01 <DinaBelova> bauzas, yeah :)
10:03:14 <bauzas> so he won't be there for the next month
10:03:14 <DinaBelova> Linkedin says you've got b-day :)
10:03:21 <bauzas> oh, ty all :)
10:03:32 <DinaBelova> bauzas, ok
10:03:45 <bauzas> swann just had a baby today, so we will have same-bday 33 years difference: )
10:03:55 <DinaBelova> :D
10:03:56 <SergeyLukjanov> :)
10:03:57 <DinaBelova> I suppose today we'll have not so much people here
10:04:05 <DinaBelova> Nick is not available today
10:04:20 <DinaBelova> he will be in office only tommorow
10:04:22 <DinaBelova> ok
10:04:24 <bauzas> ok
10:04:30 <DinaBelova> let's start
10:04:33 <bauzas> let's start then
10:04:34 <bauzas> :)
10:04:38 <DinaBelova> #link https://wiki.openstack.org/wiki/Meetings/Climate
10:04:55 <DinaBelova> I'm glad we have not large agenda today
10:05:02 <DinaBelova> #topic Action items from the last meeting
10:05:11 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/climate/2013/climate.2013-11-25-09.59.html
10:05:15 <bauzas> sure
10:05:36 <DinaBelova> ok, let's go through action items
10:05:40 <bauzas> sure, there are 5
10:06:11 <DinaBelova> Nick had no opportunity to work with his one, I suppose
10:06:23 <DinaBelova> because he left Saratov at the middle of the week
10:06:36 <bauzas> https://review.openstack.org/#/c/52296 was rebased
10:06:47 <bauzas> I can do a quick review
10:07:03 <DinaBelova> ok, but I see your comments there
10:07:06 <DinaBelova> already :)
10:07:27 <DinaBelova> So I think you've did one :)
10:07:56 <bauzas> ok, I just need to see if the new patchsets amend some changes I commented
10:08:04 <bauzas> no specific action for that
10:08:10 <DinaBelova> ok
10:08:20 <bauzas> but let's conduct the same action for Nikolay
10:08:28 <DinaBelova> ok
10:08:34 <bauzas> as eavesdrop doesn't have the possibility to backlog actions
10:08:37 <DinaBelova> #action Nikolay_St Review comments from bauzas on https://review.openstack.org/#/c/52296 and amend patch
10:08:53 <DinaBelova> the next one was Scope Climate 0.1
10:09:00 <DinaBelova> I decided to create topic for it
10:09:03 <bauzas> ok, can we discuss that on the next topic item ?
10:09:07 <bauzas> ok
10:09:12 <DinaBelova> +1
10:09:15 <DinaBelova> next three
10:09:22 <DinaBelova> were for you, Sylvain
10:09:27 <bauzas> ok, then  the next three
10:09:43 <bauzas> https://review.openstack.org/#/c/57650 is merged
10:09:48 <DinaBelova> yep
10:10:18 <DinaBelova> As for policies - Yuriy is now looking on policies in Nova, as I know
10:10:30 <bauzas> https://review.openstack.org/#/c/57200 is for reviewing
10:10:33 <bauzas> ok
10:10:37 <bauzas> good to know
10:10:50 <bauzas> on a side note, I just want to raise a flag at the end of the meeting
10:10:55 <DinaBelova> there are several strange things there, as you remember
10:11:07 <DinaBelova> bauzas, you meen?
10:11:17 <bauzas> just meaning I'm a busy man :)
10:11:26 <bauzas> with 5 open reviews plus Swann's ones :)
10:11:26 <DinaBelova> oh, ok
10:11:29 <DinaBelova> lost meaning
10:11:35 <DinaBelova> :D
10:11:39 <DinaBelova> ok
10:12:00 <bauzas> action 5. is targeted as soon as the fix is merged
10:12:15 <DinaBelova> yeah, I see it
10:12:18 <bauzas> because I don't want to open a bug related on a change on review
10:12:21 <DinaBelova> let's keep this action
10:12:33 <DinaBelova> #action bauzas Open a bug for exception handling with code
10:12:39 <DinaBelova> for this meeting too
10:12:42 <bauzas> oh !
10:12:50 <bauzas> the review has been merged
10:12:54 <bauzas> totally missed it !
10:13:01 <DinaBelova> don't worry
10:13:04 <bauzas> busy busy man :)
10:13:04 <DinaBelova> that's ok
10:13:12 <bauzas> ok, will do at the end of the meeting :)
10:13:18 <DinaBelova> that's it for action items
10:13:24 <DinaBelova> we had no many of them
10:13:29 <bauzas> yup
10:13:37 <DinaBelova> #topic Scope for Climate 0.1
10:13:39 <bauzas> can we just speak about reviews ?
10:13:46 <bauzas> ok let's discuss during open discussion
10:13:51 <bauzas> so for the scope
10:13:53 <DinaBelova> oh, let's move it to open
10:13:54 <DinaBelova> yes
10:14:01 <DinaBelova> I've got several thoughts on it
10:14:09 <bauzas> sure
10:14:26 <DinaBelova> I believe there are only two major things
10:14:36 <DinaBelova> we should really mark as needed for the 0.1
10:14:44 <DinaBelova> - support for one virtual reservation (Nova instances)
10:14:47 <DinaBelova> - support for one hardware reservation (compute hosts)
10:14:53 <bauzas> yup think so as well
10:14:56 <DinaBelova> And we should do it asap. And then add everything else. All other projects used 0.1 version to implements basic things that projects cannot exist about. I suppose these two opportunities are just these things.
10:15:04 <DinaBelova> As for compute hosts, I hope we’ll merge these changes soon after some more review cycles.
10:15:06 <bauzas> all BPs should be tagged consequently
10:15:14 <DinaBelova> yes
10:15:22 <DinaBelova> #action DinaBelova make Climate Launchpad support 0.1, … , 0.X release series.
10:15:27 <bauzas> let's use 0.1 tag ?
10:15:34 <bauzas> for BPs ?
10:15:37 <DinaBelova> yes, as agreed on last meeting
10:15:40 <bauzas> ok cool
10:15:52 <DinaBelova> As for instances, Nick start checking shelved instances POC, and he says, it looks really like a thing we need. So I hope new patch set for the https://review.openstack.org/#/c/49142/ will be soon.
10:16:00 <bauzas> just one note about physical reservations
10:16:01 <SergeyLukjanov> 0.1.X series with 0.1, 0.1.rc1, 0.1.1 (potentially) milestones
10:16:09 <bauzas> SergeyLukjanov: +1
10:16:12 <DinaBelova> SergeyLukjanov, good idea
10:16:14 <DinaBelova> +1
10:16:20 <DinaBelova> bauzas, yes?
10:16:25 <SergeyLukjanov> that's a common versioning, not my idea :)
10:16:34 <bauzas> there is just a little confusion about what the reviews are for :)
10:16:36 <DinaBelova> still good one
10:16:44 <SergeyLukjanov> DinaBelova, I'll help you with setting up correct series/milestones
10:16:54 <bauzas> so, basically, we have different reviews for implementing this
10:17:02 <SergeyLukjanov> from pov one non-fake plugin is enough to release 0.1
10:17:22 <bauzas> the review I'm currently working on, about provisioning, is not the end-user API :)
10:17:33 <DinaBelova> oh, yeah
10:17:39 <DinaBelova> I remember that
10:17:55 <DinaBelova> that's admin API, afair
10:18:01 <bauzas> for any reason I don't understand, this review is tagging the incorrect BP
10:18:16 <bauzas> I have to fix this for proper clarifications
10:18:22 <DinaBelova> bauzas, I think you may fix it asap
10:18:24 <DinaBelova> yes
10:18:28 <bauzas> yup
10:18:37 <SergeyLukjanov> are you expecting many reviews for one bp?
10:18:42 <DinaBelova> #action bauzas fix BP links for Host Reservation opportunity
10:18:55 <bauzas> SergeyLukjanov: nope, only 2 for provisioning hosts
10:19:03 <SergeyLukjanov> k
10:19:10 <bauzas> one for the API, one for the Manager
10:19:18 <SergeyLukjanov> and it's a part of Host Reservation
10:19:21 <SergeyLukjanov> yep?
10:19:23 <bauzas> I just wanted to decorrellate this
10:19:33 <bauzas> yup, an admin endpoint only
10:19:50 <DinaBelova> The last thing for the 0.1 scope is date for the release. I suppose we'll look on progress here
10:19:51 <SergeyLukjanov> bauzas, and you have bps for other parts?
10:20:03 <bauzas> SergeyLukjanov: yup
10:20:07 <SergeyLukjanov> great
10:20:21 <SergeyLukjanov> as for the release date, it'll be cool to have some kind of deadline
10:20:27 <DinaBelova> As for date, It seems to me it should be released before New Year :)
10:20:54 <bauzas> DinaBelova: I have to chase up in order to see if francois can help
10:20:58 <DinaBelova> but I had no opportunity to speak with Nick to provide some deadline for instances feature
10:21:30 <bauzas> Swann's leave is not really an issue, as we planned his absence
10:21:33 <SergeyLukjanov> let's start from the question - do we want to have EAP release with min functionality (one plugin) or we want to enable both virt and hard reservations to it?
10:22:07 <bauzas> SergeyLukjanov: as per the community feedback we had from the Summit, I think we need both
10:22:12 <bauzas> sorry about that :)
10:22:52 <DinaBelova> SergeyLukjanov, I'm good with having first release with only one working plugin. But on summit we had much problems with telling people Climate supports both virt and hard reservations
10:22:55 <SergeyLukjanov> ok, so, bauzas, DinaBelova, what's your estimates about completing corresponding plugins?
10:23:11 <bauzas> ETA by end of the year as said
10:23:20 <bauzas> for basic host reservatiosn
10:23:29 <DinaBelova> I suppose that's the same for vortual ones
10:23:33 <SergeyLukjanov> makes sense for me to have both virt and hard reservations to be clear for users
10:23:51 <DinaBelova> Nick is actively working on instances plugin
10:23:52 <DinaBelova> ok
10:24:10 <bauzas> I'm chasing up people commitment on Climate for hosts reservatiosn
10:24:21 <SergeyLukjanov> 1-2 weeks should be scheduled for the code freeze and testing before the release
10:24:21 <bauzas> should get a better visibility next week
10:24:30 <DinaBelova> #agreed V0.1 scope support for one virtual reservation (Nova instances)
10:24:36 <DinaBelova> #agreed V0.1 scope support for one hardware reservation (compute hosts)
10:24:46 <DinaBelova> ok
10:24:48 <SergeyLukjanov> ++
10:24:58 <DinaBelova> bauzas, great
10:25:17 <DinaBelova> SergeyLukjanov proposed next our topic
10:25:24 <DinaBelova> I think we may go to it
10:25:24 <bauzas> sure
10:25:29 <SergeyLukjanov> hm
10:25:36 <DinaBelova> #topic Devstack gating
10:25:45 <SergeyLukjanov> it's still not very clear for me aboud releasing ;)
10:25:55 <DinaBelova> SergeyLukjanov, oh
10:25:57 <SergeyLukjanov> lat's #undo to the prev. topic
10:26:01 <SergeyLukjanov> let's
10:26:08 <DinaBelova> #undo
10:26:09 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x35e46d0>
10:26:28 <SergeyLukjanov> don't think that it's command works ok with topics
10:26:40 <SergeyLukjanov> what's about release process?
10:26:43 <DinaBelova> It wrote 	 Removing item from minutes: <ircmeeting.items.Topic object at 0x35e46d0>
10:26:55 <SergeyLukjanov> but topic isn't rollbacked
10:27:05 <DinaBelova> yes, see it
10:27:08 <SergeyLukjanov> don't worry
10:27:30 <SergeyLukjanov> you can use milestone-proposed branch as all OpenStack projects
10:27:43 <SergeyLukjanov> or some simplified process
10:27:52 <bauzas> mmm
10:28:08 <DinaBelova> SergeyLukjanov, may you describe both of them?
10:28:15 <DinaBelova> in several words?
10:28:32 <bauzas> SergeyLukjanov: that sounds interesting, but I think that's more likely related to Openstack lifecycle, not V1 :)
10:28:55 <SergeyLukjanov> m-p branch created week before the milestone to land patches only for it, and master is opened in this time for the next ml dev
10:29:30 <SergeyLukjanov> bauzas, it could be much easier to use correct lifecycle from scratch but it's absolutely not important for the v1
10:29:45 <SergeyLukjanov> I'd like to set some dates for freeze at least
10:29:52 <SergeyLukjanov> like -1w for testing
10:30:02 <DinaBelova> I think that's good idea
10:30:19 <DinaBelova> to land only milestone related features
10:30:24 <DinaBelova> and bug fixes
10:30:26 <SergeyLukjanov> nop
10:30:31 <bauzas> well, why not
10:30:36 <SergeyLukjanov> to land only critical bug dixes
10:30:41 <DinaBelova> on the v1 branch
10:30:46 <DinaBelova> SergeyLukjanov, yes
10:30:53 <DinaBelova> missed that word :)
10:31:15 <bauzas> critical bug dixies ? :D
10:31:21 <DinaBelova> :D
10:31:25 <SergeyLukjanov> heh :)
10:31:41 <SergeyLukjanov> the main idea that in the best case nothing will be merged during  this period
10:32:02 <SergeyLukjanov> it's time to test everything and make sure that everything works ok
10:32:03 <bauzas> maybe let's discuss that by email, no ?
10:32:18 <DinaBelova> I think we agreed already :)
10:32:24 <DinaBelova> m-p branch with -1w for features and critical bug dixies :)
10:32:28 <DinaBelova> no?
10:32:29 <DinaBelova> :)
10:32:35 <bauzas> oh ok
10:32:45 <bauzas> well, ok
10:33:03 <DinaBelova> #agreed use milestone-proposed branch for v1 features and critical bug fixies
10:33:05 <SergeyLukjanov> that's very important to have some time to perform testing :)
10:33:16 <SergeyLukjanov> let's move on
10:33:17 <DinaBelova> ok
10:33:20 <bauzas> ok
10:33:38 <DinaBelova> do we already have needed topic?
10:33:47 <DinaBelova> I can't understand
10:34:01 <DinaBelova> I may set it once more
10:34:05 <SergeyLukjanov> set it again I think
10:34:10 <DinaBelova> if it was removed from logs
10:34:16 <DinaBelova> #topic Devstack gating
10:34:22 <DinaBelova> Ok
10:34:57 <DinaBelova> SergeyLukjanov, I see you are working on devstack support and gating for CLimate
10:35:02 <SergeyLukjanov> yup
10:35:09 <DinaBelova> may you describe current status?
10:35:28 <SergeyLukjanov> #link https://review.openstack.org/#/c/58702/
10:35:40 <SergeyLukjanov> it'll enable d-g jobs for climate
10:35:52 <DinaBelova> Soon we'll have heavy gating work as big-big OpenStack project :)
10:36:05 <SergeyLukjanov> for applying it we should add devstack support
10:36:09 <SergeyLukjanov> it was partially done
10:36:17 <SergeyLukjanov> I'm planning to make a CR this week
10:36:26 <DinaBelova> SergeyLukjanov, great
10:36:32 <SergeyLukjanov> it'll be located in contrib/devstack dir in main climate project
10:36:48 <SergeyLukjanov> that's a common approach for projects who can't contribute to devstack directly
10:37:03 <DinaBelova> Ok, I think that's great
10:37:11 <SergeyLukjanov> I think that the same thing could be done with tempest tests later
10:37:12 <bauzas> I'm OK with this
10:37:12 <DinaBelova> bauzas, are you ok?
10:37:23 <DinaBelova> Ok, great
10:37:25 <bauzas> contrib directory is fine :)
10:37:53 <bauzas> I basically reviewed the patch, no specific cons to say
10:37:56 <SergeyLukjanov> after applying to incubation it could be easily moved to th devstack
10:38:05 <DinaBelova> As Savanna did :)
10:38:12 <DinaBelova> yep? ;)
10:38:30 <SergeyLukjanov> we was applied before the devstack support landed to the contrib :)
10:38:39 <SergeyLukjanov> hm, nothing to add atm
10:38:40 <bauzas> :-)
10:38:41 <DinaBelova> :D
10:38:43 <DinaBelova> ok
10:38:46 <bauzas> ok, giving °1
10:38:47 <bauzas> +1
10:38:49 <DinaBelova> let's move to open discussion
10:38:59 <bauzas> sure
10:39:07 <DinaBelova> #topic Open discussion
10:39:20 <bauzas> so, about reviews
10:39:30 <bauzas> https://review.openstack.org/#/dashboard/7166
10:39:41 <SergeyLukjanov> looks like someone should keep track of https://blueprints.launchpad.net/climate/+spec/nova-dependency-removal
10:39:55 <DinaBelova> :d
10:39:57 <DinaBelova> :D
10:40:14 <bauzas> SergeyLukjanov: well, that will be handled by either francois or me
10:40:30 <SergeyLukjanov> btw I've rebases https://review.openstack.org/#/c/57675/ and looks like it'll merged soon
10:40:30 <bauzas> or can be postponed until Swann's back
10:40:50 <DinaBelova> SergeyLukjanov, nice!
10:41:25 <bauzas> I'm changing https://blueprints.launchpad.net/climate/+spec/nova-dependency-removal to icehouse-2
10:41:47 <DinaBelova> bauzas, ok
10:42:03 <DinaBelova> but I'll add v1 today to launchpad
10:42:08 <bauzas> https://review.openstack.org/#/c/49363/ and https://review.openstack.org/#/c/52396/ seem pretty reading for being merged
10:42:38 <bauzas> that would really help myself for making sure I can focus on other concerns
10:42:42 <DinaBelova> Ok, will take final look on them
10:42:47 <bauzas> esp. Policies and Manager
10:42:58 <bauzas> I mean Host Provisioning Manager
10:43:04 <bauzas> DinaBelova: cool thanks
10:43:26 <DinaBelova> #action DinaBelova Final review for https://review.openstack.org/#/c/49363/ and https://review.openstack.org/#/c/52396/
10:43:31 <DinaBelova> ok
10:43:39 <bauzas> one last note for me
10:44:30 <bauzas> https://review.openstack.org/#/c/59109/ seems pretty important for v1
10:44:48 <DinaBelova> bauzas, yes
10:45:20 <bauzas> and is also related to the policies thing about objects having their own IDs
10:45:37 <DinaBelova> Still I believe we may change it everywhere , not only here. Because we have not many usage of tenant_id in our code
10:46:11 <bauzas> DinaBelova: let's discuss that off-meeting then, and target agreement for next meeting :)
10:46:21 <DinaBelova> bauzas, ok
10:46:35 <DinaBelova> Also I want to mention one more change
10:46:41 <bauzas> I raised a bug, maybe I should promote it to a BP ?
10:46:50 <bauzas> because the scope is wide
10:47:12 <bauzas> to me it's a bug for the DB, it's a feature for objects :)
10:47:16 <DinaBelova> you had created one https://blueprints.launchpad.net/climate/+spec/tenant-to-project-ref
10:47:20 <bauzas> nope
10:47:46 <DinaBelova> is that for tenant->project entities?
10:47:47 <bauzas> this one is for cosmetic change, ie. changing 'tenant' refs to 'project'
10:47:50 <DinaBelova> ok
10:47:55 <DinaBelova> gotcha
10:48:02 <bauzas> atm, we strongly use tenant
10:48:25 <DinaBelova> SergeyLukjanov, you mentioned one change in that review
10:48:31 <bauzas> in order to prevent bugs, I would recommend sticking to this until s/o is handling the BP
10:48:43 <bauzas> DinaBelova: which review ?
10:48:55 <DinaBelova> https://review.openstack.org/#/c/59109/
10:49:45 <bauzas> yup, was part of the next actions items for me :)
10:50:01 <bauzas> trying to review other projects to see how they do :)
10:50:05 <DinaBelova> Because if that will be landed soon we may use it and have less problems with all these things
10:50:09 <DinaBelova> ok
10:50:21 <DinaBelova> I think we may fix this bug for DB now
10:50:22 <bauzas> as said, we should at least do a quick filter on tenant_id
10:50:27 <bauzas> exactly
10:50:40 <bauzas> and see on a next step how to do it right
10:50:46 <DinaBelova> and then fix tenant->project entities
10:50:47 <bauzas> could you please put me an action ?
10:50:47 <DinaBelova> ok
10:50:51 <DinaBelova> yep
10:50:53 <bauzas> to create BP to this
10:50:59 <bauzas> and investigate
10:51:03 <bauzas> I'll own the BP
10:51:44 <DinaBelova> #action bauzas Create BP for working with Projects instead of Tenants
10:51:49 <bauzas> cool thanks
10:51:51 <DinaBelova> ok
10:51:55 <bauzas> that's it for me
10:52:05 <DinaBelova> I wanted to remind you about https://review.openstack.org/#/c/57880/ :)
10:52:21 <bauzas> yup
10:52:23 <SergeyLukjanov> bauzas, about the model_query, CR that I mentioned is a result of merging from Cinder and Nova
10:52:28 <bauzas> was part of my duty :)
10:52:42 <bauzas> SergeyLukjanov: okay, will dig into it :)
10:52:52 <bauzas> DinaBelova: I can handle that
10:52:57 <DinaBelova> ok
10:53:05 <DinaBelova> #action bauzas Review https://review.openstack.org/#/c/57880/
10:53:05 <SergeyLukjanov> btw that's a cool script https://github.com/dolph/next-review
10:53:20 <bauzas> SergeyLukjanov: know it :)
10:53:42 <DinaBelova> SergeyLukjanov, new for me :)
10:53:44 <DinaBelova> Nice
10:53:51 <DinaBelova> Ok
10:54:13 <bauzas> ok, going back to my Manager.__getattr__ stuff
10:54:13 <DinaBelova> Do you have, guys, what to discuss else?
10:54:31 <bauzas> hoping we'll have consensus for managing RPC extension next patchset :)
10:54:54 <bauzas> took Yuriy's comments for handling that
10:54:55 <SergeyLukjanov> brew install terminal-notifier
10:55:01 <bauzas> :)
10:55:02 <SergeyLukjanov> ooops, wrong window :)
10:55:14 <bauzas> ok, I think we're done ?
10:55:25 <DinaBelova> bauzas, I had 51 patchsets for manager :D don't be sure about consensus :)
10:55:28 <DinaBelova> I think yes :)
10:55:36 <bauzas> DinaBelova: :D :D :D
10:55:40 <bauzas> ROFL
10:55:42 <DinaBelova> Bye, guys :)
10:55:50 <bauzas> bye akk
10:55:51 <SergeyLukjanov> have a good day!
10:55:55 <DinaBelova> #endmeeting