15:01:35 <scottda> #startmeeting cindertestwg
15:01:35 <openstack> Meeting started Wed Jun 29 15:01:35 2016 UTC and is due to finish in 60 minutes.  The chair is scottda. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:39 <openstack> The meeting name has been set to 'cindertestwg'
15:01:57 <scottda> I just put some items on the agenda around status: #link https://etherpad.openstack.org/p/Cinder-testing
15:02:35 <_alastor_> hi
15:02:35 <scottda> It look's like dulek has been making progress on patches for multinode Tempest. I don't know if he's around....
15:02:54 <patrickeast> Hi
15:02:54 <smcginnis> Haven't seen him today.
15:04:01 <scottda> I have been having a hard time with getting the project-config job name right for multi-backend #link https://review.openstack.org/#/c/330678/
15:04:18 <scottda> If anyone has insight into my problem, please let me know
15:05:01 <scottda> I've been testing geguileo patches for HA job distribution, and it seems to be working. I've added Ceph to the mix and will test that next.
15:05:16 <scottda> Anyone interested in brainstorming test cases for HA, let me know.
15:05:53 <erlon> hey
15:05:53 <akerr> scottda: you've only defined the template but not added it to any concrete project
15:05:54 <geguileo> scottda: I think we should create and Etherpad for those tests, because they can be tricky
15:06:10 <akerr> scottda: oh nvm, I didn't scroll far enough
15:06:23 <geguileo> scottda: And I'm not even sure how we'll be able to test some of that stuff without being able to modify the running code
15:06:36 <scottda> akerr: thanks for looking, I'll ping you later and see what you think...
15:07:08 <scottda> geguileo: Yeah, it's kinda tricky. Good idea about the etherpad
15:07:17 <scottda> #action scottda will create etherpad for HA testing
15:07:22 <smcginnis> That console output for the experimental job doesn't make it easy to see what's wrong. :/
15:07:50 <scottda> smcginnis: Yeah, that's the biggest problem i have is no way to test locally, and the debug isn't too clear.
15:08:21 <scottda> I'll nag some infra folks to see if they can help. Surely someone has enough knowledge to see the issue without too much time invested.
15:08:27 <akerr> scottda: tempsest is misspelt in layout
15:08:35 <scottda> akerr: Well, that could be it.
15:09:00 <scottda> BTW, I saw this bug came in today: https://bugs.launchpad.net/cinder/+bug/1597247
15:09:00 <openstack> Launchpad bug 1597247 in Cinder "CINDER retype through migration between different backends success but volume type not change" [Undecided,New]
15:09:23 <scottda> I'm not sure that the in-flight retype tempest tests would have caught this, but I hope so.
15:10:27 <scottda> erlon: How's progress on your efforts to fix up tempest? Do we need anything there?
15:11:06 <erlon> scottda: I think, we are doing good, I had another core to look in the patch
15:11:19 <erlon> scottda: I did the changes he asked,
15:11:25 <scottda> erlon: Can you please post the link again?
15:11:31 <erlon> scottda: with  some luck we can get that merged today
15:11:48 <erlon> scottda: https://review.openstack.org/#/c/310061/
15:12:02 <scottda> #link https://review.openstack.org/#/c/310061/
15:12:17 <openstackgerrit> Aleksey Ruban proposed openstack/cinder: Added HA support  https://review.openstack.org/335503
15:12:32 <scottda> OK, anyone else have something to bring up today?
15:12:38 <erlon> scottda: today, I'll ask on the meeting about the fix for the clone from bugs
15:13:02 <scottda> erlon: OK
15:13:04 <erlon> scottda: then Ill proceed with that fix: https://review.openstack.org/#/c/333037/
15:13:20 <scottda> #link https://review.openstack.org/#/c/333037/
15:14:09 <erlon> scottda: is anyone working in setup the migration tests? what is the status?
15:14:32 <erlon> scottda: the tests are ready for a long time waiting for the tempest CI
15:15:08 <scottda> erlon: I've patches in flight for that. The above request ^^^ was for help with one of them. Seems smcginnis and akerr saw issues.
15:15:43 <scottda> Alright, I'm tempted to cut thing short so we don't all get tired of this meeting. Please visit the etherpad for links to tests that need reviewing.
15:15:52 <smcginnis> scottda: I'm actually not sure on my comment there, but I noticed the other jobs are named that way.
15:16:04 <scottda> BTW, I'm on vacation next week. If you all want to chat about testing, feel free.
15:16:08 <erlon> scottda: what is missing? I known almost nothing about the gate but I can try to help
15:16:12 <scottda> smcginnis: Thanks. I'm not sure either.
15:16:24 <smcginnis> scottda: Thanks for keeping this going. Good to have visibility on the testing issues/progress.
15:16:30 <scottda> erlon: Sorry, I cannot say. I'm learning about the gate myself.
15:17:11 <scottda> erlon: Our collective lack of expertise is a big issue for the Cinder test efforts. I put something out on the ML inviting others, but there was not response.
15:17:43 <scottda> OK, well, this is the cinder channel, so we can keep chatting. But I'm going to end this so folks can move on if they like.
15:17:46 <scottda> #endmeeting