17:00:49 <ildikov> #startmeeting cinder-nova-api-changes
17:00:50 <openstack> Meeting started Mon Aug  1 17:00:49 2016 UTC and is due to finish in 60 minutes.  The chair is ildikov. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:53 <openstack> The meeting name has been set to 'cinder_nova_api_changes'
17:01:17 <ildikov> scottda DuncanT ameade cFouts johnthetubaguy jaypipes takashin alaski e0ne jgriffith tbarron andrearosa hemna erlon mriedem gouthamr ebalduf patrickeast smcginnis diablo_rojo gsilvis
17:01:30 <jgriffith> 0/
17:01:33 <cFouts> hi
17:01:45 <ildikov> hi :)
17:03:01 <gouthamr> hey
17:03:19 <mriedem> o/
17:03:53 <ildikov> ok let's start
17:04:18 <ildikov> jgriffith: I saw updates on the Cinder patches for the new attach/detach calls
17:04:39 <ildikov> jgriffith: can you update us a bit with where we are regarding those?
17:04:42 <jgriffith> ildikov: yep, fixed up the merge conflicts and a couple little things like adding a functional test
17:05:03 <jgriffith> ildikov: got stuck trying to get Cinders functional framework to allow admin api calls
17:05:25 <jgriffith> ildikov: creating the admin-api seemed easy, but didn't quite work
17:05:37 <jgriffith> ildikov: Then moved back over the Nova side.
17:06:11 <ildikov> jgriffith: I thought to extend the already existing API tests here: https://review.openstack.org/#/c/339692/
17:06:16 <mriedem> btw, my devstack change to test all of this isn't configured correctly, i think the docs for LIBS_FROM_GIT are old, but i'm failing here https://review.openstack.org/#/c/340517/
17:06:29 <ildikov> I'm not sure how useful those are though... :S
17:06:33 <jgriffith> mriedem: looking
17:07:01 <mriedem> probably just need to corner someone in -qa to ask what i'm missing
17:08:10 <jgriffith> mriedem: that *looks* correct
17:08:32 <jgriffith> basically what I used in my local.conf
17:09:09 <mriedem> d-g checks the PROJECTS list or something
17:09:10 <mriedem> and pukes on that
17:09:20 <jgriffith> ildikov: I kinda take issue with stuffing everything under a generic volume test again
17:09:25 <mriedem> http://logs.openstack.org/17/340517/3/check/gate-tempest-dsvm-full/3cf66c7/logs/devstacklog.txt.gz#_2016-07-27_19_42_38_923
17:09:31 <mriedem> i'll bug someone in -qa
17:09:33 <jgriffith> ildikov: we made that sort of mistake in our unit tests and it's sort of a mess
17:10:10 <jgriffith> ildikov: https://review.openstack.org/#/c/327408/10/cinder/tests/functional/test_attach.py
17:10:12 <ildikov> jgriffith: the currently existing functional tests are using stuff from the unit test folder, which got me delayed a bit as I didn't look for things there...
17:10:25 <ildikov> jgriffith: yeap, I will check it
17:10:27 <jgriffith> ildikov: :)  I merged a change for a few of those BTW
17:10:34 <jgriffith> ildikov: moved them up into the tests root
17:10:56 <jgriffith> mriedem: Ohh
17:11:06 <ildikov> jgriffith: it's really a mess, so thanks for all clean up work
17:11:08 <jgriffith> mriedem: the new/old thing... so it's cloning into /opt/stack I'll bet
17:11:29 <jgriffith> mriedem: I don't use new/old locally so that is likely something to do with it
17:11:34 <ildikov> jgriffith: I didn't want to change them as I wasn't sure whether anyone is working on it
17:11:50 <jgriffith> mriedem: ildikov other than that, the main thing I'm working out now is the shelve tests
17:12:20 <jgriffith> mriedem: ildikov they do the old initialize_connection and terminate calls directly still and it sort of screws things up
17:12:55 <jgriffith> mriedem: ildikov so I'll get those fixed up and then we probably need to start talking about how we all would like to see the detection of the API's and things work
17:13:01 <ildikov> jgriffith: you mean shelve now, right?
17:13:22 <jgriffith> whether that's microversions etc and how we detect/check on the Nova side
17:13:42 <jgriffith> ildikov: I'm referring to the tempest/gate dsvm tests
17:15:33 <ildikov> jgriffith: ah, ok
17:16:33 <mriedem> #action mriedem to move https://review.openstack.org/#/c/340517/ to devstack-gate
17:16:47 <ildikov> jgriffith: I'm sure there will be a few issues with the VM actions which are kind of hacked currently
17:20:03 <ildikov> jgriffith: are we planning to microversion the API now?
17:20:43 <jgriffith> ildikov: that's up to mriedem and others
17:21:03 <jgriffith> ildikov: I believe in past discussions that's what mriedem and johnthetubaguy had suggested, but I could be wrong
17:21:31 <mriedem> a new api in cinder should probably be microversioned no?
17:21:32 <jgriffith> ildikov: I can just add an API call to nova/volume/cinder that checks and sets that on init and be done as well
17:22:27 <jgriffith> mriedem: I can set it up however people would like.  Personally I don't know that new calls need to be, but I'm fine if we want that
17:22:50 <jgriffith> mriedem: I'm just putting off dealing with them as long as I can knowing that it's inevitable :)
17:24:47 <mriedem> jgriffith: so until a microversion,
17:25:01 <mriedem> you were going to call the new api and set a flag if it works or not so we can know in nova if we can use it?
17:25:32 <jgriffith> mriedem: yeah, or just hack it somehow for a POC knowing that we don't plan to merge this on the Nova side until the next release
17:26:06 <jgriffith> mriedem: well... yes, that *is* the hack
17:27:03 <mriedem> that would be easier for now
17:27:15 <mriedem> so you don't land a microversion'ed api in cinder that just needs changes
17:27:24 <mriedem> i guess the question is if cinder is going to land the api change in newton
17:27:28 <jgriffith> mriedem: ok, great.  I fully realize that whatever I push is going to be just WIP and temporary
17:27:40 <mriedem> i think you'd definitely want it microversioned when it lands in cinder
17:28:02 <jgriffith> mriedem: yeah, I'll check in with the folks running micro-versions in Cinder and see where we're at
17:28:20 <jgriffith> mriedem: I think we're pretty close so it should be a thing in Newton for sure
17:28:22 <ildikov> scottda should be able to help with that
17:28:30 <ildikov> I mean the microversion stuff
17:28:55 <jgriffith> ildikov: yeah... I got ya :)
17:29:08 <ildikov> and as we need to keep Nova be able to talk to older Cinder as well cannot avoid using this
17:30:31 <ildikov> jgriffith: I remember correctly that we will not have feature branches for this, right?
17:30:51 <jgriffith> ildikov: that's correct
17:31:18 <ildikov> jgriffith: cool, tnx
17:33:19 <ildikov> jgriffith: mriedem: I think if we can get the Cinder side merged and make the pure attach call work with the new Cinder API as a POC in Newton that would be a great starting point
17:34:53 <ildikov> jgriffith: back to testing a bit, should I abandon my patch on top of yours in Cinder and try to help out on the direction you're working at the moment?
17:36:01 <jgriffith> ildikov: that's completely up to you, I would prefer we don't have every volume related action under the sun in a single test but that's just my opinion
17:36:36 <ildikov> jgriffith: sure, that was just a test to try to make it work :)
17:36:49 <jgriffith> ildikov: test_volume is technically just fine, I'm just being picky :)
17:37:05 <ildikov> jgriffith: I was wondering more how the Cinder team and you would like to see functional tests in the future
17:37:37 <jgriffith> ildikov: well my opinion has been that an API feature should have it's own test file/module
17:38:05 <ildikov> jgriffith: that sounds reasonable
17:38:43 <ildikov> jgriffith: are the fake drivers and other helper methods going to stay but maybe re-organized a bit?
17:39:29 <ildikov> mriedem: one thing, I saw that hemnafk's patch to start to remove check_attach got merged
17:40:04 <jgriffith> ildikov: the fake_driver is already in cinder/tests  not quite sure what you mean?
17:40:05 <ildikov> mriedem: can you check this one, which tries to clean it up fully: https://review.openstack.org/#/c/335358/ ?
17:40:52 <mriedem> ildikov: yeah, probably not today though, i think had some concerns about the boot from volume scenario and that
17:41:01 <ildikov> jgriffith: I had to add modifications to the one that's used with the current tests: https://review.openstack.org/#/c/339692/5/cinder/tests/fake_driver.py
17:41:01 <mriedem> like race issues
17:41:47 <ildikov> mriedem: so in case of BFV, when you attach an already existing volume at boot time reserve_volume was not called at all
17:42:19 <ildikov> mriedem: so there's an extra reserve_volume call in that flow now, but I'm not 100% sure it's at the right place TBH
17:43:10 <ildikov> mriedem: there's also a grenade test that's quite constantly failing with that patch, I need to take a look at that one as well
17:43:35 <ildikov> mriedem: I appreciate if you can check that patch some time this week :)
17:44:28 <ildikov> jgriffith: so by adding the modifications I got a little bit unsure I'm using the right thing :)
17:44:47 <mriedem> ildikov: i think the thing was with boot from volume, we didn't reserve the volume in the api today, we reserved it in the compute
17:45:24 <mriedem> at least i thought we did
17:45:26 <mriedem> but i'm not seeing that
17:46:36 <ildikov> mriedem: I mistyped some stuff during trying to debug it in reserve_volume and attaching a volume during BFV still worked like a charm, so I'm sure it's not called at all
17:47:06 <ildikov> mriedem: when I detached the volume and tried to attach it again reserve failed as expected
17:47:20 <mriedem> i guess i'm not sure why we don't reserve the volume during BFV today
17:47:35 <ildikov> not the nicest way to see what's happening, but was quite quick and effective
17:47:47 <mriedem> anyway, we can take it offline
17:47:57 <ildikov> I couldn't come up with any scenario either besides it got forgotten
17:47:58 <mriedem> i have about 10 things going on at once today
17:48:25 <ildikov> sure, I hate Mondays too
17:48:40 <jgriffith> mriedem: I don't know of a reason other than oversight either
17:48:41 <ildikov> so I'm happy to take it on the review
17:50:40 <ildikov> is there anything else for today?
17:52:03 <ildikov> ok, I take it as a no
17:52:20 <mriedem> nope
17:52:25 <ildikov> thanks guys for joining and have a nice rest of the day!
17:52:41 <ildikov> #endmeeting