14:00:18 <rosmaita> #startmeeting cinder
14:00:18 <opendevmeet> Meeting started Wed Mar 16 14:00:18 2022 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:18 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:18 <opendevmeet> The meeting name has been set to 'cinder'
14:00:28 <tosky> o/
14:00:29 <simondodsley> hi
14:00:32 <whoami-rajat> Hi
14:00:33 <eharney> hi
14:00:40 <hemna> yough
14:00:55 <geguileo> hi! o/
14:01:19 <yuval> hey
14:01:31 <rosmaita> hello everyone
14:01:42 <rosmaita> #link https://etherpad.opendev.org/p/cinder-yoga-meetings
14:02:24 <jungleboyj> o/
14:02:28 <rosmaita> light agenda today, so plenty of time for open discussion later
14:02:39 <rosmaita> #topic announcements
14:02:49 <rosmaita> Festival of XS Reviews on Friday, 1400-1600 UTC
14:03:11 <rosmaita> you can find info about the festival here: http://eavesdrop.openstack.org/#Cinder_Festival_of_XS_Reviews
14:03:15 <fabiooliveira> o/
14:03:21 <rosmaita> which reminds me that i didn't send out a reminder yet
14:03:35 <rosmaita> #action rosmaita festival of reviews reminder to ML
14:03:36 <whoami-rajat> We've a national festival on friday (Holi) so won't be able to attend...
14:03:46 <rosmaita> ok, that's a good excuse
14:04:05 <whoami-rajat> (probably anyone from India won't be around on friday)
14:04:10 <whoami-rajat> :)
14:04:12 <jungleboyj> rosmaita:  I am not sure if I will be able to attend.  My son has a college visit.
14:04:33 <rosmaita> ok, that's also a good excuse, though not as good as Rajat's
14:04:37 <rosmaita> :D
14:04:58 <jungleboyj> :-)
14:04:59 <rosmaita> enriquetaso also won't be there
14:05:25 <rosmaita> i have the time blocked off, so i am planning to be there
14:05:37 <rosmaita> next item
14:05:45 <rosmaita> final cinder RC must be released by Thursday next week
14:06:09 <rosmaita> not much more to say about that, i think everyone knows what it means
14:06:23 <rosmaita> RC-1 was released on Monday
14:06:37 <rosmaita> (that's "cinder release candidate #1"
14:06:47 <rosmaita> the stable/yoga branch has now been cut
14:06:56 <rosmaita> bugfixes must merge to master and then be backported to stable/yoga
14:07:11 <jungleboyj> ++
14:07:28 <rosmaita> that's the case for everything (cinder, os-brick, cinderclient) other than cinderlib
14:07:39 <rosmaita> cinderlib master remains yoga development until it has its yoga release at zed R-15
14:07:58 <rosmaita> which reminds me, i could use some eyes on https://review.opendev.org/c/openstack/cinderlib/+/833781
14:08:06 <simondodsley> so things we only want in Zed can now be put up in master, correct?
14:08:21 <rosmaita> that is correct
14:08:27 <simondodsley> cool
14:09:02 <rosmaita> so at this point, only release-critical changes will be merged to stable/yoga
14:09:10 <rosmaita> so let's take a quick look at what we have
14:09:19 <rosmaita> #link https://etherpad.opendev.org/p/cinder-yoga-release-critical-changes
14:09:41 <rosmaita> so, first the good news
14:09:54 <rosmaita> the transition-to-alembic patches were all merged
14:10:23 <hemna> I hope that works when upgrading a real deployment :)
14:10:23 <rosmaita> we don't have any db migrations for yoga, but probably will soon
14:10:33 <rosmaita> so, https://docs.openstack.org/cinder/latest/contributor/database-migrations.html
14:10:45 <rosmaita> that explains how to use the new stuff
14:11:18 <rosmaita> hemna: me too, i'll be putting up a patch very early in Zed to do a minor migration so we can make sure it works as expected
14:11:46 <rosmaita> we have the advantage that nova is about 1.5 cycles ahead of us on this, and the bugs have been mostly shaken out
14:12:12 <rosmaita> anyway, i want to thank stephenfin for working on this for cinder
14:12:20 <rosmaita> we will declare Stephen Finucane a "Hero of Cinder" at the PTG
14:12:26 <jungleboyj> ++
14:12:54 <whoami-rajat> also there's a new grenade job that checks migration from tock -> tock (or it's tick->tick) but it checks skipping one intermediate release
14:12:57 <rosmaita> as i mention on the etherpad, stephenfin has also posted a series of patches so that cinder will no longer use a deprecated oslo.db feature
14:13:12 <rosmaita> we will aim to merge those into Z quickly after the final RC
14:13:23 <rosmaita> ok, now the not-so-good news
14:13:57 <rosmaita> there is still some work ongoing for known issues in Xena
14:14:15 <rosmaita> the good thing is that i don't think any of them are destabilizing
14:14:25 <rosmaita> they are fairly localized
14:14:37 <rosmaita> so, we will consider them release-critical
14:15:13 <rosmaita> other than that, if anyone finds a bug that looks like it needs to be addressed before release, please put it on the etherpad so we can be aware
14:15:22 <rosmaita> and decide whether it really is release-critical or not
14:15:42 <rosmaita> any questions?
14:17:10 <rosmaita> ok, next item
14:17:21 <rosmaita> Zed virtual PTG 4-8 April
14:17:30 <rosmaita> #link https://etherpad.opendev.org/p/zed-ptg-cinder-planning
14:17:51 <rosmaita> usual deal, you need to register even though it's free
14:18:04 <rosmaita> whoami-rajat is doing the organization this time
14:18:19 <whoami-rajat> o/
14:18:28 <rosmaita> if you look at the etherpad, there are a bunch of driver topics that i added
14:18:44 <rosmaita> it's looking like maybe we'll have a drivers' day
14:19:02 <whoami-rajat> ah, they weren't there the last time i checked
14:19:03 <rosmaita> so if you are a driver maintainer, and have something we should discuss, please add it
14:19:12 <whoami-rajat> looks like a drivers' day is needed
14:19:33 <whoami-rajat> (it could also be called Brian's day)
14:19:41 <rosmaita> btw, i will be happy to let anyone else who's interested take those over
14:20:17 <rosmaita> the PTG is coming up fast, so please spend a bit of time thinking about it
14:20:23 <geguileo> driver's day++
14:20:57 <rosmaita> hemna: i didn't see your recomputing available space topic on there yet
14:21:36 <jungleboyj> Oooh, that sounds like an exciting one.
14:22:05 <rosmaita> that doesn't necessarily have to be on drivers day, though i imagine there may be some reporting issues that it would be good to get input on
14:22:10 <simondodsley> I won't be able to attend, but I'm going to add a topic for discussion if that is ok.
14:22:15 <geguileo> jungleboyj: was that a sarcastic comment?  XD
14:22:29 <geguileo> simondodsley: nvme related?
14:22:38 <rosmaita> simondodsley: that's fine
14:22:46 <jungleboyj> No ... I have a feeling that it will be somewhat contentious.  :-)
14:22:55 <rosmaita> though you'll need to get someone to agree to lead the discussion for you
14:22:59 <geguileo> jungleboyj: probably :-)
14:23:03 <jungleboyj> Might be interesting.
14:23:58 <rosmaita> since we're not in a hurry today, i will pause to give people time to look at the etherpad and add comments
14:24:02 <simondodsley> I'll add the topic and if someone want s to lead it that would be great, but if not it can be dropped for another session
14:24:12 <rosmaita> #link https://etherpad.opendev.org/p/zed-ptg-cinder-planning
14:25:01 <geguileo> I'll probably add a couple of topics:  Current nvme-of connector issues, drivers reporting their storage_protocol, quota update
14:25:49 <rosmaita> geguileo: ++
14:27:31 <whoami-rajat> If you've added a topic and have a preferred time and won't be attending the whole PTG, you can add the time (UTC) suited for your TZ (only in the available time slot)
14:27:47 <whoami-rajat> geguileo++
14:29:18 <geguileo> simondodsley: are there leftovers on ALL successful runs or just some?
14:29:34 <simondodsley> i'd have to check, but it feels like all
14:29:54 <rosmaita> just a reminder about the PTG schedule for cinder: the Cinder team will meet in the 13:00-17:00 UTC blocks on Tuesday 5th April through Friday 8th April 2022.
14:31:15 <rosmaita> wow, we do have a lot of topics for drivers' day!
14:31:19 <geguileo> simondodsley: that'd be the best case scenario, because going into the system we can tell the test that left it behind
14:31:37 <rosmaita> ok, the etherpad is available 24 hours a day, so please add items as they occur to you
14:31:43 <geguileo> and the new field that tells us if it's a temporary resource may help as well
14:32:20 <rosmaita> ok, final announcement
14:32:34 <rosmaita> reminder about the cinder resource count survey
14:32:43 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-March/027660.html
14:33:16 <rosmaita> we are trying to get geguileo some data to determine what direction his quotas improvement plans should take
14:33:22 <rosmaita> so please tell your customers
14:33:32 <rosmaita> and if you run a cloud, please fill it out yourself!
14:33:48 <geguileo> please, pretty please
14:33:53 <rosmaita> that's all from me, anyone else have an announcement?
14:34:10 <rosmaita> actually, if sofia were here, she would remind us about outreachy
14:34:26 <rosmaita> i believe the deadline for proposals is early next week
14:34:51 <rosmaita> i think this email has details:
14:34:54 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-February/027239.html
14:35:29 <rosmaita> #topic reminder: no "naked" rechecks
14:35:59 <rosmaita> Gorka added some documentation about this:
14:36:07 <rosmaita> #link https://docs.openstack.org/cinder/latest/contributor/gerrit.html#ci-job-rechecks
14:36:24 <rosmaita> the basic idea is that we want to do a bit of troubleshooting before rechecking
14:36:53 <rosmaita> because a failure in any test that has 'volume' in the name is immediately ascribed to cinder, whether it's a cinder failure or not
14:37:53 <rosmaita> i guess that's all i have to day about that
14:38:15 <whoami-rajat> geguileo, found out a typo if you would like to fix "without locking at the errors" locking -> looking
14:38:51 * geguileo is the king of typos
14:38:53 <rosmaita> that's a good typo given that geguileo is our race conditions expert
14:39:12 <whoami-rajat> :D true
14:39:39 <rosmaita> #topic open discussion
14:40:07 <jungleboyj> :-)
14:43:00 <eharney> i have this cool patch that just removes a bunch of dead code, if someone wants an easy review: https://review.opendev.org/c/openstack/cinder/+/800704
14:43:28 <geguileo> eharney: that one has a couple of +2 already...
14:43:37 <eharney> indeed
14:43:48 <eharney> last week's meeting got it this far, maybe today's can really do it
14:44:51 <rosmaita> eharney: i think you should feel free to +W it
14:45:09 <rosmaita> or maybe jungleboyj will
14:45:20 <geguileo> eharney: why do we need this change? https://review.opendev.org/c/openstack/cinder/+/800704/3/cinder/volume/drivers/remotefs.py
14:45:30 <rosmaita> looks like he and e0ne had a race condition, both thought they were putting the first +2 on it
14:45:38 <jungleboyj> rosmaita:  I can.
14:45:43 <rosmaita> ty
14:45:47 <eharney> geguileo: good question
14:45:54 <eharney> geguileo: i wrote this last summer, so lemme go find out...
14:46:08 <geguileo> I know how that feels
14:46:50 <jungleboyj> *sad trombone*
14:47:42 <rosmaita> i wonder if that's a pylint thing
14:48:33 <yuval> I can bring up an idea
14:48:43 <geguileo> eharney: looks like it's irrelevant, it's merging now   XD
14:48:59 <yuval> what about moving out unittest from using tox to use docker
14:49:07 <yuval> our*
14:49:18 <eharney> tox works pretty well
14:50:31 <rosmaita> yuval: can you say some more about what you're thinking there?
14:50:37 <yuval> my exp with tox - first was that its not working - every env I had to install it I had to debug certain bug, missing dependency libs
14:51:09 <yuval> just a docker with the minimum req to run the unittests
14:52:09 <yuval> zuul running py36 and py39 in my machine I am running py38
14:52:18 <yuval> I would like to run exactly the same tests
14:52:41 <yuval> docker solves that
14:53:10 <yuval> is there someone here which is also active in kolla project?
14:53:20 <whoami-rajat> geguileo, eharney i can see those variables not used anywhere so maybe signifying that those are unused (_<var> instead of __)
14:53:39 <geguileo> whoami-rajat: makes sense
14:53:41 <eharney> whoami-rajat: that is the convention of what the leading underscore means, yes -- pylint etc. actually check based on this
14:53:42 <geguileo> thanks
14:54:19 <whoami-rajat> np
14:54:24 <whoami-rajat> ack
14:55:55 <rosmaita> yuval: i use pyenv to give me multiple pythons beyond what's available in my operating system distro
14:56:12 <rosmaita> don't know if that would help you
14:58:04 <rosmaita> ok, two-minute warning ... anyone else have something to mention?
14:59:30 <rosmaita> guess not ... thanks for attending, and don't forget about the festival of reviews on friday
14:59:48 <rosmaita> #endmeeting