14:00:53 <rosmaita> #startmeeting cinder
14:00:53 <opendevmeet> Meeting started Wed Feb  2 14:00:53 2022 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:53 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <opendevmeet> The meeting name has been set to 'cinder'
14:01:00 <rosmaita> #topic roll call
14:01:05 <simondodsley> hi
14:01:09 <yuval_> hey
14:01:10 <TusharTgite> hi
14:01:10 <eharney> howdy
14:01:13 <agarwchh> hi
14:01:18 <jungleboyj> o/
14:01:19 <e0ne> hi
14:01:22 <fabiooliveira> o/
14:01:53 <whoami-rajat> Hi
14:02:52 <tosky> o/
14:03:03 <rosmaita> ok, tosky is here, so let's get started
14:03:05 <rosmaita> :)
14:03:08 <tosky> O.o
14:03:12 <rosmaita> #topic announcements
14:03:30 <rosmaita> next PTG is 4-8 April 2022
14:03:39 <rosmaita> #link https://openinfra-ptg.eventbrite.com/
14:03:41 <rosmaita> ot
14:03:54 <rosmaita> it's virtual and free, but you are asked to register anyway
14:04:00 <rosmaita> so please do
14:04:14 <rosmaita> this is week R-8
14:04:22 <jungleboyj> It's virtually free?  ;-)
14:04:28 <rosmaita> reminder that this week is the cinder driver features declaration
14:04:36 <rosmaita> #link https://releases.openstack.org/yoga/schedule.html#y-cinder-driver-features-declaration
14:04:53 <simondodsley> jungleboyj: too early in the morning for that...
14:05:05 * jungleboyj laughs
14:05:23 <rosmaita> next item: yoga os-brick release during R-7 week
14:05:27 <rosmaita> so, that's next week
14:05:50 <rosmaita> and to keep smcginnis happy, it is scheduled for thursday
14:06:06 <rosmaita> here is a handy dashboard for reviewers: http://tiny.cc/brick-patches
14:06:12 <jungleboyj> Bwah ha ha!
14:07:10 <rosmaita> so, not surprisingly, the review priorities over the next week are: 1. os-brick reviews, 2. stephenfin's alembic patches
14:07:45 <rosmaita> if anyone pings me with a review request, please indicate which os-brick or stephenfin patch you have reviewed
14:08:05 <rosmaita> "to get reviews, you need to do reviews"
14:08:16 <rosmaita> ok, also happening next week
14:08:25 <rosmaita> we will release from the stable branches during R-7 week
14:08:31 <rosmaita> whoami-rajat will talk more about that later
14:08:44 <rosmaita> now some stuff for the future
14:08:53 <rosmaita> (where the future is after next week)
14:08:59 <rosmaita> cinderclient release during R-5 week
14:09:07 <rosmaita> cinder feature freeze during R-5 week
14:09:20 <rosmaita> and ... Cinder 3rd Party CI Compliance Checkpoint around R-5
14:09:27 <rosmaita> #link https://releases.openstack.org/yoga/schedule.html#y-cinder-ci-checkpoint
14:09:51 <rosmaita> about that ... you don't need me to tell you if your CI is working or not
14:10:00 <rosmaita> you should already know that
14:10:31 <rosmaita> any drivers declared 'unsupported' at RC-1 time, will be 'unsupported' in the yoga release
14:10:48 <rosmaita> so, if you don't want that to happen to you, take appropriate action now
14:10:56 <rosmaita> all the info you need is at the link above ^^
14:11:16 <rosmaita> ok, then some other general events happening
14:11:35 <rosmaita> the TC is having a release cadence discussion tomorrow at 1600 utc
14:11:43 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-January/026962.html
14:12:12 <rosmaita> there's probably a more recent email with a link to the videocong
14:12:16 <rosmaita> *videoconf
14:12:39 <rosmaita> if you are wondering what people are thinking, there is a long thread over 2 months:
14:12:48 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-November/025684.html
14:12:57 <rosmaita> #link https://lists.openstack.org/pipermail/openstack-discuss/2021-December/026137.html
14:13:49 <rosmaita> finally, Z cycle PTL self-nominations start next week
14:14:09 <rosmaita> they are always self-nominations, because if you could nominate other people ... well, you can imagine what would happen
14:14:24 <rosmaita> the nomination period will be 2022-02-08T23:45 through 2022-02-15T23:45
14:14:50 <rosmaita> if you are curious about what being a PTL entails, you can look at the docs, or ask me or jungleboyj
14:15:16 <rosmaita> OK, that's it for announcements ... anyone have anything else people should be aware of?
14:15:22 <jungleboyj> Happy to answer questions.  :-)
14:15:38 <jungleboyj> smcginnis is a resource as well.  :-)
14:16:00 <rosmaita> yes, i only didn't mention him because he's not here
14:16:21 <rosmaita> but i'm sure he'd be happy to answer your questions if you PM him on irc
14:18:00 <rosmaita> ok, looks like no more announcements.
14:18:10 <rosmaita> just want to repeat two items:
14:18:18 <rosmaita> the review priorities over the next week are: 1. os-brick reviews, 2. stephenfin's alembic patches
14:18:24 <rosmaita> also, if anyone pings me with a review request, please indicate which os-brick or stephenfin patch you have reviewed
14:18:34 <rosmaita> i am completely serious about ^^
14:18:41 <rosmaita> ok, let's move on
14:18:54 <rosmaita> Any tasks or ideas for Outreachy internships?
14:19:03 <rosmaita> don't think Sofia is here
14:19:18 <rosmaita> but the deadline to submit ideas is in one month (March 4)
14:20:33 <rosmaita> i think Sofia is away for this week and next
14:20:53 <rosmaita> i will look into what this would entail beyond having ideas and we can discuss next week
14:21:06 <agarwchh> rosmaita: can internship students pick the blueprints which has potential changes in cinder core
14:21:18 <rosmaita> #action rosmaita - info about Outreach internships
14:21:30 <rosmaita> agarwchh: i don't see why not
14:21:52 <rosmaita> the question is what support the cinder projects will give them in their work
14:22:10 <jungleboyj> ++
14:22:34 <rosmaita> ok, agarwchh ... you are up next
14:22:50 <rosmaita> multiple volume group spec
14:22:58 <rosmaita> #link https://review.opendev.org/c/openstack/cinder-specs/+/821372
14:23:03 <agarwchh> need to check on the multiple-volume-group spec, we got the spec updated.
14:23:23 <rosmaita> i took a quick look, the REST API section needs some more details
14:23:51 <rosmaita> also, i didn't think it was clear how you are going to prevent volumes being put into groups with conflicting requirements?
14:24:07 <agarwchh> We had put high level details which APIs will be impacted and what will be the new APIs
14:24:09 <rosmaita> i saw you responded to my question  in a comment, but didn't see anything in the text
14:24:18 <simondodsley> I think I have to declare a vested interest in this spec
14:25:08 <rosmaita> agarwchh: i don't think you explicitly addressed the question of what will be in the group_id field in volume-show request for the new mv
14:25:23 <rosmaita> and what will be displayed there for an older mv but when the volume is in multiple groups
14:25:36 <rosmaita> because the older mv will not have a group list field
14:25:46 <agarwchh> group_id needs to be deprecated and replaced with groups, which will be the list of multiple associated group_id
14:25:53 <rosmaita> nope cannot do trhat
14:25:55 <rosmaita> *that
14:26:42 <rosmaita> please review the contributor docs about microversions
14:26:44 <agarwchh> introducing the new API microversion should help,
14:27:03 <agarwchh> for older version it will still return the single group
14:27:22 <agarwchh> in that case it should populate group_id
14:27:57 <rosmaita> with which group, though?
14:28:08 <agarwchh> rosmaita: the single group
14:28:24 <agarwchh> for older version it will be still 1-1 volume group
14:28:57 <rosmaita> someone can make a call to the API that supports mv 3.87 but ask for mv 3.22
14:29:19 <rosmaita> you need to have a plan for a sensible response
14:29:35 <agarwchh> I need to check more on microversion how we can handle multiple scenarios,
14:30:03 <agarwchh> but overall i need to understand if we can start the work for this spec and plan for Z release
14:30:53 <rosmaita> well, it would be good to get the spec approved first
14:31:17 <rosmaita> you won't be allowed to merge any code until week R-1
14:31:20 <agarwchh> sure, apart from microversion do you see any other open issues
14:31:31 <agarwchh> i can update the spec for those details
14:31:57 <rosmaita> well, yes, the whole issue of how you are going to decide which volumes can be in multiple groups, and which groups are ok for this
14:32:14 <rosmaita> that seems to be a really big deal
14:32:34 <rosmaita> the database and API work are easy, but i'm not clear on the logic
14:32:36 <agarwchh> sure, i have some details on that will add it to spec.
14:32:42 <rosmaita> ok, thanks
14:32:49 <agarwchh> thanks
14:32:57 <rosmaita> ok, any other comments
14:34:04 <agarwchh> nothing from my side
14:34:18 <rosmaita> thanks! let's move on to whoami-rajat
14:34:24 <rosmaita> #topic stable releases
14:34:30 <whoami-rajat> hi
14:34:34 <rosmaita> #link https://etherpad.opendev.org/p/cinder-stable-releases
14:35:16 <whoami-rajat> as rosmaita already mentioned, we are planning to do stable branch releases for last 3 releases i.e. victoria, wallaby and xena in the R-7 week which is same as of os-brick release
14:36:13 <whoami-rajat> I reviewed all of the patches and we are looking good, looks like most of the things in xena/wallaby were merged today
14:36:55 <whoami-rajat> I've created an etherpad to track all patches, so if you've something that you think is important to get in these releases, please do the appropriate backport and add the patch to the etherpad
14:37:25 <whoami-rajat> One question i had for dell team
14:38:12 <whoami-rajat> simondodsley gave a -1 on all of the dell patches in stable/xena regarding CI not running, was it running previously and stopped or it never ran on stable branches?
14:39:52 <rosmaita> not sure we have any dell people here
14:40:01 <whoami-rajat> ok
14:40:08 <whoami-rajat> i think that can be addressed on the patches in question
14:40:10 <simondodsley> i don't think they have ever run stable CIs
14:40:27 <simondodsley> that was why I raised the issue at the mid-cycle
14:40:36 <rosmaita> yeah, we haven't had that requirement previously, i don't think we can make it a requirement until Z
14:40:44 <jungleboyj> ++
14:40:53 <jungleboyj> Yeah, we shouldn't be blocking patches on that right now.
14:41:17 <rosmaita> but it would be good for them to state explicitly on the review that the fix has been tested in the appropriate stable branch, etc.
14:41:54 <simondodsley> ++
14:41:58 <whoami-rajat> ++
14:41:59 <rosmaita> that goes for all proposed backports for vendor drivers ^^
14:42:27 <rosmaita> #action rosmaita - email to vendor driver maintainers about explicitly test statement
14:42:37 <rosmaita> while i'm at it
14:42:45 <whoami-rajat> thanks rosmaita
14:42:55 <rosmaita> #action rosmaita - email to ML about driver compliance check upcoming
14:43:00 <rosmaita> np
14:43:20 <rosmaita> i notice that grenade seems to be broken in victoria, possibly also wallaby
14:43:39 <rosmaita> i didnt' have time to look at the ML this morning, is that a known issue?
14:43:50 <rosmaita> was just looking at https://review.opendev.org/c/openstack/cinder/+/827242
14:44:07 <whoami-rajat> I saw the error related to devstack
14:44:24 <whoami-rajat> related to devstack not supporting py3.6
14:44:43 <whoami-rajat> but it was merged in master, i think backports are proposed for stable branches
14:45:04 <rosmaita> you're right, i missed the error message
14:45:13 <rosmaita> "ERROR: This script does not work on Python 3.6 The minimum supported Python version is 3.7."
14:45:31 <rosmaita> ok, so same issue, will hopefully be fixed very soon
14:45:34 <whoami-rajat> so the victoria devstack patched failed at zuul https://review.opendev.org/c/openstack/devstack/+/827414
14:45:57 <whoami-rajat> when it merged the gates should be unblocked
14:46:00 <whoami-rajat> merges
14:46:46 <rosmaita> great ... so people, no rechecks on stable branch patches until ^^ merges
14:46:59 <jungleboyj> ++
14:47:13 <rosmaita> ok, thanks whoami-rajat
14:47:19 <whoami-rajat> np
14:47:44 <rosmaita> #topic operator survey -- resource count
14:47:53 <whoami-rajat> so that's all for stable branch release, stable cores can take a look at the etherpad for reviewing patches
14:48:01 <rosmaita> this is a followup from the midcycle last week
14:48:42 <rosmaita> geguileo needs to gather some data about number of volumes per project because it impacts dynamically determining usage
14:48:57 <rosmaita> (which is part of his quota redesign spec)
14:49:33 <rosmaita> here's what we came up with ... if you have comments, please let me know by tomorrow at 20:00 UTC
14:49:40 <rosmaita> https://rosmaita.wufoo.com/forms/cinder-resource-count-survey/
14:49:54 <rosmaita> not sure geguileo is here
14:50:03 <geguileo> geguileo: he may be around
14:50:10 <rosmaita> hooray!
14:50:23 <rosmaita> my question is when should we close the survey?
14:50:36 <rosmaita> i think we need to give you time to look at the results before the PTG
14:50:51 <rosmaita> so you can decide on what direction to take with your spec
14:51:06 <geguileo> sounds good
14:51:13 <rosmaita> i think if we don't have an end date, people will procrastinate and not fill it in
14:51:28 <geguileo> definitely need an end-date for this purpose
14:51:33 <geguileo> so before PTG sounds good
14:51:45 <geguileo> 1 or 2 days earlier is enough
14:51:53 <rosmaita> oh, ok
14:52:06 <jungleboyj> Sounds good.
14:52:24 <rosmaita> let's make it wendesday of release week then
14:52:46 <rosmaita> that would be march 30
14:53:42 <rosmaita> i will update the survey to say that it closes 1200 utc on 30 march
14:54:24 <rosmaita> ok, that's all i had
14:54:29 <rosmaita> #topic open discussion
14:55:41 <rosmaita> we need to pick a mypy patch of the week
14:57:11 <eharney> https://review.opendev.org/c/openstack/cinder/+/774288   is one option (RBD driver)
14:57:29 <rosmaita> ok, works for me
14:57:38 <eharney> e0ne left a comment there this morning i'm not sure i understand
14:57:40 <rosmaita> also, someone please look at this one: https://review.opendev.org/c/openstack/os-brick/+/786731
14:57:52 <rosmaita> (already has one +2)
14:58:25 <jungleboyj> Looking.
14:59:02 <rosmaita> need a designated reviewer for https://review.opendev.org/c/openstack/cinder/+/774288
14:59:10 <rosmaita> (other than me, i will review too)
14:59:21 <e0ne> eharney: please, ignore my previous comment for https://review.opendev.org/c/openstack/cinder/+/774288. I changed a vote
14:59:34 <rosmaita> e0ne: thanks for the quick response!
14:59:44 <eharney> great, thanks
14:59:49 <e0ne> np, I'm sorry for confusing you
14:59:55 <rosmaita> e0ne: do you want to remain as a reviewer for that patch?
15:00:35 <e0ne> rosmaita: I +2'ed on it
15:00:46 <rosmaita> \o/
15:00:49 <rosmaita> thanks!
15:00:57 <rosmaita> ok, we are out of time
15:01:00 <rosmaita> thanks everyone
15:01:06 <jungleboyj> Thanks rosmaita !
15:01:46 <whoami-rajat> thanks!
15:01:52 <rosmaita> don't forget:  the review priorities over the next week are: 1. os-brick reviews, 2. stephenfin's alembic patches
15:01:52 <rosmaita> also, if anyone pings me with a review request, please indicate which os-brick or stephenfin patch you have reviewed
15:01:59 <rosmaita> #endmeeting