14:00:42 <rosmaita> #startmeeting cinder
14:00:43 <openstack> Meeting started Wed May 26 14:00:42 2021 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:46 <openstack> The meeting name has been set to 'cinder'
14:00:50 <rosmaita> #topic roll call
14:01:08 <tosky> (just on IRC for now)
14:01:16 <walshh_> Hi
14:01:33 <rosmaita> video connection info:
14:01:45 <rosmaita> https://bluejeans.com/3228528973
14:01:54 <rosmaita> meeting agenda:
14:02:01 <rosmaita> https://etherpad.opendev.org/p/cinder-xena-meetings
14:02:51 <whoami-rajat_> Hi
14:03:33 <jungleboyj> o/
14:06:03 <rosmaita> #topic announcements
14:06:09 <rosmaita> let's remove v2!
14:06:17 <rosmaita> #link https://review.opendev.org/q/topic:%22drop-v2%22+status:open
14:06:25 <rosmaita> midcycle next week
14:06:36 <rosmaita> #link https://etherpad.opendev.org/p/cinder-xena-mid-cycles
14:07:06 <enriquetaso> hi
14:07:23 <rosmaita> #topic the freenode situation
14:09:06 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-May/022675.html
14:09:11 <hemna> https://arstechnica.com/gadgets/2021/05/freenode-irc-has-been-taken-over-by-the-crown-prince-of-korea/
14:10:26 <hemna> https://www.oftc.net ?
14:10:51 <jungleboyj> hemna:  Yes.
14:12:15 <jbernard> jungleboyj: +1
14:19:44 <rosmaita> options for voting
14:20:14 <rosmaita> option A : is the TC should wait and see what happens
14:20:34 <rosmaita> option B : is the TC should move away from freenode right away
14:20:59 <rosmaita> option C: is the TC should move away from freenode right away AND we recommend the move to OFTC
14:21:45 <rosmaita> #startvote What do we recommend to the TC? A, B, C
14:21:46 <openstack> Begin voting on: What do we recommend to the TC? Valid vote options are A, B, C.
14:21:47 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:21:57 <jungleboyj> #vote C
14:22:03 <whoami-rajat_> #vote C
14:22:07 <rosmaita> #vote C
14:22:09 <enriquetaso> #vote C
14:22:26 <walshh_> #vote C
14:22:28 <geguileo> #vote C
14:22:30 <jbernard> #vote C
14:22:35 <eharney> #vote C
14:22:58 <hemna> #vote C
14:23:07 <rosmaita> voting will close in 2 minutes
14:23:08 <sfernand> C
14:23:12 <sfernand> #vote C
14:23:20 <rosmaita> #showvote
14:23:21 <openstack> C (10): sfernand, hemna, enriquetaso, whoami-rajat_, jungleboyj, geguileo, jbernard, walshh_, rosmaita, eharney
14:25:13 <rosmaita> #endvote
14:25:14 <openstack> Voted on "What do we recommend to the TC?" Results are
14:25:15 <openstack> C (10): sfernand, hemna, enriquetaso, whoami-rajat_, jungleboyj, geguileo, jbernard, walshh_, rosmaita, eharney
14:25:41 <rosmaita> #topic stable branch updates
14:26:21 <whoami-rajat_> #link  https://etherpad.opendev.org/p/cinder-stable-releases-june
14:28:18 <whoami-rajat_> #link https://etherpad.opendev.org/p/cinderlib-wallaby-release
14:31:09 <rosmaita> #action rosmaita make sure ceph-iscsi CI patches have all merged and the job is running
14:31:32 <rosmaita> (after that, we will cut a new rbd-iscsi-client release to verify that the openstack tooling is all working)
14:32:28 <rosmaita> #topic followup on "what to do about the v2 api-ref?
14:33:19 <rosmaita> #link http://eavesdrop.openstack.org/meetings/infra/2021/infra.2021-05-25-19.01.log.html#l-173
14:35:54 <rosmaita> #action rosmaita put up a patch saying the v2 api has been removed and you should be using v3
14:36:17 <rosmaita> #topic train-only backport
14:36:36 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/790963
14:38:46 <_dvd> Ideally we'd fix the driver by removing mock from master and maybe backport it
14:38:57 <_dvd> but I don't have the resources for this
14:39:05 <_dvd> py2 on train is already broken
14:39:12 <_dvd> just trying to fix it for py3 at least
14:39:25 <_dvd> this breaks oslo-config-(validator|generator)
14:39:33 <_dvd> when cloning a storage
14:39:50 <enriquetaso> master bug report:
14:39:52 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1928232
14:39:54 <openstack> Launchpad bug 1928232 in Cinder "infinidat volume driver shouldn't use mock in production code" [Medium,New]
14:40:16 <_dvd> eharney, so I'm afraid to break it for people that installed mock on py2 on train
14:40:31 <_dvd> but meanwhile, can't we just fix it for py3 ?
14:40:46 <_dvd> and once they fix it the correct way, we remove that monkeypatch
14:41:08 <_dvd> and that's a valid concern
14:41:25 <_dvd> but I don't think there's an easy way, at least for me to fix it and test it
14:41:52 <tosky> can't we just send an email to the last known contacts there?
14:43:44 <_dvd> eharney, config-generator is broken because of that
14:44:01 <_dvd> eharney, I'm working on a tripleovalidation role to run validator
14:44:15 <_dvd> and since cinder has a bunch of dynamic drivers, I need to pass opt_data
14:44:19 <_dvd> from the generator
14:44:23 <_dvd> let me link the role
14:44:36 <_dvd> https://review.opendev.org/c/openstack/tripleo-validations/+/789698
14:44:49 <_dvd> I cant try to exclude it
14:45:00 <_dvd> sorry I can*
14:45:24 <_dvd> nop, it's just a PITA to me :)
14:47:41 <_dvd> awesome thanks
14:47:54 <rosmaita> so, summary of what we said out loud
14:48:27 <rosmaita> three things:
14:48:53 <rosmaita> 1 - david's patch is acceptable in train ; it fixes py3 and doesn't break py2 any more than it is already
14:49:13 <rosmaita> 2 - pursue the proper fix in master to remove mock usage from production and backport -> train
14:49:56 <rosmaita> 3 - look into a job doing the config generator stuff to make sure it works, maybe part of pep8 check
14:50:37 <rosmaita> or somewhere
14:51:18 <_dvd> awsome thanks everyone
14:51:25 <rosmaita> #topic osc support for microversions
14:51:42 <rosmaita> #link https://review.opendev.org/c/openstack/python-openstackclient/+/792950
14:53:24 <rosmaita> we should keep an eye on ^^ and the followup patches that are adding functionality to the osc
14:54:14 <rosmaita> #topic open discussion
14:55:49 <tosky> and vote on that openstackclient patch if you feel like
14:56:07 <rosmaita> let's get some eyes on these: https://review.opendev.org/q/topic:%22remove-locks%22+(status:open%20OR%20status:merged)
15:01:08 <rosmaita> (continue discussion in video)
15:01:10 <rosmaita> #endmeeting