14:00:31 <rosmaita> #startmeeting cinder
14:00:32 <openstack> Meeting started Wed Feb  3 14:00:31 2021 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:35 <openstack> The meeting name has been set to 'cinder'
14:00:39 <eharney> hi
14:00:42 <rosmaita> #topic roll call
14:00:43 <lpetrut> hi
14:00:55 <whoami-rajat__> Hi
14:00:56 <walshh_> hi
14:01:21 <rosmaita> hello everyone
14:01:23 <rosmaita> #link https://etherpad.openstack.org/p/cinder-wallaby-meetings
14:01:30 <tosky> hi
14:01:56 <e0ne> hi
14:02:15 <rosmaita> there's a lot on the agenda today, so let's get started
14:02:26 <rosmaita> #topic announcements - upcoming events
14:02:36 <rosmaita> ok, right now is R-10
14:02:52 <rosmaita> next week we have the R-9 midcycle
14:03:02 <rosmaita> wednesday, 1400-1600 utc
14:03:11 <TusharTgite> hi
14:03:11 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-February/020194.html
14:03:15 <rosmaita> for full info ^^
14:03:20 <jungleboyj> o/
14:03:34 <rosmaita> also in R-9 is the cinder new feature status checkpoint
14:03:44 <rosmaita> #link https://releases.openstack.org/wallaby/schedule.html#w-cinder-feature-checkpoint
14:03:54 <rosmaita> read ^^ if you don't know what i'm talking about
14:04:08 <enriquetaso> hi
14:04:13 <rosmaita> and in R-8 we have  cinder driver features declaration
14:04:21 <rosmaita> #link https://releases.openstack.org/wallaby/schedule.html#w-cinder-driver-features-declaration
14:04:40 <rosmaita> #topic announcements - rbd-iscsi-client
14:05:05 <rosmaita> as you may know, the ceph-iscsi driver has a dependency on a client library that hemna wrote
14:05:35 <rosmaita> we (cinder project) are assuming maintenance of it
14:05:47 <rosmaita> #link https://review.opendev.org/c/openstack/project-config/+/772596
14:05:56 <rosmaita> #link https://review.opendev.org/c/openstack/governance/+/772597
14:06:06 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/773158
14:06:27 <rosmaita> that last one explains the gerrit group for the rbd-iscsi-client
14:06:51 <rosmaita> there may be interest from ironic or ceph people from getting in on the action
14:07:15 <rosmaita> so it will be easy to add non-cinder-cores to the rbd-iscsi-client-core team
14:07:31 <rosmaita> but as of right now, cinder-core is an included group in rbd-iscis-client-core
14:07:33 <jungleboyj> ++
14:07:41 <eharney> cool
14:07:53 <rosmaita> rbd-iscsi-client was using travis CI in github for CI
14:08:12 <rosmaita> so we'll need to set up zuul jobs for the PTI
14:08:30 <rosmaita> if someone wants to volunteer for that, i will be happy to let you do it
14:08:46 <rosmaita> let me know
14:08:57 <hemna> hi
14:08:59 <rosmaita> #announcement - add assert:supports-api-interoperability to cinder
14:09:34 <rosmaita> #topic announcement - add assert:supports-api-interoperability to cinder
14:09:53 <rosmaita> #link https://review.opendev.org/c/openstack/governance/+/773684
14:10:04 <rosmaita> i think this is a no-brainer, we already do all this stuff
14:10:23 <jungleboyj> ++
14:10:48 <rosmaita> anyway, if you have strong feelings, leave a comment on the review
14:11:14 <rosmaita> #topic announcements - requirements, lower-constraints changes
14:11:29 <rosmaita> there are still a bunch of these patches un-merged
14:11:42 <rosmaita> they won't become a big problem until suddenly they do
14:11:56 <rosmaita> i think the only ones left are on stable branches
14:12:08 <rosmaita> #link https://review.opendev.org/q/topic:%22update-l-c%22
14:12:22 <rosmaita> i could use some help on the cinderlib/stable/train patch
14:12:26 <rosmaita> there
14:12:29 <whoami-rajat__> ^ I've listed the stable branch ones in my review tracker
14:12:35 <rosmaita> whoami-rajat__: ty
14:12:45 <rosmaita> #link https://review.opendev.org/c/openstack/cinderlib/+/771091
14:13:04 <rosmaita> that one has an ansible task in pre-run playbook for cinderlib-ceph-functional job is failing in cinderlib/stable/train
14:13:12 <jungleboyj> rosmaita:  I had looked last week.  Will look again.
14:13:24 <rosmaita> thanks!
14:13:28 <hemna> I've run into issues running tox on stable/train not being nice'
14:14:09 <rosmaita> yeah, a patch merged recently about the pep8 job there, maybe that will help
14:14:21 <hemna> cool thanks
14:14:26 <rosmaita> #topic announcements - new drivers status
14:14:36 <rosmaita> ok, two drivers left
14:14:48 <rosmaita> 1 - ceph-iscsi
14:14:56 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/662829
14:15:09 <rosmaita> it has one +2 and the CI is set up and passing
14:15:20 <rosmaita> you can find the associated CI patches and support from ^^
14:15:45 <jungleboyj> Ah, I need to look at that one again and merge it.
14:15:52 <jungleboyj> I will do that today.
14:16:10 <rosmaita> ok, so if anyone wants to see it before it merges, act fast!
14:16:20 <rosmaita> 2 - kioxia kumoscale
14:16:30 <rosmaita> zohan sent a message to the ML
14:16:40 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-February/020155.html
14:17:12 <rosmaita> info in ^^ about the patches
14:17:18 <rosmaita> CI is responding
14:17:44 <hemna> what's the deadline for these to merge ?
14:17:49 <rosmaita> but we need reviews right away, because there will be some revisions needed
14:18:01 <jungleboyj> smcginnis:  Can we get the new CIs added to your list you are monitoring?
14:18:02 <rosmaita> ceph-iscisi was 5 feb (Friday)
14:18:07 <tosky> the deadline is always "yesterday"
14:18:09 <hemna> doh
14:18:18 <rosmaita> kioxia is 8 Feb (monday)
14:18:22 <jungleboyj> :-)
14:18:35 <rosmaita> hemna: i don't know why i used past tense
14:18:50 <rosmaita> jungleboyj: i was supposed to get smcginnis a list of the new CIs
14:18:59 <jungleboyj> Ok.  Good.
14:19:08 <rosmaita> #action rosmaita - get smcginnis a list of the new CIs
14:19:41 <rosmaita> ok i have a general question about CI that's not specific to kioxia
14:19:45 <rosmaita> but was something i noticed
14:19:52 <rosmaita> the driver supports thin provisioning
14:20:03 <rosmaita> but the CI is running with the default, which is thick
14:20:37 <rosmaita> which seems appropriate, you want to make sure the default works
14:20:51 <rosmaita> what do other drivers do about this?
14:21:37 <eharney> i assume most just test one or the other since which one you use isn't going to be interesting for the kind of testing we do in ci jobs
14:21:39 <rosmaita> i don't think i've seen any CI running separate jobs
14:21:59 <jungleboyj> Hmmm, I don't think it is a question we have asked before.
14:22:14 <rosmaita> ok,  then we don't want to hold anything up by asking it now!
14:22:32 <rosmaita> ok, CI with the default provisioning is fine for kioxia
14:22:34 <eharney> we don't have tests that focus enough at the data level to care about the implications of thick vs. thin
14:22:34 <hemna> plus you can change the provisioning type in a volume type as well
14:22:43 <hemna> as long as the driver is reporting it supports both it can work
14:23:19 <rosmaita> sounds good
14:23:39 <rosmaita> ok, so we have jungleboyj committed to reviewing ceph-iscsi
14:23:46 <jungleboyj> Yep.
14:24:01 <rosmaita> i'd like to get some names associated with the kioxia patches
14:24:17 <rosmaita> particularly the os-brick change for the nvmeof connector
14:24:46 <hemna> I can take a look at the os-brick change
14:24:59 * jungleboyj will try to look but would like others better with OS-Brick to look.
14:25:04 <jungleboyj> hemna:  ++
14:25:14 <rosmaita> great
14:25:33 <rosmaita> jungleboyj: that is my feeling too, i have looked, but would like more eyes on that
14:25:40 <jungleboyj> ++
14:26:03 <rosmaita> i did a first pass through the driver and picked up superficial stuff, will be going through it again
14:26:30 <rosmaita> btw, the zuul -1 is the lvm-barbican job, so don't let that stop you from looking at the driver patch
14:27:58 <rosmaita> so ... i hate to put people on the spot, but we need to perform our community duties
14:28:10 <rosmaita> need one more core to commit to the kioxia driver review
14:28:32 <rosmaita> and would like someone other than me, jungleboyj to commit to the nvmeof connector change
14:28:39 <jungleboyj> :-)
14:28:44 <rosmaita> (other than hemna, too, he has already committed)
14:29:14 <whoami-rajat__> I can take a look at the driver
14:29:24 <rosmaita> whoami-rajat__: excellent, ty
14:29:27 <e0ne> rosmaita: I can help with nvmeof review
14:29:35 <rosmaita> great
14:30:12 <rosmaita> ok, please get some comments, the kioxia team has been responding quickly
14:30:25 <chuckpiercey> thank you
14:31:01 <rosmaita> we can see where we are on 8 Feb, hopefully really close
14:31:13 <rosmaita> ok, that's all for announcements and business
14:31:21 <rosmaita> #topic stable release update
14:31:24 <rosmaita> whoami-rajat__: that's you
14:31:28 <whoami-rajat__> #link https://etherpad.opendev.org/p/stable-releases-review-tracker-22-02-2021
14:31:31 <whoami-rajat__> thanks rosmaita
14:31:58 <whoami-rajat__> I've set up a tracker doc for the patches targeted in each branch
14:32:25 <whoami-rajat__> There have been patches merged in stable/victoria since last week (I've striked and moved merged ones below open ones)
14:32:36 <jungleboyj> Nice.
14:32:38 <whoami-rajat__> sadly there were no reviews on ussuri and train
14:33:15 <whoami-rajat__> So stable cores can take a look at the patches listed and help with the reviews :)
14:33:33 <jungleboyj> I had been doing stable reviews last week.  Needed someone else to go through and give the second review.
14:33:40 <jungleboyj> So, a call for help there.
14:33:42 <rosmaita> ok, thanks ... reminder that the priority is the new drivers
14:33:49 <whoami-rajat__> yes, jungleboyj thanks for the reviews
14:33:56 <rosmaita> we don't have a hard deadline for stable releases
14:34:13 <jungleboyj> rosmaita:  ++
14:34:32 <rosmaita> so ... everyone: review ceph-iscsi and kioxia, and then we have this handy list of what to do next
14:34:42 <whoami-rajat__> yep, there's still a lot of time for stable release i.e. R-7 but i think we can delay it if other priority tasks exist
14:35:01 <rosmaita> thanks for the update
14:35:08 <whoami-rajat__> that's all from my side
14:35:23 <rosmaita> #topic Windows RBD os-brick support
14:35:28 <rosmaita> this was postponed from last week
14:35:33 <rosmaita> lpetrut: that's you
14:35:35 <lpetrut> hi. we're hoping to get the Windows RBD os-brick connector merged: https://review.opendev.org/c/openstack/os-brick/+/718403
14:35:40 <lpetrut> the CI's already running: os-brick-ceph http://cloudbase-ci.com/os-brick/718403/17/ceph/ : SUCCESS in 1h 02m 03s
14:35:47 <lpetrut> FWIW, Windows RBD support already landed in Ceph Pacific. Here's a readme: https://github.com/ceph/ceph/blob/pacific/README.windows.rst
14:35:53 <lpetrut> the os-brick patch is quite simple, it already got a few reviews. It's fully understandable if we want to wait until the new driver deadline though.
14:36:17 <rosmaita> thanks, great that this has CI, too
14:36:59 <rosmaita> so ... new drivers first, then pick this one up
14:37:17 <rosmaita> lpetrut: thanks for the links to the info
14:37:31 <rosmaita> #topic Dividing utils and volume_utils
14:37:38 <rosmaita> i think this is also from last week
14:37:42 <rosmaita> eharney: that's you
14:37:45 <eharney> yes
14:37:53 <eharney> basically we have made cinder.utils import everything under the sun
14:38:04 <geguileo> rofl
14:38:08 <eharney> the result of this is that things like the api service and cinder-manage commands etc load tons of code they don't need (like os-brick)
14:38:26 <eharney> this is reorganizing utils code into more specific areas like volume_utils to fix this coupling
14:38:28 <jungleboyj> :-9
14:38:45 <eharney> the second patch i listed moves trace utils to volume_utils since they are only used by volume code
14:39:00 <rosmaita> makes sense
14:39:01 <eharney> hemna suggests moving them to a separate trace_utils file, not sure if that is beneficial or not at this point
14:39:04 <geguileo> eharney: I like that, and we should add a comment on the cinder/utils.py file saying what shouldn't go in that file
14:39:17 <rosmaita> geguileo: ++
14:39:24 <eharney> (nothing outside of volume/ uses the trace code)
14:39:56 <eharney> i can do whatever, but i'd prefer to stick to refactoring that has a direct benefit vs. things that someone might want later
14:40:14 <hemna> I have added trace to various parts of cinder during debugging problems fwiw.
14:40:15 <geguileo> eharney: I'm ok either way
14:40:32 <geguileo> hemna: you have added it on your env, or in the Cinder code?
14:40:34 <eharney> i don't know enough about the trace stuff to know what people are really doing with it
14:40:41 <hemna> in my env
14:40:53 <hemna> it's a great facility for debugging
14:40:59 <geguileo> hemna: then if you only do it for dev, you probably don't really mind if it's in a single file
14:41:21 <geguileo> another thing is if we start adding it in the Cinder code...
14:41:31 <hemna> It's not a big issue, I just figured if we are refactoring, put the trace stuff in it's own file
14:42:15 <geguileo> hemna: I think we can add a comment on the trace methods saying that if this is used somewhere else in the API or Scheduler it should be moved out of the file
14:42:37 <rosmaita> geguileo: that sounds like a good compromise for now
14:42:39 <geguileo> that way we have it in a single file now, but we know it should be moved out if we start using it
14:42:42 <eharney> geguileo: sounds like a good plan
14:43:03 <rosmaita> i love it when a plan comes together
14:43:14 <rosmaita> #topic Support volume encryption on NFS backends status
14:43:19 <hemna> that's fine.  I have worked on custom scheduler filters and used it there
14:43:28 <rosmaita> i think this is yet another postponed topic from last week
14:43:34 <rosmaita> enriquetaso: you have the floor
14:43:41 <enriquetaso> hi
14:43:49 <enriquetaso> Hi I'd like to give a brief summary of the status of generic NFS backend with encryption and maybe catch attention for reviews and collaboration
14:43:57 <enriquetaso> Initial work merged last year https://review.opendev.org/c/openstack/cinder/+/597148/
14:44:07 <enriquetaso> Basic operations like create a volume / clone volume are supported.
14:44:21 <enriquetaso> But an important bug came out and in order to fix this should implement a driver copy_image_to_encrypted_volume() method to handle this create a volume from an image. Without it, NFS is currently falling into the base driver generic copy_image_to_encrypted_volume() method which does not work for how NFS managed encrypted volumes.
14:44:35 <enriquetaso> I have this patch waiting for lucky reviews: https://review.opendev.org/c/openstack/cinder/+/749155/
14:44:44 <enriquetaso> So any reviews or comments are welcome! \o/
14:44:54 <tosky> I think this was already touched, but just to be sure: does this affect only the generic NFS driver, or also any backend-specific NFS drivers?
14:45:01 <eharney> this is pretty important, are there CI jobs that test this path?
14:45:25 <enriquetaso> only generic tosky as far as I know
14:46:09 <enriquetaso> eharney, don't think any job uses the generic nfs
14:46:17 <eharney> we have generic nfs ci jobs
14:46:23 <tosky> we run the devstack-plugin-nfs-tempest-full job, but I don't remember if encryption is enabled there for volume tests
14:46:40 <enriquetaso> oh sorry
14:47:20 <rosmaita> i agree with eharney that it would be good to get CI coverage for this
14:47:26 <rosmaita> it looks like a pretty nasty bug
14:47:39 <eharney> but we really probably shouldn't hold up the bugfix for that if we can test and show that it works
14:48:08 <enriquetaso> #action enriquetaso get CI coverage
14:48:30 <rosmaita> ok ... so, ceph-iscsi, kioxia, windows-ceph-support, nfs-encryption-bug (for priorities)
14:48:36 <rosmaita> and stable branch reviews after that
14:48:46 <rosmaita> thanks, sofi
14:48:49 <rosmaita> anything else?
14:48:55 <enriquetaso> nop
14:49:07 <rosmaita> great, next topic is you, too
14:49:12 <enriquetaso> yes :P
14:49:18 <rosmaita> #topic Wallaby R-10 Bug Review
14:49:32 <rosmaita> enriquetaso has volunteered to take over as bug deputy
14:49:33 <enriquetaso> OK
14:49:44 <enriquetaso> First: I think I'd be useful for us to add an email 'bug deputy report for the week' like neutron do http://lists.openstack.org/pipermail/openstack-discuss/2021-February/020152.htmlIn this way, the team gets the news  even if we don't we time to talk about them in our meeting (as happened last week)
14:49:45 <jungleboyj> Cool.  Thanks enriquetaso
14:49:59 <jungleboyj> ++
14:50:01 <enriquetaso> what the team thinks?
14:50:53 <rosmaita> if you don' t mind putting together an email, that's good
14:50:58 <whoami-rajat__> We usually get time to cover all topics (except the last meeting) but I've no issues with it being published on the ML
14:51:16 <rosmaita> i think i'd still like you to talk about any important or complicated ones at the meeting
14:51:36 <enriquetaso> sure
14:51:44 <enriquetaso> We have a couple bugs reported this week: 5 for Cinder and 1 for Cinder client:
14:51:54 <enriquetaso> #link https://etherpad.opendev.org/p/cinder-wallaby-r10-bug-review
14:52:04 <enriquetaso> bug_1: DellEMC VNX driver: volume is not created but status is 'available' in openstack
14:52:09 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1914319
14:52:11 <openstack> Launchpad bug 1914319 in Cinder "DellEMC VNX driver: volume is not created on array but status is 'available' in openstack" [High,New] - Assigned to Yong Huang (yonghuang)
14:52:43 <enriquetaso> Looks pretty heavy if Cinder shows the volume as available the volume isn't and also errors with  'vnx-fc-074 cinder-volume[1486261]: ERROR oslo_messaging.rpc.server'
14:53:59 <enriquetaso> The next one looks also big deal, but not sure
14:54:08 <enriquetaso> bug_2: After attachment-delete nova still sees volume as attached
14:54:13 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1914273
14:54:14 <openstack> Launchpad bug 1914273 in Cinder "After attachment-delete nova still sees volume as attached" [Medium,New]
14:54:19 <enriquetaso> Using cinder attachment-delete command to detach a volume from a stopped instance seems to be affecting only what cinder sees but not what nova sees.
14:54:22 <eharney> i'm pretty sure this isn't a bug
14:54:36 <enriquetaso> ohh
14:55:02 <eharney> if you delete the attachment from cinder and don't detach from nova, this is what you would expect to happen, AFAIK
14:56:01 <enriquetaso> Ok, we don't have time so the last one I'm going to mention is from cinder client
14:56:07 <enriquetaso> bug_6: Cinderclient needs to support microversion 3.63
14:56:13 <enriquetaso> #link https://bugs.launchpad.net/python-cinderclient/+bug/1913474
14:56:14 <openstack> Launchpad bug 1913474 in python-cinderclient "Cinderclient needs to support mv 3.63" [Medium,Triaged]
14:56:17 <enriquetaso> We need some lucky one to implement this.
14:56:41 <rosmaita> well, we also need to merge mv 3.63 first: https://review.opendev.org/c/openstack/cinder/+/666886
14:57:07 <whoami-rajat__> I don't think we require a bug to track cinderclient mv support
14:57:11 <rosmaita> that's got a +2, also geguileo reviewed it at one point and i think all the comments were addressed, looks pretty solid now
14:57:39 <rosmaita> i think there's a patch up for the cinderclient already?
14:57:56 <enriquetaso> i couldn't find that patch
14:57:57 <rosmaita> #link https://review.opendev.org/c/openstack/python-cinderclient/+/772758
14:58:09 <geguileo> rosmaita: I'll do another review
14:58:15 <enriquetaso> cool!
14:58:22 <rosmaita> geguileo: after new drivers!
14:58:23 <enriquetaso> I'll link it to the launchpad
14:58:30 <rosmaita> enriquetaso: great
14:58:35 <geguileo> I was saying about the microversion patch...
14:58:37 <enriquetaso> that's all for me
14:58:42 <rosmaita> geguileo: i know
14:58:45 <geguileo> ok
14:59:03 <rosmaita> should be pretty quick, i think he took all your suggestions :)
14:59:27 <rosmaita> ok, thanks enriquetaso
14:59:31 <rosmaita> #topic open discussion
14:59:43 <rosmaita> some review begging on the etherpad :D
14:59:47 <eharney> i added +RP to https://review.opendev.org/c/openstack/os-brick/+/755478 , looks important
14:59:57 <eharney> data integrity issue for FC... has been sitting for months
15:00:12 <rosmaita> eharney: thanks for the link, i couldn't find it
15:00:19 <rosmaita> ok, we need to make way for horizon
15:00:23 <rosmaita> thanks everyone!
15:00:29 <whoami-rajat__> thanks!
15:00:30 <rosmaita> don't forget, midcycle next week
15:00:33 <rosmaita> #endmeeting