14:01:51 <rosmaita> #startmeeting cinder
14:01:52 <openstack> Meeting started Wed Nov 25 14:01:51 2020 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:55 <openstack> The meeting name has been set to 'cinder'
14:02:15 <rosmaita> This meeting is also being held in video
14:02:31 <rosmaita> https://bluejeans.com/3228528973
14:02:37 <e0ne> hi
14:02:40 <rosmaita> #topic roll call
14:02:44 <whoami-rajat__> Hi
14:02:58 <rafaelweingartne> \o
14:03:07 <walshh_> Hi
14:03:17 <michael-mcaleer> Hi
14:03:46 <lseki> o/
14:03:53 <rosmaita> #topic announcements
14:04:03 <rosmaita> new gerrit interface
14:04:27 <rosmaita> need git-review >= 1.27.0
14:04:56 <rosmaita> reported issues: https://etherpad.opendev.org/p/gerrit-3.2-post-upgrade-notes
14:05:27 <rosmaita> irc channel for questions, etc. is #opendev
14:05:39 <rosmaita> from clarkb:
14:05:47 <rosmaita> #opendev is for the services that opendev runs. This includes gerrit and zuul and all that.
14:05:47 <rosmaita> #openstack-infra is for openstack's interfaces with opendev. Primary we see this being used for debugging openstack CI jobs and similar
14:06:56 <rosmaita> instead of -1 Workflow, you can explicitly mark a patch as "Work in Progress"
14:08:02 <enriquetaso> o/
14:08:12 <abishop> o/
14:09:12 <rosmaita> use the old method if you actually want people to look at it
14:09:30 <rosmaita> use the new WIP if you want to stash some patch that you are still working on
14:09:51 <rosmaita> Milestone-1 next week
14:10:11 <rosmaita> tomorrow and Friday are USA holidays
14:11:02 <rosmaita> midcycle is the week after next
14:11:15 <rosmaita> #topic midcycle scheduling
14:11:26 <rosmaita> last week i asked you to check your calendars about having a 2 hour midcycle on wednesday 9 December
14:11:39 <rosmaita> let's take a quick vote to see whether we have agreement on a time, or whether i need to put together a poll
14:11:54 <rosmaita> "early" == 1300-1500 UTC wednesday 9 december
14:12:07 <rosmaita> "late" == 1400-1600 UTC wednesday 9 december
14:12:14 <rosmaita> "more" == need to take a poll with more options
14:12:40 <rosmaita> #startvote When should we have the R-18 midcycle? early, late, more
14:12:41 <openstack> Begin voting on: When should we have the R-18 midcycle? Valid vote options are early, late, more.
14:12:42 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:12:49 <walshh_> late
14:12:51 <michael-mcaleer> #vote late
14:12:54 <rafaelweingartne> later
14:13:00 <abishop> #vote late
14:13:01 <rafaelweingartne> #vote late
14:13:02 <rosmaita> #vote late
14:13:03 <enriquetaso> #vote late
14:13:04 <whoami-rajat__> #vote late
14:13:07 <amar7ibm> #vote late
14:13:08 <lseki> #vote late
14:13:10 <walshh_> #vote late
14:13:30 <rosmaita> #showvote
14:13:31 <openstack> late (9): amar7ibm, enriquetaso, walshh_, lseki, rafaelweingartne, whoami-rajat__, abishop, michael-mcaleer, rosmaita
14:14:01 <tosky> #late
14:14:03 <tosky> grr
14:14:06 <e0ne> #vote late
14:14:06 <tosky> #vote late
14:14:18 <eharney> #vote late
14:14:37 <rosmaita> last call ? anyone still thinking or looking at their calendar?
14:15:18 <rosmaita> #endvote
14:15:19 <openstack> Voted on "When should we have the R-18 midcycle?" Results are
14:15:20 <openstack> late (12): tosky, amar7ibm, enriquetaso, walshh_, lseki, rafaelweingartne, whoami-rajat__, abishop, michael-mcaleer, e0ne, rosmaita, eharney
14:15:36 <rosmaita> #link https://etherpad.opendev.org/p/cinder-wallaby-mid-cycles
14:16:01 <rosmaita> #topic Wallaby R-21 Bug Review
14:16:04 <michael-mcaleer> R-21 Wallaby Cinder Bug Review #link https://etherpad.opendev.org/p/cinder-wallaby-r21-bug-review
14:17:36 <michael-mcaleer> to review: #link https://review.opendev.org/762884
14:19:54 <rosmaita> #topic stable releases
14:20:01 <whoami-rajat__> #link https://etherpad.opendev.org/p/stable-releases-review-tracker
14:22:19 <rosmaita> #topic back-restore (shell cmd) to volume type and/or AZ
14:22:42 <rosmaita> #link https://review.opendev.org/762020
14:23:19 <rosmaita> updates the CLI command to allow you to create volumes from a backup (but uses the create-volume api under the hood)
14:27:04 <rosmaita> #topic using the intersphinx extension in release notes
14:27:21 <rosmaita> #link https://review.opendev.org/#/c/762720/
14:32:47 <rosmaita> #topic reconsidering "restricting supported Ceph versions"
14:35:01 <tosky> rosmaita: breaking the topic, but: the openstackdocstheme sphinx extension which allows you to link to a different document (but using the correct branch) is https://docs.openstack.org/openstackdocstheme/latest/#external-link-helper
14:35:51 <rosmaita> what versions of Ceph should we test with?
14:37:05 <rosmaita> not a requirement to test with all versions
14:40:23 <rosmaita> #action rosmaita revise patch to make it a bit more clear
14:42:00 <rosmaita> we do want to restrict the "supported" releases
14:42:15 <rosmaita> we do not want to run 4 CI jobs for all "supported" versions
14:42:27 <rosmaita> we will only fix bugs for problems in "supported" versions
14:42:41 <rosmaita> we may consider adding another CI job for the oldest version we support
14:43:34 <rosmaita> #topic secure RBAC checkin
14:44:22 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/763306
14:44:35 <rosmaita> #link https://review.opendev.org/#/q/status:open+project:openstack/cinder+branch:master+topic:secure-rbac
14:51:42 <rosmaita> #action rosmaita make a clear statement about who "owns" resources (projects do)
14:53:20 <rosmaita> #topic Suggestions for Spec Prosposal - " Migration(pool - pool) support for volume when replication status is set to enabled "
14:57:56 <rosmaita> gorka thinks the check in api.py is to verify that the source and target volume type have the same replication status
15:00:08 <amar7ibm> https://opendev.org/openstack/cinder/src/branch/master/cinder/volume/api.py
15:03:34 <amar7ibm> https://review.opendev.org/#/c/747425/11
15:07:19 <rosmaita> let's take this to cinder channel
15:07:21 <rosmaita> #endmeeting