14:00:03 <rosmaita> #startmeeting cinder
14:00:04 <openstack> Meeting started Wed Nov  4 14:00:03 2020 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <openstack> The meeting name has been set to 'cinder'
14:00:08 <e0ne> hi
14:00:11 <rosmaita> #topic roll call
14:00:13 <whoami-rajat__> Hi
14:00:18 <lseki> o/
14:00:19 <eharney> hi
14:00:23 <michael-mcaleer> hi
14:00:39 <jungleboyj> o/
14:01:13 <whoami-rajat__> rosmaita: hi, can you provide link the new etherpad?
14:01:19 <rosmaita> sure
14:01:20 <geguileo> hi! o/
14:01:29 <rosmaita> #link https://etherpad.opendev.org/p/cinder-wallaby-meetings
14:01:34 <rosmaita> good turnout!
14:01:35 <whoami-rajat__> thanks
14:02:04 <rosmaita> it was nice to see everyone last week, hope you had safe travels home, even if you only had to go upstairs or to the next room
14:02:19 <jungleboyj> :-)
14:02:32 <rosmaita> #topic announcements
14:03:06 <rosmaita> this isn't on the agenda, but if you want a courtesy ping in the #openstack-cinder channel approximately 2 minutes before the weekly meeting ...
14:03:15 <rosmaita> add your nick to the list at the top of the etherpad
14:03:24 <rosmaita> line 32
14:03:53 <michael-mcaleer> thanks brian, added myself to it
14:03:54 <e0ne> rosmaita: thanks for copy the old list:)
14:04:14 <geguileo> +1
14:04:28 <rosmaita> that's a good reminder, if you have changed your nick, please update the list or remove the old one
14:04:46 <rosmaita> #topic announcements - stable/stein going to EM
14:04:58 <rosmaita> I think i mentioned this at the PTG
14:05:16 <rosmaita> stable/stein is going into Extended Maintenance mode on 11 november or thereabouts
14:05:27 <rosmaita> this etherpad shows what's up for cinder deliverables:
14:05:39 <rosmaita> #link https://etherpad.opendev.org/p/cinder-stable-stein-em
14:05:44 <rosmaita> please open it
14:06:01 <rosmaita> you will see that we only need to release from cinder
14:06:23 <rosmaita> there are two un-merged patches proposed for stable/stein
14:06:38 <rosmaita> #link https://review.opendev.org/759934
14:06:47 <rosmaita> has one +2, i think it's fine to backport
14:07:01 <rosmaita> #link https://review.opendev.org/729657
14:07:17 <rosmaita> has a -W by the owner, who i think is sfernand ?
14:08:16 <lseki> sfernand is on vacation, not sure if he's actually online
14:08:23 <rosmaita> lseki: oh, ok
14:08:34 <lseki> I'll ask him to remove his -W
14:08:49 <tosky> there is also https://review.opendev.org/#/c/761184/, waiting for the dependencies to merge, but it doesn't need to hold the release
14:09:21 <rosmaita> ok, cool ... i believe it's already been backported, so shouldn't be an issue, i was wondering whether there was a testing holdup for stable/stein on the vendor side
14:09:44 <rosmaita> tosky: correct, we will merge that eventually, but do not need to have it for the release
14:10:01 <whoami-rajat__> rosmaita:  lseki: i think we can rebase the patch, W-1 and CR-1 will automatically be removed
14:10:29 <rosmaita> #action lseki check about whether https://review.opendev.org/729657 should be backported
14:10:54 <rosmaita> whoami-rajat__: i think you are right ... lseki verify that it looks good from the vendor side, and we can work from there
14:11:32 <rosmaita> no other patches have been proposed, so unless someone says something before the end of the meeting, only the stuff currently on the etherpad is elegible for the final stein release
14:12:08 <rosmaita> #topic announcements - summary of last week's PTG is available
14:12:17 <rosmaita> #link https://wiki.openstack.org/wiki/CinderWallabyPTGSummary
14:12:28 <rosmaita> please look through and make corrections if necessary
14:12:38 <rosmaita> also pay attention to ACTION items assigned to you
14:12:52 <rosmaita> is hemna here?
14:13:14 <rosmaita> when i was writing that up, i realized that we didn't discuss ceph iscsi support last week
14:13:32 <rosmaita> which i believe hemna is still working on
14:13:40 <rosmaita> ok, he can update us at a future cinder meeting
14:13:52 <rosmaita> #topic announcements - X release naming
14:14:05 <rosmaita> #link https://wiki.openstack.org/wiki/Release_Naming/X_Proposals
14:14:14 <rosmaita> if you have ideas, add them!
14:15:08 <rosmaita> i gave up in V when "Vaiveahtoish" wasn't selected
14:15:16 <smcginnis> Hah
14:15:21 <rosmaita> :)
14:15:48 <rosmaita> #topic announcements - gerrit outage 20-23 november
14:15:56 <rosmaita> "The OpenDev team is planning a long weekend Gerrit outage on review.opendev.org starting 15:00UTC November 20 and running to 01:00UTC November 23, 2020 in order to upgrade to Gerrit 3.2."
14:16:21 <rosmaita> i don't think we have anything in particular as a deadline around then
14:20:29 <rosmaita> so this is just for awareness
14:20:29 <rosmaita> #link http://lists.opendev.org/pipermail/service-announce/2020-October/000012.html
14:20:29 <rosmaita> ok, that's all from me ... anyone else have something to announce?
14:20:30 <rosmaita> ok, let's move along
14:20:31 <rosmaita> #topic cinder bug deputy
14:20:32 <rosmaita> hmmm, no openstack bot
14:20:32 <rosmaita> did is misspell 'topic'?
14:20:33 <rosmaita> doesn't matter
14:20:34 <rosmaita> what does matter is that michael-mcaleer has volunteered to be the cinder bug deputy for wallaby
14:20:35 <rosmaita> we had a quick chat about what that means
14:20:36 <rosmaita> ("we" being michael and me)
14:20:36 <rosmaita> so here's what we are thinking
14:20:37 <rosmaita> tentative workflow: Michael will do a quick look, mark bugs Incomplete, Invalid, or Confirmed; will check driver bugs to make sure they are tagged correctly; report at the weekly meeting so we're aware of what Confirmed bugs need to be looked at
14:20:38 <rosmaita> he may or may not have a scheduled time to look at bugs (when other people could join and help out)
14:20:40 <rosmaita> but that's up to him
14:20:53 <jungleboyj> Weird.  There was a long gap there.
14:21:01 <michael-mcaleer> sure we can see how it goes reporting on them in here
14:21:03 <rosmaita> this is an experiment, so we will be flexible
14:21:22 * eharney also saw the long gap
14:21:23 <michael-mcaleer> if people think it would be better discussed seperately from weekly team meeting then I dont mind
14:21:37 <rosmaita> thank you for being flexible
14:21:54 <rosmaita> let's see how it works and we can make any changes
14:22:04 <michael-mcaleer> there is no final format on how these bugs are presented week to week for the moment, if anyone has any suggestions please let me know
14:22:06 <rosmaita> and if anyone has helpful suggestions, those will be welcom too
14:22:09 <rosmaita> :)
14:22:26 <michael-mcaleer> for now ive just put summary in an etherpad of what we have seen the previous week, would be wallaby r-24
14:22:29 <jungleboyj> ++ I had tried that in the past and didn't really get the progress I hoped for.
14:22:38 <jungleboyj> Glad to see we are trying it again!
14:22:43 <michael-mcaleer> #link https://etherpad.opendev.org/p/cinder-wallaby-r24-bug-overview
14:22:56 <rosmaita> already got started! great!
14:22:58 <michael-mcaleer> in short, 4 bugs this week, all for cinder repo, 3 for cinder code and 1 for driver
14:23:14 <michael-mcaleer> ive ordered them in what I percieve priority
14:23:37 <michael-mcaleer> where I feel I can provide some input ive added them in notes, where I have no idea ill just summarise as best as possible and discuss with team in here
14:24:16 <michael-mcaleer> one bug is in progress with change provided from bug submitter, other two cinder code related bugs are still in new status
14:24:28 <michael-mcaleer> are people happy for me to set them as 'triaged' once ive had a chance to look at them?
14:24:43 <eharney> fyi, i looked at 1901783 a bit -- the "lvs" command is segfaulting which means there's probably a bug on the platform outside of cinder
14:24:58 <rosmaita> eharney: thanks
14:25:25 <rosmaita> i will try to get an elasticsearch query for that bug if melanie hasn't set one up already
14:25:38 <rosmaita> we can just see how pervasive it is for now
14:25:57 <michael-mcaleer> no problem, would you like any message relayed to melanie in the meantime?
14:26:20 <rosmaita> i think if eharney puts a comment in the bug
14:26:28 <eharney> i'll add a comment
14:26:29 <rosmaita> and i will look into the elasticsearch query
14:26:35 <michael-mcaleer> great thanks eharney
14:26:40 <michael-mcaleer> and rosmaita
14:27:49 <michael-mcaleer> the DB deadlock bug ID 1901973 I believe required further information from the bug submitter
14:27:56 <rosmaita> sorry, was reading through the bugs, looks like you asked for more info on that one
14:28:10 <rosmaita> great
14:28:23 <michael-mcaleer> yeah need the version to see if it can be reproduced, I know we have done some local concurrency testing and didnt hit this
14:28:36 <rosmaita> ok, next item
14:28:42 <michael-mcaleer> the commands are there so once the version is known it can be confirmed or marked invalid
14:28:49 <eharney> bugs that need more info can be put into the "Incomplete" status if they are stuck w/o it
14:28:59 <michael-mcaleer> perfect ill keep that in mind moving forward
14:29:05 <rosmaita> i need to confirm with e0ne that he volunteered to be the v2 removal coordinator?
14:29:47 <michael-mcaleer> that reminds me, that bug log shows py27 in use, whats the policy on envs with unsupported python version?
14:30:09 <rosmaita> train still supports py2
14:30:34 <e0ne> rosmaita: are we talking about some bug still?
14:30:48 <rosmaita> e0ne: we are having two interleaved conversations!
14:31:05 <michael-mcaleer> 1901973 DB Deadlock #link https://bugs.launchpad.net/cinder/+bug/1901973
14:31:06 <openstack> Launchpad bug 1901973 in Cinder "DBDeadlock when create & delete multiple volumes" [Undecided,New]
14:31:27 * e0ne is confused
14:32:09 <e0ne> rosmaita: I'm still proposing my help to remove api v2
14:32:12 <rosmaita> michael-mcaleer: ok, let's wait to get more info
14:32:26 <rosmaita> e0ne: excellent! i just wanted to verify that with you
14:32:33 <michael-mcaleer> sure will do, thats all from me for this week rosmaita
14:32:38 <rosmaita> thanks
14:32:49 <e0ne> need to check smcginnis's patch https://review.opendev.org/#/c/554372/
14:33:16 <rosmaita> ok, great ... e0ne will keep us focused on getting rid of v2 early in wallaby
14:33:36 <rosmaita> there are other roles available if anyone wants to get more involved in cinder
14:33:53 <rosmaita> #link https://wiki.openstack.org/wiki/CinderWallabyPTGSummary#Team_roles_.26_business
14:33:54 <smcginnis> I had just rechecked that last week.
14:34:00 <smcginnis> Looks like we still have some v2 issues.
14:34:13 <smcginnis> Grenade may be a tricky one.
14:34:38 <rosmaita> yeah
14:35:32 <rosmaita> i think we can make the argument that grenade should't be doing any v2 calls because it's been deprecated for a long time
14:35:55 <tosky> so let's fix it
14:36:10 <rosmaita> sure, i was waiting for a volunteer
14:36:12 <rosmaita> :)
14:36:22 <jungleboyj> :-)
14:36:47 <rosmaita> tosky: can you take a look and see if that is the issue (that is, grenade using v2)?
14:37:03 <rosmaita> because grenade tends to be a bit unstable in general, so you never know
14:37:39 <rosmaita> this is a good segue to the next topic
14:37:51 <rosmaita> #topic emoving Block Storage API v2 support from python-cinderclient
14:38:01 <rosmaita> well, not 'e' movig
14:38:06 <rosmaita> i meant "removing"
14:38:09 <rosmaita> ok
14:38:17 <rosmaita> this is one of my action items from the PTG
14:38:25 <rosmaita> #link https://etherpad.opendev.org/p/python-cinderclient-v2-support-removal
14:38:42 <rosmaita> the issue is when do we remove Block Storage API v2 support from the client?
14:39:13 <rosmaita> i'll give everyone a few minutes to look at the etherpad
14:39:56 <e0ne> IMO, we should wait at lease one or two releases
14:40:27 <eharney> one or two releases since when?
14:40:27 <e0ne> client could be used agains different clouds at the same time
14:40:42 <e0ne> eharney: since we remove it
14:40:49 <e0ne> since we remove it from cinder
14:40:59 <rosmaita> right, but this is one place where openstackclient may actually help us
14:41:09 <rosmaita> since it supports v2
14:41:23 <eharney> i think there's a decent argument for not keeping it around too long since v3.0 is equivalent to v2 for anyone wanting to use it
14:41:56 <e0ne> eharney: it's a good point
14:42:33 <rosmaita> and v3.0 has been available for a long time
14:43:39 <rosmaita> so people "should have" switched over, but if they haven't, they can pin the requests to 3.0 and shouldn't have to do much else to their scripts
14:43:49 <eharney> right
14:44:11 <rosmaita> i am against the "extreme" proposal -- anyone else?
14:44:30 <eharney> yes, also against that one :)
14:45:14 <smcginnis> I would prefer "quick" because of the reasons stated above. But "one more" seems reasonable too.
14:45:49 <e0ne> "one more" sounds good to me
14:45:52 <rosmaita> i was thinking at first that "quick" was too fast, but I am in favor of it too
14:46:09 <jungleboyj> One more should be ok.  :-)
14:46:37 <rosmaita> ok, let's think about this and decide next week -- sounds like we can cross off "extreme" and "one year", though
14:47:45 <jungleboyj> ++
14:48:20 <rosmaita> ok, thanks ... i'll send something to the ML about us deciding next week for people who didn't make the meeting today
14:48:31 <rosmaita> #topic open discussion
14:48:38 <rosmaita> ok , that's all the agenda items
14:49:15 <rosmaita> anyone have anything to share with the team?
14:49:31 <ChuckPiercey> I can update on KIOXIA contribution status for Wallaby..
14:50:16 <rosmaita> sure
14:50:31 <ChuckPiercey> KIOXA OpenStack contributions status for Wallaby (https://launchpad.net/cinder/wallaby):
14:50:31 <ChuckPiercey> Following up on our review last week of the KIOXIA contributions, all four Wallaby blueprints have been written up and assigned to Wallaby-2 (https://launchpad.net/cinder/+milestone/wallaby-2):
14:50:51 <ChuckPiercey> - NVME-oF Connection Sharing: https://blueprints.launchpad.net/cinder/+spec/nvme-of-add-connection-sharing
14:50:51 <ChuckPiercey> - NVMe-oF Client RAID1: https://blueprints.launchpad.net/cinder/+spec/nvme-of-add-client-raid-1
14:50:51 <ChuckPiercey> - NVMe-oF RAID Volume Healing Agent: https://blueprints.launchpad.net/cinder/+spec/nvmeof-client-raid-healing-agent
14:50:51 <ChuckPiercey> -KumoScale NVMe-oF Volume Driver: https://blueprints.launchpad.net/cinder/+spec/kumoscale-driver
14:50:59 <ChuckPiercey> We will put all the details into our soon-to-be-public GitHub repository at https://github.com/KioxiaAmerica/kumoscale-openstack/. (I’m in the process of getting legal review for publishing that repository.)
14:51:31 <ChuckPiercey> The importance level for all four should be assigned as medium I think
14:52:08 <whoami-rajat__> do we need different blueprint for work items?
14:52:52 <rosmaita> i think it makes sense here, there are the general contributions and then also the kioxia-specific ones
14:52:57 <ChuckPiercey> different components was the way Zohar described it
14:53:16 <ChuckPiercey> anyway, we are mking progress
14:53:23 <whoami-rajat__> ok
14:54:01 <ChuckPiercey> (wish I had really paid better attention in typing class...di not realize how important it woul be on IRC ;o)
14:54:19 <jungleboyj> :-)
14:54:31 <rosmaita> ok, thanks for the update
14:54:35 <rosmaita> anyone else?
14:55:28 <rosmaita> lseki: don't forget to let me know the status of https://review.opendev.org/729657 as soon as you know it ... no sense holding up the stein release if it's not going to go in there anyway
14:55:51 <lseki> sure!
14:56:01 <rosmaita> thanks
14:57:20 <rosmaita> looks like that's all for today ... thanks everyone!
14:57:31 <ChuckPiercey> thank you too
14:57:35 <rosmaita> don't forget to think about the python-cinderclient v2 retirement options for next week
14:57:49 <jungleboyj> Thanks!
14:58:25 <whoami-rajat__> Thanks!
14:59:00 <rosmaita> #endmeeting