14:00:02 <rosmaita> #startmeeting cinder
14:00:02 <openstack> Meeting started Wed Aug 19 14:00:02 2020 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <openstack> The meeting name has been set to 'cinder'
14:00:08 <rosmaita> #topic roll call
14:00:10 <whoami-rajat__> Hi
14:00:12 <lseki> o/
14:00:16 <hemna> yough
14:00:21 <enriquetaso> hi
14:00:24 <amar7ibm> hi
14:00:38 <eharney> i'm partially here today
14:00:38 <jungleboyj> o/
14:00:49 <tosky> o/
14:00:49 <jungleboyj> I am double booked though.
14:00:50 <LiangFang> hi
14:01:03 <e0ne> hi
14:01:26 <sfernand> hi
14:02:00 <rosmaita> good turnout!
14:02:01 <rosmaita> #link https://etherpad.openstack.org/p/cinder-victoria-meetings
14:02:13 <rosmaita> #topic announcements
14:02:28 <rosmaita> reminder about next week's meeting ... it's the last meeting of August
14:02:32 <smcginnis> o/
14:02:36 <rosmaita> so will be videoconf + IRC
14:02:39 <rajinir> o/
14:02:52 <rosmaita> connection info will be posted on the agenda etherpad before the meeting
14:03:22 <LiangFang> o/
14:03:27 <rosmaita> #topic announcements - "berlin" forum brainstorming
14:03:39 <rosmaita> here's an email about this and what it is
14:03:47 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-August/016581.html
14:04:11 <rosmaita> so the basic idea of the forum is that we can have a few sessions and get feedback from summit participants about our plans for cinder
14:04:33 <rosmaita> and since the PTG is going to be after the summit instead of the same time, that might actually work for us
14:04:49 <rosmaita> jungleboyj has volunteered to represent cinder on the forum selection committee
14:05:06 <rosmaita> so it's up to us to do some thinking about what we want to know from operators
14:05:12 <jungleboyj> rosmaita: I misinterpreted the request there.
14:05:25 <jungleboyj> That was to represent all of OpenStack, not just Cinder.
14:05:37 <rosmaita> i misread that as well
14:05:38 <jungleboyj> Sounds like Arkady had already put his name in.
14:05:49 <jungleboyj> :-)  Ok, glad it wasn't just me.
14:06:13 <rosmaita> anyway, the proposals tool opens on 31 August
14:06:24 <jopdorp> hi! sorry for running a bit late
14:07:28 <rosmaita> ok, that wiki page is a bit sparse:
14:07:31 <rosmaita> #link https://wiki.openstack.org/wiki/Forum/Virtual2020
14:08:07 <rosmaita> i will add a cinder etherpad to that page and send something the ML asking you all to brainstorm on it
14:08:17 <rosmaita> #action rosmaita - forum etherpad
14:08:38 <rosmaita> #topic announcements - Wallaby PTG
14:08:47 <rosmaita> two items here
14:08:56 <rosmaita> #link https://etherpad.opendev.org/p/wallaby-ptg-cinder-planning
14:09:17 <rosmaita> that's the planning etherpad, so start thinking about feature proposals, code cleanup, etc and add them
14:09:27 <rosmaita> the second is when we will actually meet
14:09:40 <rosmaita> instead of taking a poll, i think we can settle it in this meeting
14:09:49 <rosmaita> so take a look at this etherpad:
14:09:57 <rosmaita> #link https://etherpad.opendev.org/p/cinder-meeting-planning
14:10:25 <rosmaita> the PTG is being set up just like the vancouver virtual ptg
14:10:40 <rosmaita> so i'm proposing that we use the same time slots as last time
14:10:53 <rosmaita> we leave monday open for cross-project stuff
14:11:10 <rosmaita> and meet 3 hours each day for tuesday .. friday
14:11:29 <rosmaita> if you scroll down to "alternative times"
14:11:31 <jungleboyj> ++
14:11:34 <enriquetaso> +1
14:11:47 <rosmaita> you can see how the time slots stack up
14:12:12 <rosmaita> i apologize to shanghai, because you have to meet late in the evening
14:12:21 <rosmaita> which i admit kind of sucks
14:12:27 <whoami-rajat__> same timings work for me
14:13:13 <rosmaita> but i don't see any other options that don't put other people into really late at night/ really early in the morning
14:13:26 <rosmaita> anyway, just wanted to post the alternatives so everyone can see
14:14:12 <rosmaita> hemna: will you be pacific time that week?
14:14:22 <rosmaita> (i hope not)
14:14:34 <LiangFang> rosmaita: np:)
14:14:45 <rosmaita> LiangFang: thanks for understanding
14:14:53 <jopdorp> rosmaita: Should I join any of those meetings? Basically I'm planning to keep my involvement scoped to the s3 backup driver. I'll do what's needed to get that into the project in a good way.
14:15:00 <hemna> no, I'll be on EST
14:15:25 <rosmaita> jopdorp: it would be good to attend what you can to get a good sense of the entire project
14:15:42 <rosmaita> also, last time we had a driver day dedicated to driver issues
14:15:51 <rosmaita> so you will want to attend that
14:15:56 <jopdorp> okay
14:15:57 <jungleboyj> jopdorp:  It is a good opportunity to learn more about Cinder and the team.
14:16:12 <jopdorp> I've added my name here https://etherpad.opendev.org/p/wallaby-ptg-cinder-planning
14:16:18 <rosmaita> great!
14:16:54 <rosmaita> OK, hearing no objections, i will add Cinder to the PTG schedule as proposed on the etherpad
14:17:13 <rosmaita> #action rosmaita - add cinder meeting times to PTG schedule
14:17:18 <jopdorp> I'm in the same time zone as madrid
14:17:23 <rosmaita> i will request the "diablo" room
14:17:28 <rosmaita> just because it sounds cool
14:17:37 <jungleboyj> :-)
14:17:48 <enriquetaso> +1
14:17:52 <rosmaita> also, last time we had a virtual happy hour ... any interest for "berlin" ?
14:18:14 <lseki> 😈
14:18:26 <rosmaita> diablo!
14:18:59 <rosmaita> i guess we don't need to decide about happy hour right now
14:19:01 <TusharTgite> hi
14:19:12 <jopdorp> actually nerlin and madrid have the same zones right? i'm in amsterdam
14:19:26 <jopdorp> berlin*
14:19:28 <jungleboyj> They happy hour would be good again.
14:19:36 <rosmaita> my thought from last time was that it would be better to have it the first day to give people an opportunity to meet each other and make the rest of the week go smoothly?
14:19:52 <rosmaita> anyway, we can think about that
14:20:11 <sfernand> sounds good
14:20:14 <whoami-rajat__> first day sounds good
14:20:19 <rosmaita> jopdorp: i think that's right about the time zones
14:20:36 <lseki> +1 for 1st day
14:20:45 <rosmaita> #topic announcements - reminders
14:20:52 <rosmaita> ok real quick
14:20:57 <rosmaita> two deadlines today
14:21:09 <rosmaita> victoria driver features declaration
14:21:17 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-August/016515.html
14:21:26 <rosmaita> victoria new feature status checkpoint
14:21:34 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-August/016514.html
14:21:50 <rosmaita> also, the 3rd Party CI checkpoint is coming up on 10 September
14:22:03 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-August/016517.html
14:22:06 <rosmaita> and, finally
14:22:21 <rosmaita> victoria os-brick release happens in 2 weeks
14:22:34 <whoami-rajat__> rosmaita: oh, should i add my feature now?
14:22:57 <rosmaita> whoami-rajat__: which one?
14:23:22 <whoami-rajat__> the default type override one
14:23:41 <whoami-rajat__> it's mentioned in the second mail we should add it which i missed :(
14:23:46 <rosmaita> sure, add it to the agenda
14:23:58 <rosmaita> but i think you are in OK shape
14:24:03 <jopdorp> rosmaita, i have the same question about the s3 backup driver
14:24:22 <whoami-rajat__> apart from the tests, yes, it works
14:24:32 <rosmaita> jopdorp: go ahead and add it and we will talk later
14:24:45 <rosmaita> ok, that's all for announcements, let's get to work
14:24:57 <rosmaita> #topic Allow removing NFS snapshots in error status
14:24:59 <sfernand> I have a bp for a solidfire feature I'm implementing (storage assisted migration) but haven't submit my patch yet. It's ok to submit until tomorrow?
14:25:04 <sfernand> ow sory
14:25:06 <rosmaita> enriquetaso: that's you
14:25:11 <enriquetaso> Hey o/
14:25:50 <enriquetaso> We've discussed it a while ago in this meeting and as requested, I updated it. I'd   like to checkif it's still relevant or should I abandon it.
14:25:58 <rosmaita> do you have a link to the patch?
14:26:01 * enriquetaso looking for link u.u
14:26:05 <rosmaita> :)
14:26:23 <enriquetaso> https://review.opendev.org/#/c/679138/
14:26:33 <enriquetaso> sorry
14:26:33 <rosmaita> thanks!
14:26:46 <enriquetaso> #link https://review.opendev.org/#/c/679138/
14:27:13 <enriquetaso> it's just that :)
14:27:26 <enriquetaso> feel free to review it again
14:27:36 <whoami-rajat__> do we have an update on the libvirt incompatibility part?
14:27:46 <enriquetaso> whoami-rajat__,  and hemna
14:28:56 <eharney> libvirt 1.2.7 is ancient, what was the concern there?
14:30:06 <whoami-rajat__> i think this was these were the tested scenarios http://paste.openstack.org/show/789714/
14:31:18 <eharney> nobody is going to pair nova+libvirt installations that old with cinder victoria
14:31:50 <smcginnis> We officially only allow an N to N-1 compatiblity.
14:32:44 <whoami-rajat__> so is it better to remove the snapshot enable/disable config option altogether ?
14:32:48 <eharney> the purpose of the check_snapshot_support check is about preventing it from being combined with nas_secure settings that are known to not work
14:32:58 <eharney> that is unrelated to versions of nova/libvirt/etc
14:34:05 <rosmaita> ok, so it sound like the on/off option still makes sense
14:34:24 <rosmaita> so we want to fix it so: the driver actually pays attention to the option
14:34:38 <rosmaita> and on delete, it lets you delete regardless of the option?
14:34:52 <enriquetaso> yes
14:35:04 <rosmaita> ok, that still makes sense to me
14:35:04 <eharney> well, this is only required because the manager doesn't know that the snapshot doesn't actually exist on the backend, and so the driver call to delete it isn't actually needed
14:35:08 <eharney> but yes
14:35:44 <rosmaita> and i think we will want to backport both fixes?
14:36:22 <eharney> i think there's just one?
14:36:48 <enriquetaso> I only have one
14:37:29 <rosmaita> maybe one patch for 2 bugs? the bug on the review is "NFS doesn't remove snapshots in error status"
14:39:13 <enriquetaso> oh, yes, we have https://bugs.launchpad.net/cinder/+bug/1842088 and a bugzilla
14:39:14 <openstack> Launchpad bug 1842088 in Cinder "NFS doesn't remove snapshots in error status" [Undecided,In progress] - Assigned to Sofia Enriquez (lsofia-enriquez)
14:40:14 <rosmaita> sounds like this is worth doing, and we should worry about the libvirt version separately because in addition to libvirt, there is another reason to not allow nfs snapshots
14:40:46 <rosmaita> so we don't want to remove the option, just make sure it works
14:40:50 <rosmaita> anything else?
14:41:02 <eharney> this is worth doing, the main thing when reviewing this one is to ensure it doesn't cause problems when deleting snaps that were in an error state for some reason other than the path described in the bug
14:41:25 <eharney> i convinced myself it should be when i was reviewing it a bit ago, may do so again just to be sure
14:41:53 <enriquetaso> sure
14:41:57 <rosmaita> ok, reviewers, please keep ^^ in mind when looking at the patch
14:42:14 <rosmaita> thanks enriquetaso
14:42:28 <enriquetaso> thanks
14:42:35 <rosmaita> #topic new feature status checkpoint
14:42:41 <rosmaita> i'm going to skip around a bit
14:42:57 <rosmaita> the S3 backup driver is new, is that correct?
14:43:01 <jopdorp> yes
14:43:19 <jopdorp> I've implemented it based on the swift backup driver
14:43:22 <rosmaita> ok, we are past the new driver deadline, so let's aim that for early wallaby
14:43:23 <jopdorp> they are very similar
14:43:30 <jopdorp> okay
14:43:33 <e0ne> rosmaita: I'm going to help jopdorp  with some CI for it
14:43:34 <rosmaita> yes, glance has a similar driver for glance_store
14:43:41 <rosmaita> e0ne: excellent!
14:43:49 <e0ne> so we'll got this driver tested
14:43:49 <jopdorp> I will be using it in production for train
14:43:50 <jungleboyj> e0ne:  Thank you.
14:44:17 <rosmaita> jopdorp: great, that will give us confidence that it works!
14:44:21 <e0ne> jungleboyj: np
14:44:34 <jopdorp> currently it's only unit tested
14:44:54 <jopdorp> today I've been working on setting up a test environment to test it against backblaze and amazon s3
14:45:10 <rosmaita> do we need a spec for a new backup driver?
14:45:22 <jopdorp> e0ne said he'll test it against radosgw and swift
14:45:22 <rosmaita> or just general agreement that it's worth doing?
14:45:26 <e0ne> rosmaita: IMO, blueprint is enough
14:45:37 <jopdorp> this blueprint already existed https://blueprints.launchpad.net/cinder/+spec/support-s3-backup-driver
14:45:53 <e0ne> rosmaita:actually, we agreed it some time ago at PTG
14:46:06 <e0ne> I guess, it was Shanghai PTG
14:46:37 <rosmaita> it doesn't affect the api or anything, so i am OK with a blueprint only (unless someone thinks it will set a bad precedent?)
14:46:42 <eharney> can we CI this against something like the ceph s3 api?
14:46:44 <eharney> we don't need a spec
14:47:04 <jopdorp> eharney: i think that would be a good idea, what about you e0ne?
14:47:06 <e0ne> eharney: that's what I'm thinking about
14:47:31 <e0ne> both radogw and swift s3 api should work with it
14:47:43 <jopdorp> e0ne: also swift for the ci?
14:47:52 <e0ne> I'm mostly interested in radosw-based CI
14:48:22 <rosmaita> sounds good -- will be a useful addition to our backup drivers
14:48:25 <e0ne> I'll start with ceph-based environment
14:48:33 <e0ne> rosmaita: +1
14:48:49 <rosmaita> i think i need to create wallaby in launchpad ... after i do that, i will target the BP
14:49:29 <rosmaita> ok, looks like several proposals from netapp
14:50:00 <lseki> yes
14:50:36 <rosmaita> ok, they mostly have patches, so the point of this is to prioritize driver reviews before the feature freeze
14:51:33 <smcginnis> Would be great to actually have a tested backup driver other than swift.
14:51:39 <rosmaita> e0ne: i think the A/A HA support is you?
14:51:50 <e0ne> rosmaita: yes
14:52:06 <e0ne> nothing special, just kind of ask for review
14:52:08 <jungleboyj> smcginnis:  ++
14:52:32 <rosmaita> ok, reviewers take note:
14:52:44 <rosmaita> #link https://review.opendev.org/#/q/topic:a-a-support
14:52:52 <e0ne> rosmaita: one path adds a new microversion :(. so it would be good to have it in before the feature freeze
14:53:31 <rosmaita> ok, eyeballing the list, a bunch already have +2s, so that should be do-able
14:54:05 <rosmaita> ok, other new feature is whoami-rajat__'s
14:54:14 <rosmaita> Default type overrides
14:54:19 <e0ne> it's a chain of 4 patches, so I need only 1 approval :)
14:54:31 <rosmaita> api + cinderclient
14:55:03 <rosmaita> ok, so i will send out an email -- we need to prioritize whoami-rajat__ and e0ne because they both have cinderclient changes
14:55:15 <e0ne> rosmaita: thanks
14:55:22 <whoami-rajat__> yes, the API to set, get and unset the default type works and is also reflected in the volume creation (priority project default > config default)
14:55:28 <rosmaita> after that, the driver BPs
14:55:51 <rosmaita> i think that's all the features that have been added to the etherpad?
14:56:29 <rosmaita> #action rosmaita - note to ML about review priorities over next 2 weeks
14:56:42 <rosmaita> ok, almost out of time
14:56:53 <rosmaita> i see the eharney has an appeal to review the mypy work
14:56:59 <rosmaita> that's the type-checking stuff
14:57:09 <rosmaita> #link https://review.opendev.org/#/c/733620/
14:57:10 <eharney> yeah, not exactly a feature per se, but, please review
14:57:20 <rosmaita> #link https://review.opendev.org/#/c/733621/
14:57:49 <eharney> this will be an ongoing series of patches for a bit adding coverage, but i'd like to get the infrastructure landed before going too far down that road
14:58:00 <rosmaita> that makes sense
14:58:15 <rosmaita> #topic open discussion
14:58:18 <rosmaita> for 2 minutes
14:58:37 <rosmaita> don't forget next week's meeting will be in videoconf
14:58:49 <jopdorp> the link will be posted here?
14:58:58 <rosmaita> yes
14:59:05 <rosmaita> and on the meeting agenda
14:59:41 <whoami-rajat__> Thanks!
14:59:44 <rosmaita> ok, thanks everyone -- we need to make way for horizon!
14:59:51 <jungleboyj> Thanks!
14:59:55 <lseki> thanks
15:00:01 <rosmaita> #endmeeting