14:00:12 <rosmaita> #startmeeting cinder
14:00:12 <m5z> hi :)
14:00:13 <openstack> Meeting started Wed Jan  8 14:00:12 2020 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <tosky> o/
14:00:16 <openstack> The meeting name has been set to 'cinder'
14:00:17 <enriquetaso> hi!
14:00:19 <smcginnis> o/
14:00:21 <geguileo> hi! o/
14:00:22 <LiangFang> o/
14:00:23 <e0ne> hi
14:00:28 <eharney> hi
14:00:31 <rosmaita> looking like a good turnout!
14:00:32 <jungleboyj> o/
14:00:37 <walshh_> hi
14:00:44 <jungleboyj> Happy New Year!
14:00:54 <rosmaita> here's the agenda:
14:00:55 <rosmaita> #link https://etherpad.openstack.org/p/cinder-ussuri-meetings
14:01:04 <rosmaita> jungleboyj: same to you
14:01:30 <rosmaita> #topic announcements - stable releases
14:01:45 <lseki> hi
14:01:46 <whoami-rajat__> Hi
14:01:49 <rosmaita> all i have to say is that we had a bunch of releases yesterday from the stable branches
14:01:53 <kaisers> o/
14:02:04 <rosmaita> wow, people keep rolling in!
14:02:17 <geguileo> and cinderlib v1.0.1 was also released  :-)
14:02:25 <rosmaita> i should have begun with, welcome to the first Cinder meeting of 2020
14:02:30 <jungleboyj> New Year's Resolutions.  ;-)
14:03:46 <rosmaita> i also guess i should say, if you are interested in what was released, consult the handy etherpad
14:03:59 <rosmaita> #link https://etherpad.openstack.org/p/cinder-releases-tracking
14:04:13 <rosmaita> #topic updates - virtual midcycle
14:04:24 <rosmaita> yep, the cycle is moving right along!
14:04:33 <smcginnis> https://releases.openstack.org/teams/cinder.html is also a handy place to see all of our deliverables and release information.
14:04:45 <rosmaita> smcginnis: ty
14:04:59 <rosmaita> at the virtual PTG, we decided to hold two virtual midcycles of 2 hours each
14:05:12 <rosmaita> timing would be around spec freeze (31 Jan 2020 (23:59 UTC)
14:05:28 <rosmaita> and around "Cinder New Feature Status Checkpoint" (week of 16 March, which is 3 weeks before the final release of client libraries)
14:05:41 <rosmaita> so time for the first one is almost here
14:05:58 <rosmaita> question is, do we want to meet the week of 20 January (which is the week after next) or do it the following week, the week of spec freeze?
14:06:11 <rosmaita> i guess a key piece of data is how many proposed specs are unmerged
14:06:22 <rosmaita> #link https://review.opendev.org/#/q/project:openstack/cinder-specs+status:open
14:06:34 <rosmaita> looks like not too many
14:07:12 <rosmaita> so i think we could have the virtual midcycle the last week of january
14:07:15 <rosmaita> to be clear
14:07:31 <rosmaita> the point of mentioning the specs was in case we needed to give people feedback
14:07:55 <rosmaita> but it looks like few enough specs that we can communicate via gerrit
14:08:06 <jungleboyj> rosmaita:  ++
14:08:31 <rosmaita> so, core reviewers, please push to take a look at open specs
14:08:54 <rosmaita> i will send out a poll via some appropriate medium to set a time
14:09:09 <rosmaita> i think bluejeans worked ok for the virtual PTG?
14:09:20 <rosmaita> if anyone has a strong feeling about that, please let me know
14:09:44 <rosmaita> and i guess we should begin collecting topics
14:09:54 <rosmaita> #link https://etherpad.openstack.org/p/cinder-ussuri-mid-cycle-planning
14:10:18 <jungleboyj> BlueJeans has worked fine.
14:10:32 <rosmaita> great
14:10:36 <smcginnis> We can see in the poll, but last week of January is also FOSDEM. There will be a few OpenStack folks there, but maybe not a lot from this team.
14:10:44 <smcginnis> Just pointing out as something to be aware of.
14:10:51 <rosmaita> smcginnis: thanks
14:11:04 <rosmaita> anyone here planning to be at FOSDEM?
14:11:31 <smcginnis> o/
14:11:52 <rosmaita> guess that's why it's on your mind!
14:11:58 <smcginnis> :)
14:12:02 <jungleboyj> :-)
14:12:18 <smcginnis> So I guess it won't be a big issue for scheduling then.
14:12:26 <rosmaita> well, i'm not opposed to the week before
14:12:39 <rosmaita> if people are motivated enough to get some topics together
14:13:34 <rosmaita> my thought is that since it's only 2 hours, we can review the action items from PTG, there are a few things there that need some followup
14:14:02 <jungleboyj> Makes sense to me.
14:14:14 <smcginnis> Good plan.
14:14:27 <rosmaita> can we get a sense here right now of which week?
14:14:39 <rosmaita> options are:
14:14:54 <rosmaita> 1 - week of 20 january
14:15:01 <rosmaita> 2 - week after that
14:15:47 <rosmaita> i'm assuming smcginnis is in favor of 1
14:16:00 <LiangFang> option 1 ++
14:16:04 <whoami-rajat__> both are fine with me
14:16:06 <enriquetaso> 1 ++
14:16:17 <enriquetaso> both are fine with me too haha
14:16:36 <LiangFang> the week after that is New year for some asia countries
14:16:45 <smcginnis> 1 works for me, 2 does not.
14:16:51 <smcginnis> Oh, great point LiangFang
14:16:51 <rosmaita> LiangFang: thanks for that info
14:16:59 <rosmaita> ok, let's go for option 1
14:17:08 <smcginnis> rosmaita: Want to do a poll?
14:17:20 <smcginnis> If I'm the only one with a conflict, I can catch up later.
14:17:27 <e0ne> both options are OK for me
14:17:31 <lseki> both works for me
14:17:34 <jungleboyj> 1 should be fine for me.
14:17:39 <rosmaita> well, it looks like nobody is opposed to option #1
14:17:45 <rosmaita> so i think let's go with that
14:17:56 <rosmaita> i'll put a poll for the time together today and send it out
14:18:10 <rosmaita> and if too many people can't attend any of the options, we can reconsider the week
14:18:21 <jungleboyj> ++  Think that is good to avoid the Chinese New Year conflict.
14:18:34 <rosmaita> but between FOSDEM and asian New Year, i think option 2 is not so good
14:18:37 <rosmaita> what jay said
14:18:44 <jungleboyj> :-)
14:19:14 <rosmaita> #action rosmaita get poll out for virtual midcycle time for week of 20 January
14:19:24 <rosmaita> ok, thanks everyone.  that's all from me
14:19:39 <rosmaita> #topic Should the iet target be deprecated
14:19:44 <rosmaita> smcginnis: that's you
14:20:14 <smcginnis> Oh right.
14:20:24 <smcginnis> That was so long ago I forgot about it. :)
14:20:33 <smcginnis> So from what I can tell, IET is long deprecated.
14:20:53 <smcginnis> I'm not sure anyone uses it anymore, and as far as I could tell, no distros have it be default.
14:21:11 <smcginnis> Though I did not investigate that last claim closely.
14:21:24 <smcginnis> Maybe some of the Red Hat and (former) SUSE folks can confirm that.
14:21:44 <smcginnis> But if that is the case, I'm wondering if we should deprecate that target driver and get it removed.
14:21:53 <smcginnis> Any thoughts? Feedback?
14:22:09 <eharney> a quick glance around the web makes it look pretty dead
14:22:21 <smcginnis> That was my impression.
14:23:16 <smcginnis> So maybe we can deprecate it and see if anyone says anything?
14:23:24 <rosmaita> smcginnis: do you want to propose a patch deprecating, and then we can send out the the ML for awareness
14:23:24 <smcginnis> Then remove it in V.
14:23:36 <rosmaita> (i am slow typing today)
14:23:49 <smcginnis> Sure, just need to swap that back into my brain, then I can get something up doing that. :)
14:23:52 <rosmaita> i think that sounds good
14:24:11 <smcginnis> Awesome, thanks!
14:24:19 * smcginnis loves removing code
14:24:25 <rosmaita> :D
14:24:46 <rosmaita> #topic Spec: Volume local cache
14:24:52 <rosmaita> LiangFang: that's you
14:24:53 <LiangFang> hi
14:25:26 <LiangFang> I have finished the spec and code modification when you are in vacation
14:25:29 <LiangFang> :)
14:26:07 <smcginnis> :)
14:26:08 <LiangFang> and hope it can be reviewed when you are free
14:26:11 <rosmaita> yes, i need to re-review
14:26:21 <LiangFang> thanks
14:26:46 <rosmaita> i'll put that near the top of my list
14:26:48 <LiangFang> the write paper is still in internal review
14:27:03 <rosmaita> ok
14:27:13 <LiangFang> the internal review meeting will be in next Friday
14:27:24 <LiangFang> Jan 17
14:27:33 <LiangFang> will let you know when it pass review
14:27:37 <rosmaita> was there anything particular you wanted to discuss, or did you just want to give us a reminder to take a look at the spec & patches
14:28:04 <LiangFang> no more from me
14:28:06 <LiangFang> thanks
14:28:39 <rosmaita> ok, thank you ... i know you've been doing a lot of work on this, so thanks for the reminder
14:28:52 <LiangFang> ty
14:28:58 <rosmaita> #topic open discussion
14:29:11 <rosmaita> that's all from the agenda ...
14:29:29 <rosmaita> anyone have any general concerns they'd like to bring up?
14:29:44 <smcginnis> There's another spec out there that just feels wrong to me for some reason, but making sure others are aware of it until I have time to think about it more.
14:29:47 <smcginnis> #link https://review.opendev.org/#/c/700977/
14:30:11 <smcginnis> Adding a backup_id to volumes so when a volume uses the convenience API we added to create a volume directly from backup it records the ID.
14:30:55 <eharney> it would be useful to maybe add it to some metadata field or description... adding a new column to the volumes table is wrong
14:31:18 <smcginnis> That's my feeling.
14:31:21 <rosmaita> i agree, i don't like messing with the DB
14:31:27 <smcginnis> Metadata would be a much better place for it.
14:31:51 <rosmaita> and if we add it as metadata, doesn't require a new microversion, is that right?
14:32:04 <rosmaita> would just show up on the volume-show response
14:32:32 <smcginnis> Yep.
14:33:03 <jungleboyj> Yeah, that looks like metadata to me.
14:34:29 <e0ne> btw, can I get some reviews for https://review.opendev.org/#/q/status:open+project:openstack/cinder+branch:master+topic:bp/backup-host-selection-algorigthm? the second patch requires some more unit tests but the first one is ready and had got +2 in the past
14:34:38 <eharney> don't we record what glance image was used to create a volume somewhere?  this sounds similar
14:35:30 <rosmaita> ok, looks like we have some suggestions for the backup_id proposal
14:35:52 <rosmaita> e0ne: thanks for bringing that to our attention
14:36:33 <rosmaita> if there's nothing else, we can adjourn early and go look at https://review.opendev.org/#/q/status:open+project:openstack/cinder+branch:master+topic:bp/backup-host-selection-algorigthm?
14:36:44 <rosmaita> :)
14:36:47 <e0ne> :)
14:37:01 <jungleboyj> :-)
14:38:28 <rosmaita> (waiting in case someone is typing a long sentence or something)
14:39:00 <jungleboyj> *Jeopardy Music*
14:39:22 <rosmaita> ok, thanks everyone!
14:39:27 <smcginnis> Thanks!
14:39:39 <LiangFang> thanks, bye
14:39:52 <e0ne> see you next week
14:39:53 <rosmaita> #endmeeting