16:00:03 <rosmaita> #startmeeting cinder
16:00:07 <openstack> Meeting started Wed Oct 23 16:00:03 2019 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:11 <openstack> The meeting name has been set to 'cinder'
16:00:11 <rosmaita> #topic roll call
16:00:14 <smcginnis> o/
16:00:17 <davee__> o/
16:00:25 <woojay> o/
16:00:32 <eharney> hey
16:00:33 <geguileo> rosmaita: hi there :-)
16:00:40 <rosmaita> hello!
16:00:43 <enriquetaso> o/
16:00:51 <jungleboyj> @!
16:00:51 <_pewp_> jungleboyj (◍˃̶ᗜ˂̶◍)ノ”
16:00:55 <sfernand> Hi
16:01:07 <rosmaita> looks like a good turnout!
16:01:14 <tosky> o/
16:01:21 <eharney> https://wiki.openstack.org/wiki/CinderMeetings needs an update (this is still how i find the etherpad half the time)
16:01:22 <rosmaita> #link https://etherpad.openstack.org/p/cinder-ussuri-meetings
16:01:34 <lseki> hi
16:01:36 <rosmaita> i thought i had updated that
16:02:18 <rosmaita> well, speaking of updates
16:02:22 <rosmaita> #topic updates
16:02:33 <eharney> er.. Ussuri is there.  maybe i found a very old browser tab...
16:02:43 <smcginnis> :)
16:02:57 <rosmaita> just a few announcements
16:03:19 <rosmaita> the final releases from stable/queens happen sometime between now and tomorrow
16:03:44 <rosmaita> and then stable/queens goes into 'extended maintenance' status, which means no more releases, but we can backport fixes
16:03:58 <jungleboyj> Sounds good.
16:04:20 <rosmaita> the idea is that some distros/packagers may want to do releases including new bugfixes, even if we (opensatck) aren't committed to doing it
16:04:44 <rosmaita> also, we had talked about doing monthly releases from the stable branches
16:04:56 <rosmaita> over the past half year, it's looking like every 2 months is fine
16:05:13 <rosmaita> (and we can always do a release at any time if there's a critical/security bugfix)
16:05:34 <smcginnis> extended maintenance ends up being pretty close to our driverfixes branches.
16:05:45 <smcginnis> Sounds good to me on the stable release cadence.
16:06:05 <rosmaita> yes, and on that note, here's a picture of what we've got open branch-wise: https://launchpad.net/cinder/+series
16:06:34 <rosmaita> i don't have anything to say, other than it's a lot of open branches!
16:06:54 <rosmaita> ok, two final things
16:06:54 <eharney> mitaka is still "Supported" :)
16:07:24 <rosmaita> yes, i wonder if we should think about unsupporting some of those
16:07:25 <jungleboyj> Is anything before Mitaka actually still hopen?
16:07:38 <rosmaita> no, i think that's the earliest open branch
16:07:52 <jungleboyj> Ok.  Maybe we should update that then.
16:07:56 <smcginnis> I think because that's where we started the driverfixes thing.
16:08:02 <eharney> smcginnis: right
16:08:13 <smcginnis> I think it's been long enough. I'd like to get rid of M and N at least.
16:08:25 <jungleboyj> smcginnis:  ++
16:08:29 <smcginnis> I think we could even decide to EOL ocata and maybe pike.
16:08:39 <eharney> M, sure.  N... i dunno
16:08:51 <rosmaita> that's what i was going to ask, what do we need to do to EOL a branch?
16:09:02 <smcginnis> Realistically, I don't think we will be paying much attention past queens.
16:09:48 <smcginnis> rosmaita: We would need to make sure all open reviews are closed. Then propose a $series-eol tag to the branch.
16:10:05 <rosmaita> i wonder if we should convert to driverfixes only for n and o ?
16:10:17 <smcginnis> I think we may need to also ask infra to delete the stable/$series branch too, just to make it clear.
16:11:00 <eharney> N is already eol, so i think it is already driverfixes only
16:11:04 <smcginnis> I think we're better staying at -em than adding a driverfixes branch. It's more "understood" now.
16:11:55 <jungleboyj> smcginnis:  ++
16:12:07 <rosmaita> eharney: you are right about N
16:12:10 <smcginnis> Well, N isn't tagged eol and the status is still set as Supported in Launchpad.
16:12:29 <eharney> there's a newton-eol tag in git..
16:12:45 <smcginnis> Ah, ok.
16:13:05 <rosmaita> well, the supported status is just me, i left that so we could target bugs to the driverfixes branch
16:13:13 <eharney> makes sense
16:14:38 <rosmaita> so with o & p, we could eol or we could have a stable-maint driverfixes only policy for those branches
16:15:21 <rosmaita> the drivers don't seem to change so much (not as much as cinder itself), so backports wouldn't be too bad for serious bugs
16:15:43 <smcginnis> The tricky part with these is keeping tests going.
16:16:00 <smcginnis> I think Mitaka and Newton might actually be effectively broken at this point.
16:16:01 <rosmaita> that';s true
16:16:20 <tosky> at least ocata would be good (it's harder to maintain, as it was caught in the early extended maintenance process and some zuul v3 jobs-related improvements can't be applied there)
16:16:34 <eharney> we're still actively supporting OSP10 so we have an interest in Newton fixes... i'm not sure if anyone is going to consume fixes for ocata & pike or not
16:16:34 <tosky> it would be good to switch it to unmaintained, I mean
16:16:55 <smcginnis> Actually...
16:16:57 <eharney> er  s/OSP10/Newton/
16:17:24 <smcginnis> I think with driverfixes we said just pep8 and py27. That just requires tox based jobs, so I think we can drop any legacy jobs there.
16:17:43 <smcginnis> Probably any extended maintenance branches if we really need to.
16:17:56 <jungleboyj> Makes sense.
16:18:00 <rosmaita> ok, that's good to keep in mind
16:18:02 <smcginnis> But good to keep broader testing around for the newer branches if/when we can.
16:18:50 <rosmaita> so would it look weird if we kept driverfixes/newton but eol'd o and p?
16:19:14 <smcginnis> Yeah
16:19:22 <rosmaita> that's what i thought
16:20:01 <jungleboyj> Yeah, because we shouldn't be backporting to Newton without hitting O and P.  Right?
16:20:12 <smcginnis> Yeah. Even for just driver fixes.
16:20:18 <eharney> that's questionable if we decide O&P don't exist anymore
16:20:33 <smcginnis> If we do that, then N goes too.
16:21:02 <tosky> what about moving o (and maybe p) to driverfix for now, and think more about it?
16:21:12 <rosmaita> well, we'd be hitting all open branches if we skip o & p and backport to N
16:21:35 <smcginnis> We can't drop newer ones and keep older ones.
16:21:59 <smcginnis> Either we keep through to the older one we want, or we cut them off.
16:22:40 <rosmaita> ok, but we could adopt the "driverfixes only" policy for them
16:23:13 <smcginnis> Yes
16:23:39 <rosmaita> i think what i'd like to do is circulate something on the ML [cinder][ops] and see what people are using
16:23:44 <rosmaita> and we can make a decision at the ptg
16:24:09 <rosmaita> basically, what tosky said
16:24:19 <smcginnis> ++
16:24:52 <rosmaita> good segue to the next announcement
16:25:04 <rosmaita> #link https://etherpad.openstack.org/p/cinder-ussuri-ptg-planning
16:25:08 <enriquetaso> ++
16:25:24 <rosmaita> i'll add possible eol to the etherpad
16:25:48 <rosmaita> but if anyone has a topic they'd like to see addressed, please add it!
16:26:07 <rosmaita> and it looks like i skipped something
16:26:24 <rosmaita> i just wanted to mention the U community goals proposals, in case anyone has a strong feeling
16:26:34 <rosmaita> #link https://etherpad.openstack.org/p/PVG-u-series-goals
16:27:09 <smcginnis> There are mailing list threads looking for goal champions for some of these. If anyone really wants to work on any of that.
16:27:09 <rosmaita> i think that's all, except a reminder about adding yourself to the courtesy ping list at the top of the agenda if you want a ping at meeting time
16:27:37 <jungleboyj> rosmaita:  ++ The new ping list is rather small right now.
16:27:55 <rosmaita> yeah, tbh, i was mentioning it mainly in case anyone saw a community goal that would be a real PITA for cinder!
16:28:23 <rosmaita> #topic leftover file locks
16:28:30 <rosmaita> geguileo: this is you
16:28:37 <geguileo> rosmaita: thanks
16:29:01 <geguileo> mostly I just wanted to confirm that everyone was onboard with the proposed solution in the ML
16:29:27 <geguileo> this is about how cinder ends up leaving a lot of lock files
16:29:37 <geguileo> even when they are no longer necessary
16:29:51 <smcginnis> Sounded like you had most scenarios covered that we could cover.
16:30:01 <eharney> that solution being, having cinder code selectively remove the more commonly leaked files?  or cleaning it on node startup?
16:30:12 <geguileo> both
16:30:19 <geguileo> well, Cinder wouldn't clean them up on start
16:30:32 <geguileo> but like you say it would be on node startup
16:30:39 <jungleboyj> The safest thing to do is cleanup on startup.  Right?
16:30:41 <geguileo> and that would be the responsibility of the deployment tool
16:30:55 <geguileo> jungleboyj: yeah, but not Cinder (in case we are sharing the location)
16:30:58 <jungleboyj> geguileo: ++
16:31:12 <geguileo> so the idea is that the installer creates a service unit that cleans up the directory
16:31:20 <geguileo> and makes all openstack services depend on that one
16:31:30 <geguileo> that way there are no races between removal and services using them
16:31:40 <tosky> uhm, would it work if you restart just one service?
16:31:42 <geguileo> and in cinder we do our best to do the clean
16:32:05 <geguileo> tosky: no, because systemd would not retrigger the other unit
16:32:24 <geguileo> for example, the cinder-volume service would depend on the remove-locks unit having run before
16:32:29 <geguileo> and since it run at the start of the node
16:32:36 <geguileo> there is no problem and won't be retriggered
16:33:01 <geguileo> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010129.html
16:33:08 <geguileo> ^ that's the ML thread
16:33:24 <geguileo> and this is a wip patch for the Cinder side of things
16:33:35 <geguileo> #link https://review.opendev.org/#/c/689486/
16:33:59 <geguileo> the cinder side basically uses oslo's lock removal feature to remove them when deleting volumes or snapshots
16:34:10 <geguileo> and if the create volume from source fails as well
16:34:45 <rosmaita> so this is a dumb question, but why don't we stop using file locks and use etcd-backed-tooz all the time, not just for active-active?
16:35:00 <geguileo> that's slower
16:35:05 <eharney> just the cinder patch will cover most of these files, right, even without the other cleanup?
16:35:07 <geguileo> and etcd is not a requirement to run cinder
16:35:18 <rosmaita> ok
16:35:25 <geguileo> eharney: yes, it should, but not for existing files
16:35:51 <eharney> that's not so bad since the main issue these cause is admins saying "why are all these files in here?"
16:35:51 <geguileo> so the cleanup on node start is kind of a failsafe
16:35:59 <geguileo> lol
16:36:19 <geguileo> in case we missed something it would be good to have the cleanup on start as well
16:36:25 <eharney> yeah
16:36:51 <geguileo> but I think this patch would be a reasonable compromise
16:37:01 <geguileo> it may not fix everything, but at least is better than nothing  XD
16:37:07 <jungleboyj> It would at least slow the future growth in the number of files.
16:37:13 <geguileo> yup
16:37:28 <rosmaita> well, it's definitely better than fixing too much (and breaking something)
16:37:35 <jungleboyj> So, I agree that it is better than nothing.
16:37:36 <geguileo> I wanted to confirm that we all agreed on this solution
16:37:44 <geguileo> ok
16:37:55 <eharney> it sounds good to me
16:37:57 <geguileo> then I'll write the unit tests and all that stuff
16:38:09 <smcginnis> Thanks geguileo
16:38:13 <rosmaita> it sounds good to me
16:38:26 <jungleboyj> geguileo:  Sounds good.  Thank you!
16:38:35 <geguileo> great, then that's all I had to say  :-)
16:38:39 <geguileo> smcginnis: jungleboyj np
16:38:52 <rosmaita> thanks, geguileo
16:38:56 <geguileo> np
16:39:09 <rosmaita> #topic request to change weekly meeting time
16:39:30 <enriquetaso> :o
16:39:37 <rosmaita> i pulled this from the PTG etherpad, since i think it needs discussion beyond people who will be in shanghai
16:39:44 <jungleboyj> *sad_trombone.wav*
16:39:59 <rosmaita> the request is to move the meeting 1 to 2 hours earlier
16:40:03 <smcginnis> That would make it worse for west coast folks.
16:40:29 <smcginnis> But I'd be curious to see if we would actually get more participation from APAC.
16:40:35 <rosmaita> right
16:40:41 <rosmaita> we don't need to decide this now
16:40:49 <rosmaita> but i wanted people to give it some thought
16:40:52 <jungleboyj> Who was it that requested this?
16:41:03 <rosmaita> and also about how we would best decide
16:41:08 <rosmaita> Liang Fang
16:41:37 <jungleboyj> Ok.  Well, I am open to it if there is enough additional participation.
16:41:41 <geguileo> for Europe I think it would be probably better
16:42:09 <rosmaita> other than hemna part-time, do we have any west coast US people these days?
16:42:23 <smcginnis> I know other teams have done alternating times, but I'm honestly not a big fan of that.
16:42:24 <eharney> abishop
16:42:25 <jungleboyj> woojay:
16:42:39 <rosmaita> apologies to abishop, if forgot he moved
16:42:40 <jungleboyj> smcginnis:  Yeah, that ends up being a mess.  I hate to say it.
16:42:40 <woojay> yes
16:42:54 <jungleboyj> oh, I didn't know abishop was west coast now.
16:43:02 <enriquetaso> for Latin America it would be better too.
16:43:23 <woojay> I'm ok w/ earlier though.
16:43:27 <smcginnis> rosmaita: Have you checked if the channel is open earlier?
16:43:29 <rosmaita> yeah, we tried the alternating times with Glance a few years ago, and what happened was that everyone always had the week wrong
16:43:43 <jungleboyj> rosmaita: ++
16:43:46 <rosmaita> smcginnis: i wasn't worried about that, figured we could use the cinder channel if we have to
16:43:55 <jungleboyj> Or things had to be repeated twice.  That was the way it was for Swift.
16:44:23 <rosmaita> woojay: how much earlier could you comfortably go?
16:44:29 <rosmaita> namely, 1 or 2 hours
16:45:04 <jungleboyj> I am more likely to have clashes because that is when China schedules meeting wtih me.  :-)  But since I am not running things that is less concerning.
16:45:09 <rosmaita> i am guessing 1 because once daylight savings time is over, it will be 2 hours
16:45:27 <woojay> 2 hours no problem.
16:45:57 <jungleboyj> woojay:  Is an early riser?
16:46:04 <smcginnis> Reminder for everyone that the time shifts in two weeks if you are in the US.
16:46:13 <woojay> my boys get up early... 8-)
16:46:18 <rosmaita> and in 1 week for most of europe
16:46:31 <smcginnis> And not in one of those enlightened sections that actually doesn't observe DST. :)
16:46:50 <tosky> and next week if you are in Europe
16:47:05 <smcginnis> Sunday it would appear.
16:47:23 <rosmaita> ok, well i just wanted to float that ... sounds like at least for the people here today, it's possible
16:48:00 <rosmaita> should i send out an email for comments?
16:48:04 <jungleboyj> Yeah.  Could make it work.  Do it on a trial basis maybe.
16:48:14 <davee__> +1
16:48:29 <geguileo> rosmaita: an email for comments would be good
16:48:52 <rosmaita> ok, i'll put out an email and figure that anyone violently opposed will respond
16:49:06 <jungleboyj> Ok.  Sounds good.
16:49:07 <rosmaita> #action rosmaita email about possibly changing weekly meeting time
16:49:41 <rosmaita> #action rosmaita email about possible EOL of some branches
16:49:44 <rosmaita> (before i forget)
16:49:53 <rosmaita> #topic open discussion
16:50:00 <abishop> rosmaita, et al: yeah I'm on US west coast, but work east coast hours so I'm OK if mtg moves
16:50:13 <rosmaita> abishop: ty, good to know
16:50:32 <jungleboyj> Cool.
16:50:41 <jungleboyj> Oh, do you want to mention the Cinder Dinner?
16:50:49 <rosmaita> sure
16:50:59 <rosmaita> what day were we thinking?
16:51:08 <jungleboyj> Thursday I think?
16:51:18 <jungleboyj> There is talk of an RDO event Wednesday night now.
16:51:39 <rosmaita> ok, we are going to plan to have a cinder team dinner in Shanghai
16:51:46 <smcginnis> Wouldn't it break tradition if we didn't schedule our team dinner at the same time as a Red Hat company party?
16:51:57 <rosmaita> :)
16:52:00 <jungleboyj> smcginnis:  ++
16:52:20 <geguileo> lol
16:52:26 <rosmaita> we are still working on time/location, but expect around dinnertime and in Shanghai
16:52:34 * jungleboyj laughs
16:52:41 <davee__> I will get Chinese Takeout and wish I was there
16:52:46 <smcginnis> Hah
16:52:49 <jungleboyj> davee__:   He he
16:52:56 <rosmaita> davee__: ++
16:53:01 <jungleboyj> I forgot to e-mail my co-workers yesterday for ideas.
16:53:04 <jungleboyj> I will do that now.
16:53:19 <smcginnis> Maybe in exchange for moving the meeting earlier, Liang Fang could make a dinner reservation for us. :D
16:53:20 <rosmaita> ok, we will keep the PTG etherpad updated
16:53:31 <jungleboyj> :-)
16:53:33 <rosmaita> smcginnis: that is not a bad idea
16:53:39 <jungleboyj> smcginnis:  No Quid Pro Quo !
16:53:45 <davee__> lol
16:53:51 <smcginnis> Haha, was just going to say something like that jungleboyj ;)
16:54:07 <rosmaita> what good is a quid if you don't have a quo?
16:54:35 <jungleboyj> https://gph.is/g/ZyPyOXb
16:54:47 <rosmaita> also, you don't have to be at the PTG to attend, just need to be constructively interested in Cinder and in Shanghai
16:54:58 <jungleboyj> rosmaita:  ++
16:55:12 <rosmaita> jungleboyj: i am not going to look, your gphs are always a time sink
16:55:17 <geguileo> rosmaita: ++
16:55:23 <jungleboyj> Bwah ha ha!
16:55:37 <rosmaita> anything else on anyone's mind?
16:56:06 <davee__> that jungleboyj staged that for the giphy!
16:56:38 <jungleboyj> rosmaita:  You are planning that I will do the project onboarding again?
16:57:04 <rosmaita> jungleboyj: yes, i was, though i may be confusing that with the upstream institute
16:57:21 <rosmaita> are we supposed to schedule project onboarding as part of PTG time?
16:57:23 <jungleboyj> It is the Cinder specific part of the Upstream Institute.
16:57:51 <jungleboyj> rosmaita:  Yes, so I was going to plan to do that early on Thursday as I will be in TC meetings on Friday.
16:57:52 <rosmaita> yes, then i am definitely counting on you, i don't arrive until late monday
16:58:20 <jungleboyj> rosmaita:  But it does happen as part of the PTG.
16:58:42 <rosmaita> let's talk about this real quick in the cinder channel after the meeting
16:58:49 <jungleboyj> rosmaita:  ++
16:59:03 <rosmaita> final minute ... any last concerns?
16:59:40 <rosmaita> ok, thanks everyone!  see you next week
16:59:45 <geguileo> thanks everyone!
16:59:51 <tosky> o/
17:00:00 <jungleboyj> Thanks!  Talk to you all later.
17:00:09 <smcginnis> Thanks!
17:00:13 <rosmaita> i lost my etherpad tab and forgot the end meeting thing
17:00:17 <rosmaita> #endmeeting