16:00:29 <jungleboyj> #startmeeting Cinder
16:00:34 <whoami-rajat> Hi
16:00:35 <openstack> Meeting started Wed Sep 11 16:00:29 2019 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:38 <openstack> The meeting name has been set to 'cinder'
16:00:48 <smcginnis> o/
16:00:52 <jungleboyj> courtesy ping:  jungleboyj whoami-rajat rajinir lseki carloss pots woojay erlon geguileo eharney rosmaita enriquetaso e0ne smcginnis davidsha walshh_ xyang hemna _hemna tosky sfernand
16:00:56 <eharney> hi
16:00:57 <rosmaita> o/
16:01:02 <walshh_> hi
16:01:05 <jungleboyj> @!
16:01:05 <_pewp_> jungleboyj |ʘ‿ʘ)╯
16:02:51 <jungleboyj> Looks like we have the usual suspects here and I need to try to wrap up the meeting early this week if possible.
16:03:04 <jungleboyj> So ... #announcements
16:03:10 <jungleboyj> #topic announcements
16:03:35 <jungleboyj> All the announcements are actually rosmaita 's .  So, I will hand the mic to him.
16:03:41 <e0ne> hi
16:03:41 <rosmaita> thanks
16:03:48 <rosmaita> ok, release update
16:04:08 <rosmaita> os-brick for train (0.11.0) was released last week
16:04:17 <rosmaita> and we  have a stable/train branch for os-brick
16:04:20 <jungleboyj> \o/
16:04:36 <rosmaita> so just a reminder that bugfixes need to go into master and then be proposed to stable/train
16:04:45 <smcginnis> We should probably do a 1.0 release for os-brick. I think it's "production ready" now.
16:04:56 <smcginnis> For ussuri ^
16:04:58 <eharney> os-brick is past 2.0 already :)
16:05:20 <rosmaita> ok, we can schedule a major release for brick in U
16:05:25 <jungleboyj> Yeah. 2.10.0
16:05:31 <rosmaita> we could do like java and release 6.0
16:05:41 <smcginnis> OK, that's what I thought.
16:05:47 <enriquetaso> o/
16:06:13 <rosmaita> sorry, i had the wrong version number there
16:06:30 <jungleboyj> :-)
16:06:33 <rosmaita> the brick cincerclient ext is 0.11.0, was released earlier this week
16:07:03 <rosmaita> and it has a stable branch too, so same deal with any bugfixes -- master then stable/train
16:07:22 <rosmaita> finally, the cinderclient new major release 5.0.0 is almost ready
16:07:29 <rosmaita> one patch remains:
16:07:41 <rosmaita> #link https://review.opendev.org/#/c/653831/
16:08:06 <rosmaita> it's still in check, will need some reviews later today please
16:08:18 <rosmaita> then we can release as soon as the change merges
16:08:29 <jungleboyj> rosmaita:  ++
16:08:41 <smcginnis> At least the gate seems a little better today.
16:08:56 <rajinir> o/
16:09:26 <rosmaita> and when we release cinderclient, we'll have a stable/train branch, etc
16:09:33 <jungleboyj> So, other than the one patch we are good to have all the libraries out on time?
16:09:48 <rosmaita> yes, i think we are in good shape
16:09:55 <rosmaita> cinderlib is a cycle-trailing release model
16:10:07 <rosmaita> so that one comes after cinder train release
16:10:15 <jungleboyj> Ok.  rosmaita  Did anyone make sure that the client changes that are being released match up with what looks to go into the server for Train?
16:10:29 <rosmaita> ummm ... not sure
16:10:33 <rosmaita> i forgot to check
16:10:56 <jungleboyj> :-)  We should probably do that before we cut the client.
16:11:09 <rosmaita> yes, i will take that action item
16:11:17 <jungleboyj> rosmaita:  Awesome.  Thank you.
16:11:23 <rosmaita> #action rosmaita verify MAX_VERSION for client
16:11:54 <rosmaita> i think that's all for releases unless anyone has a question
16:12:41 <jungleboyj> Thank you again for shepherding all that.
16:12:44 <enriquetaso> rosmaita++
16:12:48 <smcginnis> Hmm, according to https://opendev.org/openstack/cinder/src/branch/master/cinder/api/openstack/rest_api_version_history.rst, we haven't added any MV's in train?
16:13:10 <rosmaita> that should make things easy
16:13:11 <jungleboyj> That is possible.
16:13:15 <jungleboyj> :-)
16:13:57 <smcginnis> Huh, I guess so - https://opendev.org/openstack/cinder/src/branch/master/cinder/api/microversions.py#L160
16:14:57 <rosmaita> and https://opendev.org/openstack/python-cinderclient/src/branch/master/cinderclient/api_versions.py#L32
16:15:06 <rosmaita> so looks like we are ok
16:15:21 <jungleboyj> Good news.  :-)
16:16:10 <jungleboyj> Ok.  So I think we can move along then.
16:16:32 <rosmaita> ok, Shanghai Forum Topics
16:16:43 <jungleboyj> ++
16:16:49 <rosmaita> #link https://etherpad.openstack.org/p/cinder-shanghai-forum-proposals
16:17:18 <rosmaita> so, the forum is supposed to give us a chance to discuss long term strategy with users/operators/packagers
16:17:52 <rosmaita> geguileo suggested a general feedback topic, so that's on the etherpad
16:17:59 <jungleboyj> rosmaita: I have a  couple to put in there that came up at the mid-cycle.  Will do that today.
16:18:05 <rosmaita> but if anyone has a particular topic, that would be good
16:18:13 <geguileo> jungleboyj: thanks
16:18:25 <jungleboyj> rosmaita: ++ Would be great if we got people to show up for that and give feedback.
16:18:36 <rosmaita> i sent a note to the ML [ops] to see if any operators want us to address anything
16:19:18 <rosmaita> anyway, we have to formally submit topics at the end of next week, so if you could get topics on the etherpad before the next cinder meeting, that would be awesome
16:19:42 <rosmaita> the idea is we are supposed to be "brainstorming" and then vote for what the team wants to submit
16:20:01 <jungleboyj> Sounds like a good plan.
16:20:09 <rosmaita> one other thing, even if you won't be there, please add a topic if you have one
16:20:29 <rosmaita> ok, that's all for that
16:20:39 <rosmaita> one more etherpad for you:
16:20:50 <rosmaita> #link https://etherpad.openstack.org/p/cinder-ussuri-ptg-planning
16:21:10 * jungleboyj sits back and relaxes
16:21:12 <jungleboyj> :-)
16:21:15 <rosmaita> i don't think our sessions have been confirmed yet, but we can start collecting discussion points
16:21:39 <rosmaita> also, i don't know if we'll be able to do remote joining for this
16:21:43 <jungleboyj> I had requested a 2 day session with 2 to 4 hours separate for on-boarding.
16:21:45 <rosmaita> i haven't heard much about the facilities
16:22:24 <rosmaita> ok, so we should expect at least 1.5 days
16:22:25 <jungleboyj> Theoretically BlueJeans should work again.  My co-workers can join from China.
16:22:27 <smcginnis> No projectors. Zoom blocked by the great firewall. Shared large rooms.
16:22:38 * jungleboyj gags
16:23:02 <rosmaita> yeah ... so this should be fun
16:23:03 <smcginnis> Paris all over again, with the fun parties and good pastries.
16:23:11 <smcginnis> *without
16:23:14 <jungleboyj> You mean without?
16:23:15 <jungleboyj> Yeah.
16:23:19 <e0ne> :(
16:23:21 <eharney> i'd settle for an IRC live stream of the discussions
16:23:29 <rosmaita> well, we'll always have paris
16:23:32 <eharney> :P
16:23:38 <rosmaita> i guess we could do IRC
16:23:49 <rosmaita> if we use our channel, we get an automatic transcript
16:23:54 <jungleboyj> Yeah,  Well, isn't that kind of what the ehterpad is?
16:24:02 <smcginnis> Hopefully we can get to freenode.
16:24:04 <whoami-rajat> IRC live stream?
16:24:14 <jungleboyj> OMG, so we will all be in the same room typing to each other.
16:24:20 <rosmaita> smcginnis: you are Mr. Cheerful today
16:24:22 <jungleboyj> Do I have to go to China?
16:24:31 <smcginnis> rosmaita: :)
16:24:35 <jungleboyj> smcginnis:  Dude you were cheerful on Monday.
16:24:38 <geguileo> we could always VPN out of the country and use whatever we want
16:24:51 <smcginnis> Sorry, trying not to be too pessimistic, but there are a lot of little concerns with how things are shaping up.
16:25:02 <smcginnis> geguileo: That's what I've had to do while there.
16:25:13 <jungleboyj> geguileo:  Yeah, I think I have some freedom with Lenovo VPN.  I am working on setting up a backup but no idea what the latency will be jumping through my house.
16:25:13 <smcginnis> Works well, as long as you have a VPN that doesn't get blocked.
16:25:42 <geguileo> jungleboyj: I doubt my house would be any better  XD
16:25:42 <rosmaita> yeah, i thought there was some kind of vpn-detection-and-blocking ability
16:25:58 <smcginnis> rosmaita: Many are blocked, but a few still work.
16:26:22 <rosmaita> ok, so for now, let's pretend we'll all be able to have a great discussion, and please add ideas to the etherpad
16:26:22 <jungleboyj> Anyway, no point grumbling about what we can't control.
16:26:33 <jungleboyj> rosmaita:  That a boy.
16:26:35 <smcginnis> Yep, let's focus on what we want to accomplish.
16:26:36 <rosmaita> https://etherpad.openstack.org/p/cinder-ussuri-ptg-planning
16:26:51 <rosmaita> ok, that's all from me
16:27:10 <jungleboyj> Well, this is good to see names going into the etherpad as attendees.
16:27:34 <jungleboyj> Ok.  So, it looks like the next topic is ...
16:27:45 <jungleboyj> #topic Please review my Train feature ...
16:27:56 <smcginnis> Hah
16:28:02 <jungleboyj> We need to add a louder horn, better fuel efficiency,
16:28:06 <jungleboyj> Other ideas?
16:29:04 <jungleboyj> So, it looks like we have a few features that need review.
16:29:29 <eharney> yes
16:30:04 <eharney> volume rekey is one: https://review.opendev.org/#/c/664976/
16:30:25 * jungleboyj is clicking through them.
16:30:25 <rosmaita> i need to re-review that and the image compression patch
16:30:57 <zhengMa> thanks!
16:31:24 <rosmaita> e0ne's patch looks pretty straightforward, assuming everyone is good with removing BackupDriverWithVerify
16:31:34 <e0ne> :)
16:31:36 <jungleboyj> Yeah.
16:31:40 <eharney> looks sensible to me
16:31:45 <jungleboyj> smcginnis:  Loves removing code.
16:31:47 <jungleboyj> :-)
16:31:51 <e0ne> we discussed in during the last PTG...
16:32:11 <rosmaita> i thought i remembered something like that
16:33:01 <rosmaita> i don't mean to leave out whoami-rajat's patch, we definitely want to get that into Train
16:33:05 <jungleboyj> Don't we need a release note on that?
16:33:11 <jungleboyj> rosmaita: ++
16:33:40 <eharney> release note for which?
16:33:47 <rosmaita> jungleboyj: i don't think there's really anything to say, it's an unused interface
16:33:55 <jungleboyj> e0ne's patch.
16:33:57 <eharney> rosmaita: i agree
16:33:58 <rosmaita> i assumed you meant e0ne's patch
16:33:59 <e0ne> jungleboyj: I can add it but I don't think somebody uses it
16:34:10 <rosmaita> i think the less said the better
16:34:10 <jungleboyj> Ah, ok.  I guess you are right if it isn't being used.
16:34:17 <e0ne> 5 years and nothing in cinder repo
16:35:07 <jungleboyj> Ok.  I am good as is and will look at the other patches.  It looks like they all are pretty close.
16:35:13 <smcginnis> Yeah, release note might just be confusing on that one.
16:35:36 <jungleboyj> gotcha.
16:35:44 <jungleboyj> Ok, anything else to cover on reviews?
16:35:56 <eharney> i added a question to the default vol type patch
16:36:14 <rosmaita> i have a question about a feature freeze exception
16:36:24 <jungleboyj> rosmaita: Go ahead
16:36:55 <rosmaita> the change to glance that introduces 'cinder_encryption_key_deletion_policy' merged last week
16:37:08 <rosmaita> do i need a FFE for a patch for us to start using it?
16:37:19 <rosmaita> it's not really a feature, but it's not really a bug either
16:37:38 * jungleboyj defers to the release guy in the room
16:37:43 <jungleboyj> smcginnis:  ...
16:37:51 <eharney> that mostly just consists of adding a field to the glance metadata from cinder, right?
16:37:58 <rosmaita> exactly
16:38:08 <jungleboyj> That doesn't sound like it requires an FFE.
16:38:15 <rosmaita> i don't think we want any configuration on our end?
16:38:17 <jungleboyj> To enable a feature that has merged in Glance.
16:38:17 <e0ne> jungleboyj: +1
16:38:36 <eharney> IMO we need to land it either way, an FFE is probably overhead w/o a lot of benefit for a small change like that
16:38:47 <jungleboyj> eharney:  ++
16:38:48 <smcginnis> FFE is up to the PTL, but if we need that, we should get the change in.
16:39:07 <rosmaita> yeah, i'll get a patch up today or early tomorrow
16:39:19 <jungleboyj> It was something we agreed to at the PTG.  I think we are good to get that in without complicating things.
16:39:27 <rosmaita> ok, cool
16:39:30 <jungleboyj> It is unlikely to break Cinder.
16:39:34 <jungleboyj> I assume?
16:39:45 <rosmaita> pretty unlikely
16:39:54 <rosmaita> fairly unlikely
16:39:57 <jungleboyj> Ok.  And we still have a bit of runtime.
16:40:09 <jungleboyj> Lets get the patch up and take a look.
16:40:13 <rosmaita> ok
16:40:36 <jungleboyj> #topic open discussion
16:40:45 <jungleboyj> Anyone have other topics for today?
16:41:36 <jungleboyj> That sounds like a no.
16:41:47 <jungleboyj> So, going to give people 19 minutes of their day back.
16:42:00 <rosmaita> \o/
16:42:03 <jungleboyj> Thank you all for coming.
16:42:12 <jungleboyj> rosmaita: Thanks for helping get this release out properly!
16:42:23 <whoami-rajat> Thanks !
16:42:23 <jungleboyj> #endmeeting