16:00:24 <jungleboyj> #startmeeting Cinder
16:00:25 <openstack> Meeting started Wed Jun 13 16:00:24 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:28 <openstack> The meeting name has been set to 'cinder'
16:00:32 <smcginnis> o/
16:00:35 <e0ne> hi
16:00:56 <ganso> hello
16:01:09 <e0ne> #link https://etherpad.openstack.org/p/cinder-rocky-meeting-agendas
16:01:19 <tommylikehu> hi
16:01:22 <erlon_> hey
16:01:24 <jungleboyj> jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon tpsilva patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro lpetrut lseki _alastor_  courtesy ping
16:01:33 <xyang> hi
16:01:42 <gouthamr> o/
16:01:44 <jungleboyj> e0ne:  Thank you.
16:02:31 <tbarron> hi
16:02:39 <jungleboyj> Ok, guess we will get started.
16:02:46 <eharney> hi
16:02:57 <jungleboyj> tbarron:  Thanks for joining.  Can use your help with one of the subjects.  ;-)
16:03:23 <tbarron> jungleboyj: always glad to give you a strawman
16:03:32 <jungleboyj> #topic announcements
16:04:11 <jungleboyj> For everyone that couldn't get to the summit in Vancouver I have posted the recordings of the forum sessions:
16:04:22 <jungleboyj> #link https://wiki.openstack.org/wiki/VancouverSummit2018Summary
16:04:39 <tommylikehu> jungleboyj:  thanks
16:04:42 <jungleboyj> I think the recordings worked out pretty well.
16:05:13 <rajinir> o/
16:05:16 <jungleboyj> Let me know if you have any questions or issues.
16:05:30 <jungleboyj> I now have access to the YouTube channel which is helpful.  :-)
16:05:36 <jungleboyj> thank you smcginnis
16:06:05 <jungleboyj> I did cut Milestone-2 last week.  Thanks to all who helped get the last driver reviewed.
16:06:14 <jungleboyj> I have now marked all drivers that missed -2.
16:06:49 <jungleboyj> I also have proposed releases of os-brick, python-cinderclient and python-brick-cinderclient-ext
16:07:15 <jungleboyj> That will get our libs up to date.
16:08:19 <jungleboyj> I think that is all I have for announcements.
16:08:36 <jungleboyj> #topic Rocky Priorities Review
16:08:50 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:09:09 <jungleboyj> I have had a look through here before the meeting.
16:09:21 <jungleboyj> Updated those things that look like they have been closed out.
16:09:42 <jungleboyj> tommylikehu:  Is the signature verification work done?
16:09:50 <tommylikehu> yeah
16:10:13 <jungleboyj> Excellent.  Updated.
16:10:33 <jungleboyj> Any one know if the cheesecake promotion work is done or is there more to be done there?
16:11:05 <jungleboyj> eharney:  ^^^
16:11:11 <smcginnis> https://www.groupon.com/coupons/stores/thecheesecakefactory.com
16:11:17 <smcginnis> :P
16:11:22 <jungleboyj> smcginnis:  :-p
16:11:23 <e0ne> smcginnis: :)
16:11:26 <erlon_> haha
16:11:27 <eharney> umm
16:11:35 <tommylikehu> lol
16:11:39 <jungleboyj> There are a couple of patches merged.
16:12:48 <jungleboyj> Anyway, we can move on.  If you have updates for work items there please make them.  I am going to start a section for Stein Specs and I think some of the work items from Rocky are going to slip to Stein.
16:13:21 <jungleboyj> If you have one of those and are inclined to move them, please do.
16:14:01 <jungleboyj> #topic Check-in on HA
16:14:17 <jungleboyj> Gorka can't be here but you will see that he has started documentation.
16:14:29 <jungleboyj> #link https://review.openstack.org/#/c/571242/
16:14:43 <jungleboyj> Please take some time to review that if you can.
16:15:08 <jungleboyj> So, that is all I have there.
16:15:18 <jungleboyj> #topic Storyboard Migration
16:15:37 <jungleboyj> So, I keep getting the question as to when this is going to happen ...
16:15:50 <jungleboyj> So, I think we need to talk about how we want to tackle this as a team.
16:16:19 <erlon_> jungleboyj, can you give a background on that?
16:16:34 <jungleboyj> erlon_:  Sure.
16:16:44 <jungleboyj> erlon_:  Where have you been?  ;-)
16:16:49 <e0ne> :)
16:16:57 <erlon_> :P
16:17:00 <erlon_> Sorocaba
16:17:10 <e0ne> jungleboyj: what is a status of os-brick migration to storyboard?
16:17:30 <jungleboyj> So, there is a movement from using Launchpad for bug tracking and blueprints to using storyboard.
16:17:48 <jungleboyj> https://storyboard.openstack.org/#!/dashboard/stories
16:17:52 <jungleboyj> #link https://storyboard.openstack.org/#!/dashboard/stories
16:17:55 <erlon_> jungleboyj, ow, that would be awesome
16:17:59 <erlon_> hat LP
16:18:02 <erlon_> *hate
16:18:22 * jungleboyj thinks erlon_  Just volunteered to lead this up.
16:18:39 <e0ne> :D
16:18:39 <smcginnis> Storyboard is still a little rough around the edges in spots, but I think as more people start using it things will get fixed up.
16:18:40 <tbarron> hee-hee
16:18:46 <smcginnis> But something we should know going in to it.
16:18:46 <erlon_> jungleboyj, haha, that does not mean the same thing :p
16:18:53 <smcginnis> Either way, it's going to be a change.
16:19:00 <e0ne> btw, does it have integration with gerrit?
16:19:13 <jungleboyj> Yeah, it is still a bit buggy and my big problem is trying to figure out how to find what I need in there.
16:19:18 <jungleboyj> e0ne:  Yes it does.
16:19:40 <e0ne> jungleboyj: good, it fits minimal requirements for me:)
16:19:42 <jungleboyj> You use story: <story number> and then it works like Launchpad did.
16:20:23 <jungleboyj> In the past we had an os-brick test migration run to a sandbox.
16:20:52 <jungleboyj> We looked at it and opened some bugs that needed to be addressed.  I think those issues have been addressed.
16:21:25 <erlon_> jungleboyj: so this migration would be to copy the bugs/features from LP and put on storyboard?
16:22:19 <jungleboyj> erlon_:  Yes, that is the starting point is that they need to migrate all the existing bugs over.
16:22:33 <smcginnis> The migration is scripted, so not really extra work on our end.
16:22:36 <jungleboyj> Blueprints would go away and we would start using stories in storybard.
16:22:41 <jungleboyj> smcginnis: ++
16:23:10 <smcginnis> And it keeps links between things, so if there is a lauchpad bug that has cinder and python-cinderclient listed, that would still just be one storyboard bug with both repos.
16:23:13 <erlon_> smcginnis, so, what work would be left for us?
16:23:45 <tommylikehu> to make decision?
16:23:52 <smcginnis> erlon_: Really just adapting our workflow to link to the stories in our commit messages and going to storyboard.o.o for bug tracking and things.
16:24:01 <smcginnis> Hah, yeah. And to decided when to do it. ;)
16:24:20 <jungleboyj> So, what are the things I think we need to do:
16:24:27 <jungleboyj> 1) When do we want to do this?
16:24:44 <jungleboyj> 2) Do we want to move all of the projects at once?
16:25:28 <jungleboyj> 3)  We need to come to agreement as to how we are going to use Storyboard to track new work.
16:25:31 <erlon_> well we can start with os-brick again
16:26:05 <erlon_> and them after people get more aquaintted  move cinder
16:26:10 <eharney> not doing it at once and trying to track cinder bugs in launchpad and client/brick bugs in storyboard simultaneously sounds like a nightmare
16:26:25 <jungleboyj> eharney:  Yeah, that is the problem with that approach.
16:26:30 <jungleboyj> smcginnis:  Also mentioned that.
16:26:39 <smcginnis> I'd rather move all of our repos over at once.
16:26:48 <tommylikehu> move all of them started from Stein?
16:26:58 <tommylikehu> start
16:27:02 <jungleboyj> I think it may be one of those things where we just need to rip the bandaid off.
16:27:24 <eharney> yeah, it's going to be kind of messy in the ideal case... don't need to make it even more complicated
16:27:35 <jungleboyj> I am going to need to update documentation and everything like that.
16:27:44 <eharney> are we migrating all open blueprints and bugs?  or closed ones too?  what's the idea there?
16:28:03 <smcginnis> I believe closed bugs get moved too. Nothing with blueprints though.
16:28:39 <jungleboyj> smcginnis: ++ Think that is correct.
16:28:45 <tbarron> +1
16:28:57 <smcginnis> We do refer to launchpad a few places in code and in our docs and wiki, so we will have to find all those references and get them updated too.
16:29:05 <jungleboyj> tbarron:  What is you rplan?
16:29:09 <jungleboyj> smcginnis: ++
16:29:23 <tbarron> jungleboyj: to talk about it in tomorrow's meeting :) but
16:29:28 <smcginnis> :)
16:29:30 <jungleboyj> :-p
16:29:43 <tbarron> I want to build some queries and boards before we cut over
16:29:46 <tbarron> in a sandbox
16:30:06 <tbarron> the issue with storyboard IMO is that besides being young it is in a way a
16:30:13 <tbarron> lower level tool than launchpad
16:30:18 <tbarron> that's also a virtue
16:30:21 <jungleboyj> tbarron: ++
16:30:29 <tbarron> it can be used to do lots of different things
16:30:37 <jungleboyj> Don't know anything about building queries and stuff yet.
16:31:00 <tbarron> but we need to make some "canned" worklists and boards and links to these for our project that
16:31:22 <tbarron> will get us the stuff we want to keep from launchpad like targeting bps and bugs to milestones
16:31:39 <tbarron> so I want to play with that a little bit before we actually cut over
16:31:51 <tbarron> not too worried about it being do-able though
16:32:16 <tbarron> and of course there will be rough edges anyways
16:32:43 <jungleboyj> Yeah, most likely.
16:33:32 <jungleboyj> tbarron:  Are you planning to do the cut over at the beginning of Stein?
16:34:03 <tbarron> I'd rather do it earlier if we can get ready but that means moving soon
16:34:15 <tbarron> Don't want to be doing it after M3
16:34:33 <jungleboyj> tbarron:  Ok.  Well, if you go first then we can learn from your experience.  :-)
16:34:51 <tbarron> But it might be as Stein begins, maybe likely
16:35:20 * tbarron pictures jungleboyj and himself standing at the edge of an iceberg
16:35:22 <jungleboyj> Ok.  Sounds good.
16:35:28 <tbarron> nudging one another
16:35:31 <jungleboyj> tbarron:  ++
16:35:40 <jungleboyj> You go first.
16:35:46 <eharney> what happens to launchpad bugs that are opened on both cinder and nova components?  we just close the cinder half of it?
16:35:59 <tbarron> nah, you'll give the orcas more to eat :)
16:36:09 <jungleboyj> tbarron:  Ouch.
16:36:13 <jungleboyj> :-)
16:36:31 <jungleboyj> eharney:  I think they were working on that but I can't remember what happens.
16:36:35 <jungleboyj> smcginnis:  ??
16:37:11 <tbarron> I think it's all "tags" and flexible and all just works.
16:37:21 <tbarron> That's the problem too :)
16:37:30 <tbarron> We need to establish some conventions.
16:37:55 <tbarron> But maybe they've built something more static into storyboard now.
16:38:11 <jungleboyj> Yeah, I am concerned that there isn't more as far as conventions right now.
16:38:23 <jungleboyj> That, however, isn't going to change until we start using it.
16:39:09 * eharney looks forward to the rename to "group 23"
16:39:22 <e0ne> :)
16:40:02 <jungleboyj> eharney:  I hate that.  For the love of Pete ...
16:40:28 <jungleboyj> Perhaps we need to change our logo.
16:40:33 <smcginnis> I think if a nova bug in lp closes after we go to sb, once nova goes to sb that status will get reflected in our common "story".
16:41:27 <jungleboyj> So, let me make the following proposal for going forward ...
16:42:15 <jungleboyj> I can ask diablo_rojo_phon to migrate our projects over to the sandbox.
16:42:24 <jungleboyj> tbarron:  I assume you will be doing the same?
16:42:52 <tbarron> jungleboyj: yes, we have asked and she up us in line in front of you :)
16:43:09 * tbarron is feeling particularly constructive today
16:43:14 <jungleboyj> I will start playing around with SB more and tbarron  and I can share experiences.
16:43:19 <jungleboyj> tbarron: Cool.
16:43:28 <tbarron> seriously, she's going to try to get manila in sandbox by the end of this week
16:44:33 <jungleboyj> I will be prepared to go over how it works and how we should use it and we can plan to come to agreement on anything that needs to be decided at the PTG and then we will cut over after that.
16:44:41 <jungleboyj> Anyone have concerns with that plan?
16:44:49 <smcginnis> Sounds like a good start to me.
16:45:08 <jungleboyj> Any dissent?
16:46:06 <smcginnis> Just want to point out that if/when we all move over, this gets us closer to having single signon across all OpenStack properties so we don't have to go out to Ubuntu One to login.
16:46:20 <smcginnis> So there will be some pain, but some goodness in the long run.
16:46:20 <jungleboyj> That is good.
16:46:50 <jungleboyj> #action jungleboyj to ask diablo_rojo_phon to do migration of the Cinder repos from LP to SB.
16:47:29 <jungleboyj> #action jungleboyj to start working with/documenting SB for Cinder.  Create some task lists and boards.  Create some queries.
16:48:12 <jungleboyj> #action jungleboyj  to present what we have learned at the PTG and come to agreement with a plan to move after the PTG.
16:49:08 <jungleboyj> Ok, so, I think we have a plan.
16:49:15 <jungleboyj> tbarron:  Please keep me updated as you progress.
16:50:39 <jungleboyj> #topic Hackathon for Rocky:
16:50:42 <jungleboyj> tommylikehu:
16:50:51 <tommylikehu> yes
16:50:57 <tommylikehu> that's only a reminder that the hackathon is coming next week again:)
16:51:15 <tommylikehu> please help the developers to review the patches then:)
16:51:33 <jungleboyj> Ok.  Are those patches going to be tracked anywhere?
16:51:47 <tommylikehu> here is the etherpad links: https://etherpad.openstack.org/p/OpenSource-Hackathon-Rocky-Beijing-Bugs-List
16:51:51 <tommylikehu> haha
16:52:35 <jungleboyj> Cool.
16:52:39 <smcginnis> jungleboyj: Didn't we use a tag on some bugs in the past to try to get an easy list to query for potential bugsmash bugs to work on?
16:52:51 <jungleboyj> tommylikehu: Are you going put some bugs in there?
16:52:55 <jungleboyj> smcginnis:  Yes, we did.
16:52:57 <tommylikehu> there would be about 40 developers there, so I guess this hackathon would be more productive
16:53:07 <tommylikehu> jungleboyj:  will do
16:53:45 <tommylikehu> smcginnis:  no sure how many bugs are tagged with bug smash
16:54:23 <smcginnis> We would probably have to go through again and tag more.
16:54:40 <jungleboyj> Yeah, we used 'bugsmash'
16:54:50 <tommylikehu> smcginnis:  ok
16:55:00 <jungleboyj> There are 8 with that Tag.
16:56:09 <tommylikehu> tbarron: also there would be some developers coming for manila:)
16:56:42 <gouthamr> tommylikehu: +1, i didn't see any on teh etherpad though and was going to ping you/zhongjun
16:56:44 <jungleboyj> eharney: tommylikehu smcginnis Can you take a few minutes to look through and mark some bugs with bugsmash?
16:56:59 <jungleboyj> I will also try to look through them.
16:57:13 <smcginnis> Will try to get to that today.
16:57:20 <tbarron> tommylikehu: right, ty!
16:57:37 <tommylikehu> gouthamr:  you mean the name list? I should be on the list
16:57:50 <tbarron> we had lots of fixes from the wuhan bug smash
16:58:03 <gouthamr> tommylikehu: nope, there was a doc with 40 contributors and the projects they intended to contribute to
16:58:15 <jungleboyj> smcginnis:  Thank you!
16:58:17 <gouthamr> unless i misunderstood what the doc was for :) which is possible.
16:58:45 <jungleboyj> Ok, so we have two minutes left.  Anything else people need to cover?
16:59:30 <jungleboyj> Going, going ....
16:59:43 <e0ne> see you next week!
16:59:49 <jungleboyj> Ok.  Going to wrap up then.
17:00:00 <smcginnis> o/
17:00:08 <jungleboyj> I have a conflict the next two weeks so Sean will be covering for me.
17:00:13 <jungleboyj> @!
17:00:23 <jungleboyj> smcginnis:  Thank you!
17:00:29 <jungleboyj> #endmeeting