16:01:18 <jungleboyj> #startmeeting cinder
16:01:21 <openstack> Meeting started Wed Jan 31 16:01:18 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:24 <openstack> The meeting name has been set to 'cinder'
16:01:26 <Swanson> Hallo
16:01:28 <amito> o/ hello
16:01:32 <smcginnis> o/
16:01:36 <luizbag> o/
16:01:36 <jungleboyj> Courtesy ping:  jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon tpsilva patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro
16:01:38 <abishop> o/
16:01:41 <jungleboyj> @!
16:01:41 <_pewp_> jungleboyj (♦亝д 亝)ノ
16:01:41 <walshh2> Hello
16:01:45 <tpsilva> hey
16:01:45 <eharney> hi
16:01:46 <e0ne> hi
16:02:05 <jungleboyj> smcginnis:  Sorry, I am having an issue in IRC cloud where it lags when trying to change channels.
16:02:10 <smcginnis> :)
16:02:13 <jessegler> o/
16:02:20 <jungleboyj> Keep hoping they will fix it but it eats up a crap load of processor, whatever it is doing.
16:02:37 * jungleboyj continues to be addicted to IRCCloud anyway.
16:03:14 <ildikov> jungleboyj: works well on my Mac ;)
16:03:53 <jungleboyj> ildikov:  Eeeew.  You said Mac.
16:03:57 <Swanson> Bourgeoisie. I just use hexchat.
16:04:07 <luizbag> hexchat FTW
16:04:09 <erlon> hey
16:04:11 <jungleboyj> Swanson:  The minimalist
16:04:22 <smcginnis> irssi FTW! :)
16:04:28 <e0ne> ildikov: everything works on mac except cinder's unit tests:(
16:04:30 <jungleboyj> smcginnis:  The massive nerd
16:05:09 <jungleboyj> Ok, we should get started.
16:05:11 <ildikov> e0ne: not sure only the Mac is the issue in that case :)
16:05:20 <ildikov> e0ne: but I hear ya
16:05:20 <jungleboyj> ildikov:  Ouch.
16:05:21 <e0ne> ildikov: :)
16:05:28 <jungleboyj> #announcements
16:05:35 <jungleboyj> #topic announcements
16:05:49 * jungleboyj blames the super uber massive blue moon thing.
16:06:01 <jungleboyj> Q-3 was cut last week.
16:06:11 <jungleboyj> We are now in a short period of time to merge bugs.
16:06:36 <Swanson> Nicely defined unit of time.
16:07:28 <jungleboyj> :-)
16:07:39 <jungleboyj> So, please make sure to not be merging any new features.
16:07:48 <jungleboyj> Please also work on merging bugs.
16:08:05 <jungleboyj> #link https://releases.openstack.org/queens/schedule.html
16:08:12 <jungleboyj> RC-1 is next week.
16:08:26 <jungleboyj> I am guessing that means that I need to cut RC-1 next THURSDAY?
16:08:29 <jungleboyj> smcginnis: ???
16:08:41 <smcginnis> jungleboyj: Yep, Thuuuursday.
16:08:53 <e0ne> :)
16:08:55 <jungleboyj> Would that be the day after Wednesday?
16:09:00 <smcginnis> :)
16:09:01 <e0ne> :)
16:09:11 <jungleboyj> See, I can be taught.
16:09:13 <smcginnis> The day before Friday.
16:09:17 <Swanson> My coal fired jebus that is coming up quick.
16:09:20 <jungleboyj> I love Fridays.
16:09:25 <jungleboyj> Swanson:  Yeah.
16:09:41 <e0ne> jungleboyj: usually, Thursday is between Wed and Fri, but who knows...
16:09:46 <smcginnis> :)
16:09:53 <jungleboyj> e0ne:  I know nothing anymore.
16:10:05 <jungleboyj> PTL Nominations are now open.
16:10:14 <jungleboyj> #link http://lists.openstack.org/pipermail/openstack-dev/2018-January/126700.html
16:10:35 <jungleboyj> That has also come up quick.
16:10:50 <jungleboyj> And finally a reminder about the PTG planning etherpad:
16:10:59 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-ptg-rocky
16:11:09 <jungleboyj> Looks like we have a good crowd coming and we are getting topics.
16:11:11 <jungleboyj> Yay!
16:11:20 <Swanson> What ever happened with longer cycles?
16:11:40 <ildikov> FYI, ticket prices raise on Thursday
16:11:43 <jungleboyj> I am also planning to go back to the notes from the Queens PTG and pull forward things that didn't get addressed during the release.
16:11:43 <e0ne> Swanson: TC decided to not change anything at least for Rocky
16:11:45 <smcginnis> Swanson: Too many issues were raised with extending it.
16:11:50 <jungleboyj> ildikov: ++ Thank you!
16:12:38 <jungleboyj> Any other announcements?
16:13:16 <jungleboyj> Ok, moving on.
16:13:26 <jungleboyj> #topic Feature Checkpoint
16:13:43 <jungleboyj> Transfer Snapshots with Volumes was too big a change.
16:13:52 <jungleboyj> Anyone strongly object to not merging it?
16:14:23 <jungleboyj> I will take that as a no.
16:14:51 <jungleboyj> Thank you for the work to get Provisioning and RBD encryption changes in.
16:14:54 <jungleboyj> Those merged.
16:15:09 <jungleboyj> Looks like there will be a spec for the RBD change here later today.
16:15:10 <jungleboyj> Thank you.
16:15:18 <jungleboyj> eharney:  Just ping me when that is up.
16:15:28 <eharney> yep, will do
16:15:32 <jungleboyj> :-)
16:15:48 <jungleboyj> #topic Project Interviews at PTG.
16:15:58 <smcginnis> Taco run?
16:16:02 <jungleboyj> So, they are interviewing people from the project again.
16:16:09 <jungleboyj> https://docs.google.com/spreadsheets/d/1MK7rCgYXCQZP1AgQ0RUiuc-cEXIzW5RuRzz5BWhV4nQ/edit#gid=0
16:16:22 <jungleboyj> Is there anyone willing to be my backup incase I get stuck on a Taco Run?
16:16:27 <smcginnis> :)
16:16:34 <jungleboyj> smcginnis:  You had to beat me to the joke, didn't you?
16:16:44 <smcginnis> I nominate ildikov.
16:17:03 <jungleboyj> smcginnis: :-)  She can talk about how wonderful it is that we got Multi-attach in.
16:17:05 <jungleboyj> Do a dance!
16:17:31 * jungleboyj is also going to figure out where the heck the interviews are happening ahead of time this time.
16:18:50 <jungleboyj> So, I guess I will arrange a time for Cinder.  Not near a meal time and see who wants to join me when the time comes.
16:19:02 <jungleboyj> I do think that ildikov is a good choice though.  :-)
16:19:15 <jungleboyj> Even though she is ignoring us.
16:19:49 <smcginnis> I didn't hear an objection from her, so I think that means you can sign her up for it. ;)
16:20:03 <jungleboyj> smcginnis:  I like the way you think when you aren't harassing me.
16:20:37 <smcginnis> Hah
16:20:39 <ildikov> jungleboyj: I only do it with my dream team jgriffith and patrickeast :)
16:20:57 <jungleboyj> ildikov: Ouch.  You cut me deep.
16:21:25 <ildikov> jungleboyj: I think we did an awesome job last time :)
16:21:51 <jungleboyj> Niether of who are on the attendance list though.
16:21:52 <ildikov> jungleboyj: you need to learn to delegate ;)
16:22:08 <ildikov> jungleboyj: yeah, you need to fix that!
16:22:09 <jungleboyj> ildikov:  Ok, I will sign you guys up then.
16:22:17 <jungleboyj> jgriffith:  Where you at!?!
16:22:53 <jungleboyj> I will sign us up and we can figure out the details.
16:23:24 <jungleboyj> #topic Cisco FC ZM Driver
16:24:15 <jungleboyj> So, Cisco is working on getting CI working.
16:24:29 <jungleboyj> It isn't pretty but it is reporting and they have been working on this.
16:24:31 <smcginnis> They do have one (and only one) test running.
16:24:44 <jungleboyj> smcginnis: Ok, it is something.
16:25:02 <jungleboyj> I wanted to get an idea of what you think smcginnis  and if anyone else has opinions.
16:25:27 <smcginnis> I had worked with Angela in the past and we came up with a list of 13 tests that actually go through the fczm.
16:25:37 <smcginnis> I think that should apply to Cisco as well.
16:25:48 <e0ne> I'm ok with this if CI is stable and reporting to the needed patches
16:25:49 <smcginnis> I need to try to find that though. That was like 2 years ago.
16:26:08 <smcginnis> e0ne: OK with it now with one test?
16:26:20 <smcginnis> Not disagreeing, just clarifying.
16:26:33 <jungleboyj> smcginnis:  That sounds reasonable.  They should do the same thing as the other FC ZM.
16:27:12 <smcginnis> That said, I don't think Brocade is reporting anymore now either since the Broadcom acquisition.
16:27:26 <jungleboyj> smcginnis:  *Laughing*
16:27:29 <e0ne> smcginnis: one tests doesn't look good enough
16:27:56 <smcginnis> I would be willing to accept "good enough for now" with the understanding that they need to add more tests.
16:28:13 <e0ne> I'm not expert in FC at all, but I would like to see FC-related tests with some volume backend tests
16:28:17 <jungleboyj> smcginnis:  ++ and then we should follow up with Angela on Brocade.
16:28:48 <smcginnis> If either is still around...
16:29:02 * jungleboyj shakes my head
16:29:15 <smcginnis> e0ne: At least the one they have running is volume attach/detach, so it is at least covering the main happy path.
16:29:24 <jungleboyj> smcginnis:  I feel like marking it unsupported had the desired effect.
16:30:01 <smcginnis> True
16:30:25 <jungleboyj> smcginnis:  Do you have bandwidth to continue working with Liqin Dong?
16:30:45 <smcginnis> Thermo nuclear option, we remove FCZM from cinder and it's up to Cisco and Brocade/Broadcom to provide this functionality to their end users. I don't like that option though.
16:31:21 <jungleboyj> I am not a fan of Thermo Nuclear options.
16:31:28 <smcginnis> jungleboyj: Yeah, I'll try to track down that conversation with Angela and get them the list of expected tests.
16:31:42 <smcginnis> ACtually, now that I think of it, I might have been smart enough to add that to the wiki.
16:31:45 * smcginnis checks...
16:31:59 <Swanson> smcginnis, I like this. Let's give it the ol Kim Jong Un. I can have a patch up for my driver in 15 minutes.
16:32:32 <e0ne> smcginnis: attach/detach - is good to start. from my experience, most problems were with FC and migrations. but we didn't use FC zone manager in that deployments
16:32:32 * jungleboyj shakes my head at Swanson
16:33:03 <smcginnis> e0ne: Oh, good point.
16:33:14 <jungleboyj> #action smcginnis to follow up with Cisco on tests being run by Broacde.
16:33:28 <jungleboyj> #action jungleboyj  To follow up on state of the Brocade driver.
16:34:18 <jungleboyj> That all sound good?
16:34:23 <smcginnis> ++
16:34:29 <jungleboyj> Sweet.
16:34:41 <jungleboyj> #topic Provisioning report bugs:
16:34:47 <jungleboyj> tpsilva: Take it away.
16:34:52 <tpsilva> alright
16:35:22 <tpsilva> so, as part of the provisioning improvements, we went through all the drivers checking what they were reporting
16:35:23 <jungleboyj> Alright ...
16:35:57 <tpsilva> and we came up with a list of bugs
16:36:19 <tpsilva> for each driver that had incorrect provisioning reports
16:36:34 <tpsilva> most of the bugs are pretty simple to fix, so it shouldn't take much
16:36:37 <jungleboyj> tpsilva:  Excellent.
16:36:48 <tpsilva> but vendors should check this list to see if their drivers are affected
16:37:24 <jungleboyj> #action Vendors need to check if their drivers are impacted and make changes.
16:37:41 <eharney> it sounds like we could just push these changes rather than requiring driver owners to make them, if the fix is to just not report a value from the driver anymore
16:37:50 <e0ne> and we should be careful with RemoteFS driver since it can broke some other drivers
16:38:09 <jungleboyj> eharney:  I am ok with that.
16:38:30 <smcginnis> tpsilva: I think I saw about 5-6 bugs go through. Does that sound right?
16:38:45 <tpsilva> smcginnis: I opened 8 bugs
16:38:51 <erlon> eharney, some of the changes deal with some internal driver logic and we didnt wanted to mess with that
16:38:55 <tpsilva> the complete list is on the meeting agenda etherpad
16:39:04 <smcginnis> tpsilva: OK, thank you.
16:39:07 <jungleboyj> smcginnis:  List is in the meeting notes.
16:40:54 <erlon> eharney, and, changing drivers without having the hardware to test means to rely on their CIs, and that use to be a pain
16:41:19 <jungleboyj> erlon:  What is the impact of leaving them as is?
16:41:20 <eharney> erlon: well that is one of the main reasons that we have all of these CIs...
16:42:22 <jungleboyj> eharney:  True.  Assuming they work.
16:42:51 <eharney> don't they?
16:43:01 <jungleboyj> eharney:  Some do.  :-)
16:43:13 <jungleboyj> eharney:  That is a whole other discussion though.
16:43:17 <erlon> jungleboyj, true
16:43:55 <eharney> seems like a reasonable assumption given the numerous man-years put into dealing with them, but i dunno
16:43:58 <jungleboyj> erlon:  Did you see the question about what the impact of leaving drivers as they are?
16:44:08 <erlon> jungleboyj, I have done some work through several drivers and waiting on CIs to get things tested is very time consuming
16:45:06 <erlon> eharney, the impact is that those drivers will not behave correctly when using thin provisioning, some will not schedule when they should, other will always create volumes etc
16:45:25 <jungleboyj> erlon:  Ok.
16:45:50 <erlon> the idea of have then fixed is to have a consistent behaviour on thin provisioning supported drivers
16:47:18 <jungleboyj> erlon:  So, I am looking at this list and it shouldn't be hard for those drivers to get people involved to make sure the right change is pulled in.
16:47:36 <jungleboyj> Huawei is one of them.  I know someone with connections there.  :-)
16:47:43 <jungleboyj> Storwize, same thing.
16:48:01 <jungleboyj> So, let me take this and follow up with people to get it attention.
16:48:31 <jungleboyj> Keep this on the meeting agenda to track progress.
16:48:42 <jungleboyj> I don't think we want drivers with inconsistent behavior.
16:48:47 <erlon> jungleboyj, nice! Its good to have vendors involved
16:49:17 <jungleboyj> erlon:  Yeah, I feel they should be involved.  If you have patches, that is great, they should review them.
16:49:37 <jungleboyj> Lucian is active on SMBFS.
16:49:55 <jungleboyj> eharney: e0ne  You guys have the most experience with remotefs.  Right?
16:50:49 <eharney> yes?
16:52:07 <jungleboyj> That is the one kind-of concerning one as it impacts multiple drivers.
16:52:15 <jungleboyj> erlon: How complicated is the change there?
16:52:49 <e0ne> jungleboyj: I can try to fix remotefs
16:52:58 <jungleboyj> e0ne:  Excellent.
16:53:02 <tpsilva> jungleboyj: we just need to remove the report for allocated_capacity_gb
16:53:09 <tpsilva> not that complicated
16:53:13 <jungleboyj> tpsilva:  Ok, good.
16:53:23 <erlon> piece of cake :)
16:53:26 <jungleboyj> So here is what I have:
16:53:32 <e0ne> but any input from tpsilva  will be extremely useful
16:53:47 <jungleboyj> #action jungleboyj to make vendors aware of bugs against their drivers .
16:54:06 <jungleboyj> #action erlon to push up any patches he has started and to look from input from the vendors
16:54:22 <jungleboyj> #action e0ne to look at the remotefs driver.
16:54:47 <jungleboyj> I assume all these changes are things that could be backported in the case they don't go in before RC?
16:54:54 <erlon> jungleboyj, Ill send an email for the maintainers, dont have any patches tough
16:55:10 <jungleboyj> erlon: Oh, you are going to e-mail the vendors?
16:55:46 <jungleboyj> erlon:  That would be awesome if you can do it.
16:55:57 <erlon> jungleboyj, wasnt that what you meant by 'make vendors aware'?
16:56:23 <e0ne> need to head home. I'll be online in ~1.5 hours
16:56:36 <jungleboyj> erlon:  Yep, that was it.  If you are able to do it, that is great.
16:56:51 <erlon> jungleboyj, ok, I wll
16:57:02 <jungleboyj> erlon: Excellent.  Thank you!
16:57:27 <jungleboyj> #action erlon to coordinate with driver maintainers to make sure that drivers are properly fixed.
16:57:34 <jungleboyj> erlon:  Let me know if you need help.
16:57:38 <jungleboyj> I had one more topic.
16:58:06 <jungleboyj> #topic Bug:  Volume details shows attached compute host for non-admins
16:58:09 <erlon> jungleboyj, np
16:58:22 <jungleboyj> #link https://bugs.launchpad.net/cinder/+bug/1740950
16:58:23 <openstack> Launchpad bug 1740950 in Cinder "Volume details shows attached compute host for non-admins" [Undecided,New]
16:58:36 <jungleboyj> This bug was opened a bit ago and could be a security issue.
16:58:45 <jungleboyj> Doesn't look like anyone has had a chance to look at it.
16:58:52 <jungleboyj> Don't think we want to release it as is.
16:58:59 <jungleboyj> Anyone able to investigate it?
16:59:31 * jungleboyj hears crickets
16:59:39 <smcginnis> Just wanted to point, while we are feature and string freeze, now would be a good time to spend time reviewing pike backports. That transitions to Phase II support in just a few weeks.
16:59:51 <smcginnis> jungleboyj: I can try to take a look later unless someone else beats me to it.
17:00:02 <smcginnis> Which would be just fine with me.
17:00:07 <smcginnis> Times up.
17:00:18 <jungleboyj> smcginnis:  Thank you and thanks for the note on backports!
17:00:40 <jungleboyj> Thanks everyone!  Talk to you all next week!
17:00:44 <jungleboyj> #endmeeting