16:00:08 <jungleboyj> #startmeeting cinder
16:00:09 <openstack> Meeting started Wed Jan 24 16:00:08 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:12 <openstack> The meeting name has been set to 'cinder'
16:00:15 <smcginnis> o/
16:00:17 <xyang> hi
16:00:29 <jungleboyj> Courtesy ping:  jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro
16:00:36 <jungleboyj> @!
16:00:36 <_pewp_> jungleboyj (。・д・)ノ゙
16:00:39 <tommylikehu> hi
16:00:41 <eharney> hey
16:00:42 <geguileo> hi o/
16:00:50 <e0ne> hi
16:00:53 <bswartz> .o/
16:01:01 <walshh> hi
16:01:03 <Swanson> hello
16:01:16 <patrickeast> o/
16:02:02 <jungleboyj> Hello.  Just wait another minute to see if others show up.
16:02:14 <ganso> hello
16:02:19 <tpsilva> hey
16:02:26 <erlon> hey
16:03:05 <jungleboyj> Cool.  Have a good crowd today.  Lets get started.
16:03:18 <jungleboyj> #topic Announcements
16:03:34 <e0ne> #link https://etherpad.openstack.org/p/cinder-queens-meeting-agendas
16:03:54 <enriquetaso> Hi
16:04:05 <jungleboyj> Reminder that we will be cutting the release for Cinderclient tomorrow.  Yes, on THURSDAY.
16:04:23 <amito> hey
16:04:26 <jungleboyj> Is anyone aware of things that need to get it that are not in?
16:04:36 <smcginnis> :)
16:04:56 <jungleboyj> If not I will even try to propose the cut today.
16:05:10 <smcginnis> Last time I looked, I think we had all the important stuff in.
16:05:34 <e0ne> jungleboyj: please, don't forget to release python-brick-cinderclient for Queens too
16:05:38 <jungleboyj> I don't think there is anything pending for brick-cinderclient-ext but I think there is a dependency change.  I will look at that.
16:05:46 <jungleboyj> e0ne:  Great minds think alike.  :-)
16:05:49 <e0ne> :)
16:06:25 <jungleboyj> Ok, I think that is all I had for that.
16:06:38 <geguileo> jungleboyj: there is the backup issue
16:06:50 <geguileo> oh, we are talking cinderclient...
16:06:55 * geguileo shutsup
16:06:57 <jungleboyj> I wanted to introduce and welcome Sofia Enriquez enriquetaso
16:07:13 <enriquetaso> Hey :)
16:07:13 <jungleboyj> She is interested in helping as a Google Summer of Code intern.
16:07:38 <jungleboyj> e0ne:  Could use help with the Generic Backup Implementation.  So, she will be helping with that.
16:07:56 <e0ne> jungleboyj: thanks!
16:07:57 <enriquetaso> I met some of you in Barcelona :)
16:08:19 <jungleboyj> enriquetaso:  Awesome!  You previously helped jbernard on some work for Cinder?
16:08:23 <smcginnis> enriquetaso: Welcome!
16:08:33 <e0ne> enriquetaso: welcome!
16:08:33 <tommylikehu> enriquetaso:  Welcome!
16:08:35 <erlon> enriquetaso, welcome!
16:08:52 <enriquetaso> Yes, I worked with Jon !
16:08:55 <ganso> enriquetaso: welcome!
16:09:02 <jungleboyj> I have gotten enriquetaso  started with code reviews and if we have any little bugs that come in she is eager to look at them.
16:09:25 <enriquetaso> Yay
16:09:45 <jungleboyj> enriquetaso:  Anything you want to share to introduce yourself?
16:09:45 <e0ne> enriquetaso: feel free to ping me if you need any help
16:10:02 <enriquetaso> Ok, thanks e0ne !
16:12:05 <jungleboyj> So, if enriquetaso  needs any help please make yourself available to help.  Want to give her another good internship experience.  :-)
16:12:19 <jungleboyj> We must have done ok the first time around given that she wanted to come back.
16:12:38 <e0ne> :)
16:12:58 <jungleboyj> Moving on.
16:13:10 <jungleboyj> Reminder that we have the PTG Planning etherpad:
16:13:23 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-ptg-rocky
16:13:43 <jungleboyj> Thank you to everyone that has already indicated their attendance.  Looks like we have a good crowd shaping up.
16:14:04 <jungleboyj> hemna: Is going to be able to be there to do the hangouts streaming and video recording.
16:14:19 <jungleboyj> So, if you are remote we should be able to support you.
16:14:36 <e0ne> great! we've got our camera-man back! :)
16:14:49 <jungleboyj> Please start adding topics.  I will start proposing things as I start going through specs.
16:14:52 <jungleboyj> e0ne:  ++
16:14:59 <tommylikehu> jungleboyj:  will do
16:15:27 <jungleboyj> Ok, that is all for announcements.
16:15:37 <jungleboyj> #topic Features not Complete
16:15:55 <jungleboyj> So, we have a couple of specs we talked about last week that still need attention.
16:16:03 <jungleboyj> Transfer Snapshots with Volumes:
16:16:13 <jungleboyj> #link https://review.openstack.org/533564
16:16:21 <jungleboyj> eharney:  You were -2 on this.  Can that be removed?
16:16:29 <eharney> jungleboyj: already removed
16:16:38 <eharney> has anyone reviewed this substantially?
16:16:43 <jungleboyj> eharney:  Excellent.  So we just need reviews.
16:17:21 <jungleboyj> eharney: So, we need to get people reviewing that with a target to merge by Friday.  If it doesn't merge by then, then I think it should be held.
16:17:26 <jungleboyj> Any disagreements?
16:17:57 <e0ne> jungleboyj: sounds like a good plan go to forward with this one
16:18:01 <smcginnis> Feature freeze is tomorrow (Thursday) so it would be good if we can do something before that.
16:18:04 <smcginnis> :)
16:18:14 <jungleboyj> Yes, by friday.
16:18:22 <jungleboyj> On Thursday.
16:18:23 <erlon> ??
16:18:26 <erlon> ok
16:18:26 <jungleboyj> smcginnis:  :-p
16:18:51 <erlon> jungleboyj, what time tomorrow?
16:19:00 <jungleboyj> smcginnis:  Technically we FF'ed last week for Cinder.
16:19:05 <jungleboyj> ON THURSDAY.
16:19:12 <smcginnis> Oh, good point! :)
16:19:12 <e0ne> do we still have  something for feature freeze exception?
16:19:24 <jungleboyj> The teacher becomes the student.
16:19:43 <e0ne> I mean something not mentioned in etherpad
16:19:45 <jungleboyj> e0ne: Just the Snapshots with Volumes and Provisioning improvements.
16:19:53 <jungleboyj> e0ne:  No, not that I am aware of.
16:19:53 <erlon> jungleboyj, wasnt that the proposal freeze?
16:20:14 <jungleboyj> erlon:  No, was FF, but we gave these two an exception.
16:20:33 <jungleboyj> erlon:  Do you think you can hit mid day tomorrow?
16:20:48 <erlon> jungleboyj, just on point, our driver side changes for the Overprovisioning changes are just needing to pass CI: https://review.openstack.org/534855
16:21:32 <jungleboyj> erlon: Ok.
16:21:38 <erlon> jungleboyj, I got a +2 from geguileo, just added some documentation that was missing in this last patch
16:22:04 <jungleboyj> So, lets work to review/get these patches through in the next ~28 hours.
16:22:18 <erlon> jungleboyj, there are some additions to doc, but that does not count in the feature freeze right?
16:22:32 <jungleboyj> erlon:  Right.  Doc updates can continue.
16:22:52 <jungleboyj> Oh, we also have eharney 's RBD encryption change.  Where is that at?
16:23:02 <eharney> jungleboyj: got lost in zuul somewhere, i'm watching it today
16:23:13 <eharney> jungleboyj: it was +W'd
16:23:26 <jungleboyj> eharney:  Ok, that was what I had though.
16:23:29 <jungleboyj> *thought
16:23:38 <jungleboyj> So, just need a spec to go with that before too long.
16:23:43 <eharney> yes
16:24:01 <jungleboyj> #action eharney  To get spec associated with RBD Encrypted Volume support.
16:24:30 <eharney> the nova side is also in the process of merging, i believe
16:24:41 <jungleboyj> We have two other specs that have been moved out and it looks like those have been merged.
16:25:07 <jungleboyj> I will also propose moving out 'Update Backup's Size when Backup is Created'
16:25:20 <tommylikehu> jungleboyj:  ok
16:25:44 <jungleboyj> Anything more on Features for Queens?
16:26:28 <jungleboyj> Ok, Moving on.
16:26:44 <jungleboyj> #topic Priorities going forward.
16:26:50 <jungleboyj> So, the PTG is about a month away.
16:27:07 <jungleboyj> So, we need to focus on getting bug fixes in place, reviewed and merged.
16:27:14 <jungleboyj> Test, test, test.
16:27:27 <erlon> Agreed!
16:27:34 <jungleboyj> I also would like to see us focus on reviewing the specs out there so we know what all we need to discuss when we meet in Dublin.
16:27:53 <erlon> Its always fun to add more feature! But Im fan of the stable releases
16:28:19 <jungleboyj> erlon:  :-)  Well, I think we have done a decent job of not releasing anything too unstable lately.
16:28:24 <jungleboyj> Would like to keep it that way.
16:28:38 <jungleboyj> So, appreciate everyone's support in meeting those goals.
16:29:03 <jungleboyj> Next topic.
16:29:13 <jungleboyj> #topic Recent timeouts in backup test cases
16:29:21 <jungleboyj> Not sure that there is much more to talk about here.
16:29:26 <jungleboyj> geguileo:  Looks like you are on top of it?
16:30:05 <geguileo> yup
16:30:16 <geguileo> there's a patch already
16:30:22 <jungleboyj> geguileo: Awesome.  Thank you for the quick response.
16:30:23 <geguileo> https://review.openstack.org/#/c/537437/2
16:30:44 <jungleboyj> geguileo:  You rock!
16:30:59 <jungleboyj> So, last item that someone added:
16:31:12 <jungleboyj> #topic CInder-tempest-plugin hardcoded path bug
16:31:20 <jungleboyj> Who added this?
16:31:28 <ganso> jungleboyj: I did
16:31:33 <ganso> jungleboyj: sorry forgot to add my name
16:31:36 <jungleboyj> Take it away ganso
16:32:05 <e0ne> geguileo: did you check our rbd driver for this issue? it has tpool usages too
16:32:07 <ganso> so I opened this bug a few minutes ago
16:32:31 <geguileo> e0ne: The RBD driver only has tpool for calls to librados library
16:32:33 <ganso> because I have a third party CI with custom tests which code imports the code that has been moved
16:32:55 <e0ne> geguileo: ok, thanks for the clarification
16:32:57 <eharney> #link https://bugs.launchpad.net/cinder/+bug/1745175
16:32:58 <openstack> Launchpad bug 1745175 in Cinder "hardcoded plugin path in cinder-tempest-plugin" [Undecided,New]
16:33:05 <geguileo> e0ne: np
16:33:25 <ganso> I am having problems with that because I am installing the plugin as one normally would I suppose, but there is a hardcoded line in the plugin
16:33:25 <jungleboyj> eharney: Thanks.  :-)
16:33:35 <ganso> that forces the plugin module folder to be within the cinder folder
16:33:51 <ganso> I haven't found that plugin being used in any of the CI jobs
16:34:05 <eharney> that's the entry point in setup.cfg?
16:34:16 <ganso> eharney: no, plugin.py
16:34:30 <erlon> ganso, I remember there might be some experimental jobs on project-config
16:35:02 <eharney> ah
16:35:09 <erlon> not sure if that heavily relied on the internal tests or just run the tests if found
16:35:28 <ganso> eharney: plugin.py should return the path of the plugin. It is usually __file__, as it could be installed anywhere, and the egg just returns its path
16:35:36 <eharney> i agree
16:35:39 <ganso> eharney: but being cinder.__file__ forces it to be inside cinder folder
16:36:14 <ganso> eharney: I believe this doesn't make much sense since it is a separate repo, and one would need to move the module folder around
16:36:22 <eharney> i agree, it's a bug that should be fixed
16:37:02 <ganso> on that note, I believe this plugin is not being tested, and we have a coverage gap here
16:37:59 <eharney> it's just finishing getting bootstrapped as a new repo/plugin/etc, but IIRC the guts are there to start testing it properly
16:38:02 <ganso> I know that there are some tests in tempest repo and some other that were in-tree (and have now been moved to this repo), do we have any plans to run those tests?
16:38:05 <smcginnis> We were discussing a couple days ago about adding a tempest run to this repo. Right now it just runs pep8.
16:38:27 <smcginnis> But we also need at least some of our Cinder jobs to include this plugin.
16:38:46 <ganso> smcginnis: yes
16:39:15 <ganso> it is sad to see tests that have been written not being run :(
16:40:19 <smcginnis> ganso: Third party CI's should have been running them before if they were following our stated requirements, but I think I only saw one or two actually doing it.
16:40:57 <ganso> smcginnis: I guess I was the first to stumble on this bug
16:41:12 <ganso> anyway, I think that's all for this topic
16:41:48 <jungleboyj> ganso:  Something for follow-up discussion at the PTG?
16:42:42 <ganso> jungleboyj: maybe we could discuss the new jobs planned to run those tests
16:43:05 <smcginnis> We could probably contact Chandan (?) the goal champion for the tempest split if he has any advice based on other repos.
16:43:07 <ganso> jungleboyj: or if we intend to run them within one of the existing jobs
16:43:21 <jungleboyj> ganso:  Yeah.  Do we have anyone who understands this whole split well?
16:43:32 <ganso> jungleboyj: erlon is probably the guy
16:43:38 <eharney> the plugin tests should run within existing jobs
16:43:47 * erlon who?
16:43:51 <jungleboyj> :-)
16:44:14 <jungleboyj> I admit I don't understand how this is all supposed to work very well and it sounds like others are in the same boat.
16:45:06 <smcginnis> It _should_ just need to have the plugin installed, then as long as the tests are run with "tox -e all_plugin" it should pick up any of those plugins and run.
16:45:09 <erlon> eharney, seems to now that very welll :p
16:45:36 * jungleboyj is enjoying watching the game of hot potato.
16:46:10 <eharney> well, it's not terribly complicated
16:46:15 <erlon> smcginnis, yeap, thats true, the thing is that not all jobs run with -eall-plugin
16:46:25 <eharney> we have tempest jobs.  the plugin has additional tests for Cinder that can run in those jobs.  so, we should run them
16:47:45 <jungleboyj> So it sounds like the work is to make sure that the plugins are being installed and that our existing temptest jobs are setup to run with -e all-plugin ?
16:48:00 <ganso> jungleboyj: yup, that pretty much sums it up
16:48:08 <eharney> that plus getting people to contribute more tests\
16:48:24 <jungleboyj> eharney:  :-)  Baby steps
16:48:38 <eharney> our track record with in-tree tempest tests has been... slow
16:49:18 <jungleboyj> Yeah, having them out of tree I don't think will speed that up.
16:49:32 <jungleboyj> C'est le Vie
16:49:52 <ganso> viva la vida
16:50:13 <jungleboyj> Anyway, do we have anyone that can take a look at doing the two steps above are being done?
16:50:16 <jungleboyj> ganso:  :-)
16:50:33 <jungleboyj> ganso:  La vida loca!
16:50:46 <ganso> jungleboyj: ROFL
16:50:46 <erlon> lol
16:51:03 <enriquetaso> lol
16:51:34 * jungleboyj is channeling Ricky Martin ... oh god help me!
16:51:58 <ganso> jungleboyj: yea it was better sticking with Coldplay :P
16:52:09 <jungleboyj> Beuhler ....... Beuhler ........
16:52:14 <jungleboyj> ganso:  Indeed.
16:53:26 <jungleboyj> Well, I am going to put this as a topic for the PTG so it isn't forgotten and we will follow up then.
16:53:29 <jungleboyj> Sound good?
16:53:32 <smcginnis> ++
16:53:42 <erlon> jungleboyj, +1
16:54:04 <jungleboyj> #action jungleboyj  to add the tempest testing discussion to the PTG.
16:54:38 * jungleboyj kicks the can down the road
16:54:44 <jungleboyj> #topic Open Discussion
16:55:01 <smcginnis> Just a reminder for reviewers that soft string freeze is tomorrow too.
16:55:09 <jungleboyj> smcginnis: ++ Thanks.
16:55:13 <smcginnis> So we should be careful about not letting too many unnecessary string changes through.
16:55:32 <jungleboyj> smcginnis: Only translated strings though.  Right?
16:56:28 <smcginnis> Correct, just anything in _().
16:56:39 <smcginnis> So much less restrictive now that we don't translate all log messages.
16:56:47 <jungleboyj> Cool.
16:57:39 <jungleboyj> smcginnis:  Is that freeze on a Thursday?
16:58:24 <erlon> smcginnis, I was wondering how/who when, runs the script to update the docs according to the new and changed options
16:58:53 <erlon> smcginnis, is the string freeze related to that?
16:58:57 <smcginnis> jungleboyj: :)
16:59:05 <smcginnis> erlon: Which docs?
16:59:06 <jungleboyj> erlon:  No.  Docs are separate.
16:59:19 <smcginnis> erlon: Yeah, not documentation. Just in code.
16:59:22 <jungleboyj> We don't have automation for the config options right now though.
16:59:43 <jungleboyj> erlon:  If you have updates there you should be proposing changes to the documentation.
17:00:18 <erlon> jungleboyj, don't we? theres a *bold* header in the file saying we shuld run the automation
17:00:31 <jungleboyj> Which one?
17:00:39 <jungleboyj> Oh cinder/opts.py?
17:01:10 <erlon> jungleboyj, cinder-common.inc
17:01:12 <smcginnis> Times up.
17:01:22 <jungleboyj> Oy.  erlon lets take this to the channel.
17:01:31 <jungleboyj> Thanks everyone for a good meeting!
17:01:37 <erlon> jungleboyj, ok
17:01:38 <smcginnis> o/
17:01:44 <jungleboyj> #endmeeting.