16:00:19 <jungleboyj> #startmeeting cinder
16:00:24 <openstack> Meeting started Wed Jan 17 16:00:19 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:28 <openstack> The meeting name has been set to 'cinder'
16:00:37 <smcginnis> o/
16:00:38 <jungleboyj> courtesy ping:  jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro
16:00:47 <geguileo> hi! o/
16:00:49 <eharney> hey
16:00:49 <xyang> hi
16:00:54 <tbarron> hi
16:00:57 <erlon> hey
16:01:05 <tommylikehu> hey
16:01:08 <abishop> o/
16:01:26 <e0ne> hi
16:01:46 <jungleboyj> @!
16:01:46 <_pewp_> jungleboyj (✧∇✧)╯
16:02:11 <jungleboyj> Good start to a quorum here.
16:02:29 <jungleboyj> Hope everyone is well.
16:02:29 <patrickeast> o/
16:03:14 <jungleboyj> Ok, lets get started.
16:03:23 <jungleboyj> #topic Announcements
16:03:37 <jungleboyj> Queens review priorities:
16:04:06 <jgriffith> o/
16:04:11 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:04:23 <amito> (o/ not entirely present)
16:04:34 <jungleboyj> So, I just updated that list based on what I could find out in review.o.o and launchpad.
16:04:44 <jungleboyj> If you have updates, please make them ASAP.
16:04:51 <jungleboyj> More on that later in the meeting.
16:05:06 <jungleboyj> The proposed Rocky schedule is now available:
16:05:16 <jungleboyj> #link https://releases.openstack.org/rocky/schedule.html
16:05:48 <Swanson> Hello.
16:05:51 <jungleboyj> I am going to propose a patch to that, that will basically keep the same release schedule had for Queens if there are no objections.
16:05:59 <jungleboyj> Swanson:  Moving slow in the cold?  ;-)
16:06:12 <DuncanT> Another 6 month cycle?
16:06:21 <jungleboyj> DuncanT:  Hey!
16:06:23 <smcginnis> DuncanT: Yep, no change there.
16:06:30 <jungleboyj> DuncanT:  Yes, couldn't get agreement on anything else.
16:06:41 <jungleboyj> The train moves on.
16:06:43 <e0ne> looks pretty the same as for Pike
16:07:02 <jungleboyj> e0ne:  Exactly, so don't see a need to change things for Rocky.
16:07:11 <e0ne> jungleboyj: +1
16:07:42 <jungleboyj> Anyone disagree?
16:07:48 <smcginnis> Sounds good to me.
16:08:11 <jungleboyj> #action jungleboyj  To propose schedule for Rocky based on the Queens schedule.
16:09:02 <jungleboyj> Last item for announcements is a reminder that the Dublin PTG Planning etherpad is up.  If you are planning to go, please add your name
16:09:09 <jungleboyj> If you have topics, please add them.
16:09:17 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-ptg-rocky
16:09:24 <tommylikehu> great
16:09:45 <jungleboyj> Thank you for smcginnis  for getting the link into the greater list of etherpads.  :-)
16:10:15 <jungleboyj> I think that was all I had for announcements.
16:10:25 <jungleboyj> #topic Queens release schedule
16:10:34 <jungleboyj> #link https://releases.openstack.org/queens/schedule.html
16:10:45 <jungleboyj> So, we are quickly approaching the end of Queens.
16:10:49 * jungleboyj wonders how that happened.
16:10:51 * erlon is ready: https://i.pinimg.com/originals/c2/0a/bc/c20abc45453fba99285395310a1e5e69.jpg
16:11:16 <jungleboyj> OMG, I dare you erlon
16:11:21 <jungleboyj> I gotta see taht.
16:11:40 <jungleboyj> :-)
16:11:48 <erlon> jungleboyj: haha don't challange me :P
16:11:48 <smcginnis> That's Scottish, not Irish. :)
16:11:59 <jungleboyj> smcginnis:  Shhhh, don't tell him that!
16:12:29 <erlon> smcginnis: crap, spend a lot of money on that
16:12:31 <jungleboyj> So, Feature freeze is Friday 1/19 as is library Freeze.
16:12:39 <e0ne> erlon: :)
16:13:22 <e0ne> jungleboyj: do we have any multiattach-ralated patches in progress now?
16:13:24 <jungleboyj> I tried to get the remaining patches for os-brick through yesterday.  I need to see if those merged.
16:13:31 <jungleboyj> e0ne:  I will get to that.
16:13:49 <jungleboyj> I should cut os-brick mid day tomorrow.
16:14:51 <jungleboyj> Client Library freeze is next Friday.
16:15:07 <jungleboyj> Not sure where we are on client patches.  I will look into that.
16:15:22 <smcginnis> Thursday!
16:15:25 <jungleboyj> I really would like to make sure that we don't let a release go out where the Client and Server MVs don't match.
16:15:34 <smcginnis> Freeze is always and has always been Thursday.
16:15:42 <smcginnis> Not sure why people never seem to remember that. :)
16:16:15 <jungleboyj> smcginnis:  Sorry.  So that date on the list is actually the day after?
16:16:26 <smcginnis> Where?
16:16:49 <Swanson> You aren't the boss of us, McGinnis!
16:16:59 <tommylikehu> Swanson: lol
16:17:03 <smcginnis> Swanson: :P
16:17:24 <jungleboyj> smcginnis:  The release page says Jan 21 to 26 is the freeze week.
16:17:53 <smcginnis> Yes, that is the freeze week. And deadlines are always on Thursday as noted in a few of the specific items.
16:18:15 <jungleboyj> Ok.  :-)  thank you release master.
16:18:21 <jungleboyj> So, I stand corrected.
16:18:32 <tbarron> smcginnis: you ought to send out weekly reminders about that stuff
16:18:32 <jungleboyj> Updated the notes in the meeting notes.
16:18:39 <tbarron> :)
16:18:43 <jungleboyj> tbarron:  Oh hush!
16:18:56 <smcginnis> tbarron: :)
16:19:39 <jungleboyj> Anyway, moving on.  If anyone knows of client code that needs to go in please get that up ASAP and make me aware of it.
16:19:59 <jgriffith> jungleboyj: yeah
16:20:15 <jgriffith> jungleboyj: I haven't had a chance to work on it, but the whole broken client AUTH_TYPE thing needs fixed
16:20:15 <jungleboyj> jgriffith:  Is there going to be anything related to multi-attach?
16:20:29 <jungleboyj> jgriffith:  I think there is a patch for that out there.
16:20:49 <jgriffith> jungleboyj: Ideally I'd liek to get the mode patch finished and proposed this week
16:20:57 <jgriffith> s/liek/like/
16:21:19 <jgriffith> but figuring out the mv issues from the shell is going to slow me down even more than usual
16:21:21 <jungleboyj> jgriffith:  That would be good.
16:21:22 <smcginnis> Gah, is that still out there?
16:21:26 <e0ne> jungleboyj, jgriffith: is it https://review.openstack.org/#/c/532217/ a needed patch?
16:21:35 <smcginnis> Let's fix it and revert it a few more times.
16:21:57 <jgriffith> e0ne: I'll test it now and if so +2/A it and remove my shell alias that does unset OS_AUTH_TYPE
16:22:09 <jgriffith> I swear we've broken/fixed this at least 3 times now :)
16:22:14 <smcginnis> At least.
16:22:34 <e0ne> jgriffith: I'll added a  reminer for myself to
16:22:46 <e0ne> jgriffith: I'll added a  reminer for myself to create functional tests for this
16:22:53 <jungleboyj> jgriffith:  Is that what you were talking about needing to fix though?  https://review.openstack.org/#/c/532217/
16:23:32 <smcginnis> Looks like that might be it.
16:23:43 <jgriffith> e0ne: jungleboyj smcginnis yep, that fixes it
16:23:50 <jungleboyj> smcginnis:  That was how I interpreted it.
16:24:04 <jungleboyj> jgriffith:  Great.  I will take another look at that now that it has been updated.
16:24:14 <jgriffith> jungleboyj: oops :)
16:24:19 <jgriffith> I already +2/A 'd it
16:24:27 <jungleboyj> jgriffith:  WFM.
16:24:35 <e0ne> :)
16:24:35 <jgriffith> WFM?
16:24:43 <jungleboyj> Work For Me
16:24:48 <jungleboyj> *Works
16:24:53 * jungleboyj can't type today.
16:24:58 <jgriffith> Ahh.. worried you meant WTF Man?
16:24:59 <jgriffith> :)
16:25:03 <smcginnis> Not Well FU Man.
16:25:12 <jgriffith> that's ok, I can't type ever
16:25:12 <e0ne> :)
16:25:17 * jungleboyj shakes my head
16:25:26 <jungleboyj> Damn numb finger.
16:25:27 <jgriffith> smcginnis: yeah, that's kinda what I was thinking he meant :)
16:25:43 <jungleboyj> Yes, because I so often say that to you.  ;-)
16:26:10 <smcginnis> hehe
16:26:36 <jungleboyj> Anyway, so I am going to check the state of the os-brick patches, spin up a release and then take a look at where things are for the client.
16:26:50 <smcginnis> By tomorrow.
16:26:53 <jungleboyj> #action jungleboyj  To spin os-brick release.
16:26:53 <smcginnis> Thursday.
16:26:56 <smcginnis> :)
16:27:22 <jungleboyj> #action Get cinderclient patches merged ... brick-cinderclient-ext as well.
16:27:33 * jungleboyj ignores smcginnis
16:27:50 <e0ne> jungleboyj: FYI, we don't have opened brick-cinderclient-ext patches now
16:28:08 <jungleboyj> e0ne:  Ok, good.  I didn't think we did but I wanted to verify.
16:28:15 <smcginnis> e0ne: Good point, we could do a final release for this cycle on that if we have unreleased things.
16:28:19 <e0ne> I just checked it
16:28:42 <jungleboyj> smcginnis:  I am not sure that we do.  I did a release of that a bit ago and don't think anything new has gone in but will check.
16:28:59 <xyang> so the deadline for both cinderclient and brick-cinderclient-ext is next Thursday?
16:29:07 <e0ne> xyang: yes
16:29:14 <xyang> ok
16:29:33 <smcginnis> Yep, Thursday. :)
16:29:44 <jungleboyj> #action Jay to do brick-cinderclient-ext release if necessary.
16:29:46 <jungleboyj> smcginnis:  When?
16:29:50 <smcginnis> jungleboyj: Just a requirements update: https://github.com/openstack/python-brick-cinderclient-ext/compare/0.7.0...master
16:29:55 <jungleboyj> Wednesday?
16:29:55 <smcginnis> THURSDAY
16:30:17 <jungleboyj> I love releasing on Saturday.
16:30:38 <e0ne> jungleboyj: do you mean Friday-Monday night?
16:30:57 <jungleboyj> #action release brick-cinderclient-ext by next THURSDAY
16:31:21 <jungleboyj> Ok, lets stop beating the THURSDAY horse and move on.
16:31:35 <smcginnis> :)
16:31:38 <jungleboyj> #topic Feature Freeze Concerns:
16:32:14 <jungleboyj> So, follow up on a few of the things in our review list that look like they are going to miss.
16:32:26 <jungleboyj> We have Update cheesecake promotion specification
16:32:36 <jungleboyj> I don't see code for this anywhere.
16:32:47 <jungleboyj> patrickeast:  You know anything about this?
16:33:00 <jungleboyj> Or eharney ?  I don't see jbernard around.
16:33:20 <eharney> no
16:33:52 <jungleboyj> Ok, I am thinking that is one that is going to get pushed out to Rocky.  I can move the spec.
16:34:06 <jungleboyj> Will put it as a discussion item for the PTG to see where that is at?
16:35:02 <jungleboyj> eharney:  jbernard coming to the PTG again?
16:35:08 <eharney> yes
16:35:21 <jungleboyj> #action jungleboyj to move spec out and add discussion at the PTG.
16:35:25 <jungleboyj> eharney:  Cool.
16:35:46 <jungleboyj> transfer snapshots with volumes
16:35:53 <jungleboyj> The only code for this out there is a WIP.
16:36:14 <jungleboyj> eharney:  You were -2 on this.
16:36:21 <eharney> i had some complaints on this one, it got updated a couple of days ago still as WIP... not sure about the current status
16:36:58 <jungleboyj> Ok, I will put at note in the review asking what is up.
16:37:11 <jungleboyj> #action jungleboyj  Follow up on state of the patch.
16:37:33 <jungleboyj> I would be willing to let that slip a little after FF if we can make progress on that.
16:37:39 <jungleboyj> eharney:  smcginnis  any arguments?
16:37:52 <eharney> i'm a little concerned about the driver calls for that work, but it's been too long since i've looked at it, need to go study up on the spec again
16:37:53 <smcginnis> I agree, I think that's kind of a bug we have that we should fix.
16:38:10 <eharney> having it in general would be good though
16:38:35 <jungleboyj> Ok.  So, lets see if we can work that one in.  I need to look closer at that review.
16:38:57 <jungleboyj> #action jungleboyj smcginnis eharney  To work the patch through if possible.
16:39:45 <jungleboyj> Next provisioning improvements.
16:39:49 <jungleboyj> erlon:  Where is this at>?
16:40:28 <jungleboyj> paging erlon
16:41:06 <erlon> jungleboyj: hey, so, have finished the code, but have hit a hidding bug on unit tests :/
16:41:15 <jungleboyj> erlon:  Ok ...
16:41:21 <jungleboyj> Is there a WIP patch pushed up?
16:41:21 <erlon> working activelly to get that ready
16:42:08 <erlon> jungleboyj: we have some internal preocess to get things upstream, and that usually starts when the code is ready and passing our internal CI
16:42:25 <erlon> Ill try to see there if I can get a version upstream
16:42:33 <jungleboyj> erlon:  Ok.
16:42:57 <jungleboyj> smcginnis:  Thoughts on this one.  Again, it is kind of a bug we are fixing up but also it seems like it could have broader impact.
16:43:23 <smcginnis> erlon: Is it close, or do you think the internal review will take long?
16:44:09 <smcginnis> jungleboyj: But yes, that's kind of an existing bug that I would agree we could still try to get in if possible.
16:44:21 <erlon> smcginnis: its close, we have done the internall review actually, the only problem are that there are some tests not related to the change breaking
16:44:35 <jungleboyj> erlon:  Ok.
16:44:37 <geguileo> erlon: is the unit test bug the only thing stopping the process from moving forward?
16:44:46 <geguileo> erlon: can we help you with those?
16:44:54 <erlon> smcginnis: if we pushing that upstream even with the problem people coud try to help, migh be a problem elsewhere
16:45:01 <erlon> geguileo: yes
16:45:27 <jungleboyj> erlon:  Yeah, that sounds like a reasonable note.
16:45:50 <geguileo> erlon: I can try to help you if you want, ping me on the channel and we can try to debug the issues
16:45:53 <erlon> jungleboyj: smcginnis let me see what I can do to make that available ASAP
16:45:59 <erlon> geguileo: thanks
16:46:02 <geguileo> np
16:46:20 <jungleboyj> geguileo:  Thanks!
16:46:40 <jungleboyj> So I would say that the two issues above can go in if we can get it done in the next week or so.
16:47:00 <jungleboyj> I would put Multi-attach in the same bucket.  Not a train I think we should get in front of.
16:47:34 <jungleboyj> So, work those and checkpoint next week.
16:47:40 <jungleboyj> Any concerns?
16:48:03 <jungleboyj> Good, so I want to get to the next topic and make sure we don't run out of time.
16:48:15 <jungleboyj> #topic RBD encryption changes
16:48:17 <jungleboyj> eharney:
16:48:34 <eharney> hey
16:48:43 <jungleboyj> Hey.  Take it away.
16:48:53 <eharney> i've submitted some patches to enable encryption support in the RBD driver
16:49:25 <eharney> this is a feature that's been missing for quite a while, and it looks like things are lining up to land it in Queens
16:49:34 <eharney> lyarwood has some Nova changes in flight to support this as well
16:50:05 <eharney> there are three patches up for cinder -- i'm going to squash it down into two patches later today
16:50:08 <eharney> https://review.openstack.org/#/c/534811/
16:50:15 <smcginnis> I know I've been asked a few times about support for this, so I think it would be good to get in.
16:51:02 <jungleboyj> Right.  We have encryption for our other backends but not for the one that the most people use.
16:51:26 <jungleboyj> That was why I am open to this.
16:51:45 <eharney> yeah, it's been a fairly significant feature gap for a while
16:52:30 <eharney> so i'll update the patches in a bit, and start making sure we have all of the details documented about system-level requirements etc
16:52:34 <jungleboyj> Haven't looked at the patches yet but you said you could keep them mostly in the RBD driver with only minor changes to the general code base?
16:52:48 <eharney> yeah, the non-RBD driver patch is this: https://review.openstack.org/#/c/534810/
16:53:28 <eharney> we need to pass a context object in create_volume()
16:54:02 <eharney> pretty minor change, and it lines up with how a lot of other driver calls, so it seems good
16:54:07 <eharney> how a lot of other driver calls work*
16:54:11 <jungleboyj> Ok.  Which is something that is surprising we don't already do.
16:54:52 <jungleboyj> Ok.  As I mentioned earlier, the one request is that we get a spec for this addition put in place before we cut the release so that this is documented as an addition.
16:55:08 <eharney> yep, i can do that
16:55:23 <jungleboyj> Cool.  jgriffith smcginnis  Any concerns with that?
16:55:27 <smcginnis> Nope
16:55:44 <jungleboyj> eharney:  Do you think you can do this by next Wednesday?
16:55:54 <jungleboyj> At least get the code all worked up and merged in?
16:56:16 <eharney> jungleboyj: yes
16:56:21 <jungleboyj> Excellent.
16:56:59 <jungleboyj> #topic Cinder Shirts
16:57:22 <jungleboyj> So, I want back and looked at the notes from the PTG and it sounds like we all just wanted a shirt that had the new logo on the front.
16:57:41 <jungleboyj> Do people just want a T-Shirt with a large logo or a polo type shirt with a smaller logo?
16:58:26 <jungleboyj> If we go the T-Shirt route I thought it might be cool to have 'Who manages your backend?" under the logo.
16:58:48 <xyang> jungleboyj: can I have a T-shirt with the old logo on the front?:)
16:59:00 <smcginnis> :)
16:59:00 * jungleboyj laughs  I saw that coming.
16:59:38 <smcginnis> Unrelated, but I wanted to bring it up in the meeting and we are out of time. Thanks eharney for fixing driverfixes unit test problems, and CFP for the Summit is open so think about any talks.
16:59:48 <jgriffith> jungleboyj: LOL, that's AWESOME
17:00:12 <jungleboyj> xyang:  I could maybe do some of those.  I have no idea what the cost of these will be.  Asked management at Lenovo if they might be willing to help cover some costs.  No response yet.
17:00:21 <jungleboyj> jgriffith: I thought so!
17:00:27 <xyang> jungleboyj: :)
17:00:28 <jungleboyj> smcginnis:  ++
17:00:39 <jungleboyj> So, lets take that discussion to the channel for those interested.
17:00:42 <smcginnis> Time up.
17:00:48 <jungleboyj> Thank you team for a good meeting!
17:00:53 <jungleboyj> Lets get this release done!
17:00:59 <jungleboyj> #endmeeting