16:00:22 <smcginnis> #startmeeting Cinder
16:00:22 <openstack> Meeting started Wed Nov 16 16:00:22 2016 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:25 <openstack> The meeting name has been set to 'cinder'
16:00:32 <smcginnis> ping dulek duncant eharney geguileo winston-d e0ne jungleboyj jgriffith thingee smcginnis hemna xyang1 tbarron scottda erlon rhedlind jbernard _alastor_ bluex patrickeast dongwenjuan JaniceLee cFouts Thelo vivekd adrianofr mtanino yuriy_n17 karlamrhein diablo_rojo jay.xu jgregor baumann rajinir wilson-l reduxio wanghao thrawn01 chris_morrell stevemar watanabe.isao,tommylike.hu mdovgal ildikov
16:00:42 <geguileo> Hi! o/
16:00:43 <smcginnis> https://wiki.openstack.org/wiki/CinderMeetings#Next_Cinder_Team_meeting
16:00:46 <rajinir> o\
16:00:47 <erlon-airlong> Hey!
16:00:49 <eharney> hi
16:00:50 <Cibo> hello
16:01:02 <e0ne> hi
16:01:05 <mdovgal> hello
16:01:06 <smcginnis> #topic Announcements
16:01:27 <dulek> o/
16:01:33 <ildikov> o/
16:01:39 <smcginnis> Regular public service announcement: nova-net will be gone soon. CI operators - update your config to use neutron
16:01:41 <xyang1> hi
16:01:51 <smcginnis> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking Review focus
16:01:55 <bswartz> .o/
16:02:11 <smcginnis> Finally did some work on that etherpad ^^
16:02:30 <smcginnis> Cores (and anyone who is willing to help with reviews) please take a look at that links in there.
16:02:42 <smcginnis> We have several proposed drivers.
16:02:58 <smcginnis> We're already at O-1, so not really much time until the new driver deadline with O-2.
16:03:00 <markstur> o/
16:03:04 * erlon-airlong me will miss friendly nova :/
16:03:20 * stevemar lurks
16:03:30 <geguileo> I can review the QNAP since I'll be able to test it locally
16:03:33 <smcginnis> stevemar: I see you back there. Oo
16:03:37 <stevemar> o_O
16:03:38 <smcginnis> geguileo: Great
16:03:40 <jungleboyj> o/  Kind of here.
16:03:56 <smcginnis> All action items go to Jay.
16:04:00 * patrickeast wanders in
16:04:03 <Cibo> can anybody help with contributing Open-E driver?
16:04:32 <e0ne> Cibo: what help do you need?
16:04:41 <Cibo> I have CI and code
16:04:56 <smcginnis> Cibo: Oh? I hadn't seen anything yet.
16:05:11 <smcginnis> Cibo: If you have a review link, please add it to that etherpad.
16:05:11 <Cibo> e0ne: consultancy on when my CI will be valedated as ok
16:05:26 <Cibo> I have not posted it
16:05:37 <smcginnis> Cibo: Well, that would be a good first step.
16:05:46 <e0ne> Cibo: just ask me in irc when your your will be ready
16:06:06 <Cibo> https://github.com/open-e/JovianDSS-Cinder
16:06:12 <smcginnis> #topic Attach/detach API Update
16:06:29 <smcginnis> jgriffith, ildikov: Want to give an update?
16:07:04 <Cibo> ok, so I post driver and then making CI as vouting
16:07:30 <smcginnis> Cibo: CI doesn't need to be voting, it just needs to be reporting results in the comments.
16:07:47 <smcginnis> Cibo: Make sure you've read this: https://wiki.openstack.org/wiki/Cinder/how-to-contribute-a-driver
16:07:49 <ildikov> smcginnis: sure
16:08:33 <ildikov> as most of you know during the last OpenStack release we started to discuss to create a new attach/detach API in Cinder
16:09:20 <ildikov> among other goals we hope to make the Cinder-Nova interaction easier and less racy
16:09:38 <ildikov> we also would like to get the multi-attach support out of this activity
16:10:00 <ildikov> the purpose of this slot is that we need progress in Cinder first in the sense of finalizing the API
16:10:16 <Cibo> smcginnis:ok, I'll recheck it
16:10:26 <ildikov> jgriffith has proposal code up for review: #link https://review.openstack.org/#/c/387712/
16:10:31 <smcginnis> #link https://review.openstack.org/#/c/387712/ Attach/Detach API code
16:11:04 <smcginnis> #link https://review.openstack.org/#/c/373203/ Spec in Nova to describe the usage of the new Cinder API
16:11:15 <ildikov> we need reviews from the team like now to decide whether this proposal is the one we would like to go with
16:11:43 <ildikov> also on the spec on the Nova side that smcginnis kindly posted above
16:11:47 <smcginnis> So for those that have been following this, this is pretty much the v2 proposal jgriffith was working on.
16:12:12 <ildikov> the Nova spec intends to describe how the new API will work with Nova
16:12:57 <xyang> ildikov: should we be looking at the cinder spec too? https://review.openstack.org/#/c/361512/
16:13:10 <smcginnis> The more eyes we can get on that the better. The last thing we want to have is something that needs to get rewritten again.
16:13:20 <ildikov> xyang: I think that's out of date
16:13:23 <smcginnis> xyang: I think jgriffith needs to update the spec yet.
16:13:38 <xyang> ildikov, smcginnis: ok, thanks
16:13:47 <smcginnis> #action jgriffith to update attach/detach spec
16:13:56 <ildikov> xyang: the Nova spec tries to capture the Cinder API parts too in some extent
16:14:10 <xyang> ildikov: ok
16:14:42 <smcginnis> Yeah, johnthetubaguy has been putting in a lot of work keeping that updated and incorporating feedback.
16:14:53 <smcginnis> So the nova spec is probably the best picture of the process at this point.
16:15:19 <ildikov> we would like to proceed with Nova PoC patches as soon as we can, but without having a decision about the final version of the new Cinder API we cannot move forward with the Nova side
16:15:22 <ildikov> smcginnis: +1
16:16:11 <smcginnis> ildikov: Anything else we should cover on this?
16:16:27 <ildikov> smcginnis: if no one has questions I think it's enough
16:16:40 <ildikov> smcginnis: if we go through the proposal that would hijack the meeting IMHO
16:16:44 <smcginnis> Of course anyone can ask questions in #openstack-cinder as questions come up during reviews.
16:16:49 <smcginnis> ildikov: Hah, yep. :)
16:17:01 <smcginnis> ildikov: Cool, thanks for your update.
16:17:11 <ildikov> smcginnis: give an action point to the team to review ;)
16:17:17 <smcginnis> #topic Action for driver maintainers with CG support: Add CG support to Generic Volume Groups
16:17:20 <smcginnis> ildikov: ;)
16:17:26 <ildikov> smcginnis: thanks
16:17:29 <smcginnis> xyang: All yours...
16:17:44 <xyang> sure.
16:17:52 <xyang> I have sent out email about this:  http://lists.openstack.org/pipermail/openstack-dev/2016-November/106720.html
16:18:04 <smcginnis> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/106720.html ML notice
16:18:14 <xyang> for driver maintainers whose driver supports CG, please add CG support to generic volume groups
16:18:21 <smcginnis> #info Deadline for drivers currently supporting CG to make this change: Pike-1 (as discussed in Barcelona)
16:18:35 * diablo_rojo sneaks in late
16:18:44 <smcginnis> #link https://review.openstack.org/#/c/393570/ Dev doc on how to make this change
16:18:52 <xyang> smcginnis: thanks:)
16:19:07 <xyang> Migration script to migrate CGs to generic volume groups: https://review.openstack.org/#/c/350350
16:19:20 <smcginnis> #link https://review.openstack.org/#/c/350350/ Migration script to migrate CGs to generic volume groups
16:20:19 <xyang> smcginnis: I'll send emails to driver maintainers whose driver supports CGs as reminder.  not sure if everyone pays attention to meeting nodes and mailing list
16:21:01 <smcginnis> xyang: OK, that would be great.
16:21:11 <xyang> smcginnis: so the Pike-1 deadline would be they need to submit a patch by that deadline?
16:21:27 <xyang> smcginnis: I don't know if there's enough time to get it merged by then
16:21:52 <smcginnis> xyang: Right. We can discuss that more as we get closer, but I think it would be good for everyone to start prepping for it now.
16:22:05 <smcginnis> Probably a good PTG topic.
16:22:15 <smcginnis> Guess I should get a planning etherpad going for that already.
16:22:25 <xyang> smcginnis: sure, I assume people would ask whether P-1 is proposal deadline or merge deadline
16:23:18 <smcginnis> xyang: We'd like to get everyone switched over as soon as possible I think, but we probably shouldn't be too strict about cutting off at P-1. So I think proposed is good.
16:23:42 <xyang> smcginnis: thanks
16:24:02 <smcginnis> xyang: Thanks for covering it here. Any communication on this helps.
16:24:18 <xyang> smcginnis: np
16:24:21 <smcginnis> #topic Open discussion
16:24:29 <smcginnis> Anything else to discuss?
16:24:47 <geguileo> I would like to remind that the A/A patches are still pending review
16:24:48 <geguileo> XD
16:24:54 <smcginnis> geguileo: +1 ;)
16:25:02 <geguileo> And we really want to merge them asap
16:25:13 <smcginnis> Yes, the more run time on that, the better.
16:25:22 <geguileo> With the other patch we merged there has been some issues we have detected
16:25:32 <geguileo> And they have been immediately fixed
16:25:49 <geguileo> But we need testing time for things to pop up
16:25:50 <smcginnis> geguileo: Was there still something outstanding to fix there, or did you get it all cleared up?
16:26:00 <geguileo> smcginnis: Everything is fixed now
16:26:05 <smcginnis> Great
16:26:12 <geguileo> smcginnis: The version bump in requirements is already merged
16:26:46 <smcginnis> I think there's always inevitably minor things to fix under different conditions, so the sooner we can identify those the better.
16:26:46 <geguileo> And the other patches fixing library version compatibilities are already merged as well
16:26:57 <smcginnis> geguileo: Perfect
16:27:44 <hemna> mep
16:27:46 <smcginnis> OK, I guess we finally get a short meeting.
16:27:52 <hemna> damn time change
16:27:58 <smcginnis> hemna: Hah!
16:28:03 <geguileo> lol
16:28:03 <dulek> smcginnis: Isn't it normal in the middle of the cycle? ;)
16:28:08 <smcginnis> hemna: You realize that was two weeks ago? :P
16:28:12 <hemna> yes I do
16:28:28 <smcginnis> dulek: Hah, I suppose.
16:28:29 <hemna> maybe it's the wifi thing......
16:28:35 <smcginnis> hemna: LOL
16:28:56 <smcginnis> OK, I guess that it for today. Thanks everyone.
16:29:04 <xyang> thanks
16:29:12 <smcginnis> #endmeeting