16:04:08 <thingee> #startmeeting Cinder
16:04:09 <openstack> Meeting started Wed Feb  4 16:04:08 2015 UTC and is due to finish in 60 minutes.  The chair is thingee. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:13 <openstack> The meeting name has been set to 'cinder'
16:04:15 <BobBall> sorry for the over-run thingee.
16:04:16 <thingee> hey everyone
16:04:20 <e0ne> hi
16:04:21 <rushiagr> hi!
16:04:24 <Yogi> hi
16:04:25 <tbarron> hi
16:04:25 <rhe00_> hi
16:04:25 <patrickeast> hi
16:04:25 <scottda> hi
16:04:27 <smcginnis> hey
16:04:27 <Swanson> hello
16:04:28 <thingee> BobBall: it's all good. we have a short agenda anyways :)
16:04:33 <xyang2> hi
16:04:33 <jungleboyj> Howdy!
16:04:37 <avishay> hello
16:04:38 <kmartin> hi
16:04:44 <rajinir_r> hi
16:04:44 <jungleboyj> \o/
16:04:49 <cebruns> hi
16:04:51 <flip214> the short agenda doesn't mean that there's enough time ...
16:04:54 <nikesh_vedams> hi
16:05:01 <thingee> so here's a reminder on third party CI
16:05:03 <flip214> meetings tend to fill all available time, like so many other things too
16:05:04 <thingee> #link http://lists.openstack.org/pipermail/openstack-dev/2015-January/054614.html
16:05:10 <thingee> March 19th
16:05:31 <thingee> Get help now with your third-party ci
16:05:37 <thingee> attend the third ci help meetings
16:05:52 <thingee> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty
16:06:27 <thingee> if there are any questions with this deadline, don't wait. PM, or email me
16:06:35 <thingee> ok lets get started
16:06:36 <rhe00_> if someone has a nodepool yaml they can share as an example I would be grateful
16:06:52 <thingee> Agenda:
16:06:55 <thingee> #link https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting
16:07:02 <patrickeast> rhe00_: i can send you mine in a bit when i get into the office
16:07:11 <thingee> #topic Oversubscribed for k-3
16:07:13 <thingee> #link https://launchpad.net/cinder/+milestone/kilo-3
16:07:22 <flip214> hmmm, these #next_meeting anchors are not really helpful in a week's time
16:07:22 <thingee> so I had to punt some things over from k-2
16:07:40 <thingee> and as shown from k-2, we're going to get around 14 things in, if that
16:07:56 <thingee> we have 22 things in now.
16:08:00 <thingee> for k-3
16:08:12 <thingee> I have a proposal.
16:08:21 <e0ne> thingee: we've got two not started blueprints
16:08:44 <thingee> before the proposal actually...
16:08:56 <diemt> patrickeast: it would be more helpful if you can post it somewhere, so more than one person can benefit from it :)
16:09:04 <e0ne> i'm sorry, it's k-3, not k-2:(
16:09:10 <thingee> I see a problem with people submitting changes to cinder, but they aren't approved bps. THey're just whenever they feel like post the reviews up
16:09:54 <thingee> Another problem is I'm not aware of a way for people to flag a blueprint to get my attention
16:09:59 <thingee> even if doesn't require a spec
16:10:07 <kmartin> thingee, we have two BPs for driver related changes
16:10:09 <thingee> besides just pming or emailing me
16:10:34 <kmartin> go we just ping you in IRC to get them scheduled?
16:10:43 <kmartin> do
16:11:03 <thingee> kmartin: I would be fine with that, but unfortunately I don't think everyone does IRC.
16:11:09 <thingee> I know shocking :)
16:11:23 <kmartin> I'm well aware of that :)
16:11:25 <flip214> perhaps you should offer a fax number, too.
16:11:29 <thingee> haha
16:11:31 <kmartin> lol
16:11:37 <e0ne> :)
16:11:41 <smcginnis> PTL needs a beeper.
16:12:03 <flip214> smcginnis: the modern version of that is twitter or whatsapp, right?
16:12:10 <kmartin> IRC should be required for anyone submitting code to OpenStack
16:12:18 <thingee> so we have the feb 15th deadline, but really I think we need to say no at some point for k-3. The way I look at it, is if I keep letting stuff in for k-3, we'll be way over at this point.
16:12:20 <jnrao> hi thingree, we have 2 zone manager BPs.
16:12:37 <jnrao> thingee
16:12:44 <thingee> everyone please stop telling me about your bps for a second.
16:12:49 <thingee> I'm talking about a core problem right now
16:13:07 <xyang2> should we send you an email?
16:13:40 <thingee> So again the problem is we have 22 bps right now. THis doesn't cover everything that's already in review that is missing a blueprint
16:13:45 <smcginnis> Does infra have some way of categorizing and notifying new BP submissions?
16:14:27 <xyang2> thingee: when bp author adds your name as approver, you'll get a notification, right?
16:15:17 <thingee> I'm going to ignore the notification problem for a second. I want to talk about the issue with 22 bps for k-3 and we still have more incoming
16:15:47 <thingee> There was a lack of help in the review-a-thon. I know it was last minute, but it didn't go well.
16:16:12 <jungleboyj> thingee: Sorry.  Planning to focus on reviews the rest of this week.
16:16:25 <thingee> so I'm just worried about letting any other things in at this point. If there are too many things, people can't focus on merging what we already have.
16:16:41 <thingee> am I unreasonable there?
16:17:48 <winston-d> thingee: how about -2 flood for those reviews don't have approved bp?
16:17:48 <patrickeast> just to make sure i understand the issue is a review bottleneck and not an issue of the bp's not getting finished code-wise, right?, is there anything someone like myself (non-core and kinda new) can do to help?
16:17:50 <jungleboyj> How many more are trying to get in.
16:17:56 <rushiagr> no. We just need to side-track the reviews in focus who are not turning around fast enough
16:18:14 <thingee> winston-d: +1
16:18:15 <dulek> thingee: So you want basically to move feature proposal freeze earlier?
16:18:31 <jungleboyj> patrickeast: You can help us do reviews.  Don't have to be core my friend.
16:18:33 <jnrao> jungleboyj, 2 BPs from us.
16:18:38 <thingee> the problem is people get side tracked into reviews that don't even have bps approved or even targeted
16:18:55 <thingee> if you want to know what you should be reviewing, look at https://launchpad.net/cinder/+milestone/kilo-3
16:19:02 <rushiagr> I would say even if the review-a-thon didn't get the same response as was expected, we can use the same list as the top priority for every reviewers
16:19:06 <thingee> review.openstack.org is free for all
16:19:25 <thingee> so I'm more than happy to start giving a -2 to changes, but the problem is we have a deadline to feb 15
16:19:37 <thingee> I think we should lessen that deadline and review what we have now.
16:19:52 <kmartin> thingee, did you not set a preferred deadline for the cores to review the list of BPs
16:20:05 <navneet> thingee: how about planning for a review hackathon before feb 15?
16:20:17 <jnrao> +1
16:20:18 <dulek> navneet: +1
16:20:24 <thingee> kmartin: http://lists.openstack.org/pipermail/openstack-dev/2015-January/055718.html
16:20:25 <navneet> thingee: we did for previous releases too
16:20:29 <thingee> kmartin: and I emailed people directly
16:20:53 <thingee> navneet: that's true. the problem with the last review-a-thon was it was too short notice
16:21:03 <rajinir_r> thingee: How do get bugs targeted  for a milestone
16:21:08 <thingee> I'm not upset about k-2 with people, I know it was short notice..but things did slip
16:21:21 <thingee> rajinir_r: it's the same problem we're discussings with bps
16:21:25 <thingee> we don't have a formal way yet
16:21:27 <jungleboyj> thingee: So, we try again next week now that people have had time to recover from the meet-up.
16:21:27 <xyang2> thingee: also it was right after the meet-up
16:21:38 <jungleboyj> xyang2: +2
16:21:39 <thingee> xyang2: +1
16:21:46 <jungleboyj> That is what is killing me.
16:22:23 <flip214> I won't even ask what has happened there. The few hints in Etherpad are more than enough for my poor soul.
16:22:36 <navneet> thingee: then how do we deal with it....prioritize BPs or involve more people in reviews?
16:23:18 <jungleboyj> navneet: Yes.  To Both.
16:23:23 <thingee> navneet, patrickeast: non-core are welcome to do reviews always. In fact I look for certain people giving +1's to make decisions.
16:23:35 <jungleboyj> thingee: +2
16:23:46 <kmartin> I can speak for hemna(who is off presenting to the FC standards body right now), it's been a zoo since we got back from the meetup
16:24:01 <thingee> so my message to to reviewers right now, please don't bother with reviews that aren't bugs or approved blueprints. focus on what we have now
16:24:11 <rushiagr> Being an open source project where we can't really restrict all people to review only the important stuff, I think it suffices that we just notify everybody in the meeting, make noise in the mailing list, update channel status, and thats about the stuff which is in our hand..
16:24:19 <navneet> thingee: jungleboyj: makes sense.
16:24:52 <thingee> but I can't -2 things, because most changes are driver updates. don't require a spec.
16:25:04 <thingee> I expect us to have over 30 bps with all the driver updates.
16:25:22 <thingee> my point is we need to say stop at some point and just take the ones that were submitted earlier.
16:26:10 <jnrao> We can follow what neutron had done with drivers. No approval for driver updates. Only cinder infra need BPs. How about that?
16:26:12 <jungleboyj> agreed.
16:26:27 <rushiagr> thingee: +1
16:26:29 <jungleboyj> jnrao: That is just changing the metri for the problem.
16:26:32 <thingee> another idea is organizing in two core groups on these bps like we did with the hackathon, but do it early. hopefully doing it early will allow our output to be better?
16:26:34 <jungleboyj> *metric.
16:26:56 <navneet> jnrao: good suggestion but does not solve prob right now
16:27:11 <e0ne> thingee: +1. early feedback is very useful
16:27:22 <jungleboyj> thingee: +1
16:27:27 <xyang2> thingee: do it early, well before K-3, will help
16:27:44 <thingee> ok, so I'll organize that and get a number of what we look like with bps.
16:27:51 <navneet> lets do it next week...earlier the better
16:27:57 <thingee> I really think in L we'll need to organize this better.
16:28:01 <jnrao> navneet, agree. Atleast plan for next release.
16:28:09 <rhe00_> does all the submitted changes on the launchpad have the right priority? if so, then anything new coming in could be set to the lowes priority and if reviews are done in order of priority then some changes will naturally be left out when we are out of time
16:28:15 <thingee> navneet: I'm not even doing a review-a-thon. just an etherpad to get people signed up things.
16:28:56 <thingee> rhe00_: driver updates have low priorities compared to core features and core enhancements
16:29:12 <jnrao> +1
16:29:21 <navneet> thingee: it may e good to notify but some kind of formal set up may be required for people to really involve in it....just my thought
16:29:39 <thingee> #action thingee will create an etherpad early in k-3 for people to sign up on priority reviews
16:29:39 <rhe00_> ok, so they will be reviewed if there is time left
16:30:15 <thingee> rhe00_: no, unfortunately I don't think people respect the priorities. I don't know how many people here can honestly tell me they tested the cinder object patches for example
16:30:26 <thingee> this was back in k-2
16:30:34 <thingee> and now punted to k-3
16:31:14 <cebruns> Having the prioritized one-stop-shop for "what people should be reviewing" is good but also need owners assigned IMHO
16:31:16 <rhe00_> well, then that seems to be one of the main issues. Following the priority would give a natural fall out. IMO
16:31:20 <xyang2> thingee: one problem with that one was it was in WIP for a long time, so I thought I'll wait when it is ready
16:31:58 <thingee> xyang2: I guess it's just about people watching it for updates.
16:31:59 <xyang2> thingee: when are you making the k-2 cut?
16:32:07 <thingee> today if I can
16:32:23 <thingee> #topic Volume replication update
16:32:34 <thingee> jungleboyj: I'm guessing this is you?
16:32:44 <thingee> #link https://etherpad.openstack.org/p/cinder-replication-redoc
16:32:44 <dulek> I'm not sure if you're aware of that - http://status.openstack.org/reviews/
16:33:07 <dulek> This prioretizes reviews based on BP or bug priority
16:33:07 <jungleboyj> thingee: How did you guess?
16:34:02 <avishay> ...
16:34:04 <jungleboyj> So, not a lot of discussion here.  I just wanted to update people.  We have a document out there with documentation: https://etherpad.openstack.org/p/cinder-replication-redoc
16:34:26 <jungleboyj> That is the documentation that was already out there and we have started improving.
16:34:26 <thingee> dulek: I am, thanks.
16:34:42 <jungleboyj> I also have https://review.openstack.org/#/c/152735/ which is the updated spec.
16:35:09 <jungleboyj> I think given that there was some documentation on this out here, the heart of the problem was the total disconnected between the spec and the implemented code.
16:35:27 <jungleboyj> So, hope getting that change up will help us get beyond this.
16:35:46 <jungleboyj> ronenkat apologized profusely for not wrapping up the documentation.
16:36:12 <jungleboyj> On a related note we have been chasing the volume migration issues and I will send you a follow up note with progress on that after the meeting.
16:36:34 <jungleboyj> So, that is the udpate there.  All, please take a look at the links above and comment.
16:36:56 <ronenkat> and have come in person, to repeat that apology
16:37:24 <cebruns> I thought code _was_ the documentation?  JK!
16:37:24 <thingee> ronenkat: in person would be you knocking on my door, right now ;)
16:37:27 <rhe00_> jungleboy: this is the kind of document every feature should have. helps driver developers to know what to implement. thanks!
16:37:48 <ronenkat> that I would need to apologize again... too far a way for me....
16:37:50 <jungleboyj> rhe00_: Thank you.
16:38:10 <thingee> jungleboyj: so what action items do you need from us besides the etherpad?
16:38:18 <xyang2> does this doc eventually go to the cloud admin doc?
16:38:35 <kmartin> jungleboyj, thanks for following up on this
16:38:44 <jungleboyj> thingee: Other than look at the etherpad and the updated spec, that is it.
16:39:14 <thingee> I'd recommend just having us look at it when there is a review posted in the cinder specs and doc.
16:39:22 <jungleboyj> I would like to better understand what really went wrong here.  I am thinking that th lesson learned is to keep specs in sync with what actually goes in.
16:39:25 <thingee> that way, it'll be easier to leave comments
16:39:53 <thingee> jungleboyj: also it would help to involve the people who were asking help with volume replication for their driver.
16:40:01 <thingee> I have an email address I think
16:40:02 <jungleboyj> thingee: Ok, so you would like us to take what is in the etherpad and get the doc code posted?
16:40:14 <jungleboyj> thingee: That would be helpful.
16:40:19 <thingee> I just think it would be easier to post comments and what not
16:40:30 <jungleboyj> ronenkat:^^
16:40:43 <thingee> but I appreicate the quick turn around on this
16:41:09 <jungleboyj> thingee: Of course.  Like I said, I will follow up on volume migration via e-mail.
16:41:10 <thingee> #action jungleboyj or ronenkat to post reviews to cinder specs and docs
16:41:11 <winston-d> xyang2: a doc like that for CG could be helpful too.
16:41:27 <jnrao> rejoined.
16:41:29 <thingee> #action thingee to give jungleboyj any contacts interested in volume replication
16:41:32 <jungleboyj> thingee: The spec is posted.  I will respond to comments.
16:41:38 <xyang2> winston-d: I've already submitted doc for CG in cloud admin doc
16:41:39 <thingee> winston-d: there is one
16:41:47 <xyang2> winston-d: that is why I'm asking
16:42:03 <xyang2> winston-d: my cg doc is already merged
16:42:03 <thingee> jungleboyj: thanks anything else?
16:42:11 <winston-d> xyang2, thingee good to know.
16:42:17 <xyang2> winston-d: if we need a doc for developers, I'm not sure where to submit
16:42:33 <jungleboyj> That is it.  Thanks.
16:42:33 <rhe00_> how about on the wiki?
16:42:35 <kmartin> ronenkat, this is probably a good section to add it too, http://docs.openstack.org/admin-guide-cloud/content/section_manage-volumes.html
16:42:45 <thingee> #topic What is a driver in Cinder - Reminder of k-1 deadline
16:43:07 <ronenkat> for developer docs, the best way to my view in as function comments - that is what I did for replication
16:43:18 <thingee> Ok, so yesterday there appears to be some confusion around what is a volume driver in Cinder. I want to understand if people think I'm out of line on this.
16:43:22 <xyang2> winston-d: http://docs.openstack.org/admin-guide-cloud/content/consistency-groups.html
16:43:30 <ronenkat> kmartin: Thanks!
16:43:42 <thingee> When we post a new volume driver to Cinder, it's usually to support a particular fabric
16:43:49 <winston-d> xyang2: thx!
16:44:22 <thingee> if you post an update to that driver for another fabric support, it's another driver
16:44:42 <xyang2> thingee: your design session in Atlanta?:)
16:45:16 <thingee> IMO, even if it's a configuration change for you to go from iscsi to fc (and imo you have more problems if you're not inheriting off the fc base class) that's a new driver as well
16:45:41 <erlon> thingee: doesnt it need to be a new Class? I think is also an option for defining
16:45:45 <thingee> with that said, we stopped accepting new drivers in K. That was k-1. I have already had to say no to couple of people already because of the confusion with this.
16:46:09 <thingee> erlon: I have a couple examples of where people did via config opts in the same class.
16:46:11 <jungleboyj> thingee: I am going to have trouble telling the story internally, but that isn't your problem.  :-)
16:46:14 <erlon> thingee: I could extend my driver with a few changes to support another model
16:46:17 <avishay> erlon: not necessarily
16:47:01 <thingee> jungleboyj: So I feel bad honestly with you being an example, but I thought this was clear.
16:47:26 <jungleboyj> thingee:  I have been the example lately.  Go for it.
16:47:44 <erlon> for example you could have a family of models that share similar functions and API, so, no need to add another driver
16:47:47 <jungleboyj> thingee: Your concerns and hemna 's are legit.  I will take that back and work it.
16:47:47 <thingee> I will agree that we have to rethink big driver changes for talking to new arrays...those are questionable of a new driver of the problem we're trying to reduce in the last milestones
16:47:49 <avishay> it wasn't clear IMO, but if you think about it, it requires a CI, so i think it makes sense
16:48:07 <bswartz> erlon: that violates the spirit of the rule
16:48:20 <patrickeast> should we add a section to https://wiki.openstack.org/wiki/Cinder/how-to-contribute-a-driver to clarify what a exactly counts as a driver?
16:48:31 <thingee> patrickeast: +1
16:48:39 <rhe00_> patrickeast: +1
16:48:51 <rushiagr> patrickeast: +1
16:48:58 <jungleboyj> So, here is my 2 cents.
16:49:10 <thingee> #action how to contribute a driver needs to have information on what is a driver
16:49:22 <jungleboyj> I think the IBM change, you are right on.  Requires a new CI, it is a new driver.
16:49:24 <jungleboyj> Too late.
16:49:54 <jungleboyj> As far as the driver updates go, that is frustrating for the release but probably not fair to block them now.  Need to come up with a stance for L.
16:50:53 <thingee> jungleboyj: I agree. we need to rethink driver updates. It's too crazy right now :(
16:51:07 <thingee> just people freaked out the last time I brought it up in the midcycle meetup
16:51:16 <thingee> even when I was just talk about L
16:51:26 <thingee> talking*
16:51:36 <jungleboyj> :-(
16:51:38 <smcginnis> Just to make sure I have it right, new drivers by 1, updates to drivers by 2, bug fixes till the end?
16:52:13 <thingee> smcginnis: so I really want that
16:52:16 <jnrao> Does this include zone manager?
16:52:17 <jungleboyj> smcginnis: That sounds reasonable.  Need to document what 'updates' are though./
16:52:41 <smcginnis> New functionaliity that was not previously available.
16:52:43 <erlon> smcginnis: +1
16:52:46 <jungleboyj> jnrao: Oy vey.
16:53:01 <erlon> jnrao: I think it should
16:53:08 <thingee> If we did do that. new driver features put in cinder core, need to happen in 1, so that in 2 people can make them happen in that release
16:53:10 <jnrao> ok.
16:53:23 <rajinir_r> Can refactoring code be considered updates?
16:53:27 <smcginnis> thingee: +1
16:53:38 <xyang2> thingee: problem is new feature never gets merged in 1
16:53:45 <thingee> xyang2: right
16:53:57 <xyang2> unless if it is left over from previous release
16:54:00 <thingee> and we have all new drivers coming in 1
16:54:11 <smcginnis> thingee, xyang2 Or merged by the end of one release to be available in the next for drivers?
16:54:20 <smcginnis> xyang2: Oh, what you said. :)
16:54:29 <xyang2> we can hardly get new features merged by 2
16:54:38 <thingee> xyang2: +1
16:55:28 <thingee> honestly though, I think if I went around and just -2 things that aren't targeted and had people sign up early for reviews, maybe things would be better in the first milestone
16:55:32 <thingee> xyang2: ^
16:55:34 <kmartin> thingee, I think I'm okay with that as long as it communicated clearly at the start of a release or before
16:55:38 * jungleboyj sees a chicken and egg problem
16:55:51 <xyang2> kmartin: +1
16:56:02 <erlon> kmartin: +1
16:56:16 <erlon> and announced on the ML
16:56:26 <kmartin> 15 new drivers did land in K1 that a lot
16:56:47 <thingee> it could be possible for new features to leak into 2, but I would leave that at the discretion of the ptl...will it merge early enough for new drivers to implement
16:56:59 <jungleboyj> kmartin: We did that pretty well as advertised minus the rush at the end.
16:57:44 <kmartin> jungleboyj, +1 but i think that might of caused the backlog
16:57:56 <thingee> ok, I think I got the information I need from you all on this. I'll try to formulate something and propose something early.
16:58:12 <rhe00_> if the BP for the feature is approved in 1, then driver devs have time to code against that for 2.
16:58:20 <jungleboyj> thingee: I think we have to expect that some updates are going to hang over into K-3, but we handle that on a case by case basis.
16:58:34 <thingee> #topic Open discussion
16:58:43 <thingee> 1.5 mins left!
16:58:57 <rhe00_> kmartin metioned the idea of a cross company presentation at the summit. Are we moving forward on that? If so, what's the forum for planning a presentation?
16:58:57 <flip214> let's waste them. Simply as that.
16:58:58 <smcginnis> So much for a short meeting. ;)
16:59:37 <jungleboyj> smcginnis: I have had nothing but non-short meetings since 7:30 am.
16:59:38 <kmartin> rhe00_, let me know if your interested in FC
16:59:43 <nikesh_vedams> 14 feb deadline for what?
16:59:53 <flip214> jungleboyj: which $TZ?
17:00:02 <thingee> #endmeeting