16:00:30 <jgriffith> #startmeeting cinder
16:00:31 <openstack> Meeting started Wed Jan 15 16:00:30 2014 UTC and is due to finish in 60 minutes.  The chair is jgriffith. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:34 <openstack> The meeting name has been set to 'cinder'
16:00:38 <avishay> hello all
16:00:40 <jgriffith> Hey everyone!!
16:00:40 <eharney> hi
16:00:41 <bswartz> hi
16:00:47 <jungleboyj> Hello!
16:00:50 <rushiagr> o/
16:00:56 <kmartin> hello
16:00:58 <winston-d> o/
16:01:09 <jgriffith> hmmm...
16:01:15 * jgriffith can't get to launchpad this morning
16:01:29 <bswartz> I can
16:01:30 <jgriffith> there it is
16:01:43 <jgriffith> #topic I2 status
16:01:46 <avishay> #link https://launchpad.net/cinder/+milestone/icehouse-2
16:01:50 <jgriffith> https://launchpad.net/cinder/+milestone/icehouse-2
16:01:54 <jgriffith> avishay: haha :)
16:01:55 * jungleboyj can get to launchpad.
16:02:02 <avishay> :)
16:02:08 <jgriffith> Ok... down to biz
16:02:21 <jgriffith> so we're not looking too bad, but not too good either
16:02:35 <jgriffith> You'll notice i deferred a TON of stuff
16:02:49 <avishay> gate isn't helping :)  any word?
16:02:51 <jgriffith> going forward we're going to have to be more realistic about what we sign up for I think :)
16:03:09 <jungleboyj> :-)
16:03:10 <rushiagr> jgriffith: isn't what we say every time? :)
16:03:22 <jgriffith> avishay: gate's been better this week but we had a patch that got a +2/A that promptly failed unit tests
16:03:34 <jgriffith> and caused everything behind it to puuuke
16:03:43 <avishay> yep
16:03:43 <jgriffith> rushiagr: LOL
16:03:56 <winston-d> the config sample change?
16:04:03 <rushiagr> yep
16:04:06 <jgriffith> The gates's the gate, we can fix it up and offer assistance to make it better
16:04:07 <avishay> can the CI team somehow push eharney's patch to the front of the queue?
16:04:18 <jgriffith> avishay: I just pushed everybody elses to the back :)
16:04:36 <jgriffith> avishay: and no... sadly the queue doesn't work that way I don't think
16:04:43 <avishay> jgriffith: ok, gotcha
16:04:53 <eharney> it's technically possible i think, but not sure about willingness
16:04:56 <jgriffith> avishay: it's really a queue, and build dependencies as it chugs along
16:05:07 <rushiagr> just like 'recheck bug' we can have 'get me in first'
16:05:14 <jgriffith> eharney: it would require a reset on all jobs in the queue, those are nasty
16:05:23 <eharney> ah, right
16:05:23 <avishay> yep
16:05:24 <jgriffith> rushiagr: LOL
16:05:37 <jgriffith> anywho....
16:05:46 <jgriffith> so I realize gates a challenge sometimes
16:05:47 <jgriffith> BUT
16:05:58 <jgriffith> honestly there's a good number of items not submitted
16:06:00 <winston-d> simple reboot the jenkins cluster should do the trick. :D
16:06:13 <jgriffith> particularly those that I deferred, had not been started and had no updates
16:06:30 <jgriffith> so I moved them to I3, still having doubts about them getting done there :(
16:06:34 <jgriffith> winston-d: LOL!!!!
16:06:52 <jgriffith> winston-d: "simple", "reboot" and "jenkins cluster" all in the same sentence
16:06:55 <jgriffith> :)
16:07:16 <jgriffith> dosaboy: any updated on your metadata support in backups?
16:07:57 <jgriffith> dosaboy: ok... we'll come back and see if you're available later
16:08:07 <jgriffith> avishay: do you have any contact with ronenkat?
16:08:16 <avishay> jgriffith: yes, why?
16:08:18 <jgriffith> avishay: or does he have a nifty irc nic that I just don't know :)
16:08:32 <jgriffith> avishay: https://blueprints.launchpad.net/cinder/+spec/cinder-backup-recover-api
16:08:53 <avishay> jgriffith: will ping him, 1 min
16:09:16 <jgriffith> avishay: thnx!
16:09:33 <jgriffith> anybody have objections to their items that I deferred?
16:09:55 <jgriffith> which btw puts us at 21 BP's for I-3 which I think is unrealistic
16:10:05 <rushiagr> :O
16:10:08 <avishay> wow
16:10:19 <jgriffith> https://launchpad.net/cinder/+milestone/icehouse-3
16:10:20 <avishay> mine is already submitted :)
16:10:35 <jgriffith> avishay: yes avishay you're the exception today :)
16:10:44 * coolsvap too
16:10:57 <jgriffith> I'm mostly looking at like Duncans that's been deferred twice
16:10:58 <coolsvap> just the patch set is abandoned tiil i2
16:11:08 <jgriffith> the FC changes that have been deferred for 2 releases
16:11:38 <jgriffith> Then the "new" ones from folks we never hear from or see in IRC :)
16:11:51 <avishay> jgriffith: ronenkat is here
16:11:53 <jgriffith> coolsvap: ?
16:11:57 <kmartin> jgriffith: I think the fc zone mgr is getting closer we're testing it in-house
16:12:07 <jgriffith> kmartin: You said that last year :)
16:12:12 <kmartin> lol
16:12:13 <jgriffith> kmartin: sorry... couldn't resist
16:12:14 <avishay> haha
16:12:15 <jgriffith> ok
16:12:25 <jgriffith> ok... ronenkat
16:12:31 <ronenkat> hi
16:12:43 <jgriffith> ronenkat: any update on your backup/recovery bp?
16:12:45 <coolsvap> jgriffith: my code changes for multi-volume create are done! just waiting to resubmit after i2 freeze
16:12:48 <winston-d> can we spend two minute discuss this bp? https://blueprints.launchpad.net/cinder/+spec/cinder-force-host
16:12:56 <jgriffith> coolsvap: Ahh.. got ya :)
16:12:57 <jgriffith> thanks
16:12:58 <winston-d> if there was still time
16:13:05 <jgriffith> winston-d: which one?
16:13:07 <jgriffith> lol
16:13:20 * jgriffith has lost control... it's anarchy and burning couches in the street
16:13:51 <jgriffith> ronenkat: so I'm wondering is it realistic to have your BP targetted for I2 still?
16:13:57 <jgriffith> ronenkat: are you still working on it?
16:14:09 <jgriffith> ronenkat: any chance of it landing in gerrit in the next day or two?
16:14:10 <ronenkat> jgriffith: still working, it takes a bit more than I anticipated, mainly learning the maze of getting the commands to move between client and API. I mostly need to create test code now
16:14:35 <jgriffith> ronenkat: ok, so sounds like not much chance of making it for I2 then?
16:14:42 <jgriffith> ronenkat: would you like it bumped to I3?
16:15:15 <ronenkat> jgriffith: I think you are right, I will probably make it into gerrir by mid next week, not before that
16:15:28 <jgriffith> ronenkat: TBH I suspect it's going to be significant enough of a change that I don't want to rush review/testing on it either
16:15:39 <jgriffith> ronenkat: Ok, I'm going to push it to I3 then
16:15:44 <jgriffith> ronenkat: thanks for the update
16:15:52 <ronenkat> jgriffith: ok
16:16:17 <jgriffith> That just leaves dosaboy :)
16:16:24 <jgriffith> I'll try and catch up with him later
16:16:36 <jgriffith> so to reiterate...
16:16:52 <jgriffith> The items listed for I2 "bugs and blueprints" are priority for reviewers
16:17:01 <jgriffith> the sooner we get those reviewed the better
16:17:10 <jgriffith> we REALLY don't want to wait til next week if possible
16:17:18 <jgriffith> sound good to everyone?
16:17:31 <coolsvap> +1
16:17:32 <jungleboyj> Makes sense.
16:17:40 <winston-d> +2
16:17:42 <avishay> cool
16:17:52 <jgriffith> we have a boat load of bugs too... don't forget those :)
16:18:29 <jgriffith> I'm guessing that the ones that people assigned themeselves to but aren't in the queue should be reassigned
16:18:30 <thingee> http://status.openstack.org/reviews/#cinder
16:19:04 <jgriffith> so if you're lookign for a great way to help out other than reviews grab one of those bugs up top that don't have code submitted :)
16:19:20 <jgriffith> thingee: hey!!  I thought you'd be on the train or something
16:19:34 <thingee> lurkin'
16:19:37 <jgriffith> thingee: :)
16:19:39 <coolsvap> i am available if we have any such bugs
16:19:56 <jgriffith> Anybody see any of those that they might be interested in, be able to work on?
16:19:56 <winston-d> what? we have a review opened for 165 days?
16:20:21 <eharney> winston-d: it's WIP
16:20:31 <jgriffith> eharney: winston-d that reminds me!!!
16:20:56 <jgriffith> If you have a WIP that you know is pretty much dead please abandon it
16:21:06 <jgriffith> I'm looking at you guitarzan
16:21:07 <jgriffith> :)
16:21:19 <guitarzan> jgriffith: haha, let me look :)
16:21:24 <winston-d> hah
16:21:46 <jgriffith> There are others as well, but guitarzan is good humored so I can poke at him :)
16:21:49 <jungleboyj> jgriffith: That one that is assigned to me is on my list for this week.  It is mostly done but has test case issues.
16:22:03 <jgriffith> jungleboyj: k... you think you can get it done?
16:22:22 <jgriffith> jungleboyj: the good thing is it's low pri, so I'm not terribly worried
16:22:28 <jungleboyj> jgriffith: Yessir.  I can do my best.
16:22:34 <jgriffith> The High and Med are my top concerns
16:22:45 <jgriffith> VMWare is likely best left to VMware
16:23:01 <jungleboyj> jgriffith: I wonder why that doesn't show as in progress.  I need to look at that.
16:23:07 <jgriffith> but the delete extra-spec with '/' we should look at
16:23:16 <rushiagr> i was looking at it
16:23:23 <jgriffith> jungleboyj: launchpad is good, but it's not perfect at auto-updating
16:23:27 <jgriffith> rushiagr: oh... cool
16:23:38 <rushiagr> I plan to look at it this week too, but cant guarantee if I can get it done
16:23:54 <jgriffith> rushiagr: ok, please keep me/us posted later this week at how it goes for ya
16:24:06 <jgriffith> rushiagr: if I can help let me know
16:24:08 <rushiagr> jgriffith: sure
16:24:11 <coolsvap> rushiagr: let me know if I can assist
16:24:20 <coolsvap> oops!
16:24:26 <rushiagr> coolsvap: appreciate ur help
16:24:26 <jgriffith> alright....
16:24:49 <jgriffith> Just a heads up, after we get I2 out, we'll need to have a meeting to take a hard look at what's targetted for I3
16:25:04 <jgriffith> You might want to be thinking about what's there between now and then
16:25:27 <jgriffith> We should trim that list down to something realistic based on previous milestone accomplishments
16:25:35 <jgriffith> and on that note....
16:25:40 <jgriffith> #topic open discussion
16:25:51 <jgriffith> winston-d: which bp did you want to discuss?
16:26:13 <winston-d> https://blueprints.launchpad.net/cinder/+spec/cinder-force-host this one
16:26:46 <avishay> jgriffith: reminder - you also had cert test on the agenda
16:26:51 <jgriffith> Ohhh yes :)
16:27:02 <jgriffith> avishay: yeah... thanks :)
16:27:22 <winston-d> I've been -2 on Jay Lau's implementation.  but I'd like to hear your opinion
16:27:41 <caitlin56> winston-d: would that translate to a filter that just specified "host must be X"?
16:28:05 <winston-d> caitlin56: yes, you can do that with a scheduler hint
16:28:48 <winston-d> scheduler is smart enough to take input like 'host' must be something, or 'free space' must be larger than a value
16:29:00 <jgriffith> winston-d: I think I would agree
16:29:32 <caitlin56> It sounds useful, and really doesn't disrupt anything. sounds good to me.
16:29:37 <jgriffith> winston-d: end user shouldn't know anything about "host" anyway
16:30:00 <winston-d> jgriffith: yes, that's my point too
16:30:14 <winston-d> caitlin56: force host or scheduler hint?
16:30:49 <caitlin56> jgriffith: specifying a host via a hint. I can't see why not. Normally you don't need to specify a host, but there are special needs.
16:31:13 <avishay> jgriffith: he is willing to make it admin-only, but it's something that can already be done
16:31:14 <winston-d> caitlin56: scheduler hint is already there.
16:31:17 <jgriffith> winston-d: caitlin56 Ok... I think -2 is appropriate and implement as sched hint
16:31:32 <jgriffith> avishay: thingee kmartin jungleboyj objections/agreement?
16:31:53 <avishay> jgriffith: agreed, -2, should be accompanied with how to do it alternately
16:32:07 <winston-d> jgriffith: we can already do that with scheduler hint, i think i provided an example in the reviews
16:32:20 <winston-d> let me check
16:32:46 <jgriffith> winston-d: I'm looking through your comments but there are a lot of them :)
16:32:48 <caitlin56> Winston-d, so if you can do it already do you really need anything other than better documentation to highlight it?
16:32:53 <thingee> agreed, scheduler hints is what I've been advocating in my talks too :)
16:33:09 <jungleboyj> jgriffith: That is fine with me.
16:33:11 <thingee> don't make me update a slide, or something
16:33:43 <jgriffith> thingee: haha
16:34:18 <winston-d> jgriffith: don't know how the get a link for specific review comment, but if you look at the longest comment i left for patch set 2: https://review.openstack.org/#/c/55076/
16:34:21 <jgriffith> #action make sure openstack-docs has example of how to do sched hint for host
16:34:27 <avishay> thingee: i will update for you :)
16:34:38 <jgriffith> Ok... sounds good...
16:34:40 <jgriffith> done deal
16:34:42 <jgriffith> :)
16:34:56 <jgriffith> anybody have anything else before I talk about the cert stuff again?
16:35:00 <winston-d> i actually gave an example of how to use scheduler hint to 'force' a volume on certain host
16:35:36 <jgriffith> #topic cert tests/script
16:35:49 <jgriffith> It seems there's something broken in the tempest env when trying to run this
16:36:17 <jgriffith> I'm looking at it, but it's also interesting that everybody thought this was a good idea but apparantly nobody is running it :)
16:36:23 <jgriffith> Do we stil want to do this?
16:36:31 <winston-d> yes, please
16:36:46 <avishay> yes, i was hoping to get around to it soon
16:37:00 <jgriffith> Ok... cool
16:37:00 <kmartin> yes, still need to run the 3par and lefthand drivers against it
16:37:18 <jgriffith> so I believe the problem is that the run_tests.sh script doesn't build the test lib any more
16:37:26 <winston-d> i'd ask for a cert test result from vendors before we considering next purchase
16:37:29 <jgriffith> so when you run it on a clean setup it doesn't find any tests
16:37:42 <jgriffith> and you get the silly "Ran 0 tests in xxx" OK
16:37:55 <winston-d> really?
16:38:01 <jgriffith> winston-d: FYI I have a plan for the next iteration that will be even better
16:38:07 <jgriffith> just need to work out some details
16:38:08 <eharney> i've seen this in some instances with "run_tests.sh -V cinder.some.test" too
16:38:36 <kmartin> jgriffith: did you document the location of the script somewhere?
16:38:42 <jgriffith> eharney: Yeah, I tried to avoid it by not doing venv
16:38:45 <avishay> that's why i usually use tox instead of run_tests.sh
16:39:03 <jgriffith> avishay: educate me :)
16:39:16 <jgriffith> avishay: tox would be the answer here I believe
16:39:20 <avishay> jgriffith: winston-d taught me the little that i know :)
16:39:27 <thingee> detox, if you got the cores :)
16:39:37 <jgriffith> thingee: lol
16:39:52 <jgriffith> avishay: the problem is I wasn't sure how tox worked in tempest/devstack
16:40:04 <jgriffith> avishay: when trying to use 'real' devs and conf files
16:40:15 <jgriffith> suppose it should just work still
16:40:20 <avishay> jgriffith: no idea
16:40:22 <jgriffith> Ok
16:40:27 <jgriffith> I'll play with it
16:40:31 <avishay> sorry
16:40:34 <jgriffith> probably ping avishay and winston-d :)
16:40:50 <jgriffith> since I've always been the only fan of run_tests.sh :(
16:40:56 <avishay> hah
16:41:38 <jungleboyj> jgriffith: You aren't the only fan.
16:41:38 <rushiagr> jgriffith:  me too. tox never runs for me, and I never cared
16:41:49 <jungleboyj> rushiagr: +1
16:41:51 <jgriffith> rushiagr: jungleboyj yayy!!!
16:41:55 <jgriffith> I've never liked tox
16:42:09 * jungleboyj starts run_tests.sh lovers anonymous
16:42:21 <winston-d> rushiagr: you must be kidding. :)
16:42:38 <rushiagr> winston-d: only about 'never cared' part ;)
16:42:46 <jgriffith> alright... we can take this offline :)
16:42:52 <avishay> next topic - vim or emacs? ;)
16:43:00 <jgriffith> avishay: LOL!!!
16:43:06 <jgriffith> avishay: you're a funny guy
16:43:07 <coolsvap> :D
16:43:17 <jgriffith> avishay: MS Notepad FTW!!!
16:43:33 <avishay> jgriffith: :)
16:43:41 <jgriffith> alright... thanks everyone!!
16:43:58 <jgriffith> Hang tough on reviews the next few days please :)
16:44:03 <avishay> jgriffith: please update when the cert script is working, will like to try it out
16:44:04 <jgriffith> #endmeeting cinder