19:03:13 <jeblair> #startmeeting ci
19:03:14 <openstack> Meeting started Tue Jan  8 19:03:13 2013 UTC.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:17 <openstack> The meeting name has been set to 'ci'
19:03:24 <jeblair> #topic meeting name
19:03:33 <jeblair> should we call this thing the "infra" meeting? :)
19:03:53 <jeblair> i mean, it's longer to type, but seems more accurate to me.
19:03:54 <clarkb> that would make the naming consistent
19:04:13 * fungi agrees
19:04:16 <fungi> motion carried?
19:04:21 <jeblair> motion carried
19:04:23 <jeblair> #topic CLA
19:04:32 <jeblair> i just got the new cla text from jbryce
19:04:39 <fungi> yes!
19:04:40 <mordred> w00t!
19:04:52 <clarkb> all your code is belong to the openstack foundation
19:04:54 <fungi> now my plans for what i'm working on this week change slightly ;)
19:05:45 <jeblair> i just fwded it to fungi and mordred
19:05:55 <jeblair> i haven't read it yet, so first order of business is make sure it's actually what we want
19:05:57 <fungi> so we're basically ready to make it go. i'll touch up docs edits and rebase stuff accordingly
19:06:13 <fungi> and yes, read the new cla of course
19:06:38 <jeblair> fungi: cool, when you're done with that, let us all know.  i want to make another pass at reviewing all that
19:06:38 <fungi> and assuming everything looks okay, we can agree on a date and announce stuff
19:07:02 <fungi> jeblair: will do. second order of business after the meeting, once i fix the review expiration script
19:07:06 <mordred> mmm
19:07:22 <clarkb> is the foundation's server up and ready to return 200s?
19:07:44 <fungi> clarkb: yes, has been. i just have to give toddmorey the new keys i installed in heira for production
19:07:49 <clarkb> and we can put it in place on review-dev in the same way that will be deployed to review.o.o right?
19:07:57 <fungi> yep
19:07:59 <clarkb> cool
19:08:28 <fungi> #link https://review.openstack.org/14099
19:08:31 <fungi> for reference
19:08:33 <jeblair> fungi: btw, toddmorey is a foundation employee now (which probably doesn't change much)
19:08:43 <fungi> jeblair: so are you ;)
19:09:08 <jeblair> yep.  just mentioning it in case he may have slightly less rackspace stuff to deal with (i'm hoping)
19:09:11 <fungi> oh, you mean in a good way!
19:09:22 <jeblair> i like to think so.  :)
19:09:35 <mordred> woot!
19:09:45 <fungi> so that's all on that topic for the moment i think?
19:09:47 <jeblair> he's always been super busy (but does great work)
19:09:51 <jeblair> i think so
19:10:02 <jeblair> #topic review expiration
19:10:16 <jeblair> fungi: plan?
19:10:23 <clarkb> we should probably send an email nowish giving people a heads up
19:10:33 <clarkb> otherwise the potential flood of gerrit email may be confusing to people
19:10:43 <fungi> clarkb: good point
19:10:55 <fungi> i'll follow up to my pre-holiday e-mail on the -dev ml
19:11:09 <fungi> and then give it an hour and approve the fix
19:11:13 <fungi> #link https://review.openstack.org/#/c/18541/
19:11:41 * mordred is going to be sad when several of his reviews expire...
19:11:49 <fungi> mordred: you and me both
19:12:19 <jeblair> #topic rechecks
19:12:32 <jeblair> I'm not ready to announce the recheck bug linking yet...
19:12:59 <jeblair> I'd like to write up wiki docs on the final syntax and make sure we can point to those before making an announcement
19:13:03 <mordred> ++
19:13:11 <fungi> sounds like a plan
19:13:15 <jeblair> so I'll try to do that this week, and maybe we can announce the new syntax next week
19:13:16 <clarkb> jeblair: have you decided on a way to handle the non bug rechecks?
19:13:38 <jeblair> clarkb: no.  any suggestions?
19:14:16 <jeblair> the idea is most rechecks can be linked to a bug, but sometimes you just need to recheck something because master has moved on, and it really doesn't make sense to link to a bug in that case.
19:14:17 <clarkb> maybe a dummy bug so that the rechecks page tracks cases of that properly?
19:14:38 <clarkb> or some verb in place of a bug number
19:14:55 <jeblair> clarkb: well, it's just not very interesting, so i don't think i want to collect data on it (and have a huge list of changes linked to it)
19:15:02 <jeblair> so maybe just "recheck no bug" or something
19:15:22 <jeblair> which is, frankly, a weird thing to say, so i'd still love to find something better.  :)
19:15:25 <clarkb> my only worry with not tracking it is that it may be too easy to use that in place of a bug
19:15:36 <fungi> recheck kthxbye
19:15:39 <clarkb> but thats a social problem and not a technical one
19:15:45 <jeblair> indeed
19:16:29 <jeblair> we're trying to get useful data, and if people chose to be jerks about it, that's better solved with social pressure than tech
19:16:49 <mordred> or with wolves
19:17:01 <jeblair> i hadn't thought of that, but it just may work
19:17:09 * mordred is occasionally helpful
19:17:17 <fungi> so having a nonbug keyword still helps remind not-jerks that we appreciate bug numbers if they can dig one up for us
19:17:43 <jeblair> fungi: yeah' and saying specifically "there is no bug" and lying about it reminds them they're jerks
19:17:45 <clarkb> ya I definitely think we shouldn't allow the old 'recheck'
19:19:03 <fungi> and i agree there's not much to be done about people not caring. they need a reason to care and if we can't give then one, laziness will often prevail over helpfulness
19:19:30 <fungi> er, give them one
19:19:46 <fungi> having a good stats page about that stuff counts as a good reason, in my view
19:19:50 <clarkb> ++
19:19:57 <jeblair> so i'd like to talk about the wiki and status page, and continue the ttx all-request hour, but I don't think Ryan_Lane or ttx are here now...
19:20:10 <jeblair> anyone else have topics while we wait a bit?
19:20:16 <clarkb> jenkins upgrade
19:20:21 <jeblair> #topic jenkins upgrade
19:20:23 <fungi> we upgraded jenkins?
19:20:27 <jeblair> we did that
19:20:43 <jeblair> we still need to fix devstack-oneiric image builds
19:20:49 <clarkb> #link https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2013-01-04
19:20:56 <jeblair> and then we also need to fix the scp plugin race
19:21:02 <jeblair> (which is not related to the upgrade)
19:21:18 <clarkb> I had to change hudson's authorized_keys file on tarballs.openstack.org
19:21:37 <jeblair> clarkb: good catch.  we should work on moving tarballs.o.o to static.o.o
19:21:43 <clarkb> ++
19:22:00 <jeblair> anything else creep up since the upgrade?
19:22:03 <clarkb> jeblair: http://paste.openstack.org/show/29012/ is a preliminary patch to fix scp
19:22:24 <jeblair> clarkb: cool, thanks!
19:22:52 <clarkb> we may need to consider having more devstack nodes
19:23:03 <jeblair> clarkb: we're still down because of the oneiric thing...
19:23:10 <fungi> pretty sure i got through all the rechecks/reverifies last night before i passed out, so should have been ready for most people by the time they saw the e-mail
19:23:13 <jeblair> clarkb: the providers that have oneiric images aren't creating precise images
19:23:20 <clarkb> ah
19:23:22 <clarkb> ok
19:23:43 <clarkb> will non diablo make use of the oneiric devstack hosts?
19:24:04 <jeblair> clarkb: no, it's just they both get built in the same job
19:24:06 <mordred> nope.
19:24:10 <jeblair> clarkb: and oneiric gets built first
19:24:16 <mordred> we could just fix it by dropping support for diablo
19:24:39 <fungi> or with rhel devstack slaves ;)
19:24:59 <mordred> I was only half kidding .. anybody know when the last time we took a patch for diablo was?
19:25:34 <jeblair> mordred: no, but if we're going to make a case for dropping diablo based on red bitrot jobs, i'd like the bitrot jobs to actually be running.  :/
19:26:04 <fungi> i'd like to think we'd still patch serious security issues in a year-old release
19:26:26 <jeblair> fungi: i would like to think that but i'm far from sure
19:26:41 <mordred> just putting it out there - we've done 6 diablo patches since last april
19:26:53 <fungi> right. would be great for missing slaves not to be the reason we don't get a security fix out though
19:27:11 <jeblair> so anyway, the oneiric problem is a really weird apt/dpkg issue, so if anyone with expertise in that area has some time to pitch in this afternoon, that would be great.  :)
19:27:31 <clarkb> jeblair: I had planned to take a second look at it, but I do not claim apt expertise
19:27:37 <fungi> now that i'm a little more awake, i can try to take a look
19:27:39 <jeblair> i'm currently stuck at "but that number _is_ greater than that other number".
19:28:01 <mordred> jeblair: what are the two numbers? (what's the problem?)
19:28:11 <fungi> i still think it has to do with the arch-specificness of the one version, but that's just a hunch. it was late
19:28:32 <mordred> also - I hear that zul might know something about packaging...
19:28:49 <jeblair> mordred: it's yucky and detailed, let's work on it in #-infra after the meeting.. i'd like to move onto wiki...
19:29:14 <jeblair> #topic wiki
19:29:32 <jeblair> btw, i saw some scrollback in #-infra... i did upgrade moin on wiki.o.o
19:29:36 <Ryan_Lane> not much has changed there
19:29:40 <Ryan_Lane> for mediawiki
19:29:46 <jeblair> i _think_ i mentioned that in channel at the time
19:30:04 <jeblair> Ryan_Lane: so yeah, if possible, we're even more excited about moving to mediawiki...
19:30:08 <Ryan_Lane> heh
19:30:20 <jeblair> Ryan_Lane: with, like, people paying attention to it and stuff.  :)
19:30:34 <Ryan_Lane> I thought we had a volunteer for the skin, but I guess it was more work than he expected
19:30:41 <olaph> o/
19:30:54 <Ryan_Lane> ah. right
19:31:00 <jeblair> olaph: are you volunteering to write a mediawiki skin?
19:31:01 <Ryan_Lane> olaph: did you get a chance to look at it?
19:31:04 <olaph> i essentially have a default skin with a openstack logo slaped in there
19:31:08 <Ryan_Lane> heh
19:31:24 <fungi> that's more than a default skin with no openstack logo
19:31:35 <olaph> how should it look?  should it be obvious it is mediawiki, or should it look like the openstack site as much as possible?
19:31:41 <Ryan_Lane> it honestly may be enough to just change the logo and the css
19:31:49 <jeblair> olaph: consider https://jenkins.openstack.org/
19:32:05 <jeblair> which is not responding for me right now...
19:32:22 <jeblair> ah there it goes..
19:32:32 <jeblair> anyway, it's basically a logo, and some text colors changed to match
19:32:33 <fungi> each release gets slower
19:32:36 <jeblair> and it made a world of difference
19:32:52 <jeblair> olaph, Ryan_Lane: so yeah, it may not take much more than that...
19:33:06 <jeblair> which is pretty much what the moin theme is like too
19:33:12 <jeblair> it still looks like moinmoin
19:33:12 <clarkb> ++
19:33:15 <Ryan_Lane> that's much easier, then. it may not even require a full skin
19:33:33 <clarkb> is the other open item the column data?
19:33:47 <Ryan_Lane> redirects
19:33:50 <jeblair> #action olaph to finish openstack skin
19:34:00 <Ryan_Lane> column data? for tables?
19:34:03 <clarkb> Ryan_Lane: ya
19:34:12 <clarkb> forgive me if I am not describing it properl
19:34:15 <Ryan_Lane> it would be ideal to fix that, but that perl script is frightening
19:34:29 <Ryan_Lane> it may be best to just fix the spots its broken in the content
19:35:14 <Ryan_Lane> I'd also like to have the mobile skin working, but that's really more of an enhancement
19:36:06 <Ryan_Lane> if we do the skin and the redirects, I think the rest can be handled by a doc sprint
19:36:38 <jeblair> Ryan_Lane: are you taking a stab at redirects?
19:36:42 <Ryan_Lane> yep
19:36:51 <jeblair> I think ttx said he was going to try to make a nicer front page
19:36:51 <zul> mordred: only a little
19:36:53 <Ryan_Lane> I'll try to get that done soon. maybe I'll work on it tonight
19:37:28 <jeblair> #action Ryan_Lane handle redirects
19:37:37 <jeblair> #action ttx make nice front page
19:38:09 <jeblair> so maybe we'll check back next week and see if we're at the point of scheduling a cutover date/sprint?
19:38:41 <Ryan_Lane> sounds good
19:38:43 <olaph> works for me...
19:39:01 <mordred> ++
19:39:28 <jeblair> cool.  other topics while we wait and see if ttx shows up?
19:39:46 <clarkb> askbot?
19:39:54 <jeblair> #topic askbot
19:39:56 <jeblair> reed: around?
19:40:33 <jeblair> based on the complexity of the system uncovered by the work clarkb has done so far...
19:40:33 <clarkb> over the holidays I hacked on an askbot puppet module that would install askbot with apache, memcached, and mysql
19:41:14 <ttx> o/
19:41:15 <clarkb> those three pieces work, but lack performant search functionality which requires the use of haystack. unfortunately askbot's haystack support appears to currently be broken with circular imports due to django's i8ln support
19:41:29 * ttx reads scrollback
19:41:45 <jeblair> ...i think if the askbot people are able to fully host an instance for us, that would be best.
19:41:55 <clarkb> so we are taking a second look at the other options available to us
19:42:28 <clarkb> what jeblair mentions is one potential option. Another option is running a server that they support. we would probably use postgres in that case to avoid search problems
19:43:21 <clarkb> reed is currently handling the communication with askbot as we sort out our options
19:43:29 <clarkb> jeblair: anything else to add?
19:43:50 <jeblair> yep.  i'm worried about who takes reponsibility for what aspects of managing that server, and us ending up with more work that we bargained for, which is why i prefer the other option first.
19:44:59 <jeblair> #topic status page
19:45:11 <jeblair> ttx: over the holidays, i threw together http://status.openstack.org/
19:45:24 <mordred> it's purty
19:45:36 <jeblair> ttx: it incorporates some zuul status stuff and your 3 things that currently are on the wiki server
19:45:39 <ttx> Saw that. I'll use the same headers on the status pages
19:45:40 <jeblair> (that you've been puppetizing)
19:46:03 <jeblair> ttx: you think that's a good general direction?
19:46:19 <jeblair> also, i think we can put things like outage notices, monitoring info, etc on the main page
19:46:26 <jeblair> once we get our act together on that sort of thing
19:46:26 <ttx> I'll have to look into how to properly puppetize the scripts, now that they are poublished
19:46:38 <ttx> jeblair: sure
19:47:08 <jeblair> cool, then i think i'll reconfigure zuul to point there instead of zuul.o.o when it leaves comments
19:47:13 <ttx> I have the following on my todo:
19:47:25 <ttx> apply same theme to release status and bugday status
19:47:27 <jeblair> and have zuul.o.o redirect
19:47:36 <ttx> Make bugday run in a rolling fashion
19:47:47 <ttx> (i.e. automatically have the past 48 hours activity
19:47:48 <ttx> )
19:47:58 <ttx> (rather than needing to start and top it manually)
19:48:04 <jeblair> that sounds good
19:48:28 <ttx> http://status.openstack.org/reviews/ is horribly stale
19:48:48 <ttx> I think we should remove it and/or plug reviewday instead
19:49:11 <jeblair> dprince: ping
19:49:19 <mordred> we have a todo list task which is "integrate reviewday"
19:49:30 <dprince> jeblair: hi
19:49:40 <mordred> https://bugs.launchpad.net/openstack-ci/+bug/1082785
19:49:42 <uvirtbot> Launchpad bug 1082785 in openstack-ci "Import reviewday into OpenStack infrastructure" [High,Triaged]
19:49:49 <jeblair> dprince: we're putting together http://status.openstack.org/
19:49:56 <ttx> jeblair: ideallly I'd just include your header with all the links, rather than copy it over
19:50:08 <jeblair> dprince: as a point of integration for various project statusy things
19:50:26 <dprince> Okay. I like it.
19:50:33 <jeblair> dprince: and were thinking that would be good to incorporate reviewday in there
19:51:32 <dprince> Okay. I'm up for helping here if you guys need it.
19:52:12 <dprince> The ticket mentions projects.yml...
19:52:34 <jeblair> dprince: great!  is reviewday cron -> static html?  or a web app?
19:52:49 <jeblair> dprince: and is http://pypi.python.org/pypi/reviewday/0.1.0 current?
19:52:51 <dprince> cron -> static.
19:52:55 <mordred> yeah. as a second step, we could have reviewday grab the list of projects it monitors from projects.yaml
19:53:04 <ttx> jeblair: it's a rewrite of my review code, so static generation
19:53:08 <dprince> jeblair: I did push an initial release to Pypi.
19:53:11 <mordred> but I don't think we need to do that right off the bat
19:53:14 <dprince> jeblair: But that is now stale
19:53:19 <ttx> takes.. a bit of time to extract all necessary data from lp :)
19:53:24 <jeblair> gotcha
19:53:47 <dprince> most recent code is under git://github.com/dprince/reviewday
19:54:05 <jeblair> dprince: want to make a gerrit project for it, and get automatic tag-based releases to pypi in the bargain?
19:54:08 <dprince> We can move that elsewhere if it makes sense too.
19:54:28 <dprince> fine by me
19:54:42 <jeblair> why don't we make openstack-infra/reviewday, publish a new version to pypi from there...
19:54:43 * dprince calls it a project promotion
19:55:05 <jeblair> ...then it should basically be a matter of writing some puppet to install it and cron it on static.o.o
19:55:06 <ttx> jeblair: had two topics to raise before meeting end
19:55:13 <jeblair> ttx: go!
19:55:24 <dprince> Is openstack-infra stuff mirrored to github?
19:55:32 <jeblair> dprince: yep, same as the rest
19:55:33 <ttx> Private Gerrit for security reviews
19:55:42 <ttx> are we making progress on that front ?
19:55:44 <jeblair> #topic ttx all-request hour
19:55:55 <jeblair> no, i don't think anyone has started that yet
19:55:58 <mordred> ttx: we still think it's a good idea!
19:56:03 <ttx> heh
19:56:12 <jeblair> yes, i consider it high priority
19:56:15 <ttx> we did not regress, that's still positive I guess
19:56:33 <fungi> there were still questions around how to trigger jenkins tests for ir and keep it integrated with the pipeline, right?
19:57:11 <fungi> the gate pipeline specifically
19:57:20 <jeblair> #link https://bugs.launchpad.net/openstack-ci/+bug/1083101
19:57:20 <ttx> the second thing is mostly for mordred: he was supposed to send some requirements email to the Launchpad SSO folks
19:57:22 <uvirtbot> Launchpad bug 1083101 in openstack-ci "Set up private gerrit for security reviews" [High,Triaged]
19:57:40 <ttx> with things they could improve for us to be happier
19:58:48 <mordred> oh. right
19:58:53 <ttx> last thing, how is transfer of openstack.org website under our marvelous infrastructure going on so far ?
19:59:00 <mordred> it's not
19:59:07 <jeblair> we need to bug todd and jbryce about it
19:59:23 <mordred> but I believe that now that todd is a foundation employee, he will have more time to give us love on that front
19:59:41 <jeblair> both of them support the idea in theory.  need to translate to practice.  :)
19:59:42 <ttx> ok, that was all
19:59:51 <mordred> ttx: the version/tarball stuff
19:59:54 <ttx> (since you covered askbot and wikimove)
19:59:58 <jeblair> cool, thanks everyone!
20:00:07 <jeblair> #endmeeting