17:07:15 <tinwood> #startmeeting charms
17:07:16 <openstack> Meeting started Mon Nov 25 17:07:15 2019 UTC and is due to finish in 60 minutes.  The chair is tinwood. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:07:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:19 <openstack> The meeting name has been set to 'charms'
17:07:26 <tinwood> Good morning/afternoon/evening all.
17:07:34 <tinwood> Starting with:
17:07:42 <tinwood> #topic Review ACTION points from previous meeting
17:08:21 <tinwood> Only outstanding action is for jamespage: setup bug hug day (monthly)
17:08:29 <jamespage> omg I am useless
17:08:37 <jamespage> please carry that over again...
17:08:39 <tinwood> well, there's been a lot going on recently.
17:08:41 <thedac> :)
17:08:44 <tinwood> Will do
17:08:55 <thedac> That is the least true thing ever stated on IRC :)
17:08:59 <tinwood> #action jamespage setup bug day
17:09:10 <jamespage> thanks
17:09:21 <tinwood> okay, let's move to the next topic:
17:09:28 <tinwood> #topic State of Development for next Charm Release
17:09:42 <tinwood> Anyone have any comments?
17:10:12 <tinwood> ...
17:10:17 <thedac> MySQL 8 charms (mysql-innodb-cluster and mysql-router) are available for testing on Eoan now
17:10:24 <tinwood> \o/
17:10:24 <thedac> Could use public testing
17:10:31 <tinwood> Big piece of code and change.
17:10:35 <tinwood> Exciting stuff
17:10:44 <thedac> Same with OVN charms
17:11:03 <tinwood> Yes, very interesting changes.
17:11:26 <tinwood> Anyone else?
17:11:29 <jamespage> feels like we should setup a small deploy somewhere and run it for a week or two - and use it?
17:11:38 <jamespage> kinda like serverstack for a bit
17:11:51 <thedac> Agreed
17:12:40 <tinwood> Does that need an action?
17:12:51 <thedac> Sure
17:12:52 <jamespage> can we come up with a 4 machine bundle which combines the mysql and OVN work for deployment to the icarus lab? I have something for OVN we could start with if that's helpful
17:13:03 <jamespage> guess this needs to be eoan
17:13:09 <thedac> Right, that is the only catch
17:13:13 <thedac> But yes we can do that
17:13:14 <jamespage> that's fine
17:13:27 <jamespage> its really just early focal testing after all!
17:13:34 <tinwood> #action thedac set up small (4 machine bundle) on Eoan with mysql8 and OVN
17:13:37 <thedac> FWIW, we already have OVN and mysql8 overlays for the openstack bundles
17:13:46 <jamespage> that's probably good then
17:14:07 <jamespage> we'll just need to ensure we manage the address space in icarus
17:14:19 <jamespage> i.e. there will be other things under test :)
17:15:05 <jamespage> lets move on
17:15:15 <tinwood> okay, anything else for this topic?
17:15:29 <tinwood> ...
17:15:35 <tinwood> ..
17:15:41 <tinwood> .
17:15:51 <tinwood> Next up:
17:15:59 <tinwood> #topic High Priority Bugs
17:15:59 <tinwood> https://bugs.launchpad.net/openstack-charms/+bugs
17:15:59 <tinwood> Use stable-backport tag for bugs  http://tinyurl.com/charm-stable-backports
17:15:59 <tinwood> Critical bugs: https://tinyurl.com/osc-critical-bugs
17:16:00 <tinwood> High priority bugs: https://tinyurl.com/osc-high-priority
17:16:25 <tinwood> No new critical bugs; all existing ones in progress.
17:17:00 <tinwood> Quite a few high priority bugs.
17:17:40 <tinwood> One that was fixed, is been reverted, on openstack-dashboard: https://bugs.launchpad.net/charm-openstack-dashboard/+bug/1822751
17:17:40 <openstack> Launchpad bug 1822751 in OpenStack openstack-dashboard charm "When enforcing HTTPS, enforce cookies to be HTTPS-Only too" [High,New] - Assigned to Sahid Orentino (sahid-ferdjaoui)
17:18:13 <jamespage> ack
17:18:17 <tinwood> The issue is around CSRF tokens, Angular and being able to read them.
17:18:40 <tinwood> Any thing else important here?
17:19:08 <tinwood> (on the topic of bugs)
17:19:29 <tinwood> Okay, just to mention that I'm on bugs this week.
17:19:36 <tinwood> Moving on.
17:19:43 <tinwood> #topic Openstack Events
17:20:15 <tinwood> Any events we know about?
17:20:28 <jamespage> yep
17:20:49 <jamespage> I'm talking about automating security in your openstack cloud at the open infra meetup in london on thursday
17:21:06 <jamespage> intend on covering vault, etc... from the charms
17:21:18 <tinwood> Sounds good.
17:21:26 <thedac> nice
17:21:54 <tinwood> Anyone else?
17:22:21 <tinwood> ...
17:22:33 <tinwood> ..
17:22:41 <tinwood> .
17:22:45 <tinwood> Okay, and:
17:22:51 <tinwood> #topic Open Discussion
17:22:57 <tinwood> The floor is open.
17:23:18 <thedac> Nothing to add from me
17:23:34 <jamespage> nought from me
17:23:41 <coreycb> nothing here
17:23:44 <tinwood> ...
17:23:49 <tinwood> ..
17:23:55 <tinwood> .
17:23:59 <tinwood> So finally:
17:24:05 <tinwood> #topic Next Chair
17:24:23 <tinwood> And the winner is sahid
17:24:34 <tinwood> Who isn't here, I think, so perhaps a bit unfair!
17:24:42 <tinwood> Alternative, is coreycb
17:25:19 <tinwood> Okay, I'll put sahid, but it may be you coreycb.
17:25:23 <tinwood> That's a wrap
17:25:27 <thedac> The list is inviolable :)
17:25:28 <coreycb> yeah sahid sounds good ;)
17:25:35 <tinwood> #endmeeting