10:03:40 <jamespage> #startmeeting charms
10:03:41 <openstack> Meeting started Mon Sep  9 10:03:40 2019 UTC and is due to finish in 60 minutes.  The chair is jamespage. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:03:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:03:45 <openstack> The meeting name has been set to 'charms'
10:04:03 <jamespage> good morning and welcome to the EMEA/APAC charms irc meeting!
10:04:25 <tinwood> hi
10:04:26 <jamespage> lets just take 2 mins for folk to arrive - please o/ if you're here for the meeting
10:04:36 <icey> o/
10:05:12 <jamespage> hey gnuoy
10:05:15 <gnuoy> \o
10:05:20 <jamespage> so maybe just fnordahl ?
10:05:35 <jamespage> lets get the first topic clear
10:05:35 <jamespage> #topic Review ACTION points from previous meeting
10:05:45 <jamespage> no action points so nothing to discuss!
10:05:47 <jamespage> next
10:05:51 <jamespage> #topic State of Development for next Charm Release
10:06:11 <jamespage> dates went up for the next charm release during last week
10:06:17 <jamespage> #link https://docs.openstack.org/charm-guide/latest/release-schedule.html
10:06:30 <jamespage> Freeze is about 1 month away on the 8th October
10:06:37 <jamespage> with release on the 17th October
10:07:01 <icey> coming up quick!
10:07:11 <gnuoy> The purestorage charm will be official once https://review.opendev.org/#/c/680676/ lands
10:07:25 <jamespage> I'm optimistic that our re-org around QA focus will help make that a smoother process
10:07:29 <jamespage> thanks gnuoy
10:07:53 <jamespage> done
10:08:30 <jamespage> specs should be up and reviewed/landed asap
10:08:39 <jamespage> to ensure that feature make cutoff for freeze
10:09:08 <jamespage> tinwood- I know there where some queries around the need for template support in the policy.d feature - do we need to discuss that here?
10:09:13 <gnuoy> \o/ thanks for the review jamespage
10:09:16 <jamespage> we can do so at the end if need be
10:09:25 <jamespage> #topic High Priority Bugs
10:09:33 <jamespage> #link https://bugs.launchpad.net/openstack-charms/+bugs
10:09:40 <tinwood> jamespage, re: policyd
10:09:45 <jamespage> #link https://tinyurl.com/osc-critical-bugs
10:09:47 <tinwood> maybe?
10:09:52 <jamespage> #link https://tinyurl.com/osc-high-priority
10:09:58 <fnordahl> o/
10:10:26 <tinwood> jamespage, re: policyd - the only question is around templating
10:10:31 <jamespage> yah
10:10:36 <jamespage> lets discuss at the end
10:10:41 <tinwood> okay
10:10:51 <jamespage> 8 open critical bugs
10:11:26 <jamespage> 103 high's
10:12:21 <jamespage> I'm pondering whether we try to introduce a monthly bug hug day again?
10:12:29 <tinwood> I've always liked that idea
10:12:33 <jamespage> fnordahl: any thoughts as upcoming PTL on that?
10:13:03 <fnordahl> that sounds like a good idea
10:13:22 <jamespage> fnordahl: how about I set that up as an outgoing PTL action in the next month...
10:13:35 <jamespage> #action organised schedule and comms for monthly bug hug day!
10:13:49 <jamespage> next up
10:13:50 <jamespage> #topic Openstack Events
10:14:35 <jamespage> summit upcoming in shanghai - I know that sahid, icey and beisner are all attending and I'm sure they may be others
10:14:48 <jamespage> upcoming == november (after next release)
10:15:01 <jamespage> anyone got any other related events? I remember a ceph day for london?
10:15:17 <jamespage> #link https://ceph.com/cephdays/ceph-day-london-2019/
10:15:29 <jamespage> October 24th - I may endeavour to get along to that
10:15:45 <jamespage> CFP is still open ;)
10:15:51 <jamespage> till end of this week
10:16:09 <jamespage> ...
10:16:10 <jamespage> ..
10:16:11 <jamespage> .
10:16:18 <jamespage> #topic  Open Discussion
10:16:20 <fnordahl> https://mail.openvswitch.org/pipermail/ovs-announce/2019-August/000253.html
10:16:31 <jamespage> oh right forgot that one
10:16:35 <jamespage> #topic Openstack Events
10:16:42 <jamespage> I think we should rename this one 'events'
10:16:51 <jamespage> we do a bit more that OpenStack these days!
10:16:54 <fnordahl> +1
10:16:58 <jamespage> OVS/OVN conference
10:17:12 <jamespage> fnordahl: are you still intending on submitting a talk?
10:17:19 <fnordahl> CFP deadline September 23rd
10:17:24 <jamespage> yikes
10:17:28 <jamespage> all happening this month
10:17:34 <jamespage> shall we draft something together in Paris?
10:17:55 <fnordahl> That's a great idea, I think we have multipel topics that would be relevant from work this cycle
10:18:46 <jamespage> ok lets do that then
10:18:50 <jamespage> #topic Open Discussion
10:19:02 <jamespage> tinwood: lets discuss that policy templating challenge here
10:19:07 <tinwood> okay
10:19:15 <jamespage> #topic policy.d and whether to provide templating support...
10:19:22 <tinwood> so: background:
10:19:46 <tinwood> policyd override with templating = template from context variables (probably).
10:20:07 <tinwood> policyd override without templating = put variables in charms' default policy file and reference them from override.
10:20:13 <tinwood> i.e. static files.
10:20:23 <tinwood> variables always under control of charm.
10:20:25 <tinwood> Thoughts?
10:20:53 <tinwood> (we tend to render the default policy file in general, in the charm)
10:21:01 <jamespage> the idea being that UUID's of various standard things could then be used in the policy files
10:21:09 <jamespage> i.e. the admin domain, or the admin project or whatever?
10:21:09 <tinwood> yes
10:21:33 <gnuoy> Why wouldn't we do the templating option?
10:21:45 <tinwood> dmitrii had some use cases: https://review.opendev.org/#/c/604238/3/specs/stein/approved/policy-customization.rst@32
10:22:20 <tinwood> gnuoy, complexity; risk of accidents; less control.
10:22:26 <tinwood> (by charm authors)
10:22:55 <tinwood> i.e. it's the old discussion between config values vs. free for all in config files.
10:23:16 <gnuoy> I think if they are rolling their own policy overrides then they are already in the wild west
10:23:30 <jamespage> well injecting policy increased footgun potential exponentially anyway
10:23:36 <jamespage> gnuoy: snap !
10:23:38 <tinwood> gnuoy, well possibly; I was trying to limit it to things orthogonal to what the charm does.
10:23:44 <gnuoy> I would think templates reduces the risk tbh
10:23:58 <gnuoy> I mis-typed the uuid etc
10:24:19 <tinwood> gnuoy, templates would mean that ANYTHING potentially in a context can end up in an override.
10:24:20 <jamespage> I think if we add template support as part of the feature, then it needs to be well documented and clear what can be used
10:24:31 <gnuoy> tinwood, shrug
10:24:32 <jamespage> I would constrain the scope
10:24:45 <gnuoy> I don't think I mind that tbh
10:24:46 <jamespage> i.e. have a specific context for the policy.d templates
10:24:54 <tinwood> jamespage, that's a bit "how long is a piece of string" though; it's hard to control once its out there.
10:25:22 <tinwood> So there's two bits; charm-helpers, and how a charm implements it.
10:25:40 <tinwood> We can put templating in charm-helpers, and not use it, or use it selectively in each charm
10:25:53 <tinwood> (but it feels a bit like gold plating :)
10:26:16 <tinwood> I'm happy either way, tbh
10:26:34 <jamespage> I guess some actual examples of policices from end-users would be useful here.
10:26:44 <jamespage> maybe we can get those
10:27:12 <jamespage> lets park a decision for now and see if we can find out some good examples to make the requirement concrete rather than 'we might need'
10:27:20 <jamespage> tinwood: does that sound OK?
10:27:29 <tinwood> Sounds good; can I just add to refs here now
10:27:36 <jamespage> yup
10:27:51 <tinwood> Original policy concept: https://review.opendev.org/#/c/604238/3/specs/stein/approved/policy-customization.rst@32  (for charms)
10:28:09 <tinwood> Bug with some more use cases: https://bugs.launchpad.net/charm-nova-compute/+bug/1688612
10:28:10 <openstack> Launchpad bug 1688612 in OpenStack nova-compute charm "feature: read-only users within openstack" [Wishlist,Triaged]
10:28:20 <tinwood> I'll gather these into the spec.
10:28:30 <tinwood> (me done)
10:28:38 <jamespage> ta
10:28:46 <jamespage> #topic Next Chair
10:28:49 <jamespage> is gnuoy!
10:28:55 <jamespage> #endmeeting