17:00:02 <beisner> #startmeeting charms
17:00:03 <openstack> Meeting started Mon Jul 22 17:00:02 2019 UTC and is due to finish in 60 minutes.  The chair is beisner. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:07 <openstack> The meeting name has been set to 'charms'
17:00:26 <beisner> hi, all.  thanks for joining the openstack-charms irc mtg.
17:00:32 <icey> o/
17:00:35 <beisner> #topic Review ACTION points from previous meeting
17:00:54 <beisner> We had a couple of items from last time:
17:00:56 <beisner> #link https://bugs.launchpad.net/charm-neutron-api/+bug/1830536
17:00:58 <openstack> Launchpad bug 1830536 in OpenStack neutron-api charm "All users with the admin role are cloud admins" [Critical,Fix committed] - Assigned to Liam Young (gnuoy)
17:01:13 <beisner> merged, fix-committed.  thank you gnuoy et al
17:01:32 <beisner> #link https://bugs.launchpad.net/bugs/1832021
17:01:32 <openstack> Launchpad bug 1832021 in neutron "Checksum drop of metadata traffic on isolated networks with DPDK" [Medium,New]
17:02:04 <beisner> same, looks to be merged
17:03:23 <coreycb> o/
17:03:31 <beisner> anything else to review from last time?
17:03:46 <beisner> #topic State of Development for next Charm Release
17:03:49 <coreycb> i don't think so
17:03:58 <beisner> we are in feature freeze for OpenStack Charms
17:04:24 <beisner> functional test and scenario test validation is underway;  as is end-to-end release integration testing as always.
17:05:04 <beisner> charm release may be delayed 1-2 days (best guess at this point) based on a couple of outstanding bugs, and the required validation following their resolution
17:05:35 <beisner> anything to add to the charm release currently underway?
17:06:10 <beisner> #topic High Priority Bugs
17:06:18 * beisner #link https://bugs.launchpad.net/openstack-charms/+bugs
17:07:18 <beisner> one that jumps out as needing attention:  https://bugs.launchpad.net/charm-nova-cloud-controller/+bug/1813311
17:07:19 <openstack> Launchpad bug 1813311 in OpenStack nova-cloud-controller charm "VIP does not get set in hacluster" [High,New]
17:08:48 <beisner> looks like the reporter uploaded the example bundle, and it's back to us to interpret that, see if there are any items out of place, and try to confirm.
17:08:50 <beisner> any takers?
17:10:02 <beisner> #action beisner to find bug owner for lp1813311 out-of-band
17:10:19 <beisner> next
17:10:22 <beisner> #link http://tinyurl.com/charm-stable-backports
17:10:59 <beisner> n/a, release is imminent
17:11:08 <beisner> #link https://tinyurl.com/osc-critical-bugs
17:11:58 <beisner> adding "scaleback" tag to the one that jumps out of that list ^
17:11:58 <beisner> https://bugs.launchpad.net/charm-rabbitmq-server/+bug/1818260
17:11:59 <openstack> Launchpad bug 1818260 in OpenStack rabbitmq-server charm "forget cluster node failed during cluster-relation-changed hook" [Critical,Triaged] - Assigned to David Ames (thedac)
17:12:43 <beisner> There is an effort brewing to tag scaleback bugs (remove unit, shrink cluster size) and once we have a better view on the whole, we will make a plan to address them.
17:12:50 <beisner> #link https://tinyurl.com/osc-high-priority
17:13:51 <beisner> We have plenty of bugs triaged @ high, need to make sure everyone is doing bug rotas and aiming to pick off some of these.  (Call for action to all)
17:14:00 <beisner> Any other updates on bugs?
17:14:01 <tinwood> kk
17:14:06 <beisner> tia
17:14:19 <beisner> appreciate all the effort on crits etc. of course!
17:14:28 <beisner> #topic Openstack Events
17:14:43 <beisner> Shanghai OpenInfra + PTG planning is underway
17:14:55 <icey> There's an OpenInfra Nordics thing coming up
17:15:03 <beisner> charms team will have people present, attendees tba.  I will be there @ Shanghai for the full duration.
17:15:21 <beisner> Ah yes, anyone attending the OI Nordics event?
17:15:53 <beisner> I recall seeing some talks proposed, but I don't think we have any on the final agenda for charmers.
17:16:16 <beisner> Thanks to everyone who continues to brainstorm interesting ideas and stories for these events.  Please keep at it.
17:16:23 <beisner> #topic Open Discussion
17:16:54 <coreycb> one thing if anyone has cycles https://review.opendev.org/#/c/670622/ https://review.opendev.org/#/c/670620
17:17:04 <coreycb> just need a +1 on approach, don't need to land
17:17:07 <coreycb> or -1
17:17:13 <beisner> ah ok on that
17:17:25 <coreycb> thanks
17:17:28 <beisner> I noticed that some 3rd party ci bits will need to change so that osci will pass
17:17:59 <coreycb> yes, happy to help with that if needed. i think something was dependent on an envlist target.
17:18:21 <beisner> but I would ask that we get at least 1 or 2 other charmers to review the changes in https://review.opendev.org/#/c/670622/ https://review.opendev.org/#/c/670620 -- ignore osci failure for now, that is due to rigidness in 3rd party ci.
17:18:39 <icey> I'll look as well
17:18:49 <beisner> thanks for the proposed changes there.  on the whole, i think it makes sense.  we just need to make sure all of the machinery is in place.
17:19:03 <coreycb> icey: beisner: thanks, yep sounds good
17:19:09 <beisner> Anything else for today?
17:19:33 <coreycb> nothing here, thanks beisner
17:19:34 <beisner> If not, I owe the rotation another chair, so:
17:19:35 <beisner> #topic Next Chair beisner
17:19:46 <beisner> Thanks, all
17:19:49 <beisner> #endmeeting