10:03:33 <jamespage> #startmeeting charms
10:03:34 <openstack> Meeting started Mon Jan 30 10:03:33 2017 UTC and is due to finish in 60 minutes.  The chair is jamespage. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:03:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:03:37 <openstack> The meeting name has been set to 'charms'
10:03:42 <jamespage> hi folks
10:03:56 <jamespage> so this is the first run for the earlier meeting slot - lets see how this goes
10:04:00 * jamespage reads previous
10:04:26 <jamespage> #topic Review ACTION points from previous meeting
10:04:35 <jamespage> jamespage    talk py27 retirement with tc as ptl
10:04:49 <jamespage> carry that forward still - hoping to chat with folks about that at the PTG
10:04:58 <jamespage> #action jamespage  to  talk py27 retirement with tc as ptl
10:05:04 <jamespage> cholcombe    close out bugs against ceph-fs
10:05:23 <jamespage> as cholcombe won't be at this slot, lets carry that forwards but I'm pretty sure he's close
10:05:24 <gnuoy> I think he just had one left
10:05:28 <jamespage> #action cholcombe    close out bugs against ceph-fs
10:05:36 <jamespage> #topic State of Development for next Charm Release
10:05:48 <jamespage> reminder on dates
10:06:04 <jamespage> Feb 9 - feature freeze - new features must be landed by this date
10:06:10 <jamespage> Feb 23 will be the charm release date
10:06:38 <jamespage> in terms of new features I think we have some work to complete on the new charms in terms of functional tests
10:06:58 <jamespage> and I know that huats is working on the functional tests for the cloudkitty charm, so hopefully we can include that as wll
10:07:32 <jamespage> I'm also working on a feature to support domain specific backends in the keystone charm; I anticipate that the changes for keystone will land this week
10:07:45 <jamespage> with a new keystone-ldap backend charm in the pipe for freeze day as well
10:08:01 <jamespage> BUT I would say a few of us have travel and conference commitments over the next 10 days or so
10:08:07 <jamespage> so that might be tight!
10:08:18 <jamespage> gnuoy, tinwood: anything else to add?
10:08:20 <gnuoy> I'm going to finally move the charm templating stuff upstream
10:08:29 <jamespage> \o/
10:09:05 <tinwood> I'm still circling the manila templating stuff, but I'm a bit pushed for time.  Hope so.
10:09:40 <jamespage> lets get a baseline in first, and then we can iterate on new templates
10:10:02 <jamespage> I was going todo one for keystonebackends but then realized that ldap is pretty much the only one :-)
10:10:24 <jamespage> #topic High Priority Bugs
10:10:33 <tinwood> :)
10:10:50 <tinwood> (not :) to high priority bugs btw)
10:11:21 <jamespage> OK so current breakdown is that we have 4 critical and 71 high priority bugs open still (that excludes anything fix committed btw)
10:11:46 <jamespage> thursday is a bug day so maybe we can get some traction on that subset of the bug base
10:12:23 <gnuoy> yay for bug day
10:12:39 <jamespage> we're still getting a general tickover of new bugs entering the queue so please remember to try to spend some time each week looking at new bugs please
10:12:56 <tinwood> sure thing
10:13:15 <gnuoy> ack
10:13:16 <jamespage> link to LP is in the topic in #openstack-charms
10:13:28 <jamespage> #topic Openstack Events
10:13:30 <jamespage> OKIES
10:13:46 <jamespage> so we have FOSDEM and ConfigMangement camp coming up over the weekend and next week
10:14:00 <gnuoy> I'll be at ConfigMangement camp
10:14:04 <tinwood> Mee too
10:14:07 <jamespage> I'l speaking at FOSDEM on LXD + Nova-LXD with stgraber on saurday
10:14:23 <jamespage> and we have sessions scheduled in the Juju track at configmangement camp so see you all there!
10:14:33 <jamespage> and then the PTG is three weeks away
10:14:48 <jamespage> #action jamespage to send out etherpad link to list for charms planning for mon/tues
10:15:05 <jamespage> #action all - brainstorm ideas so we can come up with a scheduler and objectives for the PTG
10:15:20 <jamespage> #topic Open Discussion
10:15:25 <jamespage> floor is open
10:15:34 <tinwood> gnuoy and me are doing a workshop on writing better charms at cfgmgmtcamp
10:15:40 <tinwood> On the Tuesday.
10:15:52 <tinwood> It's an interactive workshop.  Should be fun.
10:15:55 <gnuoy> I shall be tinwood debbie mcgee
10:16:02 <tinwood> :)
10:16:29 <gnuoy> s/tinwood/tinwoods/
10:20:20 <gnuoy> jamespage, are we done with the open chat?
10:20:34 <jamespage> #endmeeting