17:00:44 <gnuoy> #startmeeting charms
17:00:45 <openstack> Meeting started Mon Sep 19 17:00:44 2016 UTC and is due to finish in 60 minutes.  The chair is gnuoy. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:47 <cargonza> o/
17:00:48 <openstack> The meeting name has been set to 'charms'
17:01:05 <tinwood> o/
17:01:11 <gnuoy> I'm standing in for the PTL until he pops along
17:01:17 <gnuoy> #topic Review ACTION points from previous meeting
17:01:23 <gnuoy> #subtopic tinwood to update charm guide with refactored charms_openstack bits
17:01:34 <beisner> o/
17:01:44 <gnuoy> tinwood, I was wondering if I could take that action if you haven't done it?
17:02:00 <tinwood> sure; I was away so couldn't get to it.
17:02:18 <gnuoy> #action gnuoy update charm guide with refactored charms_openstack bits
17:02:31 <gnuoy> #subtopic jamespage to review current newton specs against plan
17:02:45 <gnuoy> Lets circle back to that when he arrives
17:02:57 <jamespage> o/
17:02:59 <wolsen> o/
17:03:01 <jamespage> sorry I'm late
17:03:08 <gnuoy> ah, here he is
17:03:30 <gnuoy> jamespage, : jamespage to review current newton specs against plan
17:03:41 <gnuoy> reviewing action from previous meeting ^
17:03:46 <jamespage> yeah carry that forward pls
17:03:55 <gnuoy> #chair jamespage
17:03:56 <openstack> Current chairs: gnuoy jamespage
17:04:03 <jamespage> ta
17:04:12 <gnuoy> #action jamespage  review current newton specs against plan
17:04:14 <jamespage> was that it for previous actions?
17:04:21 <gnuoy> jamespage, yep
17:05:08 <jamespage> #topic State of Development for next Charm Release
17:05:28 <gnuoy> The Freeze it is a comin
17:05:32 <jamespage> ok so headlines - feature freeze is week on thursday - 29th september;  bugfixes only past that date
17:05:58 <icey> Winter is coming
17:06:15 <jamespage> so features need to be reviewed and landed by the end of 29th
17:06:30 <jamespage> anything past that - apply for a feature freeze on the openstack-dev ML
17:06:44 <jamespage> [charms] feature freeze exception: <name>
17:06:46 <beisner> or work on tests, we can still land tests :-)
17:06:53 <jamespage> thats true
17:07:09 <jamespage> I have one more cross charm feature to land:
17:07:13 <jamespage> #link https://review.openstack.org/#/c/372548
17:07:23 <tinwood> technically, it's not a feature unless it has tests :)
17:07:25 <gnuoy> ah yes
17:07:26 <jamespage> that's the proof - sets the application version for a deployed charm
17:08:18 <beisner> I sent a mail to the list a while back about removing tests/charmhelpers and pulling that into the test's venv instead.  Anyone have a chance to think about that or look at it?  the one poc is merge-conflict atm, but principle remains workable.
17:08:28 <jamespage> also don't forget its 16.10 bug squash day on thursday
17:08:31 <beisner> it removes 2K lines of cargo-code
17:08:35 <beisner> per repo
17:08:41 <jamespage> beisner, hmm - I'll have to dig that out but in principle +1
17:08:53 <jamespage> charms on a diet - nice
17:09:10 <beisner> it'd be one more stable/master bit to flip every time we release, but, sed.
17:09:48 <jamespage> beisner, if you have cycles to refresh, I'll review
17:10:03 <jamespage> ok next up
17:10:06 <beisner> ok i'll rebase and update, will circulate the poc when ready.  thx
17:10:11 <jamespage> #topic High Priority Bugs
17:10:27 <jamespage> anything nasty biting us atm? I'm aware of a few ks v3 compat issues
17:10:44 <gnuoy> swift-proxy and ceilometer are having keystone v3 headaches
17:11:01 <gnuoy> jamespage, fwiw we skipped a small agenda item
17:11:10 <gnuoy> "Rotate the chair"
17:11:17 <jamespage> oh sorry
17:11:20 <gnuoy> np
17:11:26 <jamespage> did I do the last one as well?
17:11:33 <jamespage> ok we should rotate things
17:11:43 * beisner spins around
17:11:57 <gnuoy> Shall we stick names in https://etherpad.openstack.org/p/openstack-charms-weekly-meeting and just pop off the list
17:12:05 <jamespage> gnuoy, +1
17:12:17 <gnuoy> kk
17:12:24 <tinwood> +1
17:12:40 <jamespage> gnuoy, can you populate the list and pop me off the top please?
17:12:49 <gnuoy> will do
17:12:54 <jamespage> #action gnuoy to make list of chairs and schedule
17:13:23 <jamespage> I'm also aware of two bugs in the storage charms - cholcombe and icey will be looking into those
17:13:40 <jamespage> specifically pruning osd and swift storage devices from updatedb
17:13:49 <cholcombe> jamespage, right
17:13:49 <jamespage> and tweak the scheduler for osd devices
17:13:59 <cholcombe> should be pretty small changes
17:14:00 <jamespage> cholcombe, great!
17:14:09 <jamespage> yeah - quick wins to largish problems IMHO
17:14:21 <sdake> i see i was paged anything relating to this meeting?
17:14:30 <jamespage> cholcombe, lets make sure we cover the charm upgrade use-case
17:14:36 <jamespage> sdake, I don't think so
17:14:44 <sdake> jamespage roger thanks
17:14:45 <cholcombe> jamespage, sounds good
17:14:59 <jamespage> #topic OpenStack Events
17:15:08 <jamespage> well one largish one on the horizon
17:15:13 <jamespage> https://etherpad.openstack.org/p/ocata-charm-summit-planning
17:15:30 <jamespage> I've added some items for our fishbowl sessions; we also have two workroom sessions scheduler
17:15:49 <jamespage> my feel is we could give one fishbowl back atm unless we can think of other things that need discussing?
17:16:13 <jamespage> thoughts?
17:16:26 <tinwood> How long is a fishbowl?  25 mins?
17:16:37 <tinwood> 35?
17:17:22 <jamespage> 40 minutes
17:17:31 <gnuoy> jamespage, in my experience they can very easily get bogged down so its v. hard to tell
17:17:33 <jamespage> we're at about 55 mins timeboxed atm
17:17:40 <jamespage> ok lets stick with two slots then
17:17:51 <jamespage> they are back to back on the wednesday afternoon atm
17:18:07 <tinwood> yes, I was thinking that a couple of those topics could spiral.
17:18:52 <jamespage> moving on
17:19:01 <jamespage> #topic Open Discussion
17:19:21 <jamespage> bad luck - you're stuck with me as PTL for the ocata cycle ;)
17:19:29 <tinwood> :)
17:19:30 <gnuoy> \o/
17:19:34 <wolsen> :)
17:19:44 <beisner> congrats, jamespage :)
17:19:44 <thedac> whew!
17:19:57 <icey> grats!
17:20:20 <jamespage> well it was by default - seat was uncontested
17:20:36 <gnuoy> I've added the people here on to the list of chairs for this meeting in the etherpad. Please take yourself off if you so desire
17:20:58 <jamespage> looks like gnuoy is up in two weeks time
17:21:07 <gnuoy> yep
17:21:16 <jamespage> speaking of which -do you think we should get that second slot on the other week?
17:21:38 <jamespage> I'd be up for that - we could do weekly imho?
17:21:52 <gnuoy> an APAC friendly slot?
17:22:10 <jamespage> yeah - that was my thinking
17:22:26 <jamespage> it might be quiet to start with, but we have a few users and contributors in asia now
17:22:42 <gnuoy> sure, we can give it a go
17:22:55 <wolsen> I think there are definitely a few folks in the AP timeslot who would like that
17:22:55 <jamespage> #action jamespage to identity alternate week slot and get scheduled
17:23:03 <jamespage> wolsen, awesome
17:23:12 <jamespage> ok anything else?
17:23:23 <wolsen> jamespage: when you pick a timeslot, I'll broadcast to the crew I know of
17:23:31 <jamespage> wolsen, excellent
17:23:45 <jamespage> ok so
17:23:48 <jamespage> #endmeeting