17:03:19 <jamespage> #startmeeting charms
17:03:20 <openstack> Meeting started Mon Sep  5 17:03:19 2016 UTC and is due to finish in 60 minutes.  The chair is jamespage. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:23 <openstack> The meeting name has been set to 'charms'
17:03:25 <jamespage> might be a quiet one today
17:03:41 <jamespage> https://etherpad.openstack.org/p/openstack-charms-weekly-meeting-20160905
17:03:50 <jamespage> #topic Review ACTION points from previous meeting
17:03:56 <jamespage> jamespage include the openstack-on-lxd README as a section in dev guide
17:04:06 <jamespage> that's still WIP - I parked it last week for a bit
17:04:12 <jamespage> jamespage Discuss future of g-ss-s charm
17:04:47 <jamespage> some discussion on that - we need to plan for the work to make it part of glance, but right now we need to adopt the current codebase in full as there are alot of challenges atm
17:04:53 <jamespage> jamespage request Barcelona Design Summit slots
17:05:03 <jamespage> I requested our slots - we need to plan to fill them
17:05:08 <jamespage> https://etherpad.openstack.org/p/ocata-charm-summit-planning
17:05:13 <jamespage> #link https://etherpad.openstack.org/p/ocata-charm-summit-planning
17:05:27 <jamespage> #topic State of Development for next Charm Release
17:06:13 <gnuoy> jamespage, I don;t think the 2nd item on there isn't quiet true
17:06:23 <jamespage> gnuoy, no?
17:06:36 <jamespage> what's your take?
17:07:21 <gnuoy> jamespage, oh, I'm getting myself confused. Its the dashboard that can now be related to a db for cookie storage. ignore me
17:07:29 <jamespage> np
17:07:37 <jamespage> okies
17:07:50 <jamespage> I find myself without the link for high priority bugs...
17:08:13 <gnuoy> jamespage, we've recently just been asking if anyone is dealing with any nasties
17:08:21 <jamespage> oh and I'm ahead of things anyway
17:08:29 <jamespage> ok state of development
17:09:00 <gnuoy> I'm working on generating some cookie-cutter charms to make SDN development easier
17:09:06 <jamespage> we're a way off freeze yet but we need to maintain velocity; I need to take a run through the approved specs to see what's still outstanding as well
17:09:08 <jamespage> gnuoy, +1
17:09:28 <jamespage> #action jamespage to review current newton specs against plan
17:09:36 <tinwood> I've simplified how to use charms.openstack to build new charms.
17:09:43 <jamespage> tinwood, nice work tinwood
17:09:44 <tinwood> well it's WIP still, but very close.
17:09:57 <jamespage> tinwood, can I action you with charm guide updates when that's landed?
17:10:07 <tinwood> yes, happy to.  i was thinking of that too.
17:10:26 <jamespage> #action tinwood to update charm guide with refactored charms_openstack bits
17:10:45 <jamespage> #topic High Priority Bugs
17:10:49 <jamespage> OK I had a nasty one
17:11:08 <jamespage> bug 1618321
17:11:08 <openstack> bug 1618321 in nova-cloud-controller (Juju Charms Collection) "mysql shared-db relation not creating successfully under certain conditions" [Critical,Fix committed] https://launchpad.net/bugs/1618321 - Assigned to James Page (james-page)
17:11:36 <jamespage> That's fixed in the master branch; pending smoke test failure resolution in OSCI before we land the cherry pick for stable branch
17:11:42 <jamespage> anyone else aware of anything nasty?
17:11:51 <tinwood> nope
17:11:56 <gnuoy> jamespage, how's the, juju hostname too long one?
17:13:07 <jamespage> https://bugs.launchpad.net/juju/+bug/1615601
17:13:07 <openstack> Launchpad bug 1615601 in juju "2.0 beta 14 + openstack: generated hostnames exceed 255 byte limit" [High,Triaged]
17:13:14 <jamespage> still outstanding afaict
17:13:25 <jamespage> scheduled for juju 2.0 but alot is
17:13:50 <jamespage> #topic Openstack Events
17:13:55 <jamespage> ok so summit not far off
17:14:16 <jamespage> my talk submissions got rejected, so just on a panel about distribution methods \o/
17:14:30 <jamespage> I've submitted out request for fishbowl and workroom sessions
17:14:34 <jamespage> we'll see what we get
17:14:47 <tinwood> okay.  sounds interesting
17:14:50 <jamespage> need to give those some thought - please can people
17:14:52 <jamespage> #link https://etherpad.openstack.org/p/ocata-charm-summit-planning
17:15:15 <jamespage> add to that pad on ideas for discussion for next cycle; I put some in already based on things we need todo across the charms
17:16:27 <tinwood> is it a 'anything we can think of' and then whittle it down thing?
17:16:47 <jamespage> yeah that's ok for now
17:17:02 <jamespage> #topic Open Discussion
17:17:07 <jamespage> okies so anything else?
17:17:22 <tinwood> nope, I'm good.
17:17:28 <jamespage> gnuoy, ?
17:17:33 <gnuoy> not from me
17:17:38 <jamespage> okies
17:17:40 <jamespage> #endmeeting