17:02:30 <thedac> #startmeeting charms
17:02:31 <openstack> Meeting started Mon Aug  8 17:02:30 2016 UTC and is due to finish in 60 minutes.  The chair is thedac. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:34 <openstack> The meeting name has been set to 'charms'
17:02:38 <thedac> #topic Review ACTION points from previous meeting
17:02:38 <jamespage> o/
17:02:55 <jamespage> gnuoy completed his action but we need to revisit
17:03:06 <jamespage> (which was to email heidi about mascots)
17:03:21 <thedac> Do we need a vote on a mascot?
17:03:27 <tinwood> I think so.
17:03:47 <jamespage> yeah - I added some new ideas to the pad
17:03:53 <jamespage> https://etherpad.openstack.org/p/openstack-charms-weekly-meeting-20160808
17:04:02 <tinwood> I quite like orangutan -- it's orange.
17:04:11 <tinwood> Or do we want purple.
17:04:18 <jamespage> orange is good
17:04:22 <icey> agreed
17:04:30 <jamespage> super clever, very strong :-)
17:05:04 <beisner> warthog?
17:05:07 <jamespage> thedac, can I suggest that people here do the following
17:05:09 <beisner> ;-)
17:05:11 <jamespage> +3 on most liked
17:05:16 <jamespage> +2
17:05:17 <jamespage> +1
17:05:29 <jamespage> do that on the pad, then we can move on :)
17:05:37 <thedac> sounds good
17:05:38 <tinwood> Okay, sounds good.
17:05:44 <jamespage> yeah - add more if you like
17:06:31 <icey> also, note: we can change our user names by expanding the users icon
17:06:36 <icey> on the pad
17:06:41 <jamespage> I'm done
17:06:57 <coreycb> done
17:07:04 <tinwood> Done.
17:07:05 <thedac> Currently orangutan 11 warthog 10. Anyone want to change a vote?
17:07:06 <icey> done
17:07:39 <thedac> orangutan 14 looks like the winner
17:07:42 <thedac> going once
17:07:59 <thedac> sold to the orange orangutan
17:08:07 <jamespage> okies
17:08:17 <coreycb> wait it's tied
17:08:37 <jamespage> lol
17:08:38 <thedac> coreycb: is correct
17:08:47 <beisner> is there a coin-flip bot?
17:08:51 <coreycb> ha
17:09:00 <tinwood> ptl?
17:09:11 <jamespage> that sounds like it might be my job
17:09:12 <tinwood> or a vote between them.
17:09:17 <thedac> We could do a second vote with just the two options
17:09:23 <jamespage> ok
17:09:31 <jamespage> simple +1 on each then
17:10:24 <thedac> currently tied again. Anyone else?
17:10:25 * coreycb hopes there's an odd number of us
17:10:28 <icey> looks like we have 6 / 7 people voting, with an even split
17:10:37 <tinwood> carried
17:10:57 <jamespage> orangutan then warthog right?
17:11:01 <icey> aye
17:11:05 <thedac> yes
17:11:08 <tinwood> Yes, looks like that
17:11:17 <jamespage> thedac, action me
17:11:41 <thedac> #action jamespage Set charm team mascot: orgutan then warthog
17:12:00 <thedac> Moving on
17:12:05 <thedac> #topic State of Development for next Charm Release
17:12:23 <beisner> jamespage, I'd like to propose that we add thedac to the charms-release group so that he can officially take part in the charm release process.  Currently, jamespage, gnuoy and I are members.  I refrained from jfdi during 16.07 release as we're a proper project with meetings and stuff.
17:12:51 <jamespage> beisner, that's cool - can you propose him on the list please
17:13:01 <beisner> jamespage, the ml yah?
17:13:15 <jamespage> beisner, yp
17:13:22 <beisner> will do thx
17:13:28 <jamespage> openstack-dev [charms] nominating thedac for charms-release team
17:13:48 <thedac> Should I action that
17:14:14 <thedac> #action beisner Nominate thedac for charms-release group
17:14:28 <jamespage> yp
17:14:35 <thedac> regarding the next charms release:
17:14:43 <thedac> We will be working on a new manilla charm
17:14:53 <thedac> Anything else to highlight?
17:15:06 <jamespage> oh yes - tinwood and I discussed the softhsm charm earlier
17:15:13 <tinwood> indeed.
17:15:20 <jamespage> we're going to park that for now - the versions of openssl in xenial are to old to make it work
17:15:33 <jamespage> so for testing we'll have to rely on the build-in crypto
17:15:49 <tinwood> which does work.
17:15:50 <jamespage> not ideal but at least that is tested as part of barbican (unlike softhsm)
17:16:16 <tinwood> We do need to find a real HSM to test with at some point.
17:16:22 <jamespage> agreed
17:16:39 <cargonza> make sure we budget for it...
17:16:45 <cargonza> or borrow from someone
17:16:57 <tinwood> Also, I killed myself on softhsm ... :I
17:17:05 <thedac> heh
17:17:21 <beisner> should we pull softhsm from the charm store next space?
17:17:47 <beisner> or just leave it as ongoing dev (unreleased unstable)?
17:17:50 <tinwood> It'll install and I can drop the API test so it 'tests'.
17:18:36 <thedac> Anything else to add to next release discussion
17:18:57 <thedac> ok, moving on
17:19:00 <thedac> #topic High Priority Bugs
17:20:10 <thedac> I am not finding our bugs link. Any particular bugs we need to highlight?
17:20:11 <beisner> so we had a batch of stable charm backports following 16.07 release to address a regression.  can we get a pointer to that bug?  i'd like to eval the test scenarios to make sure we have coverage there.
17:20:23 <beisner> ceph*
17:20:41 <cargonza> I think this is it...
17:20:41 <cargonza> https://bugs.launchpad.net/charms/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.component-empty-marker=1&field.tag=openstack&field.tags_combinator=ANY&field.status_upstream-empty-marker=1&field.has_cve.used=&
17:20:41 <cargonza> field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_no_package.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
17:20:46 <cargonza> crap sorry
17:21:51 <thedac> beisner: who did those backports? Are they in the meeting to piont us to that bug?
17:21:57 <jamespage> might have been me
17:22:01 <jamespage> was that for the /0 issue
17:22:02 <jamespage> ?
17:22:23 <jamespage> bug 1607961
17:22:23 <openstack> bug 1607961 in ceph-mon (Juju Charms Collection) "missing keyring, Couldn't init storage provider" [High,Fix released] https://launchpad.net/bugs/1607961 - Assigned to James Page (james-page)
17:22:27 <beisner> https://bugs.launchpad.net/bugs/1607961  &  https://review.openstack.org/#/q/topic:stable/bug/1607961  i believe
17:23:22 <jamespage> beisner, issue was with a 3 OSD cluster
17:23:52 <thedac> Any other bugs to bring up?
17:23:56 <jamespage> nope
17:24:03 <thedac> #topic Openstack Events
17:24:20 <thedac> ODS in October
17:24:40 <cargonza> still working on charm school - no specifics yet
17:25:07 <thedac> Any other events coming up?
17:25:29 <cargonza> Openstack East in NYC
17:25:45 <cargonza> 8/23-8/24
17:26:11 <thedac> Moving on
17:26:13 <thedac> #topic Open Discussion
17:26:24 <thedac> The floor is open
17:26:37 <thedac> Is there more to discuss on softhsm?
17:26:39 <tinwood> My issue has already been discussed
17:26:40 <jamespage> I'm not around next week - but back in the week after
17:26:49 <icey> I'm also out next week
17:27:06 <jamespage> as gnuoy is away as well I'll need a different volunteer for PTL deputy for the week - thedac?
17:27:16 <coreycb> was the release mentioned in channel since the last meeting?
17:27:22 <jamespage> I'll notify on openstack-dev if that is ok
17:27:39 <thedac> sure, I just need to know what my responsibilities are
17:27:59 <thedac> coreycb: Good point
17:28:26 <thedac> 16.07 was relased
17:28:30 <thedac> released
17:28:30 <coreycb> :)
17:28:31 <jamespage> \o/
17:28:35 <beisner> :-)
17:28:37 <jamespage> well done all
17:28:41 <tinwood> \o/
17:28:55 <thedac> Any other open discussion items?
17:29:25 <thedac> ok, that's a wrap
17:29:27 <thedac> #endmeeting