15:02:25 <gordc> #startmeeting ceilometer
15:02:28 <jd__> o/
15:02:29 <ildikov> o/
15:02:29 <idegtiarov> hi!
15:02:30 <openstack> Meeting started Thu Oct  1 15:02:25 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:34 <openstack> The meeting name has been set to 'ceilometer'
15:02:40 <KrishR> o/
15:02:44 <jasonamyers> o/
15:02:51 <r-mibu> o/
15:02:57 <cdent> o/
15:03:18 <gordc> hm... we can start i guess.
15:03:32 <gordc> #topic liberty-rc2 status
15:03:34 <pradk> o/
15:04:04 <gordc> just a headsup, around middle of next week we'll cut a rc2 release to get the final translation packages in for liberty
15:04:22 <eglynn> o/ (... late as per usual)
15:04:37 <gordc> we can also include any major blocking items in so if you find anything please let me know so i know to target it against rc2
15:04:52 <gordc> we also can put in super trivial items as well
15:05:19 <gordc> that's pretty much only update on rc2, any questions/comments?
15:05:50 <gordc> #topic deprecation project tag
15:06:19 <gordc> this is to discuss the new fun tag that was created recently
15:06:22 <gordc> http://governance.openstack.org/reference/tags/assert_follows-standard-deprecation.html
15:06:40 <gordc> we have the option of opting in and following the deprecation rules
15:07:08 <gordc> the basic overview is that any feature must be deprecated a full cycle before being removed...
15:07:14 <jd__> I think we want to opt-in but as it is currently written it's not a good fit
15:07:20 <gordc> something we go above and beyond already
15:07:21 <jd__> we went over that with gordc already
15:07:35 <gordc> jd__: right.
15:07:41 <jd__> the 3 months delay thing is not really clear or it's useless, one of that
15:08:10 <gordc> so there's also another clause which says it must be deprecated 3 months before removal.
15:08:26 <gordc> ie. if you deprecated in L-3, you can only remove in M-1
15:08:44 <jd__> that's the clause I'm talking about
15:08:56 <jd__> which does not make much sense AFAIU
15:09:20 <cdent> that is a weird clause
15:09:29 <gordc> right. to be honest, is annoying but it's not a huge deal for me. you should just need hold off for a bit
15:09:40 <jd__> right
15:10:01 <jd__> so we apply to the tag and we just forget this rule?
15:10:06 <jd__> :D
15:10:14 <cdent> but it is so fun to start a cycle by removing a bunch of stuff
15:10:18 <gordc> cdent: jd__: i believe the idea was to ensure those using the interim x-1, x-2, x-3 builds aren't broken
15:10:50 <gordc> cdent: yeah. i think we already have a crapload of stuff we can remove already see: alarms
15:11:00 <jd__> gordc: except some projects don't do interim releases
15:11:07 <jd__> and I imagine someday Ceilometer will stop too
15:11:15 <gordc> jd__: i guess that don't reflect them.
15:11:23 <jd__> #bigtentfail
15:11:28 <gordc> jd__: i can't speak for 6 months from now.
15:11:37 * jd__ nods
15:11:42 <gordc> re: release process
15:12:06 <jd__> gordc: I think you can explain that to the TC during the next meeting or whatever?
15:12:06 <gordc> to play nice with the community and it's tags, are we all ok to opt into this?
15:12:21 <gordc> jd__: explain what?
15:12:42 <jd__> that the 3 months rule suck?
15:13:35 <gordc> i reserve my complaining to offline.
15:13:54 <gordc> you can if you win tc ;)
15:13:57 <ildikov> some timeframe is needed for deprecation anyway, but well, specifying it in months is "interesting"
15:14:06 <jd__> yeah
15:14:22 <jd__> np gordc you'll just have to deal with me grumbling from time to time then :p
15:15:01 <gordc> ildikov: yeah. i figure we should try it and if it becomes a hassle we can always opt out.
15:15:44 <gordc> to be honest, right now it asks for just one full cycle of deprecation... we've been doing over 1cycle deprecation so it is actually easier in some regards
15:16:01 <jd__> good point
15:16:02 <ildikov> gordc: I hope we can comment on that docco later based on experience
15:16:32 <gordc> ildikov: i'm sure you can grumble to tc like jd__ :)
15:16:37 <ildikov> gordc: regarding API, etc we were discussing two cycles, so 1 does not sound that bad
15:16:45 <ildikov> gordc: LOL :)
15:16:53 <jd__> Team Grumble
15:17:00 <gordc> lol
15:17:19 <jd__> we could send a patch to the tag repo I guess, but that's likely more work I want to push into that system
15:17:31 <jd__> more work than what*
15:17:54 <jd__> I guess we can move on gordc :)
15:17:59 <gordc> jd__: agree. we can start patching if we find it to be super annoying in real life
15:18:15 <gordc> jd__: works for me... we need a vote or everyone cool?
15:18:26 <jd__> who's completely against that idea?
15:18:37 <jd__> nobody, no need to vote I guess :)
15:18:45 <gordc> cool. moving on
15:18:51 * cdent can live with it
15:19:07 <gordc> #action gordc to find out what needs to be done to opt-in
15:19:23 <gordc> #topic ceilometer mentoring
15:19:47 <gordc> i don't know if we have a potential task for gnocchi yet.
15:20:04 <gordc> i think jd__ said he could volunteer, and i'd help if it required too much of his time
15:20:08 <ildikov> gordc: I saw more names with Ceilometer on the list last time
15:20:20 <cdent> Is this outreachy stuff or something else?
15:20:28 <gordc> ildikov: is it only one or more than one we can take?
15:20:35 <gordc> cdent: outreachy stuff
15:20:54 <ildikov> gordc: I think one, or at least I don't think we will have that many mentors
15:20:56 <jd__> I opened a few bugs in Gnocchi that might be low hanging fruit at first
15:21:09 <jd__> we can find bigger things next
15:21:11 <ildikov> gordc: I don't know how the candidate gets selected finally though
15:21:27 <gordc> ildikov: ack.
15:22:05 <gordc> jd__: sounds good. i'll just add details on gnocchi and put yourself and me down as a single mentor
15:22:29 <gordc> if anyone else wants to mentor, feel free to volunteer since there's a lot of candidates apparentl
15:22:32 <gordc> apparently*
15:22:37 <ildikov> gordc: do you know whether we would need to specify the topic now or it can be done later?
15:23:17 <gordc> ildikov: if i recall, you should have a topic so the candidates can figure out if they're really interested or not.
15:23:31 <cdent> WORLD DOMINATION
15:23:36 <gordc> but i can confirm that
15:23:38 <ildikov> gordc: ok, makes sense :)
15:23:47 <gordc> cdent: small dreams
15:24:00 <cdent> s/world/universe/i
15:24:02 <ildikov> gordc: then WORLD PEACE ;)
15:24:20 <gordc> ildikov: dream too big.
15:24:47 <gordc> #topic Open discussion
15:25:12 <cdent> Do we have some "themes" for summit/mitaka?
15:25:35 <cdent> some kind of "here's what we care about" we can lean our thinking towards?
15:26:09 <gordc> cdent: hmm... nope.
15:26:19 <cdent> should we?
15:26:30 <gordc> you have an example? 'streamlining"
15:26:32 <gordc> ?
15:26:40 <pradk> the etherpad kinda gives that based on the topics we added?
15:26:40 <ildikov> can the roadmap serve as the list of items we care about or it's really one thing from that list or anywhere?
15:27:18 <cdent> I don't want to limit what we do to just one thing, but it is nice to have a general idea of where we are caring most: splitting things off, fixing bugs, fixing performance, adding features, whatever
15:27:36 <cdent> liberty kind of started out with splitting things off, and that led to lots of productive conversation
15:27:41 <cdent> and some good change
15:27:41 <cdent> s
15:27:56 <cdent> now it seems like we either need to continue that or consolidate things or...
15:28:03 <cdent> ?
15:28:22 <gordc> cdent: i'm open to anything.
15:28:48 <gordc> we sort of let the vote for topics dictate what our 'themes' then to be
15:29:02 <jd__> we should find something else to split next I guess
15:29:14 <cdent> have enough people provide stuff on the etherpad yet so that we can make with the voting
15:29:14 <ildikov> do we want to wait and see how much this splitting works out longer term and concentarte on smth else as focus point now?
15:29:17 <gordc> jd__: that's an idea in etherpad
15:29:41 <ildikov> have we deprecated our v2 API already BTW?
15:30:17 <ildikov> ... as it will be needed to move towards Gnocchi for instance, I guess we plan to have this step once not in the too far future
15:31:04 <gordc> cdent: we tentatively set deadline for oct 5th
15:31:18 * cdent has no sense of time
15:31:43 <gordc> we don't have anything officially proposed though
15:31:50 <gordc> https://docs.google.com/spreadsheets/d/1ea_P2k1kNy_SILEnC-5Zl61IFhqEOrlZ5L8VY4-xNB0/edit#gid=0
15:32:36 <cdent> gordc: that's kind of what I'm saying: how do we make the leap from the etherpad to the spreadsheet?
15:32:45 <gordc> we should probably have a topic on gnocchi and aodh specifically. i think there already are
15:33:06 <gordc> we need someone to take ownership who whatever they typed in etherpad
15:33:32 * cdent ask himself to do something about his stuff
15:33:34 <gordc> seems like there should be topics on:
15:33:44 <gordc> v2/v3 api
15:33:57 <gordc> aodh - expanding event alarming
15:34:03 <ildikov> we also had some chat with the Monasca guys on alarming
15:36:14 <gordc> i'm going to start copying stuff over from etherpad if we don't get much action soon on google docs.
15:36:22 <gordc> i'll send a reminder email today
15:37:17 <gordc> if we see very few submissions come oct 5th, we can re-evaluate whether we want to delay voting
15:37:25 <gordc> sound good?
15:37:51 <ildikov> gordc: +1
15:37:55 <cdent> +1
15:38:39 <gordc> cool cool
15:39:11 <gordc> jasonamyers: did we want to just have a virtual meetup again? i don't know if you got anymore feedback for January meetup
15:41:14 <gordc> i'll catch up with him later. but if you havne't replied and plan on going, reply asap
15:41:19 <gordc> any other items?
15:41:20 <jasonamyers> I guess
15:41:41 <jasonamyers> no one seems do wanna go to ireland I blame cdent
15:41:53 <cdent> Yeah, it's usually my fault
15:42:03 <gordc> jasonamyers: true true
15:42:05 <jasonamyers> :P
15:42:12 <gordc> final countdown.
15:42:27 <jasonamyers> I say we call it and go virtual
15:43:16 <gordc> jasonamyers: agree. i'll sync up with you afterwards
15:43:24 <gordc> thanks for joining everyone
15:43:28 <jasonamyers> sounds good
15:43:31 <gordc> #endmeeting