15:00:45 <gordc> #startmeeting ceilometer
15:00:45 <openstack> Meeting started Thu Sep 17 15:00:45 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:49 <openstack> The meeting name has been set to 'ceilometer'
15:00:57 <sileht> o/
15:01:04 * gordc hopes for quick meeting
15:01:12 <nijaba> o/
15:01:30 <jasonamyers> o/
15:01:37 <pradk> o/
15:01:46 <ityaptin> o/
15:01:59 <nadya> o/
15:02:35 <jd__> o/
15:02:43 <gordc> cool lets' get started
15:03:00 <gordc> #topic liberty-rc1 status
15:03:00 <liusheng> o/
15:03:19 <gordc> we're currently targetting the beginning of next week for initial rc1 tags
15:03:29 <ildikov> o/
15:03:35 <gordc> this is list of items we're currently aiming for: https://launchpad.net/ceilometer/+milestone/liberty-rc1
15:03:48 <gordc> for reviewers, if you can focus on these items that'd be great
15:04:21 <gordc> if there are any additional items that need to be targeted for rc1 and aren't please let one of the cores know
15:04:34 <gordc> so we don't tag without your patch.
15:04:44 <KrishR> o/
15:04:46 <gordc> are there any items of concern so far in testing?
15:05:09 <gordc> i haven't noticed any huge blockers... some performance tweaks required.
15:05:36 <gordc> i should mention cdent is not here today so he won't fill white space and i'd rather not talk to myself.
15:06:27 <jd__> I'm reading you gordc
15:06:29 <nadya> gordc: you are not alone!
15:06:37 <pradk> :)
15:06:39 <gordc> lol alright.
15:06:54 <gordc> i'm assuming no blockers currently?
15:07:22 <pradk> I havent seen anything specific yet
15:07:30 <ildikov> gordc: no blockers that i would know of and noticed we need focus on reviews listed on Launchpad :)
15:07:50 <gordc> yeah... so please raise asap if anything comes up. early next week is our first deadline.
15:07:51 <ildikov> gordc: we just try to support you in having a short meeting ;)
15:07:55 <gordc> ildikov: :)
15:08:01 <gordc> ok. next topic then.
15:08:31 <gordc> #topic recurring: Gnocchi status
15:08:39 <gordc> anything to update? jd__ ?
15:09:08 <jd__> I just released 1.2.0
15:09:11 <sileht> python-gnocchiclient lives in openstack namespace since yesterday
15:09:25 <jd__> so high five to everyone
15:09:26 <gordc> jd__, sileht: nice!
15:09:46 <ildikov> \o/ :)
15:10:08 <gordc> sileht: is there code in ceilometer that we can pull out? or is gnocchiclient not stable enough?
15:10:25 <sileht> gordc, this is a very light gnocchi client
15:10:37 <sileht> gordc, it can only CRUB archivepolicy and resources
15:10:43 <sileht> gordc, not yet metrics and measurements
15:10:51 <sileht> CRUB/CRUD
15:10:55 <jd__> but that's on roadmap yeah
15:10:58 <gordc> sileht: ok. so we'll aim for M* to refactor gnocchi dispatcher.
15:11:04 <sileht> jd__, of course
15:11:10 <sileht> gordc, yes
15:11:18 <gordc> sounds good folks!
15:12:03 <gordc> #topic ceilometer mentoring
15:12:24 <gordc> this is just an fyi but to follow up on ildikov's mention in previous meeting about mentoring
15:12:48 <gordc> you can sign up to mentor starting next week (sept22 - oct27)
15:12:53 <gordc> more details can be found here: http://lists.openstack.org/pipermail/openstack-dev/2015-September/074399.html
15:13:16 <gordc> so if you'd like to have an extra resource to help with an idea you have, feel free to apply.
15:14:00 <ildikov> gordc: right, thanks for bringing it up!
15:14:01 <gordc> maybe mention it if you think one of the design session proposals are a easy in for a new dev
15:14:08 <jd__> we could have someone on gnocchiclient maybe
15:15:12 <gordc> jd__: yes that's possible. i think the resource will select based on interest so you'll need to sell client work pretty hard.
15:15:39 <ildikov> or I don't know what direction we will move regarding Gnocchi-Ceilo integration, etc. but that can be an area too maybe
15:16:38 * jd__ waits to read APIv3 from ildikov
15:16:40 <gordc> ildikov: right... just wanted to get people thinking about the idea. we have a few weeks but if you have an idea now, applications start next week
15:17:09 <gordc> ildikov: if you have a apiv3 i'm interested too. :)
15:17:10 <ildikov> jd__: wasn't taht the agreement that it will mostly be Gnocchi's API? :)
15:17:23 <jd__> ildikov: s/mostly// :)
15:18:03 <jd__> gordc: I might have some idea but not sure I'll have the time to mentor TBH
15:18:04 <ildikov> jd__: ok, then I guess we just need to clean up from Ceiilo that we don't need anymore, right? ;)
15:18:16 <gordc> jd__: ildikov: it's probably something worth discussing. how we envision the apis existing. metrics, events, alarms.
15:18:17 <jd__> ildikov: what do you think I'm doing! ;)
15:18:32 <gordc> jd__: yes, i believe it requires some commitment.
15:18:34 <ildikov> jd__: ;)
15:18:59 <gordc> i think worse case you can propose an idea and see if another dev has time to mentor
15:19:00 <jd__> gordc: been there
15:19:01 <ildikov> yeap, if definitely needs, this is why I'm in trouble and did not volunteer :(
15:19:26 <jd__> I think the worst thing is that it takes more time than to it takes to do the job
15:19:32 <jd__> and that each time we lost the mentee
15:19:39 <nadya> events may be interesting field
15:20:07 <gordc> jd__: i see... yeah maybe we need to minimise scope of topic.
15:20:33 <nadya> who is mentee usually? student?
15:20:34 <jd__> gordc: I don't think that solves the issues I raised, but I don't know either what the solution might be!
15:20:37 <jd__> just my feedback
15:20:38 <gordc> but yeah not a must have to mentor. just making sure everyone is aware of opporutunity
15:20:47 <jd__> nadya: not necessarily
15:20:58 <jd__> nadya: can be someone looking to start doing programming stuff
15:21:34 <nadya> jd__: they may don't know python?
15:22:05 <gordc> nadya: possibly. i think you need to mention degree of experience required when proposing ideas.
15:22:08 <jd__> nadya: they are supposed to be familiar a bit with Python and OpenStack (they start on their own a bit before to prove they can do some stuff)
15:22:24 <nadya> ok, I see
15:22:34 <ildikov> nadya: I think there should be some minimum requirements, but I would need to check the wiki page again to be sure
15:23:22 <gordc> cool cool. let's open it up for general discussion.
15:23:27 <gordc> #topic open discussion
15:23:47 <llu-laptop> Is there any presentation in Tokyo summit about ceilometer's best practise?
15:24:02 <llu-laptop> like the one gordc did in Vancouver
15:24:17 <gordc> llu-laptop: i don't think any ceilometer talks were chosen.
15:24:25 <llu-laptop> :(
15:24:28 <jd__> so some of us would like to poll operators about Ceilometer and how they use it
15:24:35 <gordc> seems like the criteria was more ops/product driven
15:24:46 <jd__> rather than doing that at the summit, we would like to have that done as a broader scope
15:24:57 <jd__> (you know, Internet, mailing list etc)
15:24:58 <nadya> llu-laptop: good question! Also, I'm interested about best practices for Mongo tuning...
15:25:01 <llu-laptop> how to do the polling thing?
15:25:02 <nijaba> there was also a lot less rooms to do do conference talks than in previous summit
15:25:23 <gordc> nijaba: ^ that as well.
15:25:24 <jd__> so far pradk put a questionnaire https://etherpad.openstack.org/p/ceilometer-operator-questions
15:25:36 <pradk> can we propose topics for the ops sessions?
15:25:49 <nijaba> llu-laptop: I was proposing to setup a survey either in gdoc or survey monkey and open it as wide as possible
15:25:52 <jd__> just a set of questions we envision sending to operators with an online survey, I guess jasonamyers would be interested :)
15:25:55 <pradk> precisely where i was getting at , thanks jd__ for the link
15:26:07 <jasonamyers> I am jd__
15:26:14 <gordc> pradk: i haven't heard if they will be doing an ops-project session again like vancouver
15:26:19 <jd__> so feel free to add more questions
15:26:30 <gordc> jd__: are you going to post to operators list>
15:26:31 <gordc> ?*
15:26:43 <jd__> gordc: me or someone that has better connection (hint jasonamyers)
15:26:50 <pradk> gordc, hmm ok, i guess we can have an ops feedback session if we have an extra slot?
15:26:54 <jasonamyers> I don't have better connections
15:26:59 <jd__> :D
15:27:07 <jasonamyers> it's better to come from a project leader
15:27:10 <gordc> pradk: that sounds like an idea.
15:27:19 <jasonamyers> and I'll make sure it gets distributed internally and to partners
15:27:23 <jd__> cool
15:27:32 <jd__> gordc: you're up to that?
15:27:36 <gordc> kk, i can post. we might want to refine some the questions
15:27:41 <jd__> definitely
15:27:59 <gordc> jd__:  do you have a pool of money to entice people to answer
15:28:00 <jd__> gordc: also we can probably leverage some online tools (surveymonk or google forms or something like that)
15:28:10 <jd__> gordc: we're offering our time! that's money
15:28:13 <gordc> lol
15:28:44 <gordc> so i'm still waiting on the openstack survey where we submitted the original ceilometer question
15:28:53 <pradk> gordc, will add to etherpad, we can include an ops feedback session if we have time
15:28:58 <gordc> i believe we should have responses soon (i need to recheck email)
15:29:10 <gordc> jd__: oh. actually i have a great place to ask these questions
15:29:16 <jd__> gordc: ok, maybe add something to this meeting agenda to keep track of that?
15:29:18 <nadya> jasonamyers: what is the last day to become mid-cycle participant? :)
15:29:27 <jasonamyers> shrug?
15:29:43 <jasonamyers> It would be helpful to know Oct ish
15:29:44 <gordc> the product WG just ask this exact question to me (if there was any questions we wanted to ask users)
15:29:57 <jasonamyers> if we are going to hvae one
15:30:14 <jasonamyers> after we know we are going to meet, there is not limit
15:30:19 <jd__> gordc: cool
15:30:20 <gordc> i'm sure we can forward this list to Product WG so they can distribute to whoever is part of it. (hopefully it goes beyond managers)
15:30:35 <jd__> gordc: that + operators would be good indeed
15:30:37 <jasonamyers> that's my real problem is needing to get budget stuff established and dates for spending set nadya
15:32:04 <gordc> nadya: there are two times.. one in nov/dec, one in jan
15:33:01 <nadya> gordc: visit Dublin 2 times? I would stay there through nov-jan then
15:33:07 <jasonamyers> haha
15:33:22 <gordc> nadya: lol no no just different options
15:33:33 <nadya> :)
15:33:45 <gordc> only one slot would be chosen... and probably 2-3 days within the timerange
15:33:47 <jasonamyers> basically I'm open anytime from Nov 30-Jan 30
15:34:02 <jasonamyers> and any 3 days in there for meetings and we can have workspace for 5 if needed
15:34:53 <gordc> 5 days to make up for midcycles missed.lol
15:34:57 <jasonamyers> haha
15:35:03 <jasonamyers> I'm going to work from the office there for a week
15:35:18 <jasonamyers> so if others need coworking space for the other 2 days I'm happy to host them :P
15:35:33 <gordc> jasonamyers: nice.
15:35:49 <gordc> so any other topics?
15:36:07 <gordc> #action review list of questions for operators and send to ops list and product wg
15:36:30 <gordc> #action fill out availability for midcycle, put blank if you aren't coming
15:36:57 <gordc> final countdown.
15:37:21 <jasonamyers> If we don't get enough we should still do a virtual one
15:37:32 <pradk> +1
15:37:36 <gordc> jasonamyers: +
15:37:45 <jasonamyers> but I will be sad I didn't get to go to dublin
15:37:49 <jasonamyers> :P
15:37:51 <nijaba> gordc: I would still advocate to setup a survey tool instead of just sending the question
15:37:55 <nijaba> and would be happy to do so
15:38:16 <gordc> nijaba: agree. any preference on survey tool?
15:38:37 <nijaba> gordc: either survey monkey of gdoc
15:39:14 <gordc> nijaba: ack. i'll just verify how accessible either one is and choose based on that.
15:39:50 <gordc> shall we close off? any additional items?
15:40:07 <llu-laptop> b.t.w, just heard that US has the most individual foundation members
15:40:11 <nijaba> gordc: let me know when you think the list of q is final, and I'll gladly set it up
15:40:13 <llu-laptop> more than 30%
15:40:36 <llu-laptop> India is the second, China is the 3rd
15:40:38 <gordc> nijaba: sure thing. i'll sync with jd__ in case you're not in irc.
15:41:05 * jd__ nods
15:41:13 <gordc> llu-laptop: canada?lol
15:41:27 <gordc> we probably got lumped with usa
15:41:34 <llu-laptop> can't remember the actual number.
15:42:23 <llu-laptop> only remember seeing former USSR in that list
15:43:07 <gordc> llu-laptop: cool stuff.
15:43:30 <llu-laptop> totally, more than 150 countries
15:44:20 <gordc> llu-laptop: nice. i'm going to close off this meeting. will ping you for link in openstack-ceilometer
15:44:26 <gordc> thanks for attending folks
15:44:31 <gordc> #endmeeting