15:00:34 <gordc> #startmeeting ceilometer
15:00:35 <openstack> Meeting started Thu Sep 10 15:00:34 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:40 <openstack> The meeting name has been set to 'ceilometer'
15:00:59 <cdent> purple
15:01:02 <cdent> dragons
15:01:07 <eglynn> o/
15:01:08 <jasonamyers> o/
15:01:09 <pradk> o/
15:01:22 <liusheng_> o/
15:01:54 <sileht> o/
15:01:59 <pradk> cdent, is that the theme for this mtg
15:02:13 <gordc> theme for life
15:02:25 <nadya> o/
15:02:32 <gordc> will give it a few more seconds.
15:02:38 <pradk> ah kk
15:02:43 <ildikov> o/
15:03:02 <gordc> #topic liberty update
15:03:22 <gordc> so we're all set...
15:03:40 <gordc> we have both FFE items in now so code should be finalised from feature pov
15:03:55 <cdent> bugs bugs bugs
15:03:57 <gordc> we also just released Aodh 1.0.0
15:04:24 <gordc> so yeah. as cdent says, find the bugs
15:04:46 <gordc> i don't really have a target for rc1 release date
15:05:02 <gordc> we'll see how many bugs we find originally and play it by ear.
15:05:28 <gordc> that's all i have on that topic
15:05:37 <gordc> anyone else?
15:06:02 <gordc> short meeting? yeah? cool.
15:06:35 <gordc> i'm going to skip over roadmap items but cdent has something related to it later
15:06:42 <gordc> recurring: ceilometerclient release?
15:06:46 <gordc> #topic recurring: ceilometerclient release?
15:07:06 <gordc> we just released our first liberty candidate for ceilometerclient
15:07:18 <gordc> cdent: i think you opened a bug which means we'll probably need another relsae?
15:07:20 <cdent> it will want a new one after limit fixes
15:07:35 <cdent> jinx
15:07:51 <gordc> awesome
15:08:13 <gordc> anyone else have ceilometerclient issues within past 12 hrs?
15:08:46 <gordc> i assume no. let's go.
15:08:57 <gordc> #topic recurring: Gnocchi status
15:09:10 <gordc> cdent: jd__: sileht: anything?
15:09:44 <sileht> I'm waiting for infra guys to import the gnocchiclient into the openstack namespace
15:10:14 <sileht> I'm waiting from infra guys to get the integrated job merged
15:10:25 <gordc> sileht: ah ok. yeah, i believe i saw that patch. i'll try to ping someone later today.
15:10:43 <gordc> or get someone with the infra connections to take a look
15:11:30 <sileht> I'm regulary ping them
15:11:35 <jd__> we're pushing on Grafana too to improve our support
15:11:38 <jd__> (devstack patch landed)
15:12:01 <jd__> I've a talk about Gnocchi scheduled in 2 weeks at the next OpenStack Paris meetup
15:12:04 <gordc> sileht: are they replying?
15:12:22 <gordc> or is blocked because it's end of cycle?
15:12:31 <sileht> yes, but I got a couple of rebase issue, and lost my +2
15:12:37 <gordc> :(
15:13:15 <gordc> sileht: i think you need someone with connections... or just go screaming into openstack-infra and see what happens.
15:14:06 <sileht> screaming is what I do usually :p
15:14:14 <gordc> sileht: :)
15:14:25 <gordc> jd__: let us know how meetup goes.
15:14:41 <jd__> sure. I'll count the tomatoes.
15:15:06 <gordc> jd__: perfect
15:15:15 <gordc> ok. let's move on. cdent i'm going to slightly hijack your topic.
15:15:36 <gordc> #topic Tokyo sessions and planning (cdent)
15:15:48 <cdent> just one question, do we need an etherpad
15:16:04 <lsp42> 
15:16:15 <gordc> cdent: sure. you can create one. i've created a google doc for people to submit formal proposals
15:16:47 <gordc> https://docs.google.com/spreadsheets/d/1ea_P2k1kNy_SILEnC-5Zl61IFhqEOrlZ5L8VY4-xNB0/edit?usp=sharing
15:16:54 <gordc> similar as before.
15:17:12 <gordc> cdent: but i think to brainstorm, etherpad would be better.
15:17:36 <nadya> gordc: were your sessions be approved?
15:17:37 <gordc> just for reference, we received 2 Fishbowl, 7 Working room, and 1 half day session
15:18:13 <gordc> nadya: speaker session? no. i believe none of the dev talks were chosen.
15:18:24 <nadya> gordc: yep, indeed
15:18:28 <gordc> nadya: right now we're just talking about Telemetry design sessions
15:18:43 <nadya> gordc: yep, I understand; just asking
15:19:00 <gordc> luckily, we got roughly same as Vancouver (1 Working room less)
15:19:51 <gordc> so yeah, if you have an idea, feel free to use ehterpad to brainstorm and then propose a topic to google doc... and we can vote...
15:19:56 <ildikov> gordc: did you send a mail about the google docs?
15:20:11 <gordc> ildikov: not yet.
15:20:28 <gordc> #action send link to telemtry design session proposals
15:20:39 <ildikov> gordc: thanks :)
15:20:40 <gordc> the process ok with everyone?
15:20:51 <pradk> https://etherpad.openstack.org/p/tokyo-ceilometer-design-summit
15:20:57 <gordc> anyone want to change it from how we've done it previously?
15:21:31 <ildikov> I'm ok with how we've done it
15:21:41 <cdent> seems okay
15:22:02 <gordc> cool cool
15:22:46 <gordc> regarding final date for design session proposals. shall we aim for Oct5th? vote ends Oct 8th?
15:23:07 <pradk> we can use the above ^^ etherpad for discussions if necessary
15:23:22 <gordc> that would give roughly 2.5 weeks for chosen topics to be formalised/discussed further
15:23:29 <gordc> pradk: awesome
15:23:46 <ildikov> gordc: it's more than 3 weeks from now, sounds fine with me
15:24:11 <ildikov> gordc: it should be enough to collect the proposals
15:24:14 <gordc> ildikov: we can set it tentatively. i don't know how busy people will be with testing.
15:24:26 <gordc> ildikov: yeah, that's what i'm thinking/hoping.
15:24:31 <ildikov> gordc: I guess we split between modules based on the proposals, right?
15:25:12 <gordc> ildikov: true. so we have a noticeable divide for 'ceilometer', gnocchi, and aodh... i hadn't considered how many spots to reserve
15:25:36 <ildikov> IMHO we can do that on demand
15:25:46 <gordc> yeah my thoughts exactly.
15:25:48 <ildikov> gordc: would we need a joint component session?
15:26:18 <ildikov> I mean to ensure the interaction between them, how to handle old/new APIs etc is covered
15:26:41 <ildikov> not 100% sure it's needed, prolly it can be part of the regular planning and voting
15:26:57 <gordc> ildikov: sure. that can be a possible topic (if you choose to propose it)
15:27:41 <gordc> i think i'm pretty open to pretty much any 'telemetry/monitoring/metering/alarming' related topic to be proposed regardless which project it falls under
15:27:54 <cdent> unicorns
15:28:07 <gordc> cdent: alarming?
15:29:08 <gordc> any other items we need to address?
15:29:25 <ildikov> gordc: ok, cool
15:29:31 <ildikov> gordc: tnx
15:29:32 <gordc> #topic open discussion
15:29:41 <nadya> party with Monasca?
15:29:46 <gordc> sweet. short meeting.
15:29:56 <ildikov> one question, will we have a mentor for OPW internship?
15:30:13 <gordc> nadya: i've mentioned to Roland already that he is welcome to propose Monasca topics as well during our session.
15:30:23 <nadya> gordc: ok
15:30:29 <gordc> nadya: are you volunteering to plan a party?
15:30:39 <gordc> nadya: i'll support that
15:31:02 <gordc> ildikov: how does that work normally? i haven't really looked/followed the OPW internship stuff.
15:31:19 <nadya> gordc: come to my hometown :) I'm still not able to go to summits :(
15:31:50 <ildikov> gordc: don't know either
15:31:52 <gordc> nadya: doesn't mean you can't plan still. ;)
15:31:58 <nadya> lol
15:32:06 <ildikov> gordc: I got the question today, I asked back for details, no response yet
15:32:22 <gordc> ildikov: DinaBelova i believe was mentor last time during Juno
15:32:26 <gordc> or kilo
15:32:53 <ildikov> eglynn: weren't you mentor once also?
15:33:33 <ildikov> eglynn: do you remember how OPW internship works?
15:33:33 <eglynn> ildikov: for the OPW?
15:33:39 <eglynn> ildikov: yes indeed ... I mentored amalagon for Juno
15:33:41 <ildikov> eglynn: yeap
15:34:14 <eglynn> ildikov: I remember most of the details ... any specific questions on it?
15:34:45 <ildikov> I wonder what it looks like timing wise
15:36:00 <eglynn> it's a 13 week program
15:36:13 <ildikov> and well, I could ask several questions, but if you might have a link to a description and then we can come back with stupid questions :)
15:36:18 <eglynn> the end point basically lines up approx with the last milestone in the cycle
15:36:39 <eglynn> so it would start 13 weeks before mitataka-3
15:36:55 <eglynn> so the process is basically add project ideas to the OPW/outreachy wiki and await potential interns to express interest
15:37:10 <eglynn> the interns are then ranked by the mentor group on a scale of 1-5
15:37:30 <eglynn> the spots are limited as each one needs to be sponsored
15:37:42 <eglynn> (to cover the intern stipend and travel expenses)
15:38:01 <eglynn> a sponsorship IIRC costs circa US$6k
15:38:13 <ildikov> do you know what the criterias are/what the ranking is based on?
15:38:56 <eglynn> interest level, coding ability (not necessarily python), cloud knowledge, availability for fulltime work
15:39:12 <eglynn> the summer cycle is generally better for the latter
15:39:24 <gordc> ildikov: you thinking of mentoring or just inquiring?
15:39:28 <ildikov> I guess it's better to find a mentor and then propose some topics to that wiki
15:39:37 <eglynn> (since students in the US and Europe are off in the summer)
15:40:17 <ildikov> gordc: I got a mail today from a girl, who's interested, but I do not really have the bandwidth to be a mentor, but I would like to help and support her, this is why I thought to bring up a topic as we had mentors earlier too
15:40:36 <eglynn> at the diveristy panel in the OpenStack day in Seattle recently someone mentioned though that most of the applications are now from India & China
15:40:46 <ildikov> gordc: and also if we have tasks that need to be done anyway then if we have an intern working on it seems like double benefit
15:40:49 <eglynn> ... not sure how the academic year works there
15:41:09 <ildikov> gordc: so more inquiring atm :)
15:41:53 <gordc> eglynn: good to know... maybe some of our east-asian cores can help.
15:41:59 <ildikov> eglynn: do they need former contribution to he project?
15:42:10 <gordc> ildikov: i hadn't thought about it to be honest but good to bring it up
15:43:19 <ildikov> gordc: we can come back to this later, I just wanted to raise the question as heads up
15:43:28 <gordc> oh before i forget, we're going to give midcycle voting one last try, we'll send a mailing list for dates in Nov/Dec and January... if we don't get a response, we'll just do virtual midcycle agian
15:43:35 <gordc> ildikov: sounds good
15:44:19 <eglynn> ildikov: yep, *some* openstack contribution helps ... but it can just be a trivial patch
15:44:32 <ildikov> gordc: don't get a response == not enough attendees?
15:44:43 <ildikov> eglynn: ok, cool, good to know
15:45:14 <gordc> ildikov: well right now we don't have responses so the assumption is that there is very few attendees
15:45:45 <ildikov> gordc: ok
15:46:37 <gordc> jasonamyers (cisco) has offered to host so it'd be nice to stop dragging process so he has firm yes/no
15:47:17 <jasonamyers> +1
15:47:45 <gordc> any other discussion items?
15:48:56 <gordc> thanks very much folks. happy hacking
15:48:59 <gordc> #endmeeting