15:01:36 <gordc> #startmeeting ceilometer
15:01:37 <openstack> Meeting started Thu Jun 25 15:01:36 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:41 <openstack> The meeting name has been set to 'ceilometer'
15:01:59 <prad> o/
15:02:01 <eglynn> o/
15:02:23 <llu-laptop> o/
15:02:28 <_nadya_> o/
15:02:39 <cdent> o/
15:03:51 <gordc> courtesy ping: jd__, sileht, DinaBelova,
15:03:56 <gordc> let's get started
15:03:57 <jd__> o/
15:03:57 <ildikov> o/
15:04:19 <gordc> #topic Blueprint checkpoint (https://etherpad.openstack.org/p/liberty-ceilometer-contributors-meetup)
15:04:34 <gordc> so we released liberty-1 a few days ago
15:04:47 <gordc> https://launchpad.net/ceilometer/+milestone/liberty-1
15:05:20 <gordc> we got a few stuff in
15:05:26 <gordc> we have a lot more.
15:05:46 <gordc> i think only jason added a expected completion date for his b
15:05:48 <gordc> bp*
15:06:16 <gordc> i'm hoping others can add their targets to either etherpad or to blueprints.launchpad.net
15:06:22 <gordc> any blockers so far?
15:06:52 <prad> gordc, i should have something reviewable on declarative stuff next week i think
15:07:04 <prad> making good progress
15:07:21 <_nadya_> gordc: do we have any blockers for InfluxDB driver in Gnocchi?
15:07:24 <gordc> prad: awesome!
15:07:46 <gordc> _nadya_: i believe we are still waiting on a release with fixes? jd__ ?
15:07:57 <_nadya_> gordc: IlyaT is working on new version but the first version is still on review
15:08:20 <gordc> _nadya_: i see. can you paste link? i'll try to take a look.
15:08:23 <jd__> gordc: last time I checked yeah but 0.9 is out, now we need to check if the python lib is updated
15:08:42 <_nadya_> gordc: I'm asking because 'asynchrony in the API' item in etherpad
15:08:42 <gordc> jd__: cool cool
15:08:43 <jd__> I don't know if someone is actively working on it for now, last person was sileht but he's on PTO
15:09:00 <gordc> #action check influxdb python lib updated yet
15:09:14 <llu-laptop> speaking of declarative stuff, need review on the spec https://review.openstack.org/178057
15:09:14 <_nadya_> jd__: Ilya T made a lot of investigations
15:09:17 <gordc> jd__: ah i see, that'd explain why he doesn't answer.
15:09:30 <jd__> _nadya_: gordc: the API is already async, we merged that change last week
15:09:30 <gordc> llu-laptop: kk, will look today
15:09:45 <llu-laptop> gordc: thx
15:10:18 <gordc> jd__: yep. good to know
15:10:39 <_nadya_> jd__: I'm afraid we may do the same work with sileht... How to prevent it? Only keeping in touch with him?
15:10:55 <idegtiarov_> hi
15:11:23 <jd__> _nadya_: same work?
15:11:45 <jd__> _nadya_: if you're talking about InfluxDB it's out there at https://review.openstack.org/#/c/165407/
15:12:11 <gordc> jd__: you know when he's back? maybe ilya can take it over? i assume sileht  is busy with oslo.messaging work
15:12:11 <_nadya_> jd__: yep, we are working on the version with tags now
15:12:55 <jd__> gordc: next week I think
15:13:08 <gordc> jd__: kk
15:13:10 <jd__> _nadya_: not sure what it means but ok :)
15:13:34 <gordc> _nadya_: i'd suggest you guys work off that patch, we can sync up with sileht when he returns
15:13:35 <_nadya_> jd__: hehe :) it's a key feature on 0.9 Influx
15:14:05 <jd__> _nadya_: yeah but I'm not sure what you are doing in your corner but ok :)
15:14:19 <gordc> _nadya_: i'm pretty sure sileht has other bigger items on his plate than influx so it shouldn't be an issue for one of you to grab it but we can confirm next week
15:14:37 <_nadya_> gordc: ok!
15:14:41 <gordc> _nadya_: cool cool
15:15:05 <gordc> #action checkpoint with sileht on influxdb driver to see if ilya can jump in
15:15:40 <gordc> i guess aside from that. here's the list of specs targeting liberty: https://blueprints.launchpad.net/ceilometer/liberty
15:16:07 <gordc> there's a few open spec reviews still so any cores with time, please jump in
15:16:26 <gordc> anything else on liberty related stuff?
15:16:35 <jd__> the aodh split is currently blocked by the TC I think
15:16:38 <cdent> Is fabio here today?
15:16:48 <jd__> or people making weeks to approve a change to openstack/governance, whoever that is
15:16:50 <gordc> cdent: hasn't seen fabiog in a very long time
15:17:02 <cdent> I'll take over that spec then
15:17:11 <gordc> jd__: was there a blocking comment or just no one looking at it?
15:17:13 <cdent> (riding it in to acceptance)
15:17:29 <gordc> cdent: collection split?
15:17:37 * cdent nods
15:18:02 <gordc> cdent: yeah, he agreed last i had contact with him. go for it.
15:18:55 <idegtiarov_> gordc, what about this bp https://blueprints.launchpad.net/ceilometer/+spec/events-pipeline-transformers could it be approved for liberty
15:19:26 <gordc> jd__: i'll follow up with aodh stuff
15:19:33 <gordc> #action check status of aodh lib
15:19:33 <jd__> gordc: no one looking
15:20:26 <gordc> idegtiarov_: i'll try to get around to that spec today. i think i had questions about it last time. i think it overlapped with alarm stuff but i might be talking about another bp
15:21:35 <idegtiarov_> gordc, we've discussed spec with llu and it doesn't overlap with alarms any more
15:21:54 <gordc> idegtiarov_: cool cool
15:22:03 <gordc> will check later.
15:22:03 <idegtiarov_> :)
15:22:09 <idegtiarov_> gordc, thanks
15:22:13 <llu-laptop> gordc: yeah, that spec is only about event transformer
15:22:27 <llu-laptop> timeout will be another spec
15:22:45 <gordc> llu-laptop: i see. i need to give it another read i think
15:23:20 <gordc> any other liberty stuff?
15:24:11 <gordc> on to the next
15:24:15 <gordc> #topic Midcycle Meetup
15:24:18 <idegtiarov_> here new bp for timeout alarms from nitification https://blueprints.launchpad.net/ceilometer/+spec/timeout-event-alarm-evaluator
15:24:23 <gordc> darn
15:24:48 <gordc> idegtiarov_: oh ok. same topic. i'll take a glance later
15:24:55 <idegtiarov_> kk
15:25:11 <gordc> someone propose the midcycle topic?
15:25:32 <prad> not me, but here is the http://doodle.com/6vfksdu38wcwqqd3
15:25:51 <prad> seems like July 6th Monday seems like has the most votes
15:26:12 <gordc> prad: did we discuss how this was actually going to work?
15:26:31 <eglynn> prad: is there going to be a "standardized" timezone for the day?
15:26:35 <gordc> apologies for being away last week when original meetup was cancelled
15:27:05 <prad> yea we wanted to take a vote first and see if the dates match everyones availability
15:27:26 <prad> yea timezones is key, we can discuss what works best
15:28:07 <eglynn> agreed ... what TZ do they use in the Azores? :)
15:29:00 <_nadya_> how many hours do we need, btw? What do you think?
15:29:25 <cdent> there's an etherpad with the proposed topics, that should help us decide on how much time:
15:29:41 <gordc> _nadya_: that's why i asked if we figured out how we were doing this. me and llu are in complete opposite tz
15:30:02 <cdent> https://etherpad.openstack.org/p/ceilometer-liberty-midcycle
15:30:44 <gordc> i guess the idea is to tackle one topic a day? and drop in when you can?
15:31:02 <cdent> is it? dunno
15:31:06 * gordc is completely guessing.
15:31:13 <gordc> don't know what was decided last week.
15:31:26 <cdent> We were going to talk about it more this week :)
15:31:43 <_nadya_> It's the problem to set up even one session :) One per topic seems impossible
15:31:44 <cdent> actually, no, there was supposed to be some meandering discussion and some additions to the etherpad
15:31:53 <gordc> cdent: ah i see. anyone do a virtual meet up before?
15:32:01 <cdent> yeah sure
15:32:03 <ildikov> I think last week we said that people should be available to be able to discuss topics or smth like not much more
15:32:33 <cdent> You decide and agenda in advance, you put some time bounds on it, and people show up for what they care about. If people don't show up they eithe don't care or didn't pay attention during the agenda creation
15:33:27 <gordc> cdent: reason i put daily bounds was because of tz diff
15:33:58 <gordc> you euro folks lucked out being smack dab in middle
15:34:00 * cdent nods
15:35:06 <gordc> i don't have any real suggestions. i'm sort hoping someone's done a virtual meetup before but doesn't seem like it.
15:35:27 <prad> gordc, do we need a whole day? or just half a day that can atleast overlap decently with most timezones?
15:35:29 <cdent> the "yeah sure" above was me saying I had
15:35:31 <gordc> i think we should have some agenda though... else it'll just be a normal day in ceilometer channel
15:35:34 <cdent> with timezones and everything
15:35:52 <gordc> cdent: ah i see.
15:36:01 <gordc> cdent: i will let you dictate. :)
15:36:09 <_nadya_> I think that every topic should have a leader who asks the concrete questions
15:36:10 <cdent> good luck with that, you won't like it
15:36:15 <prad> yea if we can have an agenda with topics and approximate times, people can hop on and off as convenient to them?
15:36:48 <cdent> It is _critical_ to follow the time boundaries
15:36:55 <prad> and we do something like the design summit where people vote who wants to attend what
15:36:59 <cdent> we get that for free at somewhere like the design summit because of rooms and such
15:37:04 <cdent> but virtual you have to have discipline
15:37:06 <prad> based on the popular vote we schedule the time?
15:37:13 <cdent> makes sense
15:37:15 <gordc> prad: i think the concern i had was that some people will end up with a lot of hours on a topic, and others will have 1hr.
15:37:16 <prad> and see what TZ's overlap
15:37:50 <cdent> gordc: that's an unsolvable problem. An in person meetups solves it by having people shift their time by way of geography. There are other ways to shift time.
15:37:55 <gordc> i guess we can just start with a list of topics and go from there.
15:38:01 <prad> gordc, unless we have fixed time slots.. anything out of that discuss on the channel
15:38:29 <cdent> We can try our best to accomodate but only if people actively express (on the etherpad what they are interested in and the timezones they are able to hit)
15:38:50 <cdent> How about this: Prad and I will make an email and send it out to osd [ceilometer]?
15:38:58 <cdent> outlining the next steps
15:38:59 <gordc> cdent: i will trust you on this -- i will provide feedback afterwards.lol
15:39:09 <_nadya_> cdent: +1. A lot of work should be done _before_
15:39:15 <ildikov> cdent: +1
15:39:19 <cdent> _nadya_: yes that's very very important
15:39:23 <gordc> that works for me.
15:39:58 <cdent> prad, find me when you come to life tomorrow and we'll make it go? (I'm about to expire today)
15:40:19 <prad> sure
15:40:19 <gordc> #action cdent will take lead on planning virt midcycle
15:40:26 <cdent> cool, thanks
15:40:34 <gordc> cdent: there's your bus
15:40:36 <_nadya_> I think I can spend some time on planning too
15:41:03 <gordc> _nadya_: cool cool. more the better.
15:41:04 <cdent> cool _nadya_ we'll probably have some etherpad(s) started tomorrow, will let you know
15:41:10 <_nadya_> cdent: feel free to ping me
15:41:17 * cdent is not licensed to drive a bus
15:41:30 <gordc> cdent: it's ok, i just pushed you under it.
15:42:00 * cdent has a scsi terminator in his pocket
15:42:01 <cdent> safe!
15:43:17 <gordc> ok. so december midcycle?
15:43:22 * gordc just noticed time
15:44:13 <gordc> not sure who added this either... but i'm guessing it's too early to plan?
15:44:23 <cdent> that may be left over from last week
15:44:24 <gordc> maybe we should have the discussion right before summit?
15:44:36 <gordc> cdent: kk. on to the next.
15:44:48 <cdent> but jason is trying to plan ahead because of the chaos of the two prior cycle's mid-cycles
15:45:00 <cdent> and he's got approval from his employer to host in dublin
15:45:10 <cdent> and some dollar for snacks and such
15:45:22 <gordc> cdent: kk. we can revisit closer to summit i think.
15:45:30 <gordc> #topic ceilometer splits, delete or deprecate old code? impact on downstream?
15:45:35 <_nadya_> so much discussions about discussions :)
15:45:42 <gordc> cdent: go
15:46:27 <cdent> I believe this is also left over from last week, and we didn't make any progress then, andI think decided that it was good (perhaps even priority) mid-cycle topic
15:46:52 <gordc> cdent: kk
15:46:53 <cdent> basically the topic captures the whole thing and we need to decide and soon, due to the level of work it will cause us
15:47:34 * gordc will reread last weeks meeting logs i guess
15:47:46 <gordc> no strong opinion from me.
15:48:00 <gordc> #topic recurring: ceilometerclient release?
15:48:09 <gordc> it was released yesterday. next
15:48:24 <gordc> #topic recurring: Gnocchi status
15:48:36 <gordc> jd__: anything to add to what was mentioned before?
15:49:47 <gordc> #topic Open discussion
15:50:01 <cdent> I made gnocchi work on /metric instead of :8041/ and doing ceilometer now too
15:50:49 <gordc> cdent: what will ceilometer be under? meter/event?
15:51:03 <cdent> whatever we like, but the pattern seems to be /telemetry
15:51:08 <cdent> it's the service id in keystone
15:51:12 <cdent> s/id/name/
15:51:32 <gordc> telemetry/metric, telemetry/meter, telemetry/event?
15:51:50 <cdent> http://api.com/telemetry/v2/whatevers
15:51:50 <gordc> or is gnocchi going completely on it's own?
15:52:00 <cdent> http://api.com/metric/v1/whatevers
15:52:07 <gordc> cdent: i see..
15:52:08 <cdent> http://api.com/identify/some_keystone_crap
15:52:30 <cdent> this is, apparently, a long term goal from the people who make long term goals
15:52:40 <cdent> when I asked where these goals were written down I was told they just exist in the ether
15:52:44 * cdent shrugs
15:52:47 <cdent> it's a good idea anyway
15:52:49 <gordc> don't ask questions
15:53:27 <_nadya_> may I ask about my suggestion to verify meters? https://review.openstack.org/#/c/193501/ . Idea is to add is_valid during sample creation
15:54:16 <ildikov> I think if we have an is_valid check, then it should be articulated to other projects to sync up on that
15:54:36 <gordc> ildikov: i don't think it extends beyond ceilometer
15:55:05 <gordc> samples/events are ceilometer concepts, notifications (and it's schema-less madness) is openstack
15:55:08 <_nadya_> yep, we check our Sample's fields actually
15:55:29 <ildikov> gordc: if we drop samples based on it, then it does IMHO
15:56:20 <_nadya_> but how process notification without resource_id?
15:56:24 <gordc> ildikov: sure. but how would you enforce that?
15:57:13 <gordc> ildikov: if something doesn't have a resource_id, a is_valid check would help. it's a bug in that project (or a notification never intended for ceilometer)
15:57:22 <gordc> wouldn't help*
15:58:46 <_nadya_> ok, let's continue in review, I need to add a proper test. gordc has removed the file I used :)
15:59:01 <gordc> _nadya_: :)
15:59:03 <gordc> which file?
15:59:14 <gordc> test_notifier?
15:59:30 <_nadya_> gordc: yep. Anyway, it was a mistake to use it
15:59:40 <gordc> yeah we can discuss over at os-ceilometer
15:59:57 <gordc> closing this for now. thanks for attending
16:00:01 <gordc> #endmeeting