15:01:22 <gordc> #startmeeting ceilometer
15:01:22 <openstack> Meeting started Thu Jun 11 15:01:22 2015 UTC and is due to finish in 60 minutes.  The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:26 <openstack> The meeting name has been set to 'ceilometer'
15:01:30 <gordc> #chair jd__
15:01:31 <openstack> Current chairs: gordc jd__
15:01:34 <ildikov_> o/
15:01:38 <sileht> o/
15:01:42 <jd__> o/
15:01:48 <prad> o/
15:01:59 <cdent> o/
15:02:02 <gordc> hi folks, just a headsup, i'm in some super firewall country so i may or may not drop during this meeting
15:02:18 <gordc> in case i do, jd__ lost the battle and will chair in my pace
15:02:25 <gordc> place*
15:02:27 <jd__> zog zog
15:03:05 <gordc> let's begin i guess
15:03:10 <gordc> #topic Short term solution vote and decision on https://review.openstack.org/#/c/171826/
15:03:17 <eglynn__> o/
15:03:24 <jasonamyers> o/
15:03:25 <gordc> rjaiswal: any update on this? we ran out of time last week
15:03:30 <fabiog> hi
15:03:37 <Rajkumar_> Hellow Everyone
15:04:06 <gordc> fabiog: Rajkumar_: hey!
15:04:33 <gordc> rjaiswal: ping
15:05:35 <gordc> let's move on
15:05:47 <gordc> #topic Midcycle Meetup
15:05:47 <rjaiswal> gordc: Yes
15:05:53 <gordc> ... darn
15:05:55 <jasonamyers> ha
15:05:58 <rjaiswal> the bp is ready
15:06:10 <rjaiswal> https://review.openstack.org/188613
15:06:13 <gordc> #topic Short term solution vote and decision on https://review.openstack.org/#/c/171826/
15:06:20 <rjaiswal> sorry for the delay, hangsups
15:06:33 * gordc completely understands
15:07:13 <gordc> rjaiswal: so is the only thing you need now just reviews?
15:07:28 <gordc> rjaiswal: i think there was originally concerns with the scope
15:07:34 <rjaiswal> proposal is to use the polling approach
15:08:10 <rjaiswal> gordc: yes, especially the polling agent emit notification part
15:08:28 <gordc> rjaiswal: kk, i think that's the one most of us were most comfortable with
15:08:29 <rjaiswal> especially now, since we have a bp to split the agents
15:08:51 <gordc> rjaiswal: yeah, that's not in scope of your bp (i still like the idea though
15:09:15 <rjaiswal> can we have a separate bp to refactor central agent emit noti.
15:09:43 <rjaiswal> and i think there is a bp to refactor the api to do the same
15:09:48 <cdent> yes and yes
15:09:58 <gordc> rjaiswal: yeah, we were discussing it in fabiog/cdents refactor collection agents specs...
15:10:09 <rjaiswal> gordc, yes, saw that
15:10:17 <cdent> it's something that we can leave out of the discussion of the pipeline dynamic reconfig
15:10:21 <gordc> rjaiswal: we should probably track it (polling agent/pipeline refactoring) in it's own
15:10:28 <cdent> however, it kind of makes me wonder which is more important to do
15:10:57 <rjaiswal> think it should be done with the split spec at least or before that
15:11:34 <gordc> cdent: true. if we rip out pipeline from polling agent, a lot of the work rjaiswal will do may be wasted.
15:12:21 <rjaiswal> gordc: polling agent still need pipeline to determine which meters are supported?
15:12:50 <cdent> needs a config file, not quite the same thing
15:13:11 <gordc> rjaiswal: yeah... it'd be half a pipeline... or just the source part and not the sink
15:13:12 <cdent> (e.g. you don't need to worry about draining transformation pipelines when the reload happens)
15:13:45 <rjaiswal> yes, but still would want to wait for pollsters to complete before starting new ones
15:14:24 * cdent nods
15:14:39 <gordc> yeah, i think we'd still need some part of pipeline to control poll intervals
15:15:07 <gordc> i guess it's something we can look at later... possibly in late L-2 cycle
15:15:35 <rjaiswal> so i think that begs the question, there will still be a dependency of the polling agent on the pipeline
15:15:41 <gordc> rjaiswal:for now i'm inclined to prioritise the dynamic pipeline work since we have a spec and we've talked about it for a while
15:16:18 <rjaiswal> gordc: i agree
15:16:34 <gordc> rjaiswal: i think you can work on your item as if the polling agent refactor stuff doesn't exist. we need to discuss it still and we don't necessarily have resources
15:16:36 <cdent> rjaiswal: when you say pipeline do you mean the code which is a pipeline, or the pipeline.yaml?
15:17:05 <rjaiswal> cdent: i meant the yaml
15:17:39 <rjaiswal> cdent: as in its still needed to configure the pollsters with the intervals
15:18:01 <cdent> got ya, just wanted to clear
15:18:41 <gordc> cdent: cool cool. did you want to write a spec? i can write one but it'll be a week or two.
15:18:42 <rjaiswal> gordc, cdent: sure, will start working on it, also will be good to have the spec approved
15:18:58 <gordc> rjaiswal: kk. we'll get eyes on that spec
15:19:13 <gordc> i think jd__ has comments already
15:19:26 <gordc> rjaiswal: anything else?
15:19:48 <rjaiswal> i guess that its for me..
15:19:51 <cdent> gordc: spec for killing pipeline (the code not the yaml) in pollsters you mean? sure
15:19:59 <gordc> rjaiswal: cool cool
15:20:04 <gordc> cdent: yeah
15:20:07 <rjaiswal> thanks gordc, cdent
15:20:17 <gordc> next topic
15:20:22 <gordc> #topic Midcycle Meetup
15:20:24 <cdent> #action cdent write a remove pipeline from pollsters spec
15:20:44 <cdent> (did I do it right?)
15:20:59 <gordc> jasonamyers: any updates? i think we were looking for possible dates and locations so we can gauge interest
15:21:17 <gordc> cdent: i don't understand irc meeting actions
15:21:20 <gordc> #action
15:21:25 <gordc> no help
15:21:46 <jasonamyers> nothing yet we are talk with our office in IE
15:22:05 <jasonamyers> but I don't have any answers.
15:22:12 <gordc> IE = ireland?
15:22:22 <jasonamyers> yes sorry
15:22:49 <gordc> kk
15:23:05 <gordc> i guess we'd target something in the july/august time frame.
15:23:36 <jasonamyers> nod
15:23:41 <gordc> we can do a doodle on that to see if we even need to bother looking for a place.
15:23:47 <ildikov_> I guess it would be better to aim for July
15:24:01 <ildikov_> gordc: +1
15:25:21 <jasonamyers> good idea
15:25:34 <gordc> can someone create a doodle of each week in july? i feel like i'm going to get firewalled if i try
15:25:46 <gordc> and maybe first week of august
15:26:17 <gordc> so mid july to mid august? (realistically we'll never get something planned by early july
15:26:35 <ildikov_> feature freeze is first week of September
15:27:11 <ildikov_> so with the first week of August I think we should target some hackfest like mid-cycle
15:27:14 <fabiog> gordc: is going to be held in Europe only, or it could also be in Cal?
15:27:44 <cdent> Not that it should live or die on me, but if it is outside europe the changes of me going are pretty much zero.
15:28:15 <gordc> cdent: i feel like that's the same for everyone (except ppl in north america)
15:28:37 <fabiog> gordc: cdent just asking ...
15:28:43 <cdent> s/changes/chances/
15:28:53 <gordc> fabiog: i'm probably leaning more to Europe as that's where most of contributors are coming from still.
15:28:56 <cdent> yeah, I know fabiog, and I was just reporting
15:29:33 <gordc> fabiog: but i guess we can figure out that when we get a rough view of who would even attend.
15:30:03 <gordc> #action gordc will create doodle... or will delegate when he gets firewalled
15:30:20 <gordc> yeah that doesn't do anything... just looks like i'm talking to myself
15:30:33 <fabiog> gordc: sure. I think there is the possibility for Cisco to held something in Berlin. But I need to ask my boss first
15:30:33 <gordc> anything else on midcycle?
15:30:36 <jasonamyers> http://doodle.com/64b5x9q4kkmxx4eq
15:30:40 <cdent> maybe it logs pretty gordc
15:31:04 <gordc> jasonamyers: sweet! saved me the hassle
15:31:32 <gordc> fabiog: berlin would be awesome (fond memories)
15:32:23 <gordc> everyone vote up top asap... we'll decide whether we can do a meetup next week based on results.
15:32:41 * gordc is trying to get this voting asap so we can properly plan if it does happen
15:33:07 <cdent> unfortunately I can say when I can attend but not if I'll have funding to go
15:33:23 <cdent> so I feel a bit lame
15:34:00 <ildikov_> gordc: will you announce it on the mailing list too?
15:34:18 <gordc> ildikov_: sure. will do that
15:34:27 <ildikov_> gordc: ok, cool, tnx
15:35:05 <gordc> cool cool. next topic.
15:35:23 <gordc> #topic recurring: Gnocchi status
15:35:47 <gordc> jd__: sileht: cdent: life stories?
15:36:07 <cdent> jd__ has made nice progress on doing some cool asynch stuff for separating writes from aggregation
15:36:13 <cdent> which is a good thing™
15:36:53 <cdent> EOF
15:37:43 <gordc> cdent: i... err... i got nothing to inquire about.
15:37:50 <cdent> next topic!
15:37:56 <gordc> next!
15:38:11 <gordc> #topic Open discussion
15:38:34 <gordc> i skipped ceilometerclient release.... i saw/remember  nothing important
15:39:07 <prad> some eyes on https://review.openstack.org/#/c/178399/ would be helpful .. so far i think only gordc reviewed it
15:39:44 <cdent> I remain confused about who is on the hook to do the collection agent split work. I'm agnostic on who does, I just want the lack of clarity cleared up.
15:39:51 <gordc> yeah, i guess it'd be good to get eyes on all the specs so we can get work done on them asap
15:40:11 <gordc> cdent: i think fabiog said you can work on it if you like
15:40:46 <gordc> cdent: basically it's on you... unless you say otherwise.
15:40:47 <fabiog> cdent: yes. let's push the spec in and then I don't mind who start working on it
15:40:52 <rjaiswal> cdent: let me know if i can help with the remving pipeline from pollster spec
15:41:35 <fabiog> cdent: I'll add you as co-author to the spec
15:41:37 <cdent> prad: I've read that spec several times but don't have anything yet to add beyond what gordc has already been saying so I've been waiting for that to settle out before making comments or voting
15:42:29 <cdent> fabiog: that's cool, thanks, but I'm not super concerned about authorship, again just wanting clarity on what I need to be responsible for over the next few weeks. I'm happy (and want) to do the work once we decide what it is, so I'll own that part.
15:44:20 * gordc has nothing to add... is waiting to go to bed.
15:45:11 <jd__> sorry got side tracked
15:45:37 <gordc> jd__: no worries. something to add?
15:46:40 <jd__> just that I could ask to host the midcycle in Paris if needed
15:46:52 <jd__> or Montreal?
15:47:22 <gordc> jd__: my rent in mtl expires in 3 weeks.
15:47:32 <jd__> interesting :D
15:47:42 <gordc> jd__:i'll add those locations to the email
15:48:28 <gordc> i guess that's it? i'll close this off in 30 seconds
15:49:33 <gordc> we done
15:49:37 <gordc> see you later
15:49:39 <gordc> #endmeeting