21:00:03 <jd__> #startmeeting ceilometer
21:00:04 <openstack> Meeting started Wed May 22 21:00:03 2013 UTC.  The chair is jd__. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:07 <openstack> The meeting name has been set to 'ceilometer'
21:00:08 <jd__> #link https://wiki.openstack.org/wiki/Meetings/MeteringAgenda
21:00:14 <sandywalsh> o/
21:00:18 <mrutkows> o/
21:00:18 <dhellmann> o/
21:00:19 <DanD> o/
21:00:21 <n0ano> o/
21:00:24 <jd__> hey everybody
21:01:06 <m4dcoder_> o/
21:01:11 <thomasm> o/
21:01:30 <TravT> o/
21:02:07 <jd__> #topic Last week action: jd__ and dhellmann to write formal statement about limiting support for pre-grizzly versions of ceilometer
21:02:22 <jd__> I plead innocent
21:02:39 <eglynn_> o/
21:02:40 * dhellmann hangs head in shame
21:02:49 <terriyu> o/
21:03:12 <jd__> OTOH more time passes more useless it is :)
21:03:33 <jd__> shall we re-action, dhellmann ?
21:03:46 <dhellmann> yes
21:04:02 <asalkeld> o/
21:04:04 <jd__> #action jd__ and dhellmann to write formal statement about limiting support for pre-grizzly versions of ceilometer
21:04:16 <jd__> #topic Review Havana-1 milestone
21:04:22 <jd__> #link https://launchpad.net/ceilometer/+milestone/havana-1
21:04:34 <jd__> h1 is next week, in 8 days
21:04:34 <dragondm> o/
21:04:37 <asalkeld> (I can only stay a couple of minutes)
21:04:57 <jd__> asalkeld: ack
21:05:02 <eglynn_> asalkeld: hola!
21:05:08 <jd__> we're in good shape, we just need to review at this point
21:05:14 <jd__> so review !
21:05:35 <eglynn_> are we expecting any dependency changes for h1?
21:05:48 <eglynn_> (e.g. a new release of WSME before then)
21:05:59 <jd__> I don't think so
21:05:59 * eglynn_ just thinking about packaging up h1
21:06:04 <eglynn_> cool enough
21:06:25 <jd__> well, I seem to remember we upgraded our dep on WSME recently if that was the question
21:07:14 <jd__> git diff 2013.1..master -- tools/pip-requires indicates you need wsme 0.5b2 instead of wsme 0.5b1
21:07:15 <eglynn_> I thought there was a further pending issue around status code returning
21:07:33 <eglynn_> e.g s/400/404/ for NotFound
21:07:50 <jd__> eglynn_: ah maybe, but I don't think it'll be in time for h1
21:07:52 * sandywalsh has allocated every friday as full review days
21:08:00 <eglynn_> jd__: grand so
21:08:02 <jd__> sandywalsh: good news :)
21:08:43 <jd__> I'll rework my UDP patch tomorrow FWIW, the test failing is probably trivial so feel free to review even if Jenkins said -1
21:08:57 <jd__> in the case you'd have nothing to do in the next hours :-)
21:09:27 <eglynn_> jd__: I'll take a look at the UDP patch tmrw also
21:09:35 <jd__> well, I think that's it for h1, next week you'll be able to flood again
21:09:41 <jd__> eglynn_: thanks, that'll be helpful :)
21:10:18 <jd__> also don't hesitate to change milestone on bp or bugs you got merged for h1 and that were not planned for h1 initially, if any
21:10:28 <jd__> shall we move on or anybody has a question about h1?
21:11:01 <dhellmann> do we have any client stuff we need for h1?
21:11:15 <dhellmann> or, I guess, are we tracking client features with the milestones?
21:11:25 <jd__> no we are not
21:11:30 <jd__> clients do not follow this schedule
21:11:31 <dhellmann> ok
21:11:43 <jd__> so no pressure on this, though it's obviously good that work is done on it
21:12:59 <jd__> #topic Open discussion
21:13:04 <jd__> out of topic
21:13:30 <asalkeld> wow so fast even I can stay:)
21:13:41 <jd__> since we don't do this usually, I'd like to mention I've created a bp for ceilometerclient about supporting metadata query for APIv2, since I don't think we have this yet
21:13:43 <jd__> https://blueprints.launchpad.net/python-ceilometerclient/+spec/metadata-query-v2
21:13:55 <mrutkows> wanted to call to everyone's attention a bp Gordon and I submitted today
21:14:01 <jd__> this is mainly as a tracker for terriyu's job
21:14:21 <mrutkows> https://blueprints.launchpad.net/ceilometer/+spec/support-standard-audit-formats
21:14:23 <asalkeld> jd__, we can pass a generic query
21:15:17 <jd__> asalkeld: but I guess we can still enhance our shell interface, right?
21:15:25 <asalkeld> https://github.com/openstack/python-ceilometerclient/blob/master/ceilometerclient/v2/shell.py#L48
21:17:20 <jd__> asalkeld: hm.
21:17:33 <jd__> you're embarassing me
21:17:54 * dhellmann thinks jd__'s memory is getting as bad is mine
21:18:03 <asalkeld> all good
21:18:06 <jd__> I was happy I found a good idea to enhance ceilometerclient and now it seems mainly covered by this
21:18:27 <jd__> asalkeld: any other thing we could tackle on ceilometerclient? I'm trying get terriyu familiar with the API
21:18:34 <sandywalsh> dhellmann, just a heads up, the hp guys should have a proposal for v2 API changes to expose Events coming your way soon.
21:18:55 <jd__> mrutkows: since you've code, I think I'll take a look at it, though I'm not sure I understand the purpose at first glance :)
21:18:58 <asalkeld> jd__, I'll have a think (no coffee yet)
21:19:31 <jd__> asalkeld: thanks
21:19:41 <dhellmann> sandywalsh: sounds good, I'll keep an eye out for the review
21:20:01 <sandywalsh> dhellmann, it'll likely be a bp spec (elaboration on the existing bp)
21:20:07 <asalkeld> btw review client please
21:20:13 <dhellmann> sandywalsh: or that :-)
21:20:19 <asalkeld> I have a bunch there
21:20:29 <dhellmann> asalkeld: I'm going to try to catch up on reviews this evening/tomorrow morning (next 16 hrs or so)
21:21:16 <asalkeld> thanks
21:22:53 * asalkeld heading off - wave
21:22:57 <jd__> see ya
21:23:14 <jd__> .blueprint killer
21:23:16 <jd__> :)
21:24:05 <eglynn_> do we have anything else to discuss?
21:24:29 <mordred> do you guys need site-packages = True in python-ceilometerclient tox.ini ?
21:24:57 <jd__> ahah, I think we don't have the period support in ceilometerclient
21:25:08 <jd__> mordred: I don't think we should
21:25:15 <dhellmann> mordred: probably not
21:25:25 <dhellmann> that was probably copied from the tox.ini we had in the main repo at one point
21:26:53 <mordred> cool. I'm going to send in a patch
21:26:59 <asalkeld> mordred, no need
21:27:02 <mordred> it's - well - breaking something with teh jinja crap
21:27:17 <jd__> asalkeld: that was fast
21:27:27 <asalkeld> https://review.openstack.org/#/c/29876/
21:27:30 <mordred> asalkeld: whee!
21:27:36 <asalkeld> just need to review people
21:28:17 <dhellmann> approved
21:28:30 <jd__> too fast for me
21:29:04 <mordred> you guys are sexy
21:29:20 <dhellmann> /me thinks this is getting out of hand
21:29:33 <mrutkows> \o/
21:29:58 * jd__ nods
21:30:25 <jd__> closing in a minute if nobody yells
21:30:36 <dhellmann> early dinner!
21:30:58 <eglynn_> early to bed! ;)
21:31:03 <sandywalsh> later kids!
21:31:13 <mrutkows> Cheers
21:32:03 <jd__> see you guys, have fun
21:32:06 <jd__> and happy hacking!
21:32:08 <jd__> #endmeeting