21:01:54 <jd__> #startmeeting Ceilometer
21:01:55 <n0ano> here
21:01:56 <openstack> Meeting started Wed Jan  2 21:01:54 2013 UTC.  The chair is jd__. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:59 <openstack> The meeting name has been set to 'ceilometer'
21:01:59 <dhellmann> o/
21:02:01 <jd__> #link http://wiki.openstack.org/Meetings/MeteringAgenda
21:02:03 <eglynn> o/
21:02:16 <jd__> #topic dhellmann experiment with passing arrays of parameters to WSME for queries
21:02:21 <dhellmann> #link https://github.com/dhellmann/wsme-experimentation
21:02:43 <dhellmann> tl; dr: we don't need indexes on array arguments
21:02:43 <jd__> did it explode?
21:02:56 <dhellmann> that repo has a sample client file showing a few different forms
21:03:04 <dhellmann> that work and don't work
21:03:27 <jd__> okay
21:03:30 <dhellmann> and I pasted the output in the README for reference during the meeting
21:04:30 <jd__> ok
21:04:48 <jd__> I'm moving on then :)
21:04:52 <dhellmann> ok
21:04:53 <eglynn> the indices always seemed a little unnatural to me, this looks a lot cleaner
21:04:59 <jd__> #topic llu-laptop to report agreement result to wiki page
21:05:07 <jd__> llu: around?
21:05:22 <asalkeld> eglynn, what about : input.0.left
21:05:56 <eglynn> asalkeld: in what sense?
21:06:04 <jd__> #action llu to report agreement result to wiki page http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon
21:06:06 <jd__> I report
21:06:22 <asalkeld> instead of input[0].left
21:06:29 <eglynn> asalkeld: a-ha, I see
21:06:30 <jd__> I guess since nijaba isn't here I'm going to report all of his stuff too
21:06:39 <jd__> #action nijaba to get in touch with the healthmon team to see what their reaction is to our plan for integration
21:06:39 <eglynn> asalkeld: sorry, I'm a bit slow this evening ...
21:06:56 <jd__> #action nijaba to find out if EmilienM wishes to commit on https://blueprints.launchpad.net/ceilometer/+spec/api-aggregate-average
21:07:02 <jd__> #action nijaba to send an email to openstack-dev listing the orphan bps
21:07:05 <eglynn> asalkeld: yeah, that's less intrusive that full indexing
21:07:09 <jd__> #action nijaba to add bp skeleton to remind ourselves to implement higher level tests for db backends
21:07:19 <jd__> #topic API v2 proposal review http://wiki.openstack.org/Ceilometer/blueprints/APIv2
21:07:47 <jd__> I guess that's rejoin the topic you're discussing
21:07:53 <dhellmann> I'm ready to start implementing that new API, if we've agreed on what it should look like.
21:07:54 <jd__> s/'s//
21:08:03 <asalkeld> dhellmann, I have started
21:08:09 <dhellmann> asalkeld: cool
21:08:17 <asalkeld> just was blocking on the array stuff
21:08:35 <asalkeld> but I got pulled into some clustering bug
21:08:41 <dhellmann> asalkeld: that's in the tip version of WSME, so make sure you install from source
21:08:58 <dhellmann> #action dhellmann to talk to WSME author about packaging a release
21:09:14 <asalkeld> so if I can't attack it in the next day I'll post what I have
21:09:22 <dhellmann> asalkeld: sounds good
21:10:11 <asalkeld> so is everyone happy with that api?
21:10:17 <eglynn> can our CI running against the WSME tip, or just the last packaged version?
21:10:36 <dhellmann> eglynn: it can use the tip (we have an hg url in the test-requires, IIRC)
21:10:37 <eglynn> test-requires can include a dependency on a particular commit hash, right?
21:10:52 <eglynn> a-ha, yep, I remember that now ...
21:11:14 <jd__> API seems ok to me
21:11:15 <dhellmann> asalkeld: I'm happy enough to keep going with implementation. We may want to tweak as we go, but I don't have any specific objections.
21:11:37 <asalkeld> see the "Unresolved issues"
21:11:38 <dhellmann> well, aside from the things I've already noted in the wiki page and we've said we would leave for later
21:12:11 <asalkeld> ok
21:12:45 <dhellmann> how much have you needed to change the db api so far?
21:13:05 <asalkeld> not much yet
21:13:15 <asalkeld> but early stages
21:13:19 <dhellmann> ok
21:13:39 <asalkeld> I'll get stuck in and share with you
21:13:54 <asalkeld> taking a while to get back up to speed
21:14:04 <asalkeld> to much eggnog:)
21:14:09 * dhellmann needed 3 days to remember what his job was after his vacation
21:15:15 <jd__> good you remembered you had a job already
21:15:30 <asalkeld> jd__, we can probably move on.
21:15:39 <jd__> #topic open discussion
21:16:16 <eglynn> how are we fixed for the bug squashing day?
21:16:33 * eglynn hasn't triaged the bug queue as yet ...
21:16:42 <jd__> nijaba triaged a lot of bugs already
21:16:47 <dhellmann> have we had anyone express interest in participating outside of the existing team?
21:16:48 <eglynn> great!
21:16:54 <jd__> and I'll do it too tomorrow
21:17:05 <jd__> dhellmann: not that I am aware of
21:17:12 <asalkeld> so it's on friday (saturday my time)?
21:17:18 <jd__> asalkeld: yup
21:17:18 <eglynn> have we an agreed low-hanging-fruit tag?
21:17:35 <jd__> eglynn: there's t-shirt size tags on bugs
21:17:43 <dhellmann> is nijaba using effort-s for that easy?
21:17:47 <eglynn> jd__: cool, even better
21:17:52 <jd__> yep effort-s it is
21:17:58 <eglynn> sounds good
21:18:58 <jd__> anything else?
21:19:22 <dhellmann> has anyone had a chance to  look at the changes I posted to the way timestamps are handled in the v2 api?
21:19:39 <jd__> dhellmann: tomorrow I will
21:19:41 <dhellmann> asalkeld, you may want to roll that into what you're doing already
21:19:43 <dhellmann> ok, thanks
21:19:48 <asalkeld> I'll look
21:20:05 * jd__ is sick, and therefore, slow
21:20:34 <dhellmann> what's the plan for friday as far as coordinating? are we going to try to have someone online "all day" to help newcomers, or are we assuming it's going to just be us and follow the usual work procedures?
21:20:59 <eglynn> dehellmann: we could divide the TZs between us
21:21:07 <eglynn> dhellmann: ^^^
21:21:09 <jd__> I'll be online most of my CET daytime, and we'll see
21:21:20 <jd__> if other TZ can be around, that'd be good
21:21:33 <dhellmann> I may focus on afternoon, then
21:21:34 <eglynn> I'll be online for all day GMT also
21:21:57 <dhellmann> we're supposed to be going out looking for new office space that day, so I was going to carve out a chunk of time to be on irc for the bug day
21:22:09 <dhellmann> it sounds like we have "early" in my day covered pretty well
21:22:09 <jd__> I don't think we're going to be overwhelmed
21:22:17 <dhellmann> no, I agree
21:22:21 <eglynn> yep
21:22:48 <jd__> dhellmann: yes, your afternoon would be great indeed
21:23:06 <dhellmann> ok, I'll plan on that, then
21:23:07 <jd__> we'll cover the dawn
21:24:29 <jd__> anything else?
21:24:54 <asalkeld> nope, all good
21:25:01 <dhellmann> that's it for me
21:25:10 <eglynn> me too
21:25:11 <jd__> #endmeeting