21:00:05 <nijaba> #startmeeting Ceilometer
21:00:05 <openstack> Meeting started Wed Dec 19 21:00:05 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:05 <nijaba> #meetingtopic Ceilometer
21:00:05 <nijaba> #chair nijaba
21:00:05 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
21:00:05 <nijaba> ATTENTION: please keep discussion focussed on topic until we reach the open discussion topic
21:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:08 <openstack> The meeting name has been set to 'ceilometer'
21:00:10 <openstack> Current chairs: nijaba
21:00:16 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
21:00:16 <nijaba> o/
21:00:18 <asalkeld> hi
21:00:19 <yjiang5> o/
21:00:29 <danspraggins> hello world
21:00:32 <APMelton12> o/
21:00:36 <jd__> o/
21:00:49 <eglynn> o/
21:00:56 <nijaba> nice!
21:01:01 <nijaba> let's start
21:01:04 <nijaba> #topic actions from previous meeting
21:01:04 <nijaba> #topic asalkeld prepare a blueprint for v2 api "tightening" changes
21:01:13 <asalkeld> http://wiki.openstack.org/Ceilometer/blueprints/APIv2
21:01:24 <sew> me too
21:01:39 * nijaba looks
21:01:48 <asalkeld> I haven't made a blueprint as there are so many about
21:02:01 <asalkeld> wsme v2 one
21:02:05 <asalkeld> but I can
21:02:32 <asalkeld> also dependant on the pass array args
21:02:33 <nijaba> asalkeld: I think we can link it to an existing bp
21:02:44 <nijaba> asalkeld: I can take the action if you want
21:02:54 <nijaba> looks great otherwise
21:02:56 <asalkeld> ok
21:02:57 <jd__> asalkeld: is there a point to having /resources since that seems to be just /meter with ?resources= ?
21:03:12 <asalkeld> not sure
21:03:17 <jd__> ok
21:03:21 <asalkeld> https://groups.google.com/forum/?fromgroups=#!topic/python-wsme/gUJH9rLo5RI
21:03:29 <nijaba> I guess we could have a full review about this next week
21:03:50 <nijaba> once doug is back and everyone has time to review?
21:03:59 <asalkeld> sure
21:04:06 <jd__> fine with me
21:04:12 <asalkeld> so I am trying to implement, but running into wsme sort commings
21:04:15 <nijaba> #action nijaba to schedule v2 review for next meeting
21:04:34 <nijaba> #action nijaba to link proposal to appropriate bp
21:04:56 <nijaba> #topic dhellmann experiment with passing arrays of parameters to wsme for queries
21:04:56 <nijaba> #info dhellmann is still traveling, so I am re-actioning this for next week
21:04:56 <nijaba> #action dhellmann experiment with passing arrays of parameters to wsme for queries
21:05:18 <nijaba> #topic eglynn reach out to healthnmon project
21:05:18 <nijaba> #info This was obsoleted later in the meeting last week
21:05:24 <eglynn> didn't get a chance to do anything with healthnmon this week
21:05:32 <eglynn> need to bump that to the next meeting
21:05:33 <nijaba> #topic eglynn, yjiang5, llu-laptop to work on a wiki page for analysis of healthmon duplication, etc..
21:05:33 <nijaba> #info this was done, there is a full topic about this in a bit
21:05:33 <nijaba> #link http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon
21:05:55 <nijaba> so I propose we discuss lianho write up later
21:05:55 <asalkeld> that was nice
21:05:59 <eglynn> yep, some interesting observations on that wiki page
21:06:19 <nijaba> #topic jd ask eglynn if https://blueprints.launchpad.net/ceilometer/+spec/nova-independent-virt is implemented
21:06:25 <eglynn> it is
21:06:33 <eglynn> for libvirt
21:06:48 <eglynn> but if anyone is interested in xenapi support
21:06:48 <nijaba> should I change the status then?
21:06:52 <eglynn> that would be good too
21:06:59 <eglynn> yep, status complete
21:07:08 <eglynn> (xenapi is an added extra...)
21:07:24 <nijaba> #info bp marked as implemented
21:07:36 <nijaba> thanks eglynn
21:07:54 <nijaba> #topic russellb raises the question about Oslo notifications versionning on the ml
21:07:55 <eglynn> np!
21:08:09 <russellb> ooh
21:08:12 <nijaba> I think this was actually proposed as a patch
21:08:15 <russellb> i did not do that.  i wrote a patch instead
21:08:17 <russellb> yes
21:08:19 <nijaba> which I have reviewed
21:08:25 * nijaba looks for link
21:08:53 <russellb> #link https://review.openstack.org/#/c/18057/
21:08:57 <nijaba> #link https://review.openstack.org/18057
21:09:02 <nijaba> duh!
21:09:14 <russellb> #undo
21:09:20 <nijaba> eheh
21:09:42 <nijaba> other reviews are welcome, I guess
21:09:53 <russellb> so to clarify, this isn't versioning of notificaitons themselves
21:10:02 <russellb> just the wrapper part that will eventually allow us to add things like signatures
21:10:06 <russellb> encryption, other metadata
21:10:19 <nijaba> right
21:10:26 <nijaba> a usefull step!
21:10:30 <russellb> :)
21:10:36 <russellb> thanks for reviewing!
21:10:40 <nijaba> np
21:10:55 <eglynn> what's the upgrade path to the new format?
21:11:22 <eglynn> i.e. is it a big bang, or can the old envelope-less format still be tolerated by consumers?
21:12:23 <nijaba> russellb: ?
21:12:41 <eglynn> just wondering about ceilo remaining compatible-ish with pre-Folsom nova
21:12:45 <russellb> as it stands, the envelope is optional and not used by default
21:12:53 <eglynn> k
21:12:55 <russellb> and the code supports receiving both formats
21:13:00 <eglynn> cool
21:13:23 <russellb> checks to see if it looks like an envelope, and if it doesn't, assumes it didn't have one
21:13:32 <nijaba> nice
21:13:37 <eglynn> great, sounds reasonable
21:13:48 <russellb> the details of that are in the patch in front of the one linked
21:14:39 <nijaba> any other comments, or shall we move on?
21:14:45 <russellb> deserialize_msg() in https://review.openstack.org/#/c/17554/7/openstack/common/rpc/common.py
21:14:48 <russellb> none from me
21:14:53 <eglynn> looks good
21:15:10 <nijaba> #topic need to find a volunteer to organize bug squashing day on Jan 4th
21:15:10 <nijaba> again, I won't be around that week and we need volunteers to organize it.  Do we have any?
21:15:30 <jd__> o/
21:16:01 <eglynn> we'll also need to divy out some triaging work
21:16:14 <eglynn> start tagging bugs as low-hanging fruit etc.
21:16:26 <nijaba> jd__: can you take care of the organization?  I guess we should start "advertising it" soon...
21:16:40 <nijaba> eglynn: good point
21:16:52 <jd__> nijaba: sure, do you have already some idea of what we could do?
21:16:59 <jd__> I can announce it this week on the ml at least
21:17:00 <eglynn> (if we're gonna use the bug squashing day to smoke out some new contributors, good to have a nice set of getting starting style bugs ...)
21:17:00 <nijaba> #info everyin
21:17:15 <nijaba> #info everyone should start triaging and tagging bugs
21:17:24 <jd__> eglynn: I can probably do some of that the day before, but help welcome :)
21:17:30 <eglynn> jd__: cool
21:18:05 <nijaba> jd__: I think we need to have a process to help people that are willing to do some work
21:18:10 <nijaba> this could be:
21:18:14 <nijaba> - bug fixing
21:18:17 <nijaba> - testing
21:18:24 <eglynn> - docco
21:18:26 <nijaba> - bug reproduction
21:19:02 <jd__> ok, maybe writing this on a wiki page could help?
21:19:18 <nijaba> and we need to organize presence in the IRC chan to help directing people
21:19:40 <nijaba> so find volunteers to greet people throughout the day
21:19:57 <nijaba> which should be easy, since we have people all around the world
21:20:04 <eglynn> for testing, a detailed step-by-step wiki like the Fedora openstack test day, would be good to guide newbies ...
21:20:16 <nijaba> eglynn: pointer?
21:20:18 <eglynn> #link https://fedoraproject.org/wiki/Test_Day:2012-09-18_OpenStack
21:20:22 <nijaba> great
21:20:42 <jd__> I'll write as much as I could for next week so we can discuss it on next meeting
21:20:48 <jd__> s/could/can/
21:20:48 <eglynn> cool
21:20:51 <yjiang5> and need resolve the webob/wsme dependency issue before that day, so that trunk works well in devstack. (We should have fixed it at that time)
21:21:04 <nijaba> jd__: action?
21:21:17 <jd__> yjiang5: agreed, we can discuss this at the end of this meeting btw
21:21:18 <nijaba> yjiang5: good point
21:21:20 <jd__> nijaba: yup
21:21:48 <jd__> #action jd__ write a wiki page on how to participate to the bug squashing day
21:21:57 * nijaba will gladly help
21:21:57 <jd__> #action jd__ announce the bug squashing day on the ml
21:22:06 <eglynn> yjiang5: yep, good point ... the initial experience has to be smooth-ish, otherwise we'll loose the newbies straight away
21:22:32 <nijaba> jd__: we may need to advertise wider than the dev ml
21:22:36 <nijaba> may
21:22:51 <jd__> nijaba: do you have something on mind?
21:22:59 <jd__> lkml? :p
21:23:03 <nijaba> maybe on the openstack ml and community on?
21:23:05 <yjiang5> jd__: that wiki page can be a good newbie document in the future.
21:23:10 <nijaba> s/on/one
21:23:10 <yjiang5> lkml? .....
21:23:21 <nijaba> yjiang5: joke: linux kernel ml
21:23:38 <nijaba> maybe some tweets and a blog too?
21:23:50 <jd__> nijaba: yeah I was thinking about the general openstack list too, there's a community list or something too? I need to check that
21:24:08 <nijaba> jd__: yes, there is one. I'll relay if you want
21:24:09 <jd__> nijaba: yeah I'll tweet and blog like a crazy cow too!
21:24:16 <nijaba> \o/
21:24:30 <jd__> #action jd__ megatweet about the bug squashing day every hour
21:24:43 <nijaba> ok, should we move on?
21:24:43 <jd__> #undo undo undo
21:24:47 <nijaba> hehe
21:24:49 <jd__> :-)
21:25:05 <nijaba> That's it for last week action
21:25:15 <nijaba> #topic Meetings during the holiday season
21:25:15 <nijaba> So we have a couple meetings coming up that are falling in the holliday season, so I am wondering if we should still hold them?
21:25:15 <nijaba> I am proposing to do a quick check for presence in the form of a vote
21:25:43 <nijaba> do you guys agree?
21:25:52 <jd__> should we vote on agreeing?
21:25:56 * jd__ agrees :-)
21:25:57 <nijaba> lol
21:26:18 <nijaba> #startvote present on thu dec 27 15UTC? yes, no
21:26:19 <openstack> Begin voting on: present on thu dec 27 15UTC? Valid vote options are yes, no.
21:26:20 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
21:26:24 <eglynn> yep agreed not for next week, we're in shutdown mode ;)
21:26:25 <nijaba> #vote yes
21:26:29 <jd__> #yes
21:26:30 <yjiang5> #vote yes
21:26:32 <jd__> #vote yes
21:26:34 <eglynn> #vote yes
21:26:41 <asalkeld> #vote yes
21:27:03 <nijaba> looks like most of us are avail on the 27th! great
21:27:14 <nijaba> waiting a bit for more votes
21:27:15 <eglynn> #vote no
21:27:26 * eglynn got confused as to what we were voting on
21:27:29 <jd__> eglynn just took vacation actually
21:27:52 <nijaba> I guess we are done for this one
21:28:00 <nijaba> #endvote
21:28:01 <openstack> Voted on "present on thu dec 27 15UTC?" Results are
21:28:02 <openstack> yes (4): yjiang5, nijaba, asalkeld, jd__
21:28:03 <openstack> no (1): eglynn
21:28:03 <jd__> nijaba: I think Doug will be there since he just got vacations
21:28:18 <nijaba> #agreed meeting next week maintained
21:28:32 <eglynn> fair enough, I'll try to make it
21:28:37 <nijaba> #startvote present on wed Jan 2 21UTC? yes, no
21:28:38 <openstack> Begin voting on: present on wed Jan 2 21UTC? Valid vote options are yes, no.
21:28:39 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
21:28:47 <nijaba> #vote no
21:28:48 <jd__> #vote yes
21:28:49 <yjiang5> #vote no
21:28:54 <eglynn> #vote yes
21:29:16 <asalkeld> #vote no
21:29:45 <nijaba> this one lokks like a looser
21:29:53 <nijaba> any more votes?
21:30:10 <nijaba> #endvote
21:30:11 <openstack> Voted on "present on wed Jan 2 21UTC?" Results are
21:30:12 <openstack> yes (2): jd__, eglynn
21:30:13 <openstack> no (3): yjiang5, nijaba, asalkeld
21:30:30 <jd__> it's a date then!
21:30:40 <nijaba> #agreed no meeting on jan 2, unless jd and eglynn want to have fun together
21:30:55 <jd__> yeah, dhellmann might be around too
21:31:11 <jd__> we'll do a counter-party without you guys, that's it :)
21:31:18 <nijaba> good point
21:31:29 <yjiang5> jd__: but that's the day before the bug squash day, possibly someone from community want to join?
21:31:34 <nijaba> so we'll check again next week
21:31:58 <nijaba> #action nijaba to organize new vote next week
21:32:00 <jd__> yjiang5: yeah, we'll see, we can just start the meeting, chat a bit and end it if it's calm and quiet
21:32:23 <yjiang5> jd__: k
21:32:24 <nijaba> #topic Review synaps blueprints
21:32:24 <nijaba> eglynn did a great job at braking this into multiple bluprints and dependencies
21:32:24 <nijaba> #link https://blueprints.launchpad.net/ceilometer/+spec/synaps-integration
21:32:35 <nijaba> This brings a couple questions from me (others may have more):
21:32:35 <nijaba> 1/ this seems a lot of work.  Do you think we can target this for grizzly with confidence?
21:32:35 <nijaba> 2/ it seems that the symaps team is quite busy. Will you be covering all of this by yourself?
21:32:46 <eglynn> yea a lot of stuff there ...
21:33:03 <eglynn> and yep, I'm not counting on a great deal of input from their side
21:33:24 <yjiang5> eglynn: wow
21:33:32 <eglynn> so I've started working on it and will get as much done as I can
21:33:50 <eglynn> when is the g3 date?
21:34:03 <asalkeld> (heaps of distractions this time of year)
21:34:06 <nijaba> so, how should we target this?  Mark them as approved but with no milestone until you complete them?
21:34:18 <nijaba> eglynn: Feb 21st, I think
21:34:33 <nijaba> verified
21:34:34 <eglynn> right be aiming most of it for g3 so I think
21:34:50 <eglynn> g2 is way too soon given the holidays etc.
21:35:10 <nijaba> and changes may be breaking compat with folsom too?
21:35:38 <eglynn> well, it'll depend on post-Folsom ceilo features
21:35:56 <eglynn> e.g. multi-publish, nova-virt-inspector etc.
21:36:07 <nijaba> so, do everyone agree that I approve those bp?
21:36:21 <asalkeld> sure
21:36:40 <yjiang5> eglynn: we can priotize these bps
21:36:48 <eglynn> yjiang5: cool
21:36:55 <yjiang5> eglynn: some are fundamental, while some are add-ons
21:36:59 <asalkeld> nijaba, there are a lot of overlapping bps atm
21:37:03 <nijaba> #action nijaba to approve synaps's bp
21:37:12 <eglynn> yjiang5: agreed
21:37:20 <nijaba> asalkeld: I know
21:37:39 <nijaba> asalkeld: should we have a bp cleanup session next week?
21:37:48 <asalkeld> could do
21:37:49 <yjiang5> agree
21:38:15 <nijaba> you won be around though.  maybe we can start together on thu (my morning)
21:38:32 <asalkeld> ok
21:39:01 <nijaba> #action nijaba to organixe next thu as bp cleanup day
21:39:35 <yjiang5> thu means thursday, right?
21:39:36 <nijaba> let's move on?
21:39:44 <nijaba> yjiang5: yes
21:39:50 <yjiang5> nijaba: thanks
21:39:57 <nijaba> #topic Discuss heathmon/ceilometer duplication and differences
21:39:57 <nijaba> lianhao did a great job at analysing the differences and duplication:
21:39:57 <nijaba> #link http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon
21:40:09 <nijaba> From what I read, it seems that the hard points are
21:40:09 <nijaba> 1/ very different approach on the data model
21:40:09 <nijaba> 2/ healthmon does not use standard openstack events
21:40:09 <nijaba> so it seems that at best we could recommend to integrate healthmon with ceilometer through the use of the multi-publisher blueprint
21:40:09 <nijaba> what do you think?
21:40:30 <yjiang5> nijaba: lianhao is not on the meeting, can we do it in next meeting?
21:40:44 <eglynn> was their host monitoring something we could consider pulling in?
21:40:52 <nijaba> yjiang5: we can still gather some feedback and conclude next week
21:40:58 <yjiang5> nijaba: sure
21:41:07 <nijaba> asalkeld, won't be around next week
21:41:28 <asalkeld> maybe - I'll see
21:41:59 <nijaba> #action nijaba to reschdule topic for next week when lianhao is around
21:42:08 <nijaba> any comments for now?
21:42:21 <yjiang5> agree with eglyn on host monitoring
21:42:30 <asalkeld> well I'd like to see the devs on irc
21:42:43 <asalkeld> and actively supporting this
21:42:51 <nijaba> +1
21:42:59 <asalkeld> not another case of us pulling code in
21:43:09 <eglynn> yep agreed
21:43:16 <jd__> +1
21:43:36 <eglynn> we could be guided though by their approach to host monitoring
21:43:36 <nijaba> asalkeld: shall you start a thread on the ml, asking what they think?
21:43:40 <yjiang5> eglynn: but host monitor is a feature we need support in future, either from healthnmon, or restart from scratch
21:44:08 <eglynn> yjiang5: yep, just thinking we could borrow ideas that they've battle-tested
21:44:18 <asalkeld> nijaba, maybe - or just get them to the meetings
21:44:23 <eglynn> yjiang5: approaches they've proven to work at scale etc.
21:44:24 <nijaba> there is already some effort on https://blueprints.launchpad.net/ceilometer/+spec/monitoring-physical-devices
21:44:47 <nijaba> asalkeld: that could be the topic of the mail :)
21:44:57 <yjiang5> eglynn: agreed
21:45:19 <asalkeld> sure nijaba
21:46:53 <nijaba> ok, I guess we can move on then...
21:47:02 <nijaba> #topic Open discussion
21:47:30 * dragondm waves
21:48:20 <asalkeld> I have nothing
21:48:30 <yjiang5> one thing I discussed with asalkeld on IRC, current get_meters need looking for the whole table , possibly we need enhance that?
21:48:49 <asalkeld> you mean for sql?
21:48:55 <yjiang5> asalkeld: yes.
21:48:55 <jd__> I'd like to send a patch to move away the v2 api as a second citizen and get back the v1 API as the main one for now, and remove dep on pecan/wsme (unless for tests), wdyt?
21:49:08 <asalkeld> yes totally agree yjiang5
21:49:16 <yjiang5> jd__: agree
21:49:47 <asalkeld> jd__, agree until we get to one api server
21:49:47 <eglynn> jd__: second class citizen = disabled by default?
21:49:50 <nijaba> +1 (for now and until g2 is past)
21:50:13 <yjiang5> asalkeld: I will talk with you on implementation in IRC
21:50:26 <asalkeld> mv ceilometer-api ceilometer-api-v2
21:50:29 <jd__> eglynn: that means rename bin/ceilometer-api => bin/ceilometer-api-v2 and rename bin/ceilometer-api-v1 => bin/ceilometer-api
21:50:31 <asalkeld> mv ceilometer-api-v1 ceilometer-api
21:50:40 <asalkeld> yip
21:50:41 <eglynn> jd__: got it, cool
21:50:41 * jd__ high fives asalkeld
21:50:58 <jd__> I'll do that tomorrow then
21:51:06 <nijaba> action?
21:51:13 <yjiang5> jd__: will this bring jenkins back?
21:51:22 <jd__> #action jd__ rename api to api-v2 and api-v1 to api
21:51:35 <jd__> yjiang5: Jenkins is already back, I sent a patch earlier today
21:51:47 <jd__> I need to do a bunch of recheck on everything, but didn't have time to do this today
21:51:48 <nijaba> and I fast track approved it
21:51:59 <jd__> on my evil plan for tomorrow, before the world ends
21:52:06 <yjiang5> jd__: thanks.
21:52:14 <asalkeld> haha
21:52:17 <yjiang5> jd__: hehe
21:52:33 <nijaba> we should meter that...
21:52:50 <jd__> hehe
21:53:33 <nijaba> anything else?
21:53:36 <yjiang5> jd__: BTW, please have a check on the multiple-publish patch when you are available, it has been changed
21:53:36 <dragondm> Folks here @ rackspace planning to contribute more to Ceilometer. We would like to use it for some of our usage.
21:53:40 <jd__> anyway pecan/wsme looks nice and the upstream author is helpful
21:53:50 <jd__> yjiang5: yeah I see, I'll look tomorrow too! :)
21:53:59 <eglynn> yjiang5: me too
21:54:07 <yjiang5> jd__: eglynn: thanks
21:54:08 <eglynn> dragondm: great!
21:54:12 <nijaba> dragondm: yep.  I have been discussing this with sandy and dan
21:54:14 <jd__> dragondm: do you have an idea of what you want to tackle first/
21:54:39 <dragondm> We have a list of things we'll need to run it at our scale in our infrastructure
21:54:41 <nijaba> dragondm: but I would like them to propose some concrete plan on the changes they think of
21:54:50 <nijaba> so we can discuss it here first
21:55:18 <dragondm> Yes, We will break out our stuff into some blueprints.
21:55:23 <nijaba> coolio
21:55:39 <danspraggins> nijaba: definitely agree. sandywalsh is not available for this meeting and holidays mean we'll probably need to wait until first of year.
21:55:45 <dragondm> Plus, we would like to bring in some of the features of our stacktach too.
21:55:49 <dragondm> er tool.
21:55:59 <danspraggins> we're certainly interested in working with the ceilometer group though.
21:56:14 <nijaba> all goodness to me. but needs to be planned carefully against the dealines of the project
21:56:31 <dragondm> Yah, our stuff is going to be longer range.
21:57:28 <dragondm> We're not going to drop it on you for g2 or such :->
21:57:40 <nijaba> dragondm: pfeww ;)
21:58:14 <dragondm> We are in the planning stage now, testing some ideas, etc.
21:58:33 <nijaba> with synaps, healthmon and multi-publisher, we already have qui te a bit for g3
21:59:54 <nijaba> ok, we are just at the top of the hour
22:00:01 <nijaba> any last comments?
22:00:11 <jd__> clear
22:00:15 <eglynn> nothing from me ...
22:00:18 <yjiang5> no
22:00:22 <asalkeld> happy holidays!
22:00:30 <nijaba> thanks a lot everyone, another great meeting
22:00:31 <eglynn> yep, ditto!
22:00:38 <danspraggins> thanks for having us. we'll meet back up after the beginning of the year to discuss the rackspace stuff.
22:00:46 <dragondm> Yup.
22:00:47 <nijaba> #action enjoy your hollidays
22:01:03 <nijaba> danspraggins: dragondm: happy to have you join
22:01:16 <nijaba> #endmeeting