15:00:33 <nijaba> #startmeeting Ceilometer
15:00:33 <nijaba> #meetingtopic Ceilometer
15:00:33 <nijaba> #chair nijaba
15:00:33 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
15:00:34 <openstack> Meeting started Thu Dec 13 15:00:33 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:37 <openstack> The meeting name has been set to 'ceilometer'
15:00:39 <openstack> Current chairs: nijaba
15:00:44 <nijaba> ATTENTION: please keep discussion focussed on topic until we reach open discussion topic
15:00:44 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
15:00:44 <nijaba> o/
15:00:53 <n0ano> o/
15:00:55 <jd__> o/
15:01:04 <zul> hi
15:01:04 <llu-laptop> o/
15:01:06 <jiajun> o/
15:01:17 <nijaba> #topic actions from previous meeting
15:01:18 <zul> |o|
15:01:29 <nijaba> #topic asalkeld prepare a blueprint for v2 api "tightening" changes
15:01:45 <eglynn> o/
15:01:51 <nijaba> anyone seen progress on this?
15:02:11 <eglynn> AFAIK asalkeld is working away on the flattening aspect
15:02:11 <yjiang5_away> o/
15:02:26 <nijaba> ok, Iĺl rea-action for next week
15:02:32 * eglynn is not sure whether flattening == tightening
15:02:37 <nijaba> #action asalkeld prepare a blueprint for v2 api "tightening" changes
15:02:49 <nijaba> #topic dhellmann replace ceilometer.readthedocs.org with a page directing readers to the new site
15:02:57 <nijaba> #info done
15:02:57 <nijaba> #link http://ceilometer.readthedocs.org/en/latest/
15:03:07 <nijaba> #topic dhellmann experiment with passing arrays of parameters to wsme for queries
15:03:18 <nijaba> I have not seen much on this either.  anyone?
15:03:32 <jd__> nop
15:03:45 <nijaba> #action dhellmann experiment with passing arrays of parameters to wsme for queries
15:03:53 <nijaba> #topic eglynn prepare a blueprint for synaps integration
15:04:06 <nijaba> eglynn wrote: I'm trying to get them to commit to some level of participation and to contribute to an assessment of how the healthnmon APIs/concept map onto ceilo (or conversely the level of impedance)
15:04:27 <yjiang5_away> eglynn: synaps?
15:04:27 <eglynn> yep, wot he said ;)
15:04:44 <nijaba> woops, I mixed up topics
15:04:53 <nijaba> wrote: I didn't get to filing the synaps-integration blueprints yet, still figuring some stuff out, but will have at least placeholders in place for our grizzly BP deadline
15:05:17 <eglynn> yep that about sums it up for now
15:05:34 <eglynn> I'm looking at Cassandra intregation as a first step
15:05:38 <nijaba> so we should mark this in progress, I guess
15:05:46 <eglynn> trying to unpick all the dependency issues ...
15:05:52 <eglynn> so progress, but still ongoing
15:06:01 <eglynn> BTW on the BPs
15:06:01 <nijaba> #info in progress
15:06:12 <yjiang5_away> eglynn: possibly a wiki page for discussion?
15:06:14 <eglynn> can I clarify the deadline for grizzly?
15:06:25 <eglynn> yjiang5_away: yep, I'll do that ...
15:06:36 <yjiang5_away> eglynn: thanks.
15:06:57 <eglynn> so is the deadline for grizzly approval Dec 15th?
15:06:57 <nijaba> eglynn: so the idea is that all blueprint that are targetted for grizzly, have an owner before the eo week
15:07:09 <eglynn> (or did I mis-remember that date ...)
15:07:17 <eglynn> OK end of this week
15:07:26 <nijaba> yes, but approval is automatic as long as someone has raised his hand sayong ï will do it
15:07:32 <eglynn> so Monday AM? ;)
15:07:44 <nijaba> and identify himself as such as assignee
15:07:56 <nijaba> moday am will be fine too
15:08:00 * eglynn tries to squeeze a little more time ;)
15:08:02 <eglynn> cool
15:08:22 <nijaba> we'll do a review and prioritization later in the meeting
15:08:44 <nijaba> #topic eglynn reach out to healthnmon project
15:08:51 <nijaba> eglynn wrote: I didn't get to filing the synaps-integration blueprints yet, still figuring some stuff out, but will have at least placeholders in place for our grizzly BP deadline
15:09:00 <nijaba> now that's on topic
15:09:17 <yjiang5_away> nijaba: hehe
15:09:24 <eglynn> as above: I'm trying to get them to commit to some level of participation and to contribute to an assessment of how the healthnmon APIs/concept map onto ceilo (or conversely the level of impedance)
15:09:35 * eglynn is wary of a code dump
15:10:04 <nijaba> #info still trying to get commitment
15:10:07 <eglynn> (so I would like some commitment on participation)
15:10:09 <eglynn> yep
15:10:24 <eglynn> so re-action for next week I think
15:10:34 <nijaba> thanks for your efforts eglynn
15:10:35 <nijaba> thanks for your efforts eglynn
15:10:39 <eglynn> np!
15:10:48 <yjiang5_away> nijaba: possibly some anysis of the feature duplication and feature we want on ceilometer will be helpful?
15:11:05 <nijaba> #action eglynn reach out to healthnmon project
15:11:24 <yjiang5_away> nijaba: I mean for healthnmon.
15:11:25 <nijaba> yjiang5_away: yes, thatś should be a starting point
15:11:40 <nijaba> again, a wiki page would be welcome
15:11:52 <eglynn> yjiang5_away: yes, duplication is certainly there ... and yes, I'll set up a wiki for that also
15:11:53 <yjiang5_away> nijaba: we can try to create one
15:12:03 <nijaba> great
15:12:13 <llu-laptop> Yes, we can help on that healthnmon wiki
15:12:32 <yjiang5_away> #action yjiang5 create wiki page for healthnmon
15:12:57 <nijaba> #action eglynn, yjiang5_away, llu-laptop to work on a wiki page for analysis of healthmon duplication, etc..
15:13:04 <nijaba> yjiang5_away: sorry :)
15:13:14 <yjiang5_away> nijaba: :)
15:13:22 <nijaba> This was all from last week's action
15:13:25 <Divakar> Hi This is Divakar from Healthnmon
15:13:34 <yjiang5_away> Divakar: hi
15:13:34 <nijaba> hello Divakar
15:14:05 <eglynn> hey Divikar, wlecome!
15:14:15 <nijaba> so whomever starts the analysis on the wiki should post the link to the ml
15:14:22 <Divakar> thank you.. I had shared the information on Healthnmon with eglynn
15:14:57 <eglynn> Divakar: did you see my latest mail on that thread?
15:15:12 <Divakar> Yes...I just did..
15:15:18 <eglynn> Divakar: (trying to get a sense of participation on your side...)
15:15:35 <eglynn> Divakar: cool
15:15:53 <nijaba> shall we move on to the next topic?
15:16:15 <eglynn> Divakar: and great to see you on IRC, hope to see more of you guys!
15:16:25 <eglynn> nijaba: k
15:16:29 <nijaba> #topic Final blueprint review
15:16:34 <Divakar> Yeah.. this time works for me
15:16:39 <nijaba> looking at https://blueprints.launchpad.net/ceilometer
15:16:42 <Divakar> alternate weeks works..
15:16:54 <eglynn> Divakar: great!
15:16:56 <nijaba> there are quite a few bp without an assignee
15:17:16 <nijaba> if you intend to commit working on one, now is the time toi mark yourself as the assignee
15:17:43 <nijaba> any non assigned bp next week will be retardgetted for H :)
15:17:44 <eglynn> I'll take https://blueprints.launchpad.net/ceilometer/+spec/remove-nova-imports
15:17:51 <Divakar> As shared earlier with you eglynn we are looking at single common Monitoring and alerting framework that will be part of base openstack with minimal replication
15:18:08 <eglynn> (done for libvirt, may still need some work for nova-notifier)
15:18:34 <Divakar> To start with implementation with stardardization of the framework, model and API which works for KVM hypervisor
15:18:36 <yjiang5_away> I plan to  take https://blueprints.launchpad.net/ceilometer/+spec/publisher-counters-frequency after I finished the multiple publisher work
15:18:36 <nijaba> of course we can retarget back later to grizzly, but I want to have a better vioew on what we are commited to deliver for g
15:18:59 <nijaba> please mark yourself as the assignee :)
15:19:14 <yjiang5_away> I rememeber we can't mark ourselves
15:19:24 <eglynn> Brooklyn expressed an interest in https://blueprints.launchpad.net/ceilometer/+spec/horizon-plugin earlier today
15:19:32 <yjiang5_away> only the core team can do that.
15:19:33 <nijaba> #info if you intend to commit working on one, now is the time toi mark yourself as the assignee, any non assigned bp next week will be retardgetted for H :)
15:19:50 <eglynn> so I assigned him to it, he'll take his initial ideas to the ML for discussion with UX experts
15:19:57 <nijaba> in this case, feel free to ping me to assign you.
15:20:03 <yjiang5_away> nijaba: thanks!
15:20:39 <eglynn> https://blueprints.launchpad.net/ceilometer/+spec/merge-efforts-synaps is obviously mine too
15:20:45 <eglynn> (just assigned it to me)
15:20:59 <nijaba> thanks
15:20:59 <eglynn> I'll use it as an umbrella BP for the sunaps work
15:21:09 <eglynn> s/sunaps/synaps/
15:21:22 <llu-laptop> we'd like to take https://blueprints.launchpad.net/ceilometer/+spec/monitoring-physical-devices
15:21:24 <nijaba> #info please ping nijaba to get assigned to a blueprint
15:21:43 <nijaba> #info and specify your launchpad id
15:22:09 <eglynn> doesn't https://blueprints.launchpad.net/ceilometer/+spec/user-api fall out of dhellman's v2 API work?
15:22:29 <Divakar> Our intent of healthnmon also caters towards monitoring physical devices as well..
15:22:30 <nijaba> eglynn: no, but I have an assignee for it
15:22:33 <yjiang5_away> eglynn: I think you need create several other BP for synaps integration, it's a big effort IMO :)
15:22:38 <eglynn> sorry gotta drop off now ...
15:22:44 <llu-laptop> my launchpad id is lianhao-lu
15:22:48 <nijaba> eglynn: cheers
15:22:53 <eglynn> I'll catch up via the IRC logs later!
15:22:56 <eglynn> thanks all!
15:23:06 <Divakar> data model defined should support physical devices as well
15:23:45 <llu-laptop> Divakar: yes, we should refine the data model.
15:23:59 <yjiang5_away> Divakar: I think we can have more discussion on this through ml?
15:24:06 <Divakar> sure
15:24:26 <yjiang5_away> Divakar: great.
15:25:27 <nijaba> now looking at https://launchpad.net/ceilometer/+milestone/grizzly-2
15:25:39 <nijaba> This looks good to me
15:26:03 <nijaba> any bp that we should add for this target?
15:26:13 <nijaba> which is Jan 10, btw
15:26:24 <jd__> I just changed https://blueprints.launchpad.net/ceilometer/+spec/python-ceilometerclient to implemented
15:26:42 <nijaba> jd__: great, Ill change the target to g2 then
15:26:55 <jd__> I think https://blueprints.launchpad.net/ceilometer/+spec/nova-independent-virt is implemented too, eglynn?
15:27:01 <jd__> ah eglynn is AFK
15:27:21 <nijaba> duh, it was already g2
15:27:38 <jd__> #action jd__ ask eglynn if https://blueprints.launchpad.net/ceilometer/+spec/nova-independent-virt is implemented
15:27:45 <nijaba> perfect
15:28:13 <nijaba> jd__: are you still confident about https://blueprints.launchpad.net/ceilometer/+spec/pollster-swift?
15:28:16 <jd__> eglynn: ^^^ feel free to answer to me or change the status if/when you'll read the backlog :-)
15:28:47 <jd__> nijaba: I've already a working basic thing, I'll send a patch early next week
15:29:03 <jd__> I want to do some more tests on it first :)
15:29:06 <nijaba> jd__: great
15:30:01 <nijaba> any news on the implementation of the new rpc model for https://blueprints.launchpad.net/ceilometer/+spec/use-new-rpc-messsage
15:30:03 <nijaba> ?
15:30:29 <jd__> never heard of anything about this oslo side
15:30:30 <yjiang5_away> nijaba: anyone working on it?
15:30:51 <jd__> nijaba: is the oslo blueprint implemented already?
15:31:05 <nijaba> russellb is on the oslo bp
15:31:23 <nijaba> it is marked as needs review
15:31:53 <jd__> ah missed the dep graph
15:32:25 <jd__> https://review.openstack.org/#/c/17965/ seems really recent
15:33:21 <jd__> hum, the patch is against nova and not oslo, and has no tests
15:33:31 <nijaba> what about https://blueprints.launchpad.net/ceilometer/+spec/nova-cell-support ?  any news on cell implementation?
15:33:55 <nijaba> jd__: ok, can you get in touch with russellb to get some more info?
15:34:27 <jd__> #action jd__ get in touch with russellb to more info about https://blueprints.launchpad.net/ceilometer/+spec/use-new-rpc-messsage
15:34:35 <russellb> hi
15:34:43 <jd__> yeah, that was a fast action!
15:34:47 <jd__> hi russellb :)
15:34:57 <nijaba> hello russellb
15:35:14 <russellb> so ... that patch is very close, up for review, i think it's "done"
15:35:20 <russellb> bit of a complication with ceilometer actually
15:35:28 <jd__> russellb: I was looking at your patch https://review.openstack.org/#/c/17965/, why is it on nova and not oslo?
15:35:45 <russellb> it's in oslo too, the nova patch is just up so that nova tests will run against it
15:36:04 <russellb> https://review.openstack.org/#/c/17554/
15:36:06 <russellb> that's the oslo patch
15:36:21 <jd__> russellb: ah great!
15:36:23 <russellb> it's not going to be complete from the ceilometer perspective though, i'm afraid
15:36:35 <russellb> it doesn't apply the message envelope to notifications right now
15:36:45 <jd__> ok
15:37:02 <russellb> because i was thinking about it, and notifications are to be consumed by applications outside of openstack, and it would break all of them
15:37:02 <jd__> anything that's blocking doing that?
15:37:24 <jd__> :-/
15:37:39 <jd__> has (other) oslo maintainers an opinion about this?
15:37:43 <nijaba> russellb: but isn't the change made so that we can prevent future breakage?
15:37:44 <russellb> but i excluded notifications before i later updated the patch to not use the message envelope by default, so we can phase it in
15:37:44 <jd__> s/s/ve/
15:37:49 <russellb> that *may* be sufficient ...
15:38:09 <russellb> definitely interested in your thoughts on it
15:38:41 <nijaba> I'd suggest raising the question on the ml so more eyes get on it
15:38:57 <russellb> good idea, i can do that
15:39:09 <nijaba> russellb: thanks!
15:39:11 <jd__> thanks russellb
15:39:56 <jd__> #action russellb raises the question about Oslo notifications versionning on the ml
15:39:57 <jd__> :)
15:40:05 <russellb> aside from that slightly significant complication, it's done :-p
15:40:07 <nijaba> hehe
15:40:22 <jd__> that's a good first step, indeed
15:40:57 <nijaba> ok, thatś all for me on this topic of blueprints.  anything else?
15:42:03 <nijaba> ok, moving on
15:42:09 <nijaba> #topic Open Discussion
15:42:16 <zul> hi i have something
15:42:24 <nijaba> zul: pelase shoot
15:42:37 <zul> so recently pecan was added to tools/pip-requires
15:42:46 <zul> which is fine (not packaged in ubuntu)
15:42:56 <zul> however it depends on a newer version of webob
15:43:20 <zul> 1.2dev i believe which is incompatible with other openstack projects (ie: nova, glance, etc)
15:43:35 <zul> so makes me not happy
15:43:44 <llu-laptop> yes. That's bug https://bugs.launchpad.net/ceilometer/+bug/1089734.
15:43:45 <uvirtbot> Launchpad bug 1089734 in ceilometer "ceilometer-collector fail to start cause no ceilometer.collector extensions found" [Undecided,New]
15:44:02 <jd__> zul: that's only for version 2 of the API which is not finished, so you can also comment out that deps and be fine
15:44:04 <nijaba> zul: dhellmann made most of these changes and is unfortunately on vaction this week.  I would hope this would be fixed before g2
15:44:33 <zul> jd_: ok i can live with that
15:44:56 <jd__> zul: you'll probably have ceilometer-api not working but ceilometer-api-v1 will be fine
15:45:08 <zul> nijaba: im on vacation starting tomorrow so ill put it on my todo list to talk to dhellman when i get back
15:45:16 <nijaba> zul: great!
15:45:52 <nijaba> So, we decided to have a Bug squashing day on Jan 4th.  Any volunteer to organize it, as I will be on vacation that week
15:46:59 <nijaba> #action need to find a volunteer to organize bug squashing day on Jan 4th
15:47:07 <yjiang5_away> nijaba: I'm available that day, so if any help needed, I'm available, although no experience on orgnize it
15:47:52 <jiajun> nijaba: I also could help on it if needed
15:47:57 <nijaba> yjiang5_away: thanks. Well hope to get more volunteers before next week
15:47:57 <yjiang5_away> s/orginize/orgnizing/
15:48:02 <nijaba> jiajun: ditto
15:48:05 <jd__> nijaba: I can probably help too
15:48:10 <nijaba> \o/
15:48:31 <jd__> and I think dhellmann will be around too
15:48:43 <jd__> don't want to volunteer him, but… :)
15:48:51 <nijaba> so I'll send an email on the ml and we can get more on this on the ml
15:49:25 <nijaba> any other topic, or should we end the meeting early?
15:49:56 <jd__> I'm good
15:50:11 <yjiang5_away> nijaba: k
15:50:14 <nijaba> counting down to from 3
15:50:19 <nijaba> 2
15:50:23 <nijaba> 1
15:50:35 <nijaba> #endmeeting