15:04:48 <nijaba> #startmeeting Ceilometer
15:04:48 <nijaba> #meetingtopic Ceilometer
15:04:48 <nijaba> #chair nijaba
15:04:48 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
15:04:49 <openstack> Meeting started Thu Oct 11 15:04:48 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:51 <openstack> The meeting name has been set to 'ceilometer'
15:04:53 <jd__> thanks
15:04:54 <openstack> Current chairs: nijaba
15:05:01 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
15:05:01 <nijaba> o/
15:05:03 <jd__> o/
15:05:07 <gmb> o/
15:05:08 <dhellmann> o/
15:05:10 <nijaba> thanks jeblair
15:05:10 <jtran> o/
15:05:12 <DanD> o/
15:05:14 <eglynn> o/
15:05:31 <nijaba> #topic actions from previous meeting
15:05:43 <nijaba> #topic jd to create a stable branch on monday
15:06:19 <nijaba> so I think this was consider too much of a pai by the infra team, right jd__?
15:06:26 <jd__> yep
15:06:37 <jtran> pai?
15:06:42 <nijaba> pain
15:06:42 <jd__> pain
15:06:48 <dhellmann> so we will use master as our stable branch?
15:06:53 <jd__> and we can't ask all of that because we're not official nor incubated
15:07:08 * dhellmann wonders how hard it is to make branches
15:07:08 <jd__> actually, miletsone-proposed was refused
15:07:09 <jeblair> well
15:07:14 <dhellmann> ah
15:07:19 <jd__> not doing a folsom branch
15:07:27 <jeblair> so i think we wanted to set up permissions so you can make your own branches....
15:07:36 <jeblair> but we haven't gotten around to that yet
15:07:38 <dhellmann> jeblair: that would be a good compromise
15:07:39 <nijaba> yes,that would be nice
15:07:42 <jd__> we'll be able to create a folsom branch just by asking infra to create it with the commit id
15:07:58 <jeblair> so in the mean time, we should just create the branch for you instead of giving you a hard time.  :)
15:07:59 <jd__> (well unless jeblair give us permissions)
15:08:08 <jd__> +s
15:08:31 <nijaba> jeblair: can I mark an action for you?
15:08:47 <nijaba> (sorry to have pulled you in a trap)
15:08:53 <jeblair> nijaba: sure.  :)
15:09:00 <dhellmann> do we want whatever HEAD is now, or do we need to think about which revision should be used?
15:09:15 <nijaba> #action jeblair to give us rights t create our own branches
15:09:37 <nijaba> dhellmann: let's see that under the release status topic
15:09:45 <dhellmann> nijaba: ok
15:09:47 <eglynn> so in the end, it was decided not to go ahead with the milestone-proposed style branching for the run-up to the release?
15:10:02 <nijaba> eglynn: yep, we did not have much coice
15:10:11 <eglynn> nijaba: fair enough
15:10:41 <nijaba> #topic nijaba to prime release notes in the docs
15:10:52 <nijaba> his was done and is now visible at
15:10:52 <nijaba> #link http://ceilometer.readthedocs.org/en/latest/releasenotes/index.html
15:10:52 <nijaba> Please send patches if we need to add to this
15:11:20 <nijaba> doc/sources/releasenotes/ in the code
15:11:35 <nijaba> any comments or suggestions?
15:12:06 <dhellmann> thanks for doing so much work on the docs this week, nijaba, they look really good
15:12:19 <nijaba> you are welcome dhellmann
15:12:45 <nijaba> I'll skip the next action as it was already discussed as part of the first acton
15:12:57 <nijaba> #topic jd to check if infrateam can generate a tarball for us
15:13:19 <nijaba> jd__: what did infra say on this?
15:13:44 <dhellmann> would that be different than the tarballs github produces in some way?
15:13:53 <jd__> didn't ask, but we can have some on github I think
15:14:20 <nijaba> so that's link to us being admin of our projec on github, I guess?
15:14:33 <jd__> somehow yes, we need to be able to tag our project
15:14:55 <dhellmann> I wonder if we can just push a tag to that repo through gerrit?
15:15:19 <nijaba> ok, we already have an action on this, but will need to chase this quickly to be able to release
15:15:37 <jd__> i think globally that infra doesn't know more than us how to handle our project and our release, so once we want to release we'll have to go ask for things *now* and they'll have to find a way :)
15:16:03 <dhellmann> jd__: maybe if we just focus on getting the permissions, we can experiment
15:16:12 <nijaba> dhellmann: +1
15:16:35 <jd__> ah sure, but I didn't feel they wanted to give us any permission
15:16:40 <jd__> but I might be wrong :)
15:16:53 <nijaba> jeblair: any comments on this?
15:16:58 <jd__> now that we are asking for so many thing they might change their mind :-D
15:17:24 <dhellmann> jd__: I think it was only a matter of not having time to help us
15:17:44 <jeblair> hi
15:18:01 * nijaba propose that we go in #infra just after the meeting to get to the bottom of this
15:18:19 <jd__> #vote yes
15:18:23 <jeblair> so i think the way we want to handle this is for one or more of you guys brush up on how jenkins jobs are built
15:18:36 <jeblair> and then you can add it to the infra yourself
15:18:49 * dhellmann is confused
15:18:50 <jtran> that's  agood idea.
15:18:53 <jeblair> all the jobs, etc, are in a git repo anyone can submit changes to
15:19:00 <dhellmann> what does jenkins have to do with branching our repo?
15:19:11 <jeblair> dhellmann: this was tarballs, yeah?
15:19:20 <dhellmann> oh, I see
15:19:44 <dhellmann> nijaba: is the tarball a release requirement?
15:19:59 <nijaba> dhellmann: I would think so...
15:20:09 <nijaba> dhellmann: what would distro use otherwise?  brnahc?
15:20:15 <nijaba> branch even...
15:20:26 <dhellmann> nijaba: could not just point them at the tarball github produces?
15:20:52 <dhellmann> ^could not^could we not
15:20:52 <uvirtbot> dhellmann: Error: "could" is not a valid command.
15:20:55 <nijaba> dhellmann: if is clearly identifiable and durable, yes
15:20:58 <mordred> dhellmann: no
15:21:12 <mordred> the tarball github produces is not a good tarball
15:21:23 <mordred> (you guys are python, right?)
15:21:29 <dhellmann> mordred: yes
15:21:30 <nijaba> we are
15:21:50 <mordred> sadly, the github tarballs are not python sdist tarballs
15:22:10 <mordred> so they don't have metadata that's needed for the tarballs for fully-well interact with stuff like pip
15:22:13 <dhellmann> ok, so we have 2 things we have to do for the release
15:22:19 <dhellmann> 1. make the stable branch
15:22:20 <dhellmann> 2
15:22:20 <dhellmann> 
15:22:21 <dhellmann> s
15:22:22 <dhellmann> 
15:22:27 <dhellmann> 2. set up the job to make the sdist tarball
15:22:37 <mordred> ++
15:22:53 <nijaba> ok, let's park this for now.  dhellmann, jd__ are you ok to followup on this in -infra right after the meeting?
15:22:55 <jd__> 3. be able to push to the stable branch
15:22:59 <dhellmann> nijaba: yes
15:23:02 <dhellmann> jd__: +1
15:23:02 <jd__> nijaba: I'm in
15:23:27 <nijaba> #action dhellmann, jd__, nijaba to follow on infra fr our release reqs
15:23:41 <nijaba> #topic nijaba to resfresh http://wiki.openstack.org/Governance/Proposed/Ceilometer before sending email to the tc
15:23:50 <nijaba> That was done and the email to the tc was sent.  Looking at the tc ml archive, it seems that the vote on incubation will not happen during the face to face meeting for lack of logging and supposed openess of the process.
15:24:36 <dhellmann> do we know when they are holding their next online meeting?
15:24:58 <nijaba> archives: http://lists.openstack.org/pipermail/openstack-tc/2012-October/thread.html
15:25:18 <nijaba> http://wiki.openstack.org/Governance/TechnicalCommittee
15:25:35 <nijaba> it lists the in person meeting as the next meeting, next is tbd
15:25:47 <dhellmann> can anyone subscribe to that list?
15:26:13 <nijaba> "First regular TC meeting will happen the week after the Design Summit, time tbd at the inaugural meeting. "
15:26:30 <spn__> o/
15:26:41 <nijaba> dhellmann: I haven't tried, I just look at the achives now and then
15:26:53 <dhellmann> ok
15:27:07 <nijaba> I guess that's it for this week's actions...
15:27:32 <nijaba> #topic Release status
15:27:44 <nijaba> gmb, the floor is yours
15:29:09 <nijaba> gmb?
15:29:31 <gmb> Sorry, was getting pinged in another channel
15:29:32 <gmb> So
15:30:00 <gmb> All the items on the RoadMap that are required for Folsom.0 / 0.1 are committed (thanks jd__ for taking care of that last bug). We're good to go.
15:30:25 <gmb> I would have targeted all the bugs to a 0.1 milestone
15:30:32 <gmb> As I said in my email last week
15:30:39 <nijaba> anything blatently missing (we'll get to bugs in a minute)?
15:30:43 <gmb> But Launchpad is being uncooperatve.
15:30:49 <gmb> nijaba: Not AFAICT.
15:31:00 <nijaba> anyone else?
15:31:24 <jd__> nop
15:31:32 <dhellmann> do we need to add a trove classifier to our setup.py indicating this is an alpha?
15:31:55 <dhellmann> I don't know if any packaging tools other than pypi pay attention to that field
15:32:04 <nijaba> dhellmann: I do not think we need that
15:32:11 <dhellmann> ok, then I think we're ready
15:32:39 <dhellmann> it looks like I7837e80940e7ee9622bdcd3b1f253d582f383d1a (current HEAD on github) would be a good place to branch for the release
15:33:01 <dhellmann> oops, that's the change id not the commit id, I meant : f2aee4b75d07a5f4d8ecf381934452e2a8dc9a3d
15:33:16 <nijaba> dhellmann: almost. as I am going to propose one last change before release
15:33:26 <dhellmann> lol
15:33:28 <nijaba> but that in 2 topics from now
15:33:44 <dhellmann> ok
15:33:49 <jd__> suspense
15:33:59 * dhellmann moves to the edge of his seat
15:34:04 <nijaba> hehe
15:34:19 <nijaba> #topic Outstanding bugs
15:34:39 <nijaba> so, do we have any outstanding bugs that we need to fix before release?
15:34:55 <nijaba> I had a look and I can't find any...  what do you guys think?
15:35:23 <dhellmann> most of the open tickets are either wishlist, large, or small enough not to matter
15:35:38 <dhellmann> I feel good about cutting things off where we are
15:35:42 <jd__> +1
15:35:57 <nijaba> +1
15:36:18 <nijaba> anyone against (or shutup until next release) ;)
15:36:18 * eglynn is sad that https://review.openstack.org/14175 didn't make it ...
15:36:32 <eglynn> other than that, +1
15:36:50 <jtran> +1
15:36:51 <spn__> +1
15:36:58 <dhellmann> eglynn: I'll approve that right after the release is branched
15:37:00 <gmb> +1
15:37:07 <nijaba> eglynn: I think that landed a bit too late in our "feature freeze"
15:37:08 <eglynn> dhellmann: cool
15:37:16 <eglynn> nijaba: understood
15:37:39 <nijaba> ok, so we are good to go, but....
15:37:42 <nijaba> #topic Naming convention for Meters
15:37:57 <nijaba> root_disk_size
15:37:57 <nijaba> ephemeral_disk_size
15:37:57 <nijaba> floating_ip
15:37:57 <nijaba> volume_size
15:37:57 <nijaba> seem like the remaining counters that we should rename
15:38:14 <nijaba> they just stic out when looking at http://ceilometer.readthedocs.org/en/latest/measurements.html
15:38:22 <dhellmann> jd__, we talked about the disk names didn't we?
15:38:28 <nijaba> What I would propose is that we always use dot as separators and go from least to most discriminent. Ie:
15:38:28 <nijaba> disk.root.size
15:38:28 <nijaba> disk.ephemeral.size
15:38:28 <nijaba> etc...
15:38:38 <dhellmann> yes
15:38:42 <nijaba> and I would propose to do that before release
15:38:47 <dhellmann> I don't know about floating.ip though, maybe just floatingip?
15:38:47 <jd__> there's also "instance:flavor"
15:39:00 <jd__> yes, floatingip
15:39:09 <dhellmann> instance flavors have dots, so maybe instance.flavor.m1.tiny etc?
15:39:10 <nijaba> since it is a pain to change for people having it prod
15:39:14 <DanD> one issue with the dotted notation is how it gets embedded in a REST API
15:39:14 <eglynn> +1 to pre-release counter naming changes, much messier to do post-release
15:39:25 * nijaba offers to propose the pacth
15:39:29 <jd__> dhellmann: yeah why not
15:39:29 <dhellmann> +1
15:39:41 <jd__> nijaba: thanks :)
15:39:48 <jd__> DanD: think about a particular issie?
15:39:51 <jd__> s/i/u/
15:39:54 <dhellmann> nijaba: can we keep the instance:flavor meter for now and add the new one? I already have code in production that depends on that
15:40:18 <dhellmann> nijaba: we can leave it out of the documentation, and I will submit a patch to clean it up in a week or two
15:40:19 <nijaba> yes, I think this is a very particular case
15:40:52 <nijaba> I would be personally in favor to say that any variable name should be using a : before the var starts
15:41:17 <dhellmann> well, that's an idea
15:41:20 <nijaba> and therefore keep it that way
15:41:32 * nijaba makes up grammar on the fly
15:41:40 <dhellmann> ok, I meant to use both meters and keep the old version just for backwards compatibility
15:42:13 <dhellmann> but using a special indicator that part of the name is a variable makes sense, too
15:42:21 <jd__> yeah not a bad idea
15:42:50 <nijaba> so the proposed rule is "always use dot as separators and go from least to most discriminent. when a part of the name is a variable, it shold always be at the end and starts with a ':'"
15:42:57 <nijaba> woud you like to vote on this?
15:43:14 <dhellmann> sure
15:43:42 <nijaba> #startvote agree on meter convention? yes, no
15:43:43 <openstack> Begin voting on: agree on meter convention? Valid vote options are yes, no.
15:43:44 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:43:49 <dhellmann> #vote yes
15:43:50 <spn__> yes
15:43:50 <jd__> #vote yes
15:43:51 <nijaba> #vote yes
15:44:01 <spn__> #vote yes
15:44:04 <eglynn> #vote yes
15:44:10 <DanD> #vote yes
15:44:15 <gmb> #vote yes
15:44:34 <nijaba> #endvote
15:44:35 <openstack> Voted on "agree on meter convention?" Results are
15:44:36 <openstack> yes (7): jd__, nijaba, eglynn, dhellmann, gmb, spn__, DanD
15:45:01 <nijaba> ok, great.  Patch will be done tonight to fix existing meters
15:45:21 <nijaba> #action nijaba to patch existing meter name to follow rule
15:45:38 <nijaba> #action nijaba to put the rule in the doc too
15:45:47 * dhellmann was just about to suggest that
15:46:08 <nijaba> ok, so I guess that once this has landed, we should be able to release tomorrow
15:46:19 <dhellmann> \o/
15:46:24 <eglynn> (with some illustrative examples in docco, always good ...)
15:46:35 <nijaba> should we have a release meeting tomorrow at 3M UTC to finalize?
15:46:42 <nijaba> in our regular chan
15:46:53 <spn__> sounds good
15:47:00 <jd__> we might want to merge https://review.openstack.org/#/c/14338/ too
15:47:06 * jd__ sending last-minute-patches
15:47:19 * nijaba discovers it
15:47:59 <dhellmann> that's the tool for putting data in the db to test the api, right?
15:47:59 <jd__> 3PM UTC is bad for me tomorrow
15:48:03 <jd__> dhellmann: yes
15:48:11 <nijaba> jd__: later?
15:48:46 <dhellmann> or earlier?
15:48:47 <nijaba> jd__: looks pretty acceptable for me.
15:49:09 <jd__> I don't think I can after 14:00 UTC, so do it without me
15:49:23 <dhellmann> that tool wasn't really meant for end users, but we can commit it if the group feels it is important
15:49:51 <jd__> dhellmann: i think it's good to have it working so people can try with fake data :)
15:49:59 <nijaba> dhellmann: for the same reasons I can't think why not to merge it
15:50:04 <dhellmann> jd__: that makes sense
15:50:05 <dhellmann> n
15:50:05 <dhellmann> i
15:50:06 <dhellmann> j
15:50:11 * dhellmann needs a new irc client
15:50:22 <dhellmann> nijaba: just being strict :-)
15:50:26 <nijaba> hehe
15:50:44 <jd__> dhellmann: ERC! :)
15:51:02 <nijaba> ok, let's review it and merge it then...
15:51:16 <dhellmann> +2
15:51:47 <dhellmann> did we settle on a time for that meeting tomorrow?
15:51:50 <nijaba> so, back on the release meeting then.  I can do 14UTC is jd__ is ok with that, busy the hour before though
15:51:55 <jtran> oh snap, i accidentally prematurely approved that patch
15:52:12 <dhellmann> lol
15:52:14 <jtran> wait, i guess i am 2nd reviewer.  so gtg
15:52:30 <nijaba> np, thanks jtran
15:52:56 <dhellmann> 14UTC works for me
15:53:07 <nijaba> gmb?
15:53:09 <spn__> cool for me
15:53:15 <gmb> Works for me.
15:53:30 <nijaba> still waiting for jd__
15:53:31 <jd__> nijaba: 14:00 UTC is the time I leave, so… :)
15:53:43 <nijaba> :/
15:54:01 <nijaba> ok, so we'll do it at 14UTC, but without jd__ :(
15:54:11 <jd__> and french trains in the country don't have good network connectivities
15:54:31 <dhellmann> jd__: you could email the list if you have anything you want us to address
15:54:35 <nijaba> #agreed release meeting tomorrow @14UTC in #openstack-metering (no logs!)
15:54:50 <jd__> dhellmann: sure, no prob
15:55:10 <nijaba> ok, let's move to the most important topic:
15:55:19 <nijaba> #topic Open Discussion
15:55:21 <dhellmann> I can meet as early as 11UTC if we want to move it earlier
15:55:53 <eglynn> just a quick reminder that sdake floated the idea of a pre-summit meetup on Sunday evening at the conference hotel
15:56:20 <jtran> eglynn: i'd be up for that
15:56:26 <dhellmann> eglynn: yes, me, too
15:56:33 <jtran> not that i'm contributing anything :)
15:56:34 <nijaba> eglynn: great idea, but I am already booked for that evening :(
15:56:39 <eglynn> jtran, dellmann: cool
15:56:44 <dhellmann> some time that evening, around or after 18:00?
15:56:48 <nijaba> but feel free to do it without me
15:57:04 <eglynn> my flight gets in at 18.15, so maybe a bit later?
15:57:17 <dhellmann> eglynn: sure, maybe drinks instead of dinner then?
15:57:32 <eglynn> dhellmann: sounds good
15:57:42 <jd__> I've started a text/html render quickly for fun for ceilometer-api http://naquadah.org/~jd/Screenshot%20from%202012-10-11%2017:51:49.png
15:57:42 <nijaba> eglynn or dhellmann: if you ca send me your cell #, I might be able to join you a bit later
15:57:57 <eglynn> nijaba: will do
15:58:04 <nijaba> eglynn: thanks
15:58:12 <dhellmann> nijaba: great
15:59:01 <nijaba> Almost running out of time. should we clse the meeting and go in -infra?
15:59:07 <dhellmann> +1
15:59:20 <nijaba> #endmeeting