15:00:01 <nijaba> #startmeeting Ceilometer
15:00:01 <nijaba> #meetingtopic Ceilometer
15:00:01 <nijaba> #chair nijaba
15:00:01 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
15:00:02 <openstack> Meeting started Thu Oct  4 15:00:01 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:04 <openstack> The meeting name has been set to 'ceilometer'
15:00:06 <openstack> Current chairs: nijaba
15:00:12 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
15:00:12 <nijaba> o/
15:00:14 <spn> o/
15:00:17 <eglynn> o/
15:00:32 <russellb> o/
15:00:38 <cp16net> o/
15:00:51 <nijaba> nice!
15:00:56 <nijaba> #topic actions from previous meeting
15:00:56 <nijaba> #topic nijaba to share a first version of the slides with dhellmann
15:01:07 <nijaba> We've been working well together and I think we almost have a final version
15:01:21 <nijaba> about 20 slides for 40 minutes
15:01:29 <spn> cool
15:01:31 <dhellmann> o/
15:01:32 <nijaba> volunteers to review?
15:02:02 <journeeman> o/
15:02:12 <nijaba> please pm me your google enabled address if you want to give us your feedback
15:02:26 <nijaba> #topic dhellmann to provide some bullet points on DH use case
15:02:39 <nijaba> that was done too as part of the slides
15:02:49 <DanD> o/
15:02:54 <nijaba> #topic dhellmann update status on http://wiki.openstack.org/EfficientMetering/RoadMap
15:03:02 <nijaba> dhellmann: ?
15:03:12 <dhellmann> I did update it, but it is not entirely up to date
15:03:22 <jd__> lo
15:03:28 <dhellmann> I completed a review of all of the meters we're collecting earlier today, so I have enough info to finish that now
15:04:04 <nijaba> nice!
15:04:18 <nijaba> #topic gmb to email the list with a summary of how things stand for the release
15:04:36 <nijaba> gmb is busy, but he will be sending the email before the eod
15:05:15 <nijaba> #topic Release status
15:05:33 <nijaba> so, while gmb is out, I think we need to drive this forward
15:05:44 <nijaba> I think we are past our feature freeze date
15:05:50 <nijaba> but are still accepting features
15:05:59 <nijaba> so when should we be cutting off?
15:06:01 * dhellmann hangs head in shame
15:06:21 * jd__ votes $RANDOM
15:06:43 <nijaba> what feature are on the verge of delivery that we would like to have?
15:07:00 <dhellmann> there are 2 things I'd like to include
15:07:12 <dhellmann> 1. option to disable meters through configuration
15:07:23 <nijaba> I think it would be nice to have release on the 14th latest, so we can say it is done at the summit
15:07:25 <dhellmann> 2. review and standardize the meter names
15:07:41 <dhellmann> #1 isn't a requirement for a 0.1 release, but would be nice
15:07:45 <nijaba> dhellmann: do you think this can be completed before the end of this week?
15:07:55 <dhellmann> #2 will be more difficult to change later, I think, after people start depending on the current names
15:08:04 <nijaba> so that next week can be dedicated to test and release?
15:08:26 <dhellmann> I think so. jd__ what do you think?
15:08:36 <jd__> hum
15:09:02 * dhellmann just noticed a bunch of related code reviews from jd__
15:09:02 <jd__> i think both requirement makes sense
15:09:12 <jd__> I've started #2 a bit actually as you just noticed
15:09:23 <dhellmann> I'll take #1
15:09:31 <dhellmann> I know how I want that done, and Justin started the code already
15:09:32 <jd__> we have a start for #1 I think, right?
15:09:38 <jd__> ok :)
15:09:41 <jd__> that's what I though
15:09:48 <jd__> +t
15:10:03 <jd__> I think it'll be enough for a first release
15:10:16 <nijaba> so, feature free on saturday?
15:10:21 <jd__> we can call this "technical preview" or something like that
15:10:30 <jd__> i'm sure there's a good marketing name :)
15:10:32 <dhellmann> let's say sunday since I may not actually get to work on it until then
15:10:33 <nijaba> 0.1 carrues that very well, I think :)
15:10:44 <jd__> nijaba: indeed :)
15:10:48 <dhellmann> 0.1 should be marked an alpha, right?
15:10:58 <nijaba> #agreed feature freeze push to sunday
15:11:00 <jd__> one day I'll write a book on software version numbers
15:11:22 <spn> ;)
15:11:27 <dhellmann> :-)
15:11:29 <nijaba> dhellmann: call it what you want, I know crazy guys will be usingit in prod regardless ;)
15:11:44 <dhellmann> heh
15:12:03 <cp16net> nijaba: yeah i was wondering is anyone running this ina  prod env?
15:12:17 <nijaba> ok, then what do we need to do then to have a release?
15:12:20 <dhellmann> cp16net: we will be soon at DreamHost
15:12:20 <cp16net> or just dev or local env
15:12:28 <dhellmann> but so far only dev
15:12:32 <cp16net> ok cool
15:13:53 <nijaba> we need to open a new dev branch and gate the existing one to bug fix only.  Who can do that on monday
15:14:04 <nijaba> I have no idea how to do this with git
15:14:20 <nijaba> volunteers?
15:14:35 <jd__> I can try
15:14:55 <spn> do we need to have special access on github to do that?
15:14:58 <jd__> OTOH I think we need to adapt to something like other projects, we continue to commit in master but create stable branch
15:15:12 <dhellmann> +1 to stable branch
15:15:15 <nijaba> jd__: ok that works too
15:15:20 <jd__> spn: not sure, I think i'll poke the -infra guys
15:15:27 <eglynn> also a milestone-proposed branch?
15:15:27 <dhellmann> the guys in openstack-infra should be able to explain how
15:15:39 <nijaba> #action jd__ to create a stable branch on monday
15:15:39 <spn> cool
15:15:42 <dhellmann> eglynn: we would need to define some milestones first, no? :-)
15:16:04 <jd__> I think just a folsom/stable branch would be enough for now
15:16:16 <srini_g> 0/
15:16:18 <jd__> it's not like we are expected to release real working stuff
15:16:20 <jd__> :->
15:16:21 <eglynn> dhellmann: the milestone-proposed branch is usually used for pre-release fixes
15:16:23 <srini_g> o/
15:16:27 <dhellmann> nijaba: we should, after (or at?) the summit put together a set of milestones for grizzly
15:16:33 <nijaba> dhellmann: +1
15:16:40 <jd__> roooaaarr (grizzly)
15:16:41 <cp16net> and tag master as well
15:16:42 <eglynn> also shouldn't the stable/folsom only be cut once the release is done?
15:16:56 <dhellmann> eglynn: cutting after the release makes sense
15:17:05 <jd__> eglynn: we release on sunday and makes the branch on monday?
15:17:26 <nijaba> next week is QA week, we release the weekend after
15:17:35 <dhellmann> nijaba: that makes sense
15:17:46 <eglynn> jd__ we feature freeze on Sunday, but release later in the week?
15:17:55 <nijaba> so we should work on bug fixes on the stabel branch, new features land on master
15:17:56 <eglynn> so fixes next week go on master first, then cherry picked onto miletsone-proposed
15:18:00 <dhellmann> eglynn: the milestone-proposed branch may make more sense after we have our first release then? I'm not sure what it buys us now
15:18:09 <dhellmann> ah
15:18:31 <eglynn> milestone-proposed for pre-relase fixes, stable/folsom for post-relase fixes
15:18:42 <eglynn> s/relase/release/
15:18:42 <dhellmann> I see
15:18:46 <nijaba> eglynn: ah, that makes sense
15:19:10 * nijaba wonder if ttx is lurking
15:19:20 <eglynn> FYI some more detail on the process: http://wiki.openstack.org/GerritJenkinsGithub#Authoring_Changes_for_milestone-proposed
15:19:42 <nijaba> thanks eglynn
15:19:46 <jd__> http://wiki.openstack.org/BranchModel worth reading too
15:19:51 <ttx> nijaba: no
15:20:24 <ttx> need help ?
15:20:42 <nijaba> ttx: if you have best practices for handling our release
15:20:45 <jd__> we're discussing how to copy branching model for stable and milestone from other project
15:20:48 <nijaba> right now we are on:
15:20:51 <eglynn> ttx: just clarifying the use fo miletsone-proposed versus stable branch
15:20:54 <nijaba> milestone-proposed for pre-relase fixes on monday
15:21:09 <eglynn> agreed
15:21:19 <nijaba> stable/folsom for post-relase fixes next weekend when we release
15:21:32 <nijaba> we tag master
15:21:37 <nijaba> each time
15:21:56 <nijaba> ttx: makes sense to you?
15:21:57 <ttx> hmm, how is the version generated right now ?
15:22:07 <ttx> what tarballs are you producing currently ?
15:22:23 * jd__ whispers
15:22:25 <jd__> none I think?
15:22:27 <nijaba> I don't think we produce any
15:22:29 <nijaba> yet
15:22:31 <dhellmann> I think we just have the version # hard-coded in setup.py
15:22:46 <ttx> ok
15:22:53 <ttx> let me think
15:23:13 <ttx> if you don't have automatic tarball generation, that simplifies
15:23:54 <ttx> you can probably create milestone-proposed on top of master, then stable/folsom on top of milestone-proposed (after release)
15:24:08 <ttx> if you want to mimick how iot's done for core
15:24:11 <nijaba> I think this is what eglynnwas proposing
15:24:18 <jd__> ttx: that's the point, thanks
15:24:21 <nijaba> and yes, we want
15:24:23 <jd__> we'll do that :)
15:24:29 <ttx> Been working on rewriting http://wiki.openstack.org/ReleaseTeam/HowToRelease
15:24:30 <dhellmann> how do we get the branches pushed to github?
15:24:30 <nijaba> thanks a lot ttx
15:24:54 <ttx> which is the complete process I use, but you need nothing of that complexity
15:25:50 <ttx> since you have nothing like milestone codes or pre-generated tarballs
15:25:53 <nijaba> ok, so the next question is weather we are missing anything for a release?
15:25:57 <nijaba> release notes maybe?
15:26:35 <nijaba> also, do we need to produce a tarball?
15:26:36 <dhellmann> we could add those to our docs
15:26:54 <spn> dhllemann: git remote add github git@github.com:user_name/my_app.git  and git push -u github master
15:27:32 <dhellmann> spn: I don't know if any of us have permission to push directly to github because of the way the repo was created. maybe nijaba has admin rights?
15:27:49 <spn> agreed.
15:27:52 <nijaba> #action nijaba to prime release notes in the docs
15:28:24 <nijaba> dhellmann: can I grant those rights to someone else?
15:28:34 <spn> may be adding other users as collaborators
15:28:38 <dhellmann> nijaba: if you have admin rights, I think you can
15:28:48 <dhellmann> nijaba: do you have admin?
15:29:05 * jd__ does not have admin
15:29:12 <nijaba> dhellmann: I have no idea.  Dachary did the initial setup of the repo IIRC
15:29:12 * dhellmann does not have admin
15:29:23 <nijaba> how do I check?
15:29:31 <spn> admin page ( https://github.com/user/repo/admin ) and in the Collaborators tab
15:29:37 <dhellmann> go to https://github.com/stackforge/ceilometer and look for the "admin" tab
15:29:41 <spn> see if you can add users
15:30:04 <dhellmann> the admin tab should be on the right end after "graphs" etc.
15:30:25 <jd__> anyway someone from openstack-infra has admin so don't bother I'll deal with them
15:30:32 <nijaba> dhellmann: no admin tab for me.  I'll speak with dachary
15:30:37 <dhellmann> ok
15:30:47 <dhellmann> we should probably add you, me, and jd__
15:30:50 <dhellmann> at least
15:31:07 <nijaba> #action nick to find a way to give admin right to jd__ for github
15:31:09 <jd__> https://github.com/stackforge?tab=members -> Monty  :)
15:31:24 <nijaba> #action nick to find a way to give admin right to jd__ and dhellmann for github
15:31:50 <nijaba> #action nijaba to find a way to give admin right to jd__ and dhellmann for github
15:31:58 <nijaba> I think I have the action right this time!
15:32:05 <jd__> we hope so :)
15:32:16 <nijaba> so, do we need to produce a tarball?
15:32:36 <dhellmann> nijaba: that may be something we can have the infra team turn on for the project
15:32:41 <dhellmann> like they do for nova, etc.
15:32:59 <nijaba> ok, I'll check into it at the same time then
15:33:21 <nijaba> #action nijaba to check if infrateam can generate a tarball for us
15:33:37 <jd__> are you sure? that may overlap with my #action about putting the branches in place
15:33:49 <jd__> not that it's a big problem :)
15:33:53 <nijaba> jd__: you want to cover it then?
15:34:03 <jd__> as you wish, but I can handle all this at once I imagine
15:34:10 <nijaba> ok, sounds good
15:34:17 <nijaba> #action jd__ to check if infrateam can generate a tarball for us
15:34:39 <nijaba> anything else we might be missing for a release?
15:34:39 <jd__> once I have kidnapped an -infra guy, I can do whatever is needed
15:35:10 <jd__> i think it'll be a good start :)
15:35:10 <dhellmann> :-)
15:35:18 * nijaba wonders if jd__ is really jack dauer
15:35:46 <nijaba> ok, next topic then
15:35:59 <nijaba> #topic Motion to review incubation request at the next TC meeting
15:36:07 <nijaba> We need to trigger the new TC to decide if we are worth being incubated.  I think it would be nice if we ensured this would happen at their next meeting, which will be face to face in san diego.  Are you ok with me sending them an email on that subject. If they give us a green light, according to the by-laws, the board of director will then have to confirm.
15:36:55 <dhellmann> +1
15:37:05 <jd__> +1, face to face is always easier to kidnap
15:37:09 <eglynn> dumb question: what's the timeline for incubation?
15:37:11 <jd__> (what is wrong with me!)
15:37:16 <nijaba> eglynn: one cycle
15:37:20 <eglynn> (i.e. how long of a prior track-record is required?)
15:37:28 <eglynn> a-ha ok, cool
15:37:41 <dhellmann> eglynn: prior track-record is unspecified, afaik
15:37:57 <nijaba> one cycle in incubation, at least, before being core
15:38:12 <eglynn> cool, thanks for the info
15:38:15 * dhellmann thought eglynn meant prior to incubation
15:38:25 <eglynn> dhellmann: I did :)
15:38:39 <spn> dumb q?:   being in incubation and core are same?
15:38:51 <nijaba> spn: in terms of duties, yes
15:38:54 <eglynn> one preceeds the other
15:39:25 <nijaba> do we need to vote on my proposal or should I just mark that as agreed?
15:39:34 <dhellmann> I sense agreement
15:39:58 <eglynn> a yea by acclamation I think
15:40:05 <dhellmann> is anyone opposed?
15:40:12 <spn> no
15:40:29 <nijaba> #agreed nijaba to send an email to the tc to ask for a motion to put ceilometer in incubation
15:40:51 <nijaba> this bring us to the next topic
15:40:54 <nijaba> #topic ODS Grizzly
15:41:06 <jd__> roooaaarr
15:41:06 <nijaba> show of hands, who is going to be there in person?
15:41:11 <eglynn> how many slots at teh ODS does ceilometer have?
15:41:23 <nijaba> just so that I can plan for cash to buy beers ;)
15:41:24 <dhellmann> o/
15:41:25 <nijaba> o/
15:41:29 * eglynn just heard he'll probably be able to attend :)
15:41:36 <nijaba> eglynn: \o/
15:41:37 <dhellmann> wait, beer? o///
15:41:54 <eglynn> :)
15:42:00 <dhellmann> eglynn: :)
15:42:07 <spn> I think we have webex option this time
15:42:19 <dhellmann> spn: yes, that was mentioned on the mailing list
15:42:20 <nijaba> and long nights for you then...
15:42:37 <spn> hihi..
15:43:23 <spn> not sure whether we are allowed to interact on webex
15:43:49 <dhellmann> spn: I'm not sure whether it's supported, but if not we could have someone in the room on irc relay questions and comments
15:44:02 <nijaba> no one else is going to be there?
15:44:08 <DanD> o/
15:44:16 <spn> dhellmann: that would be great
15:44:17 <nijaba> ah!
15:44:25 <nijaba> I am sure jaypipes will be too
15:44:31 <nijaba> what about jtran?
15:44:39 <ttx> about design summit: I'll need your session descriptions for inclusion in the final schedule Monday
15:44:59 <nijaba> ttx: http://wiki.openstack.org/EfficientMetering/GrizzlySummit
15:45:05 <nijaba> so here you are
15:45:05 * jaypipes will be there Monday around noon
15:45:12 <ttx> nijaba: i'll try to remember that
15:45:21 <nijaba> ttx: do you want an email?
15:45:27 <ttx> nijaba: nah
15:45:30 <nijaba> k
15:45:40 <nijaba> jaypipes: will jtran be there?
15:46:15 <dhellmann> ttx, do you have other questions about the metering integration sessions?
15:46:22 <nijaba> ttx: you wanted to talk about "the multiplication of metring integration sessions"
15:46:49 <jaypipes> nijaba: yes
15:47:04 <nijaba> cool.  and I know enovance is sending a few people too
15:47:24 <ttx> nijaba: yes, Would like to reduce the duplication asap
15:47:35 <ttx> nijaba: so that you don't end up with all of them refused
15:47:42 <nijaba> I think we all agreed to merge 3 of them into one last night by email
15:47:50 <ttx> independently by the separate topic leads making independent decisions
15:47:52 <nijaba> 115,116 and 118 IIRC
15:49:15 <nijaba> 115,117 and 118  actually
15:49:26 <dhellmann> yes, the latter
15:49:29 <nijaba> ttx:  would this be good enough for you?
15:50:48 <ttx> let me check which topic they were proposed under
15:50:50 <dhellmann> I just talked to Mark about the quantum session (110) and he wants to keep that focused on quantum because it will cover more than ceilometer
15:51:09 <cp16net> i will be there.
15:51:40 <nijaba> so, I hope you have all noted that ceilometer 3 sessions will happen on moday morning
15:51:47 <ttx> OK, let's merge 117-118
15:51:59 <ttx> you can keep 115 since Horizon is missing stuff anyway
15:52:20 <ttx> and it wil give you a late session (Thursday afternoon) on the subject to wrap it up
15:52:51 <nijaba> ttx: sounds good
15:52:54 <ttx> dhellmann: can you make one out of two ? 117-118 ?
15:53:01 <ttx> dhellmann: and let me know which one to remove
15:53:12 <ttx> will be simpler than communicating the merge to markmc, isn't around
15:53:17 <dhellmann> ttx: yes, I'll do that after lunch and email you the results
15:53:32 <dhellmann> (in a couple of hours)
15:53:37 <ttx> ok, just let me know which to remove.
15:54:29 <nijaba> ok, let's move to our final topic then
15:54:37 <nijaba> #topic open discussion
15:54:49 <dhellmann> ttx, delete 118
15:54:56 <ttx> on it
15:55:04 <nijaba> 5 minutes, any topics...
15:55:08 <spn> http://wiki.openstack.org/Governance/Proposed/Ceilometer
15:55:19 <spn> This page has incubator details
15:55:22 <spn> at the bottom
15:55:25 <nijaba> spn: yes, that was our proposal 3 mo ago
15:55:29 <spn> we have integration status
15:55:43 <spn> I guess it is 3mon old status then
15:55:51 <ttx> dhellmann: nuked.
15:55:52 <nijaba> I'll need to refresh that before sending my email
15:55:59 <dhellmann> ttx: thanks!
15:56:59 <nijaba> #action nijaba to resfresh http://wiki.openstack.org/Governance/Proposed/Ceilometer before sending email to the tc
15:57:17 <nijaba> anything else?
15:57:29 * dhellmann has nothing to add
15:57:35 <spn> nothing from me
15:57:54 <nijaba> that was a full meeting!  thanks a lot everyone!
15:58:04 <dhellmann> thanks!
15:58:07 <nijaba> next week, same place, same time
15:58:09 <spn> thanks
15:58:16 <nijaba> #endmeeting