15:00:11 <nijaba> #startmeeting Ceilometer
15:00:11 <nijaba> #meetingtopic Ceilometer
15:00:11 <nijaba> #chair nijaba
15:00:11 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
15:00:12 <openstack> Meeting started Thu Sep 27 15:00:11 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'ceilometer'
15:00:16 <openstack> Current chairs: nijaba
15:00:21 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
15:00:21 <nijaba> o/
15:00:23 <dhellmann> o/
15:00:25 <jtran> me
15:00:25 <spn> o/
15:00:44 <jtran> so THAT's how you show hand
15:00:53 <nijaba> yes :)
15:01:00 <jtran> o/
15:01:01 <jd__> hello
15:01:07 <nijaba> #topic actions from previous meeting
15:01:15 <nijaba> #topic spn fix Flask pickup when setup.py is used
15:01:25 <spn> yes
15:01:36 <nijaba> how did it go?
15:01:38 <spn> I submitted patch
15:01:50 <dhellmann> that's committed, right?
15:01:56 <eglynn> o/
15:01:57 <spn> it went well. Understood about dependencies
15:01:59 <spn> yes
15:02:21 <dhellmann> thanks again for your persistence on that one, spn :)
15:02:25 <nijaba> so we can mark this as done, thanks
15:02:46 <surya> o/
15:02:57 <nijaba> #topic Need more reviews on the sqlalchemy backend from people who expect to use it
15:03:11 <spn> done
15:03:18 <Guest91638> o/
15:03:38 <nijaba> so jtran commited this great patch
15:03:56 <dhellmann> we've had some reviews, and I feel like it's getting close to approval
15:03:56 <nijaba> and dhellman wanted to get more review for it
15:04:15 <nijaba> so, no need to get fetch more?
15:04:34 <nijaba> s/get/go
15:04:35 <dhellmann> jd__ and jtran: what do you think?
15:04:41 <jtran> i think it's ready :)
15:04:52 <nijaba> :)
15:04:59 <jd__> for me it's good enough
15:05:11 <jd__> and I'm for "release early, release often"
15:05:49 <dhellmann> ok, I'm going to look at it one more time today before I +2
15:05:49 <nijaba> #agreed we've had the right amount of reviews for sqlalchemy
15:06:31 <nijaba> that's actually a great commit. thanks jtran
15:06:38 <jtran> my pleasure
15:06:51 <nijaba> #topic Discuss Conference presentation at ODS on Monday @2:40 (40min)
15:07:00 <nijaba> title of the session is "What about billing? An introduction to Ceilometer"
15:07:00 <nijaba> dhellmann and I are to co-present that session
15:07:11 <nijaba> so this is not a technical session
15:07:20 <nijaba> and should be focused on uses, not devs
15:07:38 <spn> billing?
15:07:38 <nijaba> we'll have plenty of dev sessions in the morning
15:08:03 <dhellmann> spn, the original purpose of ceilometer was to collect data for billing
15:08:04 <nijaba> spn: just to explain that metering is the first step toward billing
15:08:34 <spn> nijaba, dhellmann: :-)
15:09:01 <nijaba> dhellmann: so I was thinking of using jd__ slides that he used at xlcloud as a basis
15:09:17 <dhellmann> nijaba: that sounds like a good place to start
15:09:18 <nijaba> do you think you could add a few about DH's use of it?
15:09:24 <dhellmann> jd__: how long was your talk there?
15:09:33 <jd__> 20 minutes I think
15:09:53 <nijaba> yes, it's about 12 slides currently
15:09:57 <jd__> you'll probably have to update the schema and reorder some slide
15:10:04 <dhellmann> nijaba: sure, I can talk a little about how we are exporting data to our existing billing system
15:10:05 <jd__> but it can be a good start I think
15:10:19 <nijaba> jd__: actually, I have already produced a new version for tonight's meetup in london
15:10:34 <jd__> nijaba: great! think about sharing it after then :)
15:10:45 <nijaba> dhellmann: that would give a concrete example and a great +
15:10:52 <cp16net> o/
15:11:01 <nijaba> jd__: I''ll be forced too anyway ;)
15:11:13 <dhellmann> nijaba: +1
15:11:24 * nijaba is not on his usual keyboad, can you guess?
15:12:00 <nijaba> I'll also add a slide on the 3 steps toward billing as an intro (metering/rating/billing)
15:12:21 <nijaba> and use my architecture diagram
15:12:36 <nijaba> do you think we would need anything else?
15:13:02 <spn> that sounds good.
15:13:13 <nijaba> dhellmann I think we should target to have a first version of our respective slides before the next meeting.  od you agree and have time?
15:13:14 <jd__> you can add other usage like maybe cloudwatch some day, or statistics, i don't know
15:13:20 <dhellmann> so to summarize: we will have an intro to billing, a bit of project background and architecture based on jd__'s slides, some info from me about DH's integration
15:13:22 <dhellmann> did I miss anything?
15:13:31 <nijaba> jd__: good idea
15:13:34 <dhellmann> nijaba: yes I agree. time might be more challenging :-)
15:13:56 <jd__> (like billing is boring, let's give some other fun idea to people listening :-)
15:13:57 <nijaba> yet another dealine
15:13:58 <dhellmann> but I will work on it. can you share what you have so far?
15:14:20 <dhellmann> jd__: yes, capacity planning is another good use
15:14:24 <nijaba> dhellmann: if you prefer to send me bullets points, I'll do the slideware, if that helps
15:14:39 <nijaba> dhellmann: I will
15:14:50 <jd__> dhellmann: that's the words I was looking for :))
15:15:09 <dhellmann> nijaba: I'll work on bullets, but having the context of what you've already got will help me focus :-)
15:15:12 <nijaba> #action nijaba to share a first version of the slides with dhellmann
15:15:32 * jd__ hopes nijaba is bullet proof
15:15:33 <nijaba> #action dhellmann to provide some bullet points on DH use case
15:16:01 * nijaba always his teflon suit
15:16:08 <dhellmann> kevlar?
15:16:20 <nijaba> teflon is much better
15:16:29 <jd__> teflon's better, you can fry your eggs too
15:16:31 * dhellmann thinks kevlar would be a good name for presentation software
15:16:42 <nijaba> hehe
15:16:47 <jd__> dhellmann: +1
15:17:02 * dhellmann is here all week, tip your waitress
15:17:12 <jd__> lol
15:17:14 <nijaba> #notaction dhellmann to write the specs for kevlar
15:17:19 <dhellmann> lol
15:17:29 <zykes-> kevlar ? ;p
15:17:44 <dhellmann> zykes-: it's the material they make bullet-proof vests from
15:17:51 <eglynn> in terms of alternative uses of metering beyond billing, how about dynamic quotas?
15:17:56 <eglynn> (i.e. only go above quota if usage is outside some prediction bands based on trends in metering data)
15:17:59 <nijaba> ok, I think that's all the topic we had for today
15:18:06 <dhellmann> eglynn: interesting idea!
15:18:09 <cp16net> lol kevlar :-P
15:18:31 <spn> various groups sharing their unused quota?
15:18:37 <nijaba> but if gmb is around, I think it would be nice to check our status on release
15:18:46 <nijaba> today is folsom release day after all
15:18:52 <dhellmann> jaypipes: what's the status of your devstack patch to add glance config settings for ceilometer?
15:19:08 <gmb> Argh, otp... bear with me...
15:19:52 <dhellmann> while we wait, I noticed today that our bug tracker on launchpad had no owner set up, so I set it to the ceilometer-drivers team
15:19:53 <nijaba> #topic opendiscussion
15:19:56 <eglynn> devstack patch? is this a dupe: https://review.openstack.org/13746
15:20:09 <dhellmann> I hope that didn't generate too much extra email traffic :-)
15:20:17 <cp16net> sry this is my first meeting but anyone know/have an overview of how much of the ceilometer blueprint is implemented?
15:20:37 <dhellmann> eglynn: I was referring to https://review.openstack.org/#/c/13546/
15:20:49 <jd__> dhellmann: I didn't see any difference, but I was probably already subscribed to all bugs :)
15:20:57 <dhellmann> cp16net: that's a great question
15:21:15 <dhellmann> jd__: yeah, I'm trying to add triaging to my weekly routine
15:21:18 <cp16net> dhellmann: i ask bc i am starting to look at using it as well
15:21:37 <jd__> dhellmann: sounds like a good idea indeed
15:21:41 <dhellmann> cp16net: I don't think we have a comprehensive project plan per se. You may be able to get a sense from looking at tickets.
15:22:10 <dhellmann> we do have end-to-end functionality for collecting, storing, and querying data from multiple sources, so it is usable now
15:22:34 <dhellmann> there are quite a few meters left to implement, as well as some API end-points
15:22:35 <zykes-> is anyone using ceilo in prod ?
15:22:41 <nijaba> cp16net: http://wiki.openstack.org/EfficientMetering/Roadmap gives you some idea, bugs as well
15:22:43 <cp16net> dhellmann: ok my team has looked at using it with reddwarf and adding some meters for our product.
15:22:52 <dhellmann> zykes-: DreamHost is moving in that direction soon, but it isn't done enough yet.
15:23:11 <eglynn> dhellman: how about I just combine both glance-related devstack changes (creds & config) to get it in
15:23:13 <cp16net> nijaba: dead link? means nothing? :-P
15:23:38 <nijaba> cp16net: caps got me: http://wiki.openstack.org/EfficientMetering/RoadMap
15:23:49 <dhellmann> cp16net: what is reddwarf?
15:23:58 <dhellmann> eglynn: works for me!
15:24:00 <cp16net> nijaba: oh i see those matter in the link...
15:24:03 <spn> me too
15:24:17 <nijaba> redward is DAAS
15:24:26 <jtran> DAAS?
15:24:27 <cp16net> reddwarf is paas built on nova
15:24:36 <dhellmann> nijaba: we probably need to update that page :-)
15:24:49 * nijaba shuts up with his bad kb
15:24:50 <spn> dhellmann: good idea
15:24:53 <zykes-> cp16net: which product ?
15:25:10 <dhellmann> #action dhellmann update status on  http://wiki.openstack.org/EfficientMetering/RoadMap
15:25:11 <cp16net> dbaas is the first
15:25:13 <zykes-> RedDwarf 2 nijaba is DBaaS
15:25:31 <cp16net> ye zykes-
15:25:40 <zykes-> there are 2 implementations, one forked off of Nova and the other one is a "Lite" version
15:25:46 <zykes-> kinda like what happened to Keystone
15:25:52 <jtran> BadAas
15:25:58 <nijaba> lol
15:26:00 <cp16net> lite is the new version
15:26:00 <dhellmann> cp16net: we have tried to make ceilometer "open" to new meters
15:26:00 <zykes-> cp16net: what's your product ?
15:26:14 <zykes-> dhellmann: how is it not open now ?
15:26:14 <cp16net> cloud databases
15:26:27 <dhellmann> zykes-: it is open, that's my point
15:27:13 <dhellmann> cp16net: if you have trouble sending info from reddwarf or have suggestions for ways to make it easier, we should discuss on the mailing list
15:27:15 <cp16net> dhellmann: so would the core team be willing to accept new meters for products like reddwarf or should they have then built into their product?
15:27:24 <dhellmann> cp16net: it can work both ways
15:27:42 <dhellmann> if you use rpc to send meter events in the right format, we will accept them and store them like anything else
15:27:46 <nijaba> cp16net: I would also suggest that you come to our sessions at ODS on monday morning
15:27:48 <cp16net> dhellmann: ok thanks will do.
15:28:04 <dhellmann> if you want to add something to one of the agents, there is a plugin system for making that easy
15:28:16 <cp16net> nijaba: i'll try my best i get there monday morning.
15:28:22 <nijaba> cool
15:28:36 <dhellmann> cp16net: have a look at http://ceilometer.readthedocs.org/en/latest/index.html and ask questions on the mailing list if you have any!
15:28:58 <nijaba> cp16net: sessions that we'll have: http://wiki.openstack.org/EfficientMetering/GrizzlySummit
15:29:04 <cp16net> thx i am sure i will have some q's
15:29:22 <zykes-> cp16net: product for which company ?
15:29:22 <nijaba> cp16net: http://wiki.openstack.org/EfficientMetering/GrizzlySummit/CustomizingCeilometer would seem what you need
15:29:30 <dhellmann> cp16net: I'm on IRC a good bit, but would like to have most of the questions on the list to make the answers available to others later
15:29:38 <cp16net> damn both of the sessions are first thing monday morning
15:29:52 <cp16net> i should at least make the second one.
15:30:13 <cp16net> zykes-: rackspace
15:30:24 <zykes-> cp16net: isn't that out already ?
15:30:54 <cp16net> zykes-: yes
15:31:42 <zykes-> so what's there to launch ? : p
15:32:45 <zykes-> how hard is it to add meters ?
15:33:02 <nijaba> zykes-: depends how deply buried the information is
15:33:03 <jtran> zykes-: pretty easy
15:33:13 <cp16net> zykes-: :-P yeah but something common
15:33:16 <dhellmann> zykes-: it depends a bit on where the data comes from
15:33:34 <dhellmann> zykes-: polling and notification handling are pretty easy from the ceilometer side
15:35:07 <nijaba> #link http://ceilometer.readthedocs.org/en/latest/contributing/plugins.html
15:36:29 <gmb> Well that was staggeringly good timing...
15:36:42 <nijaba> welcome back gmb
15:37:14 <gmb> Just resolving things after a network outage; I'll email the list with a summary of how things stand for the release since things look a bit flaky.
15:37:34 <nijaba> cp16net: do you have what you need for now?
15:38:14 <nijaba> #action gmb to email the list with a summary of how things stand for the release
15:38:59 <nijaba> ok, any other topics, anyone?
15:39:19 * dhellmann shakes head
15:39:37 <spn> same here
15:39:53 <nijaba> ok then, thanks for another great meeting everyone
15:39:56 <jd__> \o/
15:40:02 <spn> :-)
15:40:08 <dhellmann> thanks, everyone!
15:40:15 <nijaba> #endmeeting