21:00:17 <nijaba> #startmeeting Ceilometer
21:00:17 <nijaba> #meetingtopic Ceilometer
21:00:17 <nijaba> #chair nijaba
21:00:17 <nijaba> #link http://wiki.openstack.org/Meetings/MeteringAgenda
21:00:18 <openstack> Meeting started Wed Sep 12 21:00:17 2012 UTC.  The chair is nijaba. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:20 <openstack> The meeting name has been set to 'ceilometer'
21:00:23 <openstack> Current chairs: nijaba
21:00:28 <nijaba> Hello everyone! Show of hands, who is around for the ceilometer meeting?
21:00:28 <nijaba> o/
21:00:36 <spn2> o/
21:00:37 <asalkeld> asalkeld, here
21:00:46 <asalkeld> o/
21:01:12 <jd___> hi
21:01:18 <nijaba> dhellmann: will try to join us in a bit
21:01:27 <nijaba> #topic actions from previous meeting
21:01:40 <nijaba> #topic nijaba to see with ttx how our sessions can be shown on official program
21:01:44 <spn2> o/
21:01:54 <nijaba> We did have an email thread with Thierry and Lauren, we'll have a meeting room dedicated to Ceilometer for half a day and our sessions will be described on the global agenda.  The same will happen for swift and both sets of sessions will be in an incubation track.
21:02:10 <nijaba> I think that's pretty good, what do you think?
21:02:24 <asalkeld> yea, great
21:02:35 <spn2> awesome
21:02:41 <notmyname> swift?
21:02:43 <jd___> perfect
21:02:53 <asalkeld> s/swift/heat
21:02:54 <nijaba> duh, I wrote swift!!  I meant heat!
21:02:56 <nijaba> of course
21:03:01 <notmyname> heh, ok :-)
21:03:16 <jtran> that's what i was thinking.  "swift" ?
21:03:22 <nijaba> long day, sorry
21:03:30 <jtran> understandable
21:03:50 <nijaba> #topic nijaba to update meeting page to note new alternating meeting time
21:03:59 <nijaba> That was done.  However, it seems that Angus is  about to go for a long due vacation, so it might make sense to not use the alternate meeting while he won't be around.
21:03:59 <nijaba> Thoughts about this?
21:04:25 <spn2> 2.30 AM here.. :)
21:04:33 <asalkeld> owch
21:04:41 <asalkeld> sorry spn2
21:04:49 <spn2> :) np
21:04:50 <nijaba> Well, I have been up for 20h :D
21:04:53 <jd___> time for a party!
21:05:05 <spn2> hehe..
21:05:41 <nijaba> so, asalkeld you will be gone until the summit, right?
21:05:47 <asalkeld> yip
21:05:55 <asalkeld> leave on sunday
21:06:29 <nijaba> so, anyone wanting that we maintain this alt meeting time while asalkeld is going around the world?
21:07:10 <jtran> i like this meeting time.
21:07:25 <nijaba> quick vote?
21:07:40 <spn2> yes
21:07:48 <jtran> +1
21:08:14 <spn2> -1
21:08:19 <jtran> spn2:  I can't blame  you
21:08:21 <nijaba> #vote should we maintain alt meet time for the next month? yes, no, bleh
21:08:35 <nijaba> #startvote should we maintain alt meet time for the next month? yes, no, bleh
21:08:36 <openstack> Begin voting on: should we maintain alt meet time for the next month? Valid vote options are yes, no, bleh.
21:08:37 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
21:08:46 <nijaba> #vote bleh
21:08:50 <spn2> #vote no
21:09:00 <jtran> yes
21:09:07 <jtran> #vote yes
21:09:20 <jd___> #vote no
21:09:41 <asalkeld> I'll stay out of it
21:10:03 <jtran> i actually don't mind if we don't keep it.  i just wanted to see how voting works.
21:10:09 <nijaba> #endvote
21:10:10 <openstack> Voted on "should we maintain alt meet time for the next month?" Results are
21:10:11 <openstack> yes (1): jtran
21:10:12 <openstack> bleh (1): nijaba
21:10:13 <openstack> no (2): spn2, jd___
21:10:36 <nijaba> #topic gmb to a plan on the ml with fixed dates
21:10:41 <jd___> :)
21:10:57 <nijaba> An email was sent today to the ml.  The proposed milestones are:
21:10:57 <nijaba> - Feature freeze for 0.1 QA: 2012-09-28
21:10:57 <nijaba> - Release: 2012-10-12
21:10:57 <nijaba> Thoughts?
21:11:40 <asalkeld> no objections
21:11:58 <asalkeld> release often
21:12:05 <spn2> is a good idea
21:12:10 <nijaba> ok, I'll mark that as agreed then
21:12:15 <nijaba> #agreed 0.1 feature freeze will take effect on 2012-09-28
21:12:15 <nijaba> #agreed 0.1 release date will be  2012-10-12
21:12:32 <nijaba> #topic dhellmann make sure flask is listed as a dependency of ceilometer
21:12:47 <nijaba> Doug was not sure to be back on time for the meeting, but he wrote on to the ml that he did check that Flask is listed in the tools/pip-requires file. It is pegged to version 0.9.
21:12:54 <spn2> It is listed
21:13:18 <nijaba> We did not seem to have any other topic on the agenda....
21:13:29 <nijaba> #topic Open Discusssion
21:13:50 <jtran> wanted to bring up the issue of prioritized tickets.  most of them are wishlist.
21:13:59 <jtran> s/tickets/bugs/
21:14:32 <nijaba> jtran: what would you think we should have?  more bugs?
21:14:40 <nijaba> I mean real ones?
21:14:53 <jtran> well, don't features get prioritized too?
21:15:05 <jtran> features are lumped together w/ bugs right
21:15:17 <spn2> hmm...
21:15:19 <nijaba> I am not sure lp allows to make a distinction between the two
21:15:26 <jd___> it would be better to implement features than bugs
21:15:28 <jd___> :D
21:15:44 <nijaba> wishlist is how you mark a bug that is a feature request
21:15:46 <asalkeld> shouldn't features be blueprints?
21:15:52 <jd___> asalkeld: probably
21:16:03 <asalkeld> well big ones
21:16:03 <nijaba> asalkeld: depends on the depth of the feature
21:16:04 <spn2> do they need to be large in size for blueprints
21:16:23 <asalkeld> yeti features
21:16:31 <jtran> oh sometimes when i worked on nova, i would see feature requests as bugs bug they were classified w/ priority level often if was a highly desired feature
21:16:36 <nijaba> I would say that a plueprint is usefull if it is going to be supported, or is the result of a discussion
21:16:40 <jtran> so i'm just thinking of that paradigm
21:16:59 <asalkeld> the other issue is it depends on the developer
21:17:23 <asalkeld> so a high prio to might not be a high prio for me
21:17:31 <asalkeld> grr
21:17:38 * dhellmann arrives late
21:17:40 <asalkeld> so a high prio to you might not be a high prio for me
21:17:53 <jtran> right, i guess that would be a job for milestones then?
21:18:17 <dhellmann> I was confused about the distinction between bugs and blueprints, too, so just opened everything as bugs for now
21:18:18 <nijaba> asalkeld: the prio only matters as much as we find implementors for the feature ;)
21:18:34 <jtran> nijaba: understood
21:18:40 <asalkeld> sure
21:18:44 <nijaba> ceilometer, as a whole, started as a blueprint
21:19:00 <nijaba> complex features, that needs a lot of discussions, warrant a blueprint
21:19:17 <spn2> rest can just be bugs?
21:19:28 <nijaba> but if we just want a quick way to know what is on the todo list, bugs are cool, I think
21:20:34 <dhellmann> right, it will be easier to see an overview of everything if the work items all appear on one list :-)
21:20:40 <nijaba> I mean, there is no absolute rule about this.  Each project generally defines its practices
21:20:48 <asalkeld> sure
21:21:24 <jtran> sounds good
21:21:27 <spn2> consolidated list is good I think
21:21:54 <jtran> maybe i can rephrase, what's the area of dev I should be looking at most right now?
21:21:54 <nijaba> asalkeld: thinking about it, I think the beyond metering wiki page should turn into a blueprint before the summit
21:21:56 <jtran> pollsters?
21:22:13 <asalkeld> ok nijaba I can do that
21:22:15 <dhellmann> jtran: yes, anything that feeds data into the system
21:22:27 <jtran> dhellmann: ok.
21:22:35 <jtran> moar data!
21:22:36 <nijaba> jtran: http://wiki.openstack.org/EfficientMetering/RoadMap is a good list of highest prios
21:22:38 <dhellmann> pollsters, listeners, etc.
21:22:50 <jtran> nijaba: thanks for reminding me about that
21:22:54 <nijaba> #link http://wiki.openstack.org/EfficientMetering/RoadMap
21:22:56 <dhellmann> jtran: https://blueprints.launchpad.net/ceilometer/+spec/config-driven-notification-monitoring
21:23:05 <dhellmann> that blueprint will make it way way simpler to add event listeners
21:23:21 <dhellmann> unfortunately the details are still just in my head
21:23:28 <jtran> dhellmann:  got it
21:23:36 <dhellmann> #action dhellmann write up details of blueprint https://blueprints.launchpad.net/ceilometer/+spec/config-driven-notification-monitoring
21:23:58 <jtran> dhellmann: right, i have a lot of reading up to do on plugins.
21:24:41 <nijaba> asalkeld: it might be worth mentioning the link you gave on the chan just before the meeting.  That's an excellent start for the discussion/blueprint
21:24:54 <asalkeld> sure
21:25:13 <nijaba> #link http://teambox.com/n/8fb5404848e9f0b9/ceilometer
21:25:37 <nijaba> which asalkeld will merge into http://wiki.openstack.org/EfficientMetering/GrizzlySummit/BeyondMetering
21:25:52 <asalkeld> it's somewhat done
21:25:57 <nijaba> cool!
21:26:04 <asalkeld> just fighting with formatting
21:26:21 <jtran> on the roadmap, metering network bandwidth is 'done' but it actually is only "half done" .  I only implemented the internet network pollster not the external network.
21:26:22 <nijaba> you gotta love moinmoin
21:26:39 <nijaba> jtran: please feel free to update :)
21:26:45 <jtran> ok
21:27:30 <jd___> jtran: do you think the missing part should be addressed in nova-network or quantum, finally?
21:29:05 <jtran> jd___: I don't know much about quantum , unfortunately
21:29:08 <dhellmann> asalkeld and nijaba : did we decide to put alarms in ceilometer, then?
21:29:19 <dhellmann> or is that just for discussion?
21:29:26 <nijaba> dhellmann: no, this is just a blueprint proposal for the summit
21:29:30 <asalkeld> discussion
21:29:38 <nijaba> dhellmann: I think the decision is to be made at the summit
21:29:39 <dhellmann> ok, thanks for clarifying
21:29:53 <jtran> jd___:  the method in the wiki described for implementing external network via nova-network via iptables accounting is difficult, from the last time i looked at it.
21:30:13 <jtran> iptables accounting in oneiric and precise is all sorts of broken
21:30:44 <nijaba> jtran: yes, this is I think the hardest pollster to implement, and jd___ and I have known that since the beginning...
21:30:49 <jd___> jtran: I agree that's not an easy path, but I don't know about Quantum either, but I sense that the place it should be implemented
21:31:19 <jd___> nijaba: shhhht, that's way I'm trying to make jtran look at it!
21:31:24 <jd___> ;-)
21:31:28 <jtran> jd___: lol
21:31:31 <jd___> s/way/why/
21:31:32 <nijaba> jtran: bug ref on the problems you mention? and is it fixed in previse?
21:31:47 <jtran> jd___:  i doubt i am the right person in this group to be looking at the hardest problems
21:32:12 <jd___> jtran: :-)
21:32:16 <jtran> the bug ref https://bugs.launchpad.net/ceilometer/+bug/1004449  is for network pollster in general…  both ext and int.
21:32:18 <uvirtbot> Launchpad bug 1004449 in ceilometer "Pollster for network traffic" [Wishlist,Fix committed]
21:32:18 <nijaba> jtran: it is really up to you.
21:32:32 <jtran> and i only did the internal part.   nijaba  : i don't mind looking at it
21:32:39 <dhellmann> jtran: based on the work you've done on the database backend, I think you underestimate yourself
21:32:56 <jtran> will try my best :)  dhellmann , most of that was copy and paste from nova and then shoehorn.
21:32:57 <dhellmann> jtran: you can split that bug into 2 tickets if it's easier for tracking
21:33:14 <jtran> it was a huge challenge though never touching sqlalchemy nor mongo, but thanks for your words of encouragement.  n
21:33:30 <jtran> dhellmann: yes will do
21:33:52 * jd___ agrees
21:34:42 * nijaba applauds jtran's work AND modesty
21:35:11 <dhellmann> jtran: I'm just learning sqlalchemy myself, so I asked a couple of co-workers to provide some feedback, too
21:35:28 <jd___> (cheater)
21:35:31 <jtran> dhellmann:  sqlalchemy is no walk in the park!
21:35:36 <jtran> learning curve is huge!
21:35:43 <dhellmann> jtran: no kidding
21:35:53 <spn2> omg!
21:35:54 <dhellmann> jd___: it's called "collaboration" ;-)
21:36:00 <jd___> dhellmann: ;)
21:36:03 <jtran> i had worked w/ ActiveRecord though thankfully, it does have some similarities altho i'm not expert at AR either
21:36:27 <spn2> rails3 - activerecord
21:37:10 * nijaba has not touch a db interface since odbc was the hype thing, or almost....
21:37:18 <jtran> lol odbc
21:37:29 <jtran> windows nt4?
21:37:56 <nijaba> nah, mac os at the time
21:38:21 <jtran> whoa
21:39:46 <nijaba> ok, looks like we are running out of subject
21:39:57 <nijaba> should we wrap for today?
21:40:04 <asalkeld> sure
21:40:12 <dhellmann> I think we're done
21:40:29 <nijaba> ok!  Thanks everyone!
21:40:54 <nijaba> #agreed next meeting thu sept 20 at 15UTC!
21:41:15 <nijaba> #endmeeting