08:59:59 <priteau> #startmeeting blazar
09:00:00 <openstack> Meeting started Tue Jan 21 08:59:59 2020 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:04 <openstack> The meeting name has been set to 'blazar'
09:00:10 <priteau> #topic Roll call
09:01:40 <tetsuro> o/
09:01:43 <bertys> o/
09:01:48 <priteau> Hi tetsuro
09:01:56 <priteau> Hi bertys, I hope you had a good break
09:02:32 <bertys> priteau: yes, thanks. Happy new year to you all
09:02:40 <priteau> Happy new year!
09:02:48 <tetsuro> happy new year!
09:04:45 <priteau> Link to agenda for today: https://wiki.openstack.org/wiki/Meetings/Blazar#Agenda_for_21_Jan_2020
09:04:50 <priteau> * Update on specs work
09:04:55 <priteau> * Ussuri cycle community-wide goals
09:04:59 <priteau> * AOB
09:05:36 <priteau> Not sure if masahito is planning to join today.
09:06:40 <priteau> #topic Update on specs work
09:07:28 <priteau> I updated my preemptible instances spec based on tetsuro's review
09:07:31 <priteau> #link https://review.opendev.org/#/c/701286/
09:07:59 <priteau> tetsuro's comments make me think that a flavor-based approach might be better
09:08:26 <tetsuro> Thanks for the update. I'll have a look tomorrow.
09:08:41 <priteau> I have proof of concept code, I would like to adapt it to flavor-based approach and submit to have an early review
09:09:12 <priteau> Thanks tetsuro
09:09:54 <priteau> Any other progress on specs?
09:11:00 <tetsuro> Not from my side, sorry
09:12:45 <priteau> We don't have a project-specific spec freeze date, but specs not approved by Ussuri-2 (Feb 13) are unlikely to get implemented in time for Ussuri-3 (Apr 9)
09:15:18 <priteau> bertys: If you have time to look at my preemptibles spec, I would appreciate it
09:15:41 <bertys> sure I will have a look as well this week
09:15:56 <priteau> Thank you
09:16:04 <priteau> #topic Ussuri cycle community-wide goals
09:16:18 <priteau> There are two community-wide goals selected for the Ussuri cycle
09:16:22 <priteau> #link https://governance.openstack.org/tc/goals/selected/ussuri/index.html
09:16:26 <priteau> 1) Drop Python 2.7 Support
09:16:30 <priteau> 2) Project Specific PTL and Contributor Documentation
09:16:43 <priteau> We've already merged some patches for 1), still more to go.
09:17:46 <priteau> Could you please review https://review.opendev.org/#/c/698819/
09:19:34 <priteau> Thank you tetsuro
09:20:34 <priteau> While reading the completion criteria (https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html#completion-criteria) I realized we've missed some steps, like dropping py27-specific requirements
09:21:11 <priteau> I will try to audit all repos for these criteria
09:21:31 <priteau> We also still have https://review.opendev.org/#/c/691551/
09:23:16 <priteau> There's also https://review.opendev.org/#/c/691551/, should we check with Ghanshyam Mann what is the status?
09:23:36 <priteau> Ussuri-1 was in December
09:24:22 <tetsuro> Right, if we are on schedule, this is ready to go.
09:24:53 <priteau> But he also said "Also we need to make sure old py2 jobs run on py2 till stable/train. I am going to start the audit of all tempest plugins by next week or so."
09:25:14 <priteau> AFAIK our stable branches use the latest tempest, so they would break following this merge?
09:26:14 <tetsuro> I am not sure.
09:26:32 <tetsuro> We need to talk to gmann possibly
09:26:51 <priteau> I'll check if I can talk with him later today.
09:27:03 <priteau> And look at how other projects handle it
09:27:55 <tetsuro> Thanks, I'll update this patch to include requirements update, too. https://github.com/openstack/blazar-tempest-plugin/blob/master/test-requirements.txt#L8
09:28:23 <priteau> +1
09:28:46 <priteau> #action tetsuro Drop py27 requirements in https://review.opendev.org/#/c/691551/
09:29:04 <priteau> #action priteau Contact gmann for tempest testing of stable branches
09:30:40 <priteau> #action priteau Audit repos for completion criteria of py27 drop
09:30:44 <masahito> hi, sorry for late joining :-(
09:31:04 <priteau> Hi masahito,
09:31:14 <priteau> The second goal is Project Specific PTL and Contributor Documentation
09:31:17 <priteau> #link https://governance.openstack.org/tc/goals/selected/ussuri/project-ptl-and-contrib-docs.html
09:32:24 <priteau> I am not sure if we need to document it ourselves or if people from the community will propose patches, like it was done for some previous goals
09:33:25 <priteau> There's recent work being done on the cookiecutter template: https://review.opendev.org/#/c/696001/
09:33:38 <priteau> I think for this one we can wait a bit longer to see what happens.
09:33:55 <priteau> Agreed?
09:35:27 <tetsuro> Yes, having doc changes is low risk compared to code changes
09:37:14 <priteau> I agree.
09:37:30 <priteau> #topic AOB
09:37:42 <priteau> Anything else to share today?
09:39:47 <priteau> I have a few small code reviews to highlight
09:39:50 <priteau> https://review.opendev.org/#/c/690786/
09:39:53 <priteau> https://review.opendev.org/#/c/690792/
09:40:12 <priteau> https://review.opendev.org/#/c/690787/
09:40:15 <priteau> https://review.opendev.org/#/c/702078/
09:40:17 <priteau> https://review.opendev.org/#/c/700633/
09:41:27 <priteau> All minor but will clean up the review dashboard
09:47:08 <tetsuro> Done
09:47:22 <priteau> Thank you tetsuro
09:47:31 <priteau> I resubmitted the one you gave -1
09:47:45 <priteau> https://review.opendev.org/#/c/690786/
09:48:38 <tetsuro> Done
09:48:44 <tetsuro> Thanks
09:49:02 <priteau> Many thanks.
09:49:10 <priteau> That's all for today, have a good rest of the week!
09:49:32 <priteau> Next meeting Tuesday next week as usual
09:49:41 <priteau> #endmeeting