08:59:58 <priteau> #startmeeting blazar
08:59:59 <openstack> Meeting started Tue Apr  2 08:59:58 2019 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:02 <openstack> The meeting name has been set to 'blazar'
09:00:03 <priteau> #topic Roll call
09:03:41 <priteau> No one available today?
09:03:57 <priteau> Bertrand said he was on travel
09:05:22 <priteau> Hi tetsuro
09:06:25 <masahito> o/
09:07:01 <priteau> Hi masahito
09:07:25 <priteau> Bertrand is on travel this week
09:07:32 <priteau> tetsuro is online but hasn't replied yet
09:07:36 <priteau> Let's wait a few minutes
09:08:23 <masahito> ok
09:12:49 <priteau> He doesn't seem to be around, let's start
09:13:03 <priteau> Agenda: https://wiki.openstack.org/wiki/Meetings/Blazar#Agenda_for_2_Apr_2019
09:13:10 <priteau> #topic Denver Summit Project Update
09:13:54 <priteau> There are still some little changes to do on the slides
09:14:14 <priteau> I was looking at updating the contributor count for Stein
09:14:48 <priteau> masahito: Do you remember how you counted 10 contributors for Rocky? Do you include contributor who push patches across all repos?
09:15:47 <masahito> maybe. or counted persons who reviewed patches.
09:16:05 <priteau> e.g. a patch like this: https://github.com/openstack/blazar/commit/ef1729ba97c0a5b460342cbbdd4fe775188de737
09:16:10 <priteau> Would you count this as a contributor?
09:16:36 <masahito> Depends on the patch type.
09:17:12 <masahito> I included the patch because it changed blazar or blazar related things, gate.
09:18:05 <masahito> But I excluded some type of patches across all repo, like fixing typo.
09:18:49 <priteau> OK, thanks.
09:19:09 <priteau> stackalytics shows we had reviews from 33 people.
09:20:21 <priteau> In Rocky the same number was 23
09:20:26 <priteau> Good improvement :-)
09:21:03 <masahito> surprised :-)
09:21:26 <priteau> Some of these reviews may be on mechanically-generated patches
09:22:07 <priteau> Anything else to discuss about the project update?
09:23:18 <priteau> If not let's move to the Stein release
09:23:22 <priteau> #topic Stein release
09:23:41 <priteau> blazar-tempest-plugin and blazar-dashboard have been tagged
09:23:51 <priteau> blazar-dashboard includes your affinity patch, thanks masahito!
09:24:36 <masahito> you're welcome.
09:26:34 <priteau> We still have the chance to release an rc2 this week if needed
09:26:52 <priteau> I'll focus my reviews on bug fix patches
09:27:39 <priteau> I think we're in good shape for the release.
09:27:46 <masahito> yes.
09:28:31 <masahito> Do you plan to release new client including floating ip support?
09:29:03 <masahito> If so, I mark it as priority in my tasks.
09:30:26 <priteau> I think it's too late to release a client to be included in Stein (client freeze was several weeks ago)
09:30:51 <priteau> The releases repo doesn't have a folder for train deliverables yet
09:31:04 <masahito> got it.
09:31:24 <priteau> We'll have to wait until after Stein is released, but please review now, I think my patch is ready.
09:32:07 <priteau> By the way, floating IP reservation was deployed in production on Chameleon and announced yesterday. Great job masahito :-)
09:32:27 <masahito> Great news!
09:32:37 <masahito> Does it work well?
09:33:12 <priteau> It does.
09:34:06 <masahito> Good to hear ;-)
09:34:21 <priteau> There were some issues because Neutron is still running Ocata, and 1) it doesn't support tagging 2) there is a bug with passing a specific address when creating a floating IP
09:34:49 <priteau> But they're going to upgrade to Rocky very soon.
09:36:01 <masahito> okay
09:36:10 <priteau> #topic Train virtual PTG
09:36:43 <priteau> Since we're not going to all be at the PTG in Denver, we should do a virtual PTG to discuss priorities for the Train release cycle
09:37:56 <priteau> We should start discussing dates, but with tetsuro and bertys not here, I will send email.
09:38:11 <priteau> Would a meeting on April 16 work for you?
09:39:31 <masahito> It works for me.
09:39:46 <priteau> #action Send email about virtual PTG
09:39:47 <masahito> Same time with the weekly meeting?
09:39:56 <priteau> Yes, we can hold it in place of the weekly meeting.
09:40:07 <priteau> We can even start earlier if preferred.
09:41:05 <priteau> I will propose options. We can also hold it on another day if it works better.
09:41:35 <priteau> #topic Blazar whiteboard
09:42:13 <priteau> I've seen other OpenStack projects use an Etherpad as a whiteboard to keep track of current status, I think it would work great for us too.
09:42:20 <priteau> #link https://etherpad.openstack.org/p/blazar-whiteboard
09:42:37 <priteau> It's in progress, I will add more categories
09:43:25 <masahito> Thanks.
09:43:27 <priteau> We can talk more about it next week when everyone's online
09:44:11 <priteau> I think the TODOs will be really useful, for example to keep track of review comments asking for follow-up patches
09:45:04 <priteau> Let's discuss more how we can use next week
09:45:06 <priteau> #topic AOB
09:45:12 <priteau> Anything else to discuss?
09:46:05 <priteau> Nothing special from me
09:46:23 <masahito> me neither.
09:47:05 <priteau> OK, let's end for today. Thanks for joining masahito!
09:47:10 <priteau> Have a good week
09:47:24 <masahito> thank you. you too.
09:47:36 <priteau> #endmeeting