09:03:23 <priteau> #startmeeting blazar
09:03:24 <openstack> Meeting started Tue Mar 12 09:03:23 2019 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:03:25 <priteau> Hello. Sorry for the delay.
09:03:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:03:28 <openstack> The meeting name has been set to 'blazar'
09:03:30 <openstack> priteau: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
09:03:31 <priteau> #topic Roll call
09:05:06 <priteau> No one today?
09:05:35 <bertys_> o/
09:05:43 <priteau> Hi bertys_
09:06:19 <priteau> I can see Masahito and Tetsuro were active on Gerrit just recently
09:06:46 <bertys_> okay, let's wait few more minutes
09:07:05 <masahito> o/
09:07:09 <masahito> sorry to be late
09:07:26 <priteau> Hi masahito
09:07:46 <priteau> We're waiting for Tetsuro as well
09:08:23 <priteau> Hi tetsuro
09:08:44 <tetsuro> Hi
09:08:50 <tetsuro> sorry, I gotta go today.
09:09:27 <priteau> No problem. We'll let you know if there are action items for you.
09:09:42 <tetsuro> Thanks.
09:10:27 <tetsuro> See you.
09:10:42 <priteau> Agenda for today
09:10:47 <priteau> 1. Denver Summit Project Update
09:10:53 <priteau> 2. Stein release
09:10:58 <priteau> 3. Train PTL election
09:11:01 <priteau> 4. AOB
09:11:07 <priteau> #topic Denver Summit Project Update
09:11:31 <priteau> I've sent confirmation that both tetsuro and bertys_ are registered for the summit
09:12:22 <priteau> I think we can assume that the project update slot is accepted
09:12:34 <priteau> I'll start a slides template and circulate it.
09:13:33 <priteau> #action priteau will start a slides template for the Project Update
09:13:44 <priteau> We may want to focus on the Stein release for now, and work on the slides in April.
09:14:02 <bertys_> +1
09:14:12 <masahito> +1
09:14:36 <priteau> Good, let's talk about Stein then :-)
09:14:40 <priteau> #topic Stein release
09:14:57 <priteau> Reminder about the Stein release schedule
09:15:00 <priteau> #topic https://releases.openstack.org/stein/schedule.html
09:15:03 <priteau> Sorry
09:15:07 <priteau> #topic Stein release
09:15:09 <priteau> #link https://releases.openstack.org/stein/schedule.html
09:15:21 <priteau> RC1 is Mar 18 - Mar 22
09:15:28 <priteau> Final RCs Apr 01 - Apr 05
09:15:38 <priteau> Stein release Apr 08 - Apr 12
09:16:27 <priteau> We're past feature freeze now, but we can make exceptions.
09:16:59 <priteau> I think we should finish merging the affinity support from Tetsuro and the floating IP reservation from Masahito.
09:17:18 <masahito> Sorry for slow reviewing and update.
09:18:37 <priteau> I see you updated the spec, thank you!
09:19:18 <priteau> Are there still pending comments on the spec?
09:19:49 <masahito> Nothing.
09:20:06 <masahito> One point I want to talk you is
09:20:43 <masahito> The current fip reservation's response body doesn't show the reserved FIPs.
09:21:18 <masahito> It means an user doesn't find out the real reserved floating ip addresses until the reservation starts.
09:22:18 <priteau> True, it could be useful to know before the reservation starts.
09:23:03 <priteau> We can add another field in the response
09:23:17 <priteau> `allocated_floatingips`
09:23:44 <priteau> Would it contain UUIDs or IP addresses?
09:24:14 <masahito> What's the UUID? I prefer IP addresses.
09:24:56 <priteau> The ID you find when you do a `floating ip list`
09:25:35 <masahito> The API is admin API in default.
09:26:22 <priteau> Actually I see you can do `floating ip show <ip-address>`, so that would be fine as well
09:27:11 <priteau> Do you think you could update spec and code to add this field?
09:27:36 <masahito> ah, the `floating ip show` is not the Blazar's floating ip list API, but Neutron's CLI, is it?
09:27:43 <masahito> okay
09:28:22 <priteau> Yes, I am talking about Neutron (OSC client)
09:28:34 <priteau> Sorry for the misunderstanding.
09:30:21 <priteau> The advantage of showing the actual IP address is that it will match the `required_floatingips` field
09:30:30 <masahito> np. The ID is assigned by Neutron when it creates the floating IP. So Blazar can't manage the ID before the reservation starts.
09:31:01 <priteau> Good catch :-)
09:31:18 <priteau> It's settled then. When do you think you could update the spec and patches?
09:31:58 <masahito> I will update the spec tomorrow and the patches in this week.
09:32:21 <masahito> I don't have much tasks to do in this week :-)
09:32:31 <priteau> How nice :P
09:34:23 <priteau> Anything else to discuss on this topic?
09:36:04 <priteau> Let's aim to merge this code during by the end of the week, and then focus on testing and bug fixing.
09:36:31 <priteau> #topic Train PTL election
09:37:15 <priteau> I've submitted my candidacy as PTL for the Train cycle: https://git.openstack.org/cgit/openstack/election/plain/candidates/train/Blazar/pierre%40stackhpc.com
09:37:23 <priteau> If you will have me :-)
09:38:43 <priteau> Nominations end today at 23:45 UTC
09:38:53 <masahito> Thanks for running the PTL in Stein cycle.
09:39:03 <priteau> Elections start right after and end next Tuesday
09:39:21 <bertys_> Thanks for your continuous support
09:39:46 <priteau> Being PTL was new to me this cycle, I hope I can do better in Train!
09:40:47 <masahito> I'll support you as much as possible :-)
09:40:59 <priteau> Thank you both.
09:41:22 <priteau> #topic AOB
09:41:26 <priteau> Anything else to discuss?
09:42:04 <masahito> Just fyi to Blazar team.
09:42:28 <masahito> Blazar support in Heat was merged in last week.
09:42:30 <masahito> https://review.openstack.org/#/q/status:merged+project:openstack/heat+branch:master+topic:bp/heat-plugin-blazar
09:42:55 <priteau> I saw it too! Looking forward to trying it
09:43:10 <priteau> I guess if I deploy a new DevStack it would be available.
09:43:15 <masahito> An user can create Blazar resources in the their stack!
09:44:32 <priteau> Next cycle we should ask them to add floating IPs
09:45:07 <priteau> Thanks for the info masahito
09:45:39 <masahito> my pleasure.
09:46:30 <priteau> Anything else to share?
09:48:03 <priteau> If not let's end the meeting here
09:48:17 <priteau> Thanks for joining. Looking forward to merge the floating IP code!
09:48:23 <priteau> #endmeeting