09:00:49 <priteau> #startmeeting blazar
09:00:50 <openstack> Meeting started Tue Nov 20 09:00:49 2018 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:53 <openstack> The meeting name has been set to 'blazar'
09:01:04 <priteau> #topic Roll call
09:01:16 <masahito> o/
09:01:22 <priteau> Hi masahito
09:01:45 <bertys> o/
09:01:55 <priteau> Hi bertys
09:03:11 <priteau> I see tetsuro is online too
09:03:20 <tetsuro> o/
09:03:27 <priteau> Hi tetsuro
09:03:43 <priteau> Agenda for today
09:03:44 <priteau> 1. Berlin Summit summary
09:03:48 <priteau> 2. stein-2 milestone
09:03:52 <priteau> 3. AOB
09:04:18 <priteau> #topic Berlin Summit summary
09:05:36 <priteau> It was a good summit. Good attendance of our project update session. I had discussions with several people who showed interest in using Blazar.
09:06:29 <priteau> A question at the project update was about how Blazar reservations differ from reservations in public clouds such as AWS.
09:07:10 <priteau> We should add a bit of content answering this in the documentation intro
09:08:08 <priteau> #action Document Blazar reservation compared to reservations in public clouds
09:09:20 <priteau> I also had a discussion with Ghanshyam Mann from the TC who strongly advise us to continue doing project onboarding sessions
09:09:46 <priteau> Looks like some of them were very well attended
09:09:58 <priteau> Let's remember it for the next summit
09:10:53 <priteau> About forum sessions now
09:11:23 <priteau> The placement session was unfortunately not attended by any placement developer, but the discussion was still productive
09:11:47 <priteau> Everyone seemed to be in agreement that having a placement client in openstacksdk is a good ide
09:11:51 <priteau> *idea*
09:13:30 * tetsuro nods
09:14:17 <masahito> right. But eventually we got the decision :-)
09:14:34 <priteau> The other session about extending reservations was trying to cover too much ground maybe. We discussed some ideas about how to handle Neutron resources but no big breakthrough.
09:16:15 <priteau> masahito: I understood that you will update the floating IP spec based on a new approach?
09:16:38 <masahito> IIUC, the main point was if the placement support non-Nova resources as well, network plugin should utilize the API.
09:16:47 <masahito> priteau: yes.
09:17:16 <bertys> just fyi, Melanie (Nova PTL) attended both sessions and shared some notes, can one of us (tetsuro maybe) replies as well to Jay/Sean on openstack discuss?
09:17:42 <bertys> e.g. #link http://lists.openstack.org/pipermail/openstack-discuss/2018-November/000017.html
09:18:11 <masahito> The new approach is quite similar to the current Allocation Reserved IP approach that enables user to handle floating ip as usuall.
09:19:37 <masahito> Once Placement supports floating ip allocation like VM scheduling, we can also utilize that.
09:19:49 <priteau> bertys: I can reply to Jay
09:20:47 <bertys> priteau: ok thanks, please let him now that we are still cool with his proposal discussed in Denver
09:22:06 <priteau> tetsuro: Do you know what is the status of the spec? Jay mentions Matt has some issues with it but I don't see any comment from him in https://review.openstack.org/#/c/603352/
09:23:18 <tetsuro> Matt has a lot of comments on that spec; PS4 and PS5
09:24:38 <priteau> Oh, I see them now
09:25:06 <tetsuro> His concern is about nova side placement request filter change.
09:25:45 <priteau> There are a lot of comments, I will check them after the meeting
09:26:14 <priteau> I heard at the summit that the placement API was frozen, what does it mean for this spec?
09:27:10 <tetsuro> It means this spec will probably be pended off at least to Train
09:29:39 <tetsuro> But we can focus placement integration of instance reservation in Stein Cycle.
09:31:53 <priteau> So for sure Ironic compatibility has to move to Train since we require placement aggregates
09:32:22 <priteau> Anything else from the summit?
09:34:42 <priteau> If not let's move to the rest of the agenda?
09:35:07 <masahito> I'm fine
09:35:13 <priteau> #topic stein-2 milestone
09:36:14 <priteau> The milestone date is getting closer and with the Christmas break it means we have around one month left really
09:37:33 <priteau> We could dedicate one of the weekly meetings to reviews, making it longer if needed. Is there a Tuesday that works best?
09:38:07 <masahito> If we do, Tuesday works for me.
09:38:53 <priteau> I mean, do you have a preference between November 27, December 4, December 11?
09:39:23 <masahito> 27 Nov. or 11 Dec. is fine.
09:39:26 <tetsuro> On December 4 I'm in DPDK Summit.
09:39:34 <bertys> I have a slight preference for December 11
09:39:44 <masahito> I'm in business trip on 4 Dec.
09:40:10 <tetsuro> Dec. 11th works for me.
09:41:10 <priteau> December 11 is getting late in the cycle, what about we discuss pending patches next week during the meeting hour, and finish on Dec 11 if there are still things to discuss on IRC?
09:43:01 <tetsuro> That's much better.
09:43:35 <priteau> Are you all available for the meeting next week?
09:44:46 <masahito> I'm fine.
09:45:08 <tetsuro> Fine
09:45:10 <masahito> I'll be in the next meeting.
09:46:02 <priteau> Agenda for the next meeting: https://wiki.openstack.org/wiki/Meetings/Blazar#Agenda_for_27_Nov_2018
09:47:49 <priteau> I propose we cancel the meeting on December 4 since masahito and tetsuro are travelling
09:48:07 <bertys> I cannot confirm now for next week, sorry, will try though
09:49:09 <priteau> OK bertys
09:50:19 <priteau> #topic AOB
09:51:18 <priteau> We have a new contributor reporting bugs and, even better, fixing them!
09:51:24 <priteau> https://review.openstack.org/#/c/618699/
09:51:28 <priteau> Great news
09:51:36 <priteau> From NTT Data
09:51:46 <masahito> yes. I noticed this patch today.
09:53:08 <tetsuro> Good news.
09:53:57 <priteau> Anything else to mention?
09:54:18 <masahito> Nothing from my side
09:54:58 <tetsuro> Nope.
09:57:26 <priteau> bertys and I discussed potentially having a Blazar meeting on a timezone compatible with America, to help engaging with potential users and contributors from there
09:58:08 <priteau> I would be in addition to the current meeting and less frequent, maybe every two or even four weeks
09:58:44 <priteau> I can take care of running it, it would be the middle of the night for Japan ;-)
09:59:59 <masahito> Nice idea.
10:00:11 <priteau> I still need to find an available time
10:00:32 <priteau> We're out of time for today, thanks folks!
10:00:43 <priteau> Good bye
10:00:43 <masahito> thanks,
10:00:47 <masahito> bye
10:00:51 <priteau> #endmeeting